aptd crashed with UnicodeDecodeError in _set_error(): 'ascii' codec can't decode byte 0xc3 in position 9: ordinal not in range(128)

Bug #926340 reported by Diego Carrera Gallego on 2012-02-03
522
This bug affects 112 people
Affects Status Importance Assigned to Milestone
Aptdaemon
Undecided
Unassigned
Ubuntu
High
Decman
Precise
High
Colin Watson

Bug Description

[Impact] Widespread crashes instead of proper error messages any time something goes wrong with aptdaemon.
[Test Case] Make sure you have the appropriate language pack installed, for some locale that uses a lot of non-ASCII characters (I chose Japanese). To make it easier to see the error in action, kill any currently-running aptd processes, and run 'sudo /usr/sbin/aptd' in one terminal. In another terminal, run 'LC_ALL=ja_JP.UTF-8 LANGUAGE= aptdcon --install germinat' (typo intentional). With a broken aptdaemon version, this will cause aptd to crash. If you're running 12.10, then to provoke this bug you need to run aptd using python rather than the default python3.
[Regression Potential] I think we just need to make sure that translated messages are still displayed correctly.

Original report follows:

i got same bug on ubuntu 12.04

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: aptdaemon 0.43+bzr769-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-12.21-ux31 3.2.2
Uname: Linux 3.2.0-12-ux31 x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Fri Feb 3 22:03:36 2012
DesktopFile: /usr/share/aptdaemon/aptdaemon.desktop
ExecutablePath: /usr/sbin/aptd
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120125)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/sbin/aptd
ProcEnviron:

PythonArgs: ['/usr/sbin/aptd']
SourcePackage: aptdaemon
Title: aptd crashed with UnicodeDecodeError in _set_error(): 'ascii' codec can't decode byte 0xc3 in position 9: ordinal not in range(128)
UpgradeStatus: Upgraded to precise on 2012-02-03 (0 days ago)
UserGroups:

Related branches

lp:ubuntu/precise-proposed/aptdaemon
Colin Watson: Approve on 2012-08-11
lp:~vorlon/aptdaemon/lp.1034806
Aptdaemon Developers: Pending requested 2012-08-11
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptdaemon (Ubuntu):
status: New → Confirmed
visibility: private → public
Alessandro Losavio (alo21) wrote :

I have the same problem in Ubuntu 12.04 amd64

RadekB (rrrbbb) wrote :

Got this error on U1 client install in Precise 32bit.

RadekB <email address hidden> schrieb:

>Got this error on U1 client install in Precise 32bit.
>
>--
>You received this bug notification because you are a member of
>Aptdaemon
>Developers, which is subscribed to aptdaemon in Ubuntu.
>https://bugs.launchpad.net/bugs/926340
>
>Title:
> aptd crashed with UnicodeDecodeError in _set_error(): 'ascii' codec
> can't decode byte 0xc3 in position 9: ordinal not in range(128)
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/ubuntu/+source/aptdaemon/+bug/926340/+subscriptions

Could you please attach the following file /var/log/syslog thanks
--
Diese Nachricht wurde von meinem Android-Mobiltelefon mit K-9 Mail gesendet.

Giovanni Mellini (merlos) wrote :
Download full text (3.8 KiB)

got this on U1 client install mee too.
This is my syslog while this appened. tks

Feb 24 19:20:30 whale AptDaemon: INFO: Initializing daemon
Feb 24 19:20:31 whale AptDaemon.PackageKit: INFO: Initializing PackageKit compat layer
Feb 24 19:20:31 whale dbus[884]: [system] Successfully activated service 'org.freedesktop.PackageKit'
Feb 24 19:20:31 whale AptDaemon.PackageKit: INFO: Initializing PackageKit transaction
Feb 24 19:20:31 whale AptDaemon.Worker: INFO: Simulating trans: /org/debian/apt/transaction/780f8b9e3dbf4349a98102a823d51270
Feb 24 19:20:31 whale AptDaemon.Worker: INFO: Processing transaction /org/debian/apt/transaction/780f8b9e3dbf4349a98102a823d51270
Feb 24 19:20:36 whale AptDaemon.PackageKit: INFO: Get updates()
Feb 24 19:20:38 whale AptDaemon.Worker: INFO: Finished transaction /org/debian/apt/transaction/780f8b9e3dbf4349a98102a823d51270
Feb 24 19:21:05 whale AptDaemon: INFO: UpdateCachePartially() was called
Feb 24 19:21:05 whale AptDaemon.Trans: INFO: Queuing transaction /org/debian/apt/transaction/ac402d549a7c49baaa4594a758dc86f4
Feb 24 19:21:05 whale AptDaemon.Worker: INFO: Simulating trans: /org/debian/apt/transaction/ac402d549a7c49baaa4594a758dc86f4
Feb 24 19:21:05 whale AptDaemon.Worker: INFO: Processing transaction /org/debian/apt/transaction/ac402d549a7c49baaa4594a758dc86f4
Feb 24 19:21:06 whale AptDaemon.Worker: INFO: Updating cache
Feb 24 19:21:06 whale AptDaemon.Worker: INFO: Finished transaction /org/debian/apt/transaction/ac402d549a7c49baaa4594a758dc86f4
Feb 24 19:21:06 whale <U+FEFF>AptDaemon: INFO: InstallPackages() was called: dbus.Array([dbus.String(u'rhythmbox-ubuntuone'), dbus.String(u'ubuntuone-client-gnome'), dbus.String(u'ubuntuone-control-panel-qt')], signature=dbus.Signature('s'))
Feb 24 19:21:06 whale AptDaemon.Trans: INFO: Queuing transaction /org/debian/apt/transaction/220a5f8792cc4ba2bdc74fcf2d8a9f86
Feb 24 19:21:09 whale AptDaemon.Worker: INFO: Simulating trans: /org/debian/apt/transaction/220a5f8792cc4ba2bdc74fcf2d8a9f86
Feb 24 19:21:09 whale AptDaemon.Worker: INFO: Processing transaction /org/debian/apt/transaction/220a5f8792cc4ba2bdc74fcf2d8a9f86
Feb 24 19:21:10 whale <U+FEFF>AptDaemon.Worker: INFO: Committing packages: dbus.Array([dbus.String(u'rhythmbox-ubuntuone'), dbus.String(u'ubuntuone-client-gnome'), dbus.String(u'ubuntuone-control-panel-qt')], signature=dbus.Signature('s')), dbus.Array([], signature=dbus.Signature('s')), dbus.Array([], signature=dbus.Signature('s')), dbus.Array([], signature=dbus.Signature('s')), dbus.Array([], signature=dbus.Signature('s')), dbus.Array([], signature=dbus.Signature('s'))
Feb 24 19:21:10 whale <U+FEFF>AptDaemon.Worker: INFO: Committing packages: dbus.Array([dbus.String(u'rhythmbox-ubuntuone'), dbus.String(u'ubuntuone-client-gnome'), dbus.String(u'ubuntuone-control-panel-qt')], signature=dbus.Signature('s')), dbus.Array([], signature=dbus.Signature('s')), dbus.Array([], signature=dbus.Signature('s')), dbus.Array([], signature=dbus.Signature('s')), dbus.Array([], signature=dbus.Signature('s')), dbus.Array([], signature=dbus.Signature('s'))
Feb 24 19:21:10 whale AptDaemon.Worker: INFO: Finished transaction /org/debian/apt/transaction/220a5f8792cc4ba2bdc74fcf2d...

Read more...

I've got this when I ran "apdcon --install germinate" when germinate was already installed.

pues la verdad este error solo salio con la seleccion del escritorio ubuntu del inicio de sesion de usuarios y solo aparese en la mia como administrador. porque en la de invitado parese todo estar bien no e tenido inconveinientes en los escritorios ni salen mensajes de error.

a central de programa nao funciona

Shelkit Wong (shelkit) on 2012-03-12
Changed in aptdaemon (Ubuntu):
status: Confirmed → Fix Released
Changed in aptdaemon (Ubuntu):
assignee: nobody → Marco Capozzi (marcocapozzi80)
Changed in aptdaemon (Ubuntu):
status: Fix Released → In Progress
Changed in aptdaemon (Ubuntu):
assignee: Marco Capozzi (marcocapozzi80) → nobody
Kevin Liang (lianghz122) wrote :

I have the same problem in Ubuntu 12.04 i386
thanks

Was calibrating my Webcam and needed the package shared -color-targets, and said that the package didn't exist. Clicked OK and crashed.

André Lopes (zipatei) wrote :

"Was calibrating my Webcam and needed the package shared -color-targets, and said that the package didn't exist. Clicked OK and crashed."

+1

Nicola de Plano (aginvrayo) wrote :

same problem in U 12.04 i386
can't format the system
can't restart from CD ROM, making the downgrade... the system cannot read the CD...

Nicola de Plano (aginvrayo) wrote :
Download full text (16.6 KiB)

tried to update the software, 273 Mb...
failed:
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/b/bash/bash_4.2-1ubuntu3_i386.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/e/e2fsprogs/e2fslibs_1.42-1ubuntu2_i386.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/e/e2fsprogs/e2fsprogs_1.42-1ubuntu2_i386.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/t/tar/tar_1.26-4ubuntu1_i386.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/e/e2fsprogs/libcomerr2_1.42-1ubuntu2_i386.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/e/e2fsprogs/libss2_1.42-1ubuntu2_i386.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.0.0_1.0.1-2ubuntu4_i386.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/i/initramfs-tools/initramfs-tools_0.99ubuntu12_all.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/i/initramfs-tools/initramfs-tools-bin_0.99ubuntu12_i386.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/c/cpio/cpio_2.11-7ubuntu2_i386.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/k/kbd/kbd_1.15.2-3ubuntu3_i386.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/g/glib2.0/libglib2.0-data_2.32.0-1ubuntu1_all.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/g/glib2.0/libglib2.0-bin_2.32.0-1ubuntu1_i386.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/g/gtk+3.0/libgail-3-0_3.4.0-0ubuntu2_i386.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/g/gtk+3.0/libgtk-3-bin_3.4.0-0ubuntu2_i386.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/g/gnome-control-center/gnome-control-center_3.4.0-0ubuntu3_i386.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/g/glib2.0/libglib2.0-0_2.32.0-1ubuntu1_i386.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/g/gtk+3.0/libgtk-3-0_3.4.0-0ubuntu2_i386.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/g/gtk+3.0/libgtk-3-common_3.4.0-0ubuntu2_all.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/libx/libxi/libxi6_1.6.0-0ubuntu1_i386.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubuntu.com/ubuntu/pool/main/g/gnome-control-center/libgnome-control-center1_3.4.0-0ubuntu3_i386.deb 404 Not Found [IP: 193.206.139.45 80]
Failed to fetch http://it.archive.ubunt...

Michael Luthardt (michalu) wrote :

Same bug here with 12.04 Beta2 amd64.

happybongers (happy-bongers) wrote :

I got the bug report when i tried to remove the full kubuntu plasma desktop/netbook system - package.

Matthias Becker (beckmatt) wrote :

I got the bug while installing Ubuntu One on 32 bit 12.04 beta. Impossible to install.

dombai (avv-baiani) wrote :

Bug was reported but i got no effective problem

Federico (fkremer-terra) wrote :

Aparece este error cuando HICOLOR requiere de un archivo de calibracion, especificamente para mi webcam.

Bugwindow popped up while running gpredict (satellite-tracking software)

Fabio Marconi (fabiomarconi) wrote :

Happened to me when trying to remove a package already removed but marked as installed again
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Sebastien Bacher (seb128) wrote :

The bug is showing on the top reported precise issues and should be adressed in a SRU

Changed in aptdaemon (Ubuntu):
importance: Undecided → High
Changed in aptdaemon (Ubuntu Precise):
importance: Undecided → High
status: New → Triaged
milestone: none → precise-updates
ZHANGKAIJS (zhangkaijs-5) wrote :

无法关机

Steve Langasek (vorlon) wrote :

Colin, assigning this to you since I know you were looking at it; if you need to hand it off, can you please let the .1 team know?

Changed in aptdaemon (Ubuntu Precise):
assignee: nobody → Colin Watson (cjwatson)
milestone: precise-updates → ubuntu-12.04.1
Sebastian Heinlein (glatzor) wrote :

Does this error occur regularly on your system?

If you are familiar with a terminal could you please open a terminal and run the following command
sudo aptd --replace -td

This should show more information required to solve this issue. After starting the above command please try to re-produce the error and copy and paste the output from the terminal here.

Sebastian Heinlein (glatzor) wrote :

Could you please run the command "locale" in a terminal and paste the output here?

Sebastian Heinlein (glatzor) wrote :

Which language do you use?

Sebastien Bacher (seb128) wrote :

@glatzor: one of the duplicate is submitted by one of the spanish translators team and one of the bugs has a french description so it's likely happening at least in spanish and french locales, though all the report have an empty ProcEnviron which is weird (could be a permission issue in the collector job or similar though)

Sebastian Heinlein (glatzor) wrote :
Changed in aptdaemon (Ubuntu):
status: In Progress → Fix Committed
Changed in aptdaemon (Ubuntu Precise):
assignee: Colin Watson (cjwatson) → Marcelo Alves (marcelo-alves-8)
Changed in aptdaemon (Ubuntu Precise):
assignee: Marcelo Alves (marcelo-alves-8) → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

Sebastian: Sorry for my delay in replying. This seems like a somewhat odd approach, to me. How about http://paste.ubuntu.com/1076420/ instead? It's longer, but I think it's more direct and clearer.

Colin Watson (cjwatson) on 2012-08-08
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 0.45+bzr848-0ubuntu2

---------------
aptdaemon (0.45+bzr848-0ubuntu2) quantal; urgency=low

  * debian/patches/fix_gettext_return_value_type.patch:
    - Make sure to always return unicode from core.Transaction.gettext()
      (LP: #926340). Based partially on a patch by Sebastian Heinlein.
 -- Colin Watson <email address hidden> Wed, 08 Aug 2012 16:19:51 +0100

Changed in aptdaemon (Ubuntu):
status: Fix Committed → Fix Released
Colin Watson (cjwatson) on 2012-08-08
Changed in aptdaemon (Ubuntu Precise):
status: Triaged → In Progress

Hello Diego, or anyone else affected,

Accepted aptdaemon into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/aptdaemon/0.43+bzr805-0ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in aptdaemon (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

The original bug appears to be fixed, however bug #1034806 is very likely to be a knock-on effect of this change and is now a top crasher for aptdaemon in precise, appearing only after the SRU for 926340.

tags: added: verification-failed
removed: verification-needed
Colin Watson (cjwatson) wrote :

Hello Diego, or anyone else affected,

Accepted aptdaemon into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/aptdaemon/0.43+bzr805-0ubuntu4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-failed
tags: added: verification-needed
Stéphane Graber (stgraber) wrote :

After discussion and base on the errors.ubuntu.com stats, marking as verification-done.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 0.43+bzr805-0ubuntu4

---------------
aptdaemon (0.43+bzr805-0ubuntu4) precise-proposed; urgency=low

  * debian/patches/fix_gettext_return_value_type.patch: also return unicode
    from aptdaemon.utils.IsoCodes.get_localised_name(). (LP: #1034806)

aptdaemon (0.43+bzr805-0ubuntu3) precise-proposed; urgency=low

  * debian/patches/fix_gettext_return_value_type.patch:
    - Make sure to always return unicode from core.Transaction.gettext()
      (LP: #926340). Based partially on a patch by Sebastian Heinlein.
 -- Steve Langasek <email address hidden> Fri, 10 Aug 2012 18:22:00 -0700

Changed in aptdaemon (Ubuntu Precise):
status: Fix Committed → Fix Released
luis mendes (lufifeme) on 2012-09-02
Changed in aptdaemon (Ubuntu):
assignee: nobody → luis mendes (lufifeme)
Colin Watson (cjwatson) on 2012-09-02
Changed in aptdaemon (Ubuntu):
assignee: luis mendes (lufifeme) → nobody
Changed in aptdaemon:
status: New → Fix Released
Jorge Suárez de Lis (ys) wrote :

Is this actually fixed on 12.04? I got this message today.

$ aptdcon -i knotes
The following NEW packages will be installed (39):
  akonadi-backend-mysql akonadi-server kdepim-runtime kdepimlibs-kio-plugins knotes
  libakonadi-calendar4 libakonadi-contact4 libakonadi-kabc4 libakonadi-kcal4
  libakonadi-kde4 libakonadi-kmime4 libakonadi-notes4 libakonadiprotocolinternals1
  libboost-program-options1.46.1 libdmtx0a libkabc4 libkalarmcal2 libkcal4
  libkcalcore4 libkcalutils4 libkdepim4 libkholidays4 libkimap4 libkldap4 libkmbox4
  libkmime4 libkontactinterface4 libkpimidentities4 libkpimtextedit4 libkpimutils4
  libkresources4 libmailtransport4 libmicroblog4 libmysqlclient18 libprison0
  libqrencode3 libqt4-sql-mysql mysql-client-core-5.5 mysql-server-core-5.5
The following packages will be upgraded (2):
  libmysqlclient18:i386 mysql-common
Need to get 16.4 MB of archives.
After this operation, 62.2 MB of additional disk space will be used.
Do you want to continue [Y/n]?Y
[+] 100% Fallou
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/aptdaemon/console.py", line 210, in _on_exit
    trans.error_details)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 59: ordinal not in range(128)

Decman (david0leo) on 2013-04-07
Changed in aptdaemon (Ubuntu):
assignee: nobody → Decman (david0leo)
enroas (enroas) on 2014-02-09
affects: aptdaemon (Ubuntu) → ubuntu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers