shutdown screen stuck after upgrade to Ubuntu 11.10

Reported by Bobocat on 2011-10-27
292
This bug affects 62 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

After the update from 11.04 to 11.10: when I shut down the pc sometimes it goes back to the login screen and then I have to do shutdown there which works well then.
Sometimes the pc shuts down but ends with the ubuntu splash screen and gets stuck there.
The issue may be driver related: I use the AMD/ATI FGLRX graphics driver.
I have a second pc where I also did the update to 11.10 and there I have no problem at all but I don't use the above driver but the NVIDIA graphics driver.
Both pc's have Ubuntu 11.10 64-bit.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
rupert (r-plumridge) wrote :

I also submitted a bug report, but have now marked it as a duplicate of this one.

I don't think this is related to the graphics driver as I am using the generic Ubuntu driver and have this issue. In fact, I dual boot Ubuntu and in Ubuntu Studio 11.10 this bug does not occur, but in standard Ubuntu 11.10 uprgraded from 11.04 I get this bug.

Shutdown bugs seem really hard to track down as logging is tunred off before the bug occurs and the damn Plymouth screen kicks in hiding a lot of the shutdown messages.

I have noticed by killing LightDM I can sometimes see some more of the shutdown messages and it is clear that this error is because a process is failing to shutdown successfully, preventing the pc from shutting down. I did once see an error message saying lightDM didn't shutdown, but that was only once....

Nicoco (truenicoco) wrote :

Same problem on two different PCs, a desktop with intel and a laptop with nvidia graphics, so I don't think it's graphic driver related. I can see the shutdown screen and the dots under "Ubuntu" keep on blinking. If I hit Esc I can see the last msg is "All processes ... within 2 seconds"
Both my PC have 64-bit installs.

Mark Ewoldt (ewoldtmark) wrote :

same issue I upgrade from 11.04 to 11.10 now it won't restart or shut down. but on the plus side my touchpad and sound card work on this version. I am using a sony vaio E seris laptop. AMD 64 Bit.

Nicoco (truenicoco) wrote :

Issue solved by uninstalling network-manager here

Stefano Bagnatica (thepisu) wrote :

I have the same problem, every shutdown hangs. I tried this before shutdown and it worked correctly:

- killed nm-applet from System Monitor
- sudo service network-manager stop
- sudo service networking restart

Maybe the only command needed is 2°, stopping the network-manager service.

j.benes (j-benes) wrote :

From the clean installation of 11.10 64-bit I have the same problem. So far I wasn't able to shutdown/restart my laptop HP 4520s (if it helps). I also tried the suggested command above, no success. Even if I get to TTY1 (or any) and try to sudo shutdown the pc just hangs up on purple ubuntu screen. When I kill lightDM, it hangs up too. Well, if I can be of any assistance here, sending logs or so, plase tell me, for the thing is becoming a pain in the ***, yes there.

John Martin (john-d-martin-iii) wrote :

I use a USB mobile internet modem and this issue occurs whether or not it has been plugged in and active at some point during my session, so I do not think that it is modem-manager causing this. I can restart if I have not logged in without a hang, but if logged in, whether network-manager has been stopped or not, I have a hang at shutdown and have to shutdown by holding the power button. This has occurred since upgrade to 11.10 via normal upgrade procedures.

Geo (george-kiselyov) wrote :

Kubuntu 11.10 amd64 upgraded from 11.04.
DM: kdm
Network-Manager not used.
When I use 'sudo shutdown -P now' from console, my PC was poweroff correctly. But using the usual way to turn off (from user session or KDM login screen) ends with the splash screen and gets stuck there.

//Sorry for my terrible English.

On Wed, Nov 2, 2011 at 05:42, Geo <email address hidden> wrote:
> Kubuntu 11.10 amd64 upgraded from 11.04.
> DM: kdm
> Network-Manager not used.

Are you certain that it is not installed? I also did not use it, but
its mere presence was sufficient to hang the shutdown. Since
uninstalling network-manager, I have not seen the issue pop up again.

Geo (george-kiselyov) wrote :

2 Thilo-Alexander Ginkel:
Network-manager is not installed

Raymond Luck (fccluck) wrote :

My Sony Vaio VGN-SZ430N seems to shut down fine, but my Vaio VGN-FZ285 does not. Same load and all.

rupert (r-plumridge) wrote :

Using poweroff --force does shutdown my laptop, but I worry that might not be a graceful or safe way of doing so...

It is clearly an issue with some process not responding correctly to the request for it to quit.

If it is of relevance, I also experienced the Xauthority issue as part of the upgrade (inability to log in to account due to LightDM borking some permissions somewhere during the upgrade), so I wonder if what caused that also caused this issue...

Jochen Voß (seehuhn) wrote :

Just for the record: I see this problem on two different machines (a desktop and a laptop): both machines shut down just fine before the upgrade to oozing ocelot. Since the upgrade, the shutdown hangs. In the hung state, the Ubuntu logo is visible, underneath there are three red dots and two white dots, and the machine doesn't react to key presses (e.g. switching virtual consoles seems not to work).

Ok, I can confirm that this is not NetworkManager related (as it still happens although I have uninstalled its package). Just to rule things out: Is someone, who is seeing this issue, not using VirtualBox?

Stefano Bagnatica (thepisu) wrote :

@ thilo.ginkel: maybe not related to network-manager, but to networking in general?

Please try these commands before shutting down:
sudo service network-manager stop
sudo service networking restart

Allan Nielsen (an-luz) wrote :

I still see it, and I'm not using virtual box.

It's on a HP pavilion ZE2300 - very annoying.

rupert (r-plumridge) wrote :

Is everyone who is impacted using a wireless connection?

I dunno why, but I am sure it is something to do with networking, that or an app that uses a connection.

None of the above, apart from sudo poweroff --force shuts down my laptop....

On Tue, Nov 8, 2011 at 22:11, rupert <email address hidden> wrote:
> Is everyone who is impacted using a wireless connection?

Nope. Standard CAT-5 cabling, no WiFi card installed.

I think this also might have something to do with this bug: https://bugs.launchpad.net/ubuntu/+source/rpcbind/+bug/844317

Stefan Zeyen (stefan-zeyen) wrote :

Hi,

I had the same problem after upgrading from natty to oneiric.
Shutdown my notebook only worked the following ways:

1. sudo shutdown -h now

2.log off the user and shutdown from the login screen

My noteboos has an ATI Grafic Card.
Monday in changed the driver from fglrx to radeon. since i changed the driver the shutdown works with the shutdown button from the panel.

Stefan Zeyen (stefan-zeyen) wrote :

btw: yes, i'm using wireless

doken (doken) wrote :

could not shutdown or reboot either. but as in #6 "sudo service network-manager stop" makes it possible.

whether that is due to the wrong ethernet driver being used or not i don't know yet, https://bugs.launchpad.net/ubuntu/+source/linux/+bug/779040

rupert (r-plumridge) wrote :

sudo shutdown --force -h now also works

doken (doken) wrote :

Actually, update to my previous: stopping the network-manager is not required, just need to disconnect my wired connection using the network menu (assuming so that no connection is active).

Stefano Bagnatica (thepisu) wrote :

I also have done some tries, and can say that stopping network-manager does not help, instead the computer shut down correctly if I do: sudo /etc/init.d/networking stop

So reading many comments it seems a problem related to networking engine in general.

Jamie Pocas (pocas-jamie) wrote :

I have an HP dv6 1350us laptop, which is a couple years old. I had originally installed Ubuntu 11.04 as a fresh install, and then upgraded to 11.10 via going to a dev branch originally and updating periodically. When we got near the RTM release date, this started happening to me as well and hasn't gone away. I suspect it has something to do with ACPI and here is why: if the laptop is unplugged and is running off the battery, it has never happened to me. If the laptop AC adapter is plugged in, it happens most of the time.

rupert (r-plumridge) wrote :

I suspect it is more complex than that, since I get it all the time regardless of it being plugged in or not. It is clearly down to a process failing to exit correctly, an process we are all running but isn't necessarily common in the default 11.10 install as not everyone has this problem.

We need to list what is non-standard on our systems. For instance I mount various drives via NFS at boot, which might be an issue...

Mass-Yas (massyas) wrote :

The trick for me to solve this issue was to manually unmount an nfs share I put in /etc/fstab before rebooting/halting the system.
Thanks rupert for pointing this out at #29

For information, the mouting point I defined is 192.168.1.20:/srv/nfs/ubuntu-11.10-desktop /media/nfs nfs ro 0 0 and i use it for tftp server.

bartounet (i-antony) wrote :

Hello i have the same problem.
Ubuntu 11.10 Desktop 64 bits UptoDate whith Unity

Config:
Intel Core I5 200K
8G Ram DDR3 1600
Radeon HD 6570 Ultimate, 1 Go
SSD Crucial C300 ( 2 partitions / (ext4) and Swap )

Nothing non-standard.
Il have 2 nfs mount at boot in fstab.

rupert (r-plumridge) wrote :

Does everyone with this bug have NFS shares mounted? Thus it is either a network or nfs server issue....

michal przadka (przadka) wrote :

I also have NFS mounted .

Erik (ubuntu-erikdokter) wrote :

I am using autofs to mount NFS shares as well

Stefano Bagnatica (thepisu) wrote :

I don't have any NFS shares or other network drives.

Bonzer (bonzer) wrote :

I have a CIFS share auto-mounted in fstab.

I had the shutdown failure problem on 11.04 and found dismounting the CIFS share before shutting down did fix it.

On 11.10 I found that dismounting the share doesn't solve it. The only way I have been able to solve is by uninstalling the network-manager.

I am using wired ethernet.

Pépou (yannickw24) wrote :

Cannot shutdown either with my dell inspiron 6400 and ubuntu 11.10. Very annoying.

rupert (r-plumridge) wrote :

I see error messages relating to a program starting with rpc.... when the shutdown fails, which is one of the nfs server daemons. Since we are getting no dev involvement in this bug at the moment, I am going to assign the bug to nfs client and hopefully people might start to show an interest, it is at least linked to file sharing at the very least....

Robert (baumgaro) wrote :

Same with me - since update to 11.10 Ubuntu hangs with [fail] on shutdown. I also have one nfs mount.
If I manual unmount this nfs mount before shutdown the system will shutdown normal.

rupert (r-plumridge) wrote :

I'm pretty sure now this is an issue with a network drive tool, most likely rpcbind, since I see an error thrown by rpcbind when my laptop fails to shutdown.

I also see the following two errors when my machine boots up:

Nov 24 20:19:57 netbook rpcbind: Cannot open '/run/rpcbind/rpcbind.xdr' file for reading, errno 2 (No such file or directory)
Nov 24 20:19:57 netbook rpcbind: Cannot open '/run/rpcbind/portmap.xdr' file for reading, errno 2 (No such file or directory)

I wonder if these missing files are causing the shutdown issue. I found these by simply

cat /var/log/syslog | grep rpcbind

Can some ubuntu devs PLEASE start to respond to this issue so we can fix it, OK, it might not be a bug of stock Ubuntu, but it is a bug of the upgrade......

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

rupert (r-plumridge) on 2011-11-24
affects: nfs-utils → rpcbind (Ubuntu)
Changed in rpcbind (Ubuntu):
status: New → Confirmed
rupert (r-plumridge) wrote :

I found a bug posted related to the issue I noted above https://bugs.launchpad.net/ubuntu/+source/rpcbind/+bug/835833 and have posted a message there to see if it is related to this issue we are having or not.

I might be wrong, but currently we are getting nowhere with lots of me toos, but no one helping us finding the cause of this bug.

Steve Langasek (vorlon) wrote :

> Nov 24 20:19:57 netbook rpcbind: Cannot open '/run/rpcbind/portmap.xdr' file for reading, errno 2 (No such file or directory)

This message has nothing to do with any shutdown problems. If you can capture the error message shown at shutdown time, please do so and post it here.

Changed in ubuntu:
status: Confirmed → Invalid
Changed in rpcbind (Ubuntu):
status: New → Incomplete
Mass-Yas (massyas) wrote :

Hello
I'm trying to get some traces at shutdown adding some commands in /etc/rc0.d/S20sendsigs because in my case the shutdown operation keep locked after "Killing all remaining processes"
I've dumped the process list at different steps, but nothing is really different between a clean shutdown and a stopped one.
I'm now trying to look at open files with lsof. I hope I will find something useful.

rupert (r-plumridge) wrote :

The only message I saw when I just failed to shutdown was:

nm-dispatcher.action: Caught signal 15, shutting down
Asked all remained processes to terminate.......failed

And then it just sits there....

Mass-Yas (massyas) wrote :

I have found this workaround on the forum http://ubuntuforums.org/showthread.php?p=11403944

Just type this in a root command prompt

cd /etc/init.d && update-rc.d -f umountnfs.sh remove && update-rc.d umountnfs.sh start 19 0 6 .

It worked for me. It is actually moving the order of umountnfs to call it before sendsigs so the nfs share are unmounted before killing all the remaining process.
It's not a bug correction, but it works.

Steve Langasek (vorlon) wrote :

> nm-dispatcher.action: Caught signal 15, shutting down
> Asked all remained processes to terminate.......failed

Right, this looks like a NetworkManager/upstart bug. I don't know what would cause nm-dispatcher.action to be run or not, but it looks like sendsigs is killing the NM subprocess, breaking the interface prematurely.

I don't see this problem here when shutting down, and I also have NFS shares mounted. What does your network configuration look like before shutdown? ('route -n' output)

affects: rpcbind (Ubuntu) → network-manager (Ubuntu)
Changed in network-manager (Ubuntu):
status: Incomplete → Triaged
Jim Louvau (jlouvau) wrote :

I think you're right Steve. I have it happening 95% of the time on 2 machines, one a laptop with wireless connectivity and the other a wired desktop. Neither have networks mounts of any kind. Both are 64-bit. Sometimes, for no apparent reason, the shutdown works (nothing is obviously different from the times it doesn't work).

Jim Louvau (jlouvau) wrote :

Sorry, forgot 'route -n' FWIW:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.1.254 0.0.0.0 UG 0 0 0 wlan0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 wlan0
192.168.1.0 0.0.0.0 255.255.255.0 U 2 0 0 wlan0

Not exactly something that should mess up ifdown.

rupert (r-plumridge) wrote :

Just the same as my route -n:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 wlan0
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 wlan0
192.168.1.0 0.0.0.0 255.255.255.0 U 2 0 0 wlan0

And thanks Steve for working on this with us, much appreciated.

Tipi Koivisto (tipit) wrote :

I got a same problem in my Lenovo S205 (jamms in shutdown) and I have tried all suggested solutions here [1] and above without any success. Hopefully someone get this fixed.

[1] http://ubuntuforums.org//newreply.php?do=newreply&noquote=1&p=11472454

Tipi Koivisto (tipit) wrote :

Could this be something to do with my four last lines printed out before the jamming?
..
*Kill all processes...
...
Umount2: Device or recource busy
Umount: /dev/sda3/ busy - remounted read only
*Unmouting local filesystems
*Will now halt.

I think there is a major misconception:

halt (or shutdown -h) will halt your PC whereas poweroff (or shutdown
-P) will power it off.

The shutdown -h behavior has changed since Natty, but according to the
man page both variants are valid.

Easy fix: Use shutdown -P and your system should power off again.

Tipi Koivisto (tipit) wrote :

Ok. But that does do any good.

Hibernate, suspend and shutdown all freezes to the same situation. "shutdown -r 0" works and reboot goes nicely...

Rafael Arroyo (rarroyo) wrote :

 I think it's the same problem as bug 891149.
Try changing the configuration of the network connection and checking the "Available to all users"
Sorry for my English

rupert (r-plumridge) wrote :

@Thilo-Alexander Ginkel (thilo.ginkel) just to confirm, this issue occurs when the user tries to shutdown normally via the GUI (i.e click on the cog > Shut Down > Shut Down), not when issuing terminal commands, although the issue is still evident when trying to shutdown via the shutdown -hP command for example.

rupert (r-plumridge) wrote :

@Rafael Arroyo (rarroyo) This doesn't fix it for me, I already had available all users checked....

Eren Tantekin (eren-tantekin) wrote :

Mine doesn't shut down even when I'm doing it from the GUI. (I'm not running Gnome though, I'm on Xmonad).

Tipi Koivisto (tipit) wrote :

I dont think it is the same bug as https://bugs.launchpad.net/bugs/891149 .

I have tried to kill all wireless devices and programs and disable modules. Nothing seems to work.

Yesterday I installed 11.10 Xubuntu again (to Lenovo S205) with the same results. GUI or not, shutdown or poweroff does not work.

When I do "shutdown -r 0" as root boot is executed nicely. Says "*Will now reboot" and reboots.

On the other hand when I do "shutdown 0" as root the last message in standard output is "*Will now halt..." and then comes Mr. Freeze. I can even hear the hardrive shutting down but then it just freezes.

Therefore I think the problem is in somewhere between Halt and hardware.

I have also tried to print messages from syslog, dmesg, kern.log when shutting down, but there seems to be nothing connected to this problem. There are a lot of similar kind of problems with 11.10 so hope this will be fixed soon.

Jim Louvau (jlouvau) wrote :

I agree with Tipi. I see this problem on notebooks with WiFi or hard connections, as well as wired desktops. The avalability to users doesn't affect anything. In my experience, neither do mappings/shares/etc., be they samba, nfs, sftp or otherwise. The apparent "it always works" "fix" is "shutdown -r 0".

Steve Langasek (vorlon) wrote :

On Thu, Dec 08, 2011 at 02:43:01PM -0000, Tipi Koivisto wrote:
> On the other hand when I do "shutdown 0" as root the last message in
> standard output is "*Will now halt..." and then comes Mr. Freeze. I can
> even hear the hardrive shutting down but then it just freezes.

> Therefore I think the problem is in somewhere between Halt and hardware.

That's a different issue. "halt" does not guarantee that the system is
powered off; to get this you need to use the 'poweroff' command or 'shutdown
-P'.

If you call 'shutdown -P' and the system still does not power off, that's a
(separate) bug. But not powering off in response to 'shutdown'/'halt' is
allowed behavior. I'm not sure *why* the behavior changed, and maybe we
should revert it for future releases, but for now please use the explicit
command.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Tipi Koivisto (tipit) wrote :

> That's a different issue. "halt" does not guarantee that the system is
> powered off; to get this you need to use the 'poweroff' command or 'shutdown
> -P'.
>
Ok. I did not now about the separation, but either one of those works.

> If you call 'shutdown -P' and the system still does not power off, that's a
> (separate) bug.

Ok. Then I will open a new issue.

> But not powering off in response to 'shutdown'�'halt' is
> allowed behavior.
> I'm not sure *why* the behavior changed, and maybe we
> should revert it for future releases, but for now please use the explicit
> command.

--
Tipi
Tipi Koivisto

Rudy Sevile (rudy-sevile) wrote :

My laptop is a Asus N61J series. I have upgraded from Ubuntu 11.04 to 11.10 and this problem appeared.

It hands when shutting down or rebooting. Usually, one or zero of the circles get filled on the splash screen and it just hangs there. Sometimes it's actually does shutdown successfully, but it's rare (1 / 3 maybe).

I am using a wired ethernet connection.

Rudy Sevile (rudy-sevile) wrote :

I forgot to mention, I am running a 64 bit version of Ubuntu.

Also the shutdown command in the terminal is not helping much, same behavior tends to happen.

corevalue (corevalue-uk) wrote :

I have this problem on a clean install of 11.10. AMD Sempron on Biostar 790 mobo. I installed 11.10 from a live CD of about a month ago, it worked fine, then updated and the problem appeared.

The machine sticks at the Kubuntu shutdown splash with the "balls" active, nothing else happens. I can't get a terminal or response to any key presses, but sometimes ctrl-del will bring up a full screen activity log. Usually (not always) it's stuck at trying to shutdown modem-manager with signal 15, there is [fail] in red on the RHS against it. More random pressing of ctrl-del or ctrl-alt-del gets it moving again, line at a time, until eventually it shuts down, BUT, it always reboots. No combination of shutdown -h -P -r now makes any difference, it ALWAYS reboots.

I tried to kill modem-manager with sudo kill (process ID) before shutting down, but it wouldn't die.

The only way to turn of the machine is the power switch, or sudo poweroff --force

anake (g-n-sivalingam) wrote :

Not sure if this is important but though I would add my experience.
I had the same issue using a desktop with 11.10, and a Tenda W54P wireless PCI card.
For unrelated reasons I removed it and started using a USB dongle (Edimax EW-7612UAn) and the problem went away.
With both of them I used the drivers which came with ubuntu so I would assume it is a problem with one of the wireless drivers. Unfortunately I have no idea how to check which driver was being used previously as I dont have the card anymore.

Andrew Kay (music1) wrote :

MORE DATA!

I'm also having the "won't power down" problem -- "FAIL" message in red on the console. Xubuntu 64 bit, Oneiric 11.10

I use an edimax USB wireless dongle.

However, when I switched to a TP-LINK TL-WN321G (stolen from my other near-identical machine, which doesn't have the problem) the problem went away.

I don't have any network drives. Just starting up ubuntu with the edimax plugged in (and connecting automatically to my WPA network) is enough to cause the shutdown problem.

Works: (TP-LINK)
Bus 002 Device 002: ID 148f:2070 Ralink Technology, Corp. RT2070 Wireless Adapter

Doesn't Work: (EDIMAX)
Bus 002 Device 003: ID 148f:2573 Ralink Technology, Corp. RT2501/RT2573 Wireless Adapter

Is this helpful?

Christopher Nyland (menyland) wrote :

I had a similar experience to Andrew. I was using my phone as my wireless link because I was having problems with my network card. The phone was attached via usb. I recently got my card sort of fixed and therefore stop using the usb connection. So are any of you guys using usb network devices or some other type of usb device that would cause this. Although it does seem to be centered around network issues by the looks of everyone else's posts.

Tamale (uictamale) wrote :

Affects me as well, and the halt 'workaround' doesn't help, either.

Dell Precision M6600
AMD FirePro M8900
Ubuntu 11.10

rupert (r-plumridge) wrote :

The only solution that worked: fresh install of lubuntu. Nothing else fixed it and it it got rid of unity which is terrible on a low power netbook (i.e. the app lens never loads, so you can't access any of your apps other than through the terminal).

Steve Langasek (vorlon) wrote :

no, the symptoms described here are unrelated to insserv.

david day (yayaday) wrote :

Affects me as well.

Dell Precision M6600
64 bit Ubuntu 11.04 Ubuntu 11.10

The laptop was on bios A03 which I updated to A07 and disabled "c state control" in bios after a few attempts but still no joy.

Removing the AC connector before issuing the shutdown command within gnome did allow for a clean power down. Later, I stopped acpi-support but left AC connected and the system also successfully powered down.

I'm currently running 64 bit 11.04. I'd consider going back to 10, but it EOL next month.

Chris Barth (chrisjbarth) wrote :

I have the same problem on the latest build of Virtual Box v4.1.12. In both 11.10 and 12.04 beta2 I install Ubuntu Server x86 with nothing but the defaults selected and I get the following:

sudo shutdown now
[sudo] password for xxx:
Broadcast message from [user]@[server]
(/dev/tty1) at 10:36 ...

Skip stopping firewall: ufw (not enabled)
 * Asking all remaining processes to terminate... [ OK ]
 * Killing all remaining processes... [fail]
 * Will now switch to singler-user mode
[user]@[server]:~#

So matter how many times I run sudo shutdown now I get the exact same thing and the server never shuts down. I've tried several of the suggestions above, but given how simple my setup it, I would imagine it should be fairly easy to replicate this.

VirtualBox Settings:
512 MB
VT-x/AMD-V, Nested Paging, PAE/NX
Video Memory: 12 MB
IDE Controller (CD)
SATA Controller (HDD)

PIIX3
Hardware clock in UTC time
Enable absolute pointing device

Bridged Adapter
Intel 82566DM-2 Gigabit Network Connection
Intel Pro/1000 MT Desktop (82540EM)

Enable USB Controller

Alex (alex-pi-gamer) wrote :

Hi,

I did not have this problem after upgrading to 11.10 but after some time it appeared. The solution for me was simple. The Session Management plugin in Compiz -> Utilities was switched on. I just switched it off and the problem gone.
Again Compiz...
Hope it will help to the others.

Success!

Jim Louvau (jlouvau) wrote :

I tried Alex's fix (disabe session management in compiz) and it may have made the hangs less frequent, it has not solved the issue on 3 different sets of hardware.

As an aside, some dual-boot testing on a couple of machines with Mint 12, using Cinnamon and Gnome Shell sessions results in zero shutdown hangs. AFAICT the issue lies in something exclusive to "genuine" Ubuntu/Unity and the way it's doing a shutdown.

Steve Langasek (vorlon) wrote :

This big report is being used to track a known issue with hangs on shutdown caused by an interaction between network-manager and network mounts on shutdown; and that issue should be fixed now in 12.04, so I'm closing this report.

If you are experiencing hangs on shutdown in 12.04, please file a separate bug report for your issue so that it can be investigated separately.

Changed in network-manager (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers