spurious syslog error message because of use of -w on boot [rpcbind.xdr / portmap.xdr : errno 2 (no such file)]

Bug #835833 reported by dino99 on 2011-08-28
346
This bug affects 80 people
Affects Status Importance Assigned to Milestone
rpcbind (Debian)
Fix Released
Unknown
rpcbind (Ubuntu)
Medium
Unassigned

Bug Description

Oneiric i386

while watching details into bootlog before sending an other report, i've seen:

fsck from util-linux 2.19.1
rpcbind: cannot open '/var/run/rpcbind/rpcbind.xdr' file for reading, errno 2 (no such file or directory)
rpcbind: cannot open '/var/run/rpcbind/portmap.xdr' file for reading, errno 2 (no such file or directory)

the directory /var/run/rpcbind/ is empty.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: rpcbind 0.2.0-6ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic-pae 3.0.3
Uname: Linux 3.0.0-9-generic-pae i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sun Aug 28 07:11:36 2011
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: rpcbind
UpgradeStatus: No upgrade log present (probably fresh install)

dino99 (9d9) wrote :
summary: - rpcbind.xdr no such file or directory
+ rpcbind.xdr / portmap.xdr : errno 2 (no such file)

wonder why this error:

cbind: cannot open '/var/run/rpcbind/portmap.xdr' file for reading, errno 2

as portmap is not installed, albeit its a rpcbind dependency (portmap dependant)

but synaptic says : rpcbind conflicts/replaces portmap

so some code cleaning may help.

dino99 (9d9) wrote :

typo in post #2: its rpcbind, not cbind ....

Changed in rpcbind (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) wrote :

From what I can see in the code, this message is only ever logged to syslog. It's also a completely non-fatal error; and it's correct that these files don't exist at boot time. Is this only about the log messages? whoop, you say that you saw this "during boot" - do you mean on the console?

Changed in rpcbind (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
whoop (tiredandnumb) wrote :

I have output enabled during boot and I get the two file not found errors on screen...

Changed in rpcbind (Ubuntu):
status: Incomplete → New
Steve Langasek (vorlon) on 2011-09-01
Changed in rpcbind (Ubuntu):
status: New → Triaged
summary: - rpcbind.xdr / portmap.xdr : errno 2 (no such file)
+ spurious syslog error because of use of -w on boot [rpcbind.xdr /
+ portmap.xdr : errno 2 (no such file)]

@Steve

from top description: " while watching details into bootlog before sending an other report "

so it was logged into : bootlog

Changed in rpcbind (Debian):
status: Unknown → New
Max (maxmax) wrote :

This "error" started for me after upgrading from ubuntu 11.04 to 11.10.

My solution suggestion since this error is harmless:

Add two lines to the "start|stop)" part in /etc/init.d/rpcbind-boot so it will look like this:

start|stop)
    $ECHO
    $ECHO "Since the script you are attempting to invoke has been converted to an"
    $ECHO "Upstart job, you may also use the $COMMAND(8) utility, e.g. $COMMAND $JOB"
    if status "$JOB" 2>/dev/null | grep -q ' start/'; then
        RUNNING=1
    fi
    if [ -z "$RUNNING" ] && [ "$COMMAND" = "stop" ]; then
        exit 0
    elif [ -n "$RUNNING" ] && [ "$COMMAND" = "start" ]; then
        exit 0
    fi
    if [ ! -f /var/run/rpcbind/rpcbind.xdr ]; then touch /var/run/rpcbind/rpcbind.xdr; fi
    if [ ! -f /var/run/rpcbind/portmap.xdr ]; then touch /var/run/rpcbind/portmap.xdr; fi
    $COMMAND "$JOB"
    ;;

Max (maxmax) wrote :

:( I cannot edit that comment anymore but the touch needs to be added somewhere else, that place is not avoiding the boot "error".

rupert (r-plumridge) wrote :

Please also check the bug here: https://bugs.launchpad.net/ubuntu/+bug/882817

Quite a lot of people with issues being unable to shutdown after upgradeing to 11.10 and it seems a lot of us have nfs shares mounted. I see the above error message when booting up on the console before LightDM kicks in.

I then also see an error relating to rpcbind trying to restart during shutdown, which they seems to halt shutdown as not all processes are killed, I am thus concluding this is an issue relating to rpcbind or similiar.

It'd be great if we can get someone who knows what they are talking about to dealing with this bug, since having a PC that doesn't shut down and needs to be hard powered off is a right pita.

Steve Langasek (vorlon) wrote :

> Quite a lot of people with issues being unable to shutdown after upgradeing
> to 11.10 and it seems a lot of us have nfs shares mounted.

This error message has nothing to do with any boot or shutdown problems; that's what "spurious" means.

dino99 (9d9) wrote :

One more "spurious" issue that seems related to:

on cold boot with Precise i386, plymouth screen is showing several messages: "waiting dor network configuration", "waiting 60 more seconds" and finally "booting without complete network configuration"

these messages appear immediatly after rpcbind error (seeing if i switch to text console with F2)

Changed in rpcbind (Debian):
status: New → Fix Released
dino99 (9d9) wrote :

On Precise i386 with latest kernel 3.2.0.6 & util-linux 2.20.1-1ubuntu1
now the bootlog is clean, dont get the previous errors:
rpcbind: cannot open '/var/run/rpcbind/rpcbind.xdr' file for reading, errno 2 (no such file or directory)
rpcbind: cannot open '/var/run/rpcbind/portmap.xdr' file for reading, errno 2 (no such file or directory)

so it seems that this report can be closed and declared fixed.

dino99 (9d9) wrote :

Get this error back again; and now i cant boot completly: it hang at "check battery state", but its a desktop, so
Have to call a terminal to continue and login.

Ming Lei (tom-leiming) wrote :

On Precise amd64 with kernel 3.2.0-10 and util-linux 2.20-1, I still can see the error message, also my
machine may stop during 'warit for network configuration' for long time.

Ming Lei (tom-leiming) wrote :

The error message can be avoided by the change below[1], but which can not
prevent the warning[2] from being dumped during boot, so something is still
wrong.

[1],
--- /etc/init/portmap.conf.ori 2012-01-25 16:26:41.294206952 +0800
+++ /etc/init/portmap.conf 2012-01-25 16:16:03.884262204 +0800
@@ -31,5 +31,7 @@
   . /etc/rpcbind.conf
  fi

+ if [ ! -f /var/run/rpcbind/rpcbind.xdr ]; then touch /var/run/rpcbind/rpcbind.xdr; fi
+ if [ ! -f /var/run/rpcbind/portmap.xdr ]; then touch /var/run/rpcbind/portmap.xdr; fi
  exec rpcbind $OPTIONS
 end script

[2],
"waiting for network configuration",
"waiting 60 more seconds"
"booting without complete network configuration"

dino99 (9d9) wrote :

As this package is now fixed in Debian, please sync it before Precise release.

tags: added: precise

On Mon, Apr 16, 2012 at 05:34:26PM -0000, dino99 wrote:
> As this package is now fixed in Debian, please sync it before Precise
> release.

Debian has fixed an init script. A sync doesn't help fix the upstart-based
package in Ubuntu. Also, I recall looking at the fix in Debian and not
being very happy with it - I don't remember if it was because it wasn't very
good on its own, or if it just didn't translate well to the upstart job.

How about using the fix suggested by in Debian Bug # 645880 (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=645880) ?
Simply start rpcbind without the '-w' option if neither of the relevant xdr files exist.

I've modified the patch from the above Debian bug for compatibility with Upstart:

--- /etc/init/portmap.conf (0.2.0-7ubuntu1) 2012-05-23 11:06:40.755992557 +1200
+++ /etc/init/portmap.conf 2012-05-23 11:43:56.813215443 +1200
@@ -24,11 +24,15 @@
 pre-start exec mkdir -p /run/rpcbind

 script
- OPTIONS="-w"
+ OPTIONS=""
        if [ -f /etc/default/rpcbind ]; then
                . /etc/default/rpcbind
        elif [ -f /etc/rpcbind.conf ]; then
                . /etc/rpcbind.conf
        fi
+ if [ -e /run/rpcbind/portmap.xdr ] || \
+ [ -e /run/rpcbind/rpcbind.xdr ] ; then
+ OPTIONS="$OPTIONS -w"
+ fi
        exec rpcbind $OPTIONS
 end script

The attachment "portmap.conf.diff" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

+1 for the patch in #18, can we get a build and test done before 12.04.1?

martin suc (martin-suc) wrote :

+1 for the patch in #18

Steve Langasek (vorlon) wrote :

I realize that patch would suppress the error, but it's the wrong way to do fix this bug. The right way to suppress the error is to make -w not emit the error message in the first place.

pdf (pdffs) wrote :

Really? Considering `rpcbind -w` is meant to do a warm start, based on reading those files, having it warn when you tell it to do so and they don't exist seems pretty fair to me. And it's a simple fix, with minimal (no?) impact that doesn't require changing source code, or trying to get upstream to merge anything, seems like an easy win.

jth (jth) wrote :

Hi
I also have to dissagree with Steve Langasek (vorlon). If you use a command wrongly I do not see why it should supress the errormessages. Please apply the patch or this modified version after you have tested it.

I would like it as a default option and not to override or add to the custom options.
I have not tested it yet, but it should be something like this:

--- /etc/init/portmap.conf (0.2.0-7ubuntu1) 2012-05-23 11:06:40.755992557 +1200
+++ /etc/init/portmap.conf 2012-05-23 11:43:56.813215443 +1200
@@ -24,11 +24,15 @@
 pre-start exec mkdir -p /run/rpcbind

 script
- OPTIONS="-w"
+ if [ -e /run/rpcbind/portmap.xdr ] || \
+ [ -e /run/rpcbind/rpcbind.xdr ] ; then
+ OPTIONS="-w"
+ fi

        if [ -f /etc/default/rpcbind ]; then
                . /etc/default/rpcbind
        elif [ -f /etc/rpcbind.conf ]; then
                . /etc/rpcbind.conf
        fi
        exec rpcbind $OPTIONS
 end script

Please apply some patch, it has gone almost a year now since first report and that is not so great I think. Thank you.

Sparhawk (sparhawkthesecond) wrote :

Also related is bug # 947638, a supposed duplicate, where rpcbind complains about /run/rpcbind/* as opposed to /var/run/rpcbind/* (I get that error instead).

On 01/09/12 09:53, Sparhawk wrote:
> Also related is bug # 947638, a supposed duplicate, where rpcbind
> complains about /run/rpcbind/* as opposed to /var/run/rpcbind/* (I get
> that error instead).
>

The path changed between Oneiric and Precise, so they're essentially the
same error, unless you're getting the wrong path for your version, in
which case it's a totally different problem.

Ah ok. Thanks for that. I'm using Precise, and have a reference to /run/rpcbind/*, so that makes sense. Cheers.

Thomas Hood (jdthood) on 2012-09-26
summary: - spurious syslog error because of use of -w on boot [rpcbind.xdr /
- portmap.xdr : errno 2 (no such file)]
+ spurious syslog error message because of use of -w on boot [rpcbind.xdr
+ / portmap.xdr : errno 2 (no such file)]
dino99 (9d9) wrote :

Seen again these errors on booting, when the system had forced a fsck due to max mounted partition on QQ i386.

tags: added: quantal
Jason Tackaberry (tack) wrote :

jth's approach in #24 looks sensible to me. Why has it gone ignored?

dino99 (9d9) wrote :

Latest feedback while using RR i386:

at boot time, if fsck is forced to check a partition, then the "rpcbind.xdr / portmap.xdr" error appear, otherwise that error is not shown. Looks like a conflict or race situation.

Thomas Hood (jdthood) wrote :

Fixed upstream in 0.2.0-7. Precise now has 0.2.0-7ubuntu1.

Changed in rpcbind (Ubuntu):
status: Triaged → Fix Released
Steve Langasek (vorlon) wrote :

The Debian fix is not relevant, it's a change to the init script and Ubuntu is using an upstart job instead.

Changed in rpcbind (Ubuntu):
status: Fix Released → Triaged
Bogdan Stanciu (bstanciu) wrote :

hi there,

As I see this problem is still there, allow me to add my 2 cents to it...

first, from the man, -w' Cause rpcbind to do a "warm start" by read a state file when rpcbind starts up. The state file is created when rpcbind terminates.

therefore, the rpcbind throws a legitimate error when checking for non-existing state files. now, either it checks for wrong files (then where are the good ones) or the files should be there.

by running rpcbind stop, the files do get written to /run/rpcbind folder. however, they disappear after reboot (not sure when).

so, IMHO, either the files never get written on shutdown, or they get deleted sometimes between shutdown and boot (I doubt).

if the -w option was meant to be there, niether the patch nor the suppresion of the error message are valid solutions.

we should look into the shutdown scripts.

regards,
b

On Tue, Jan 29, 2013 at 02:10:01PM -0000, Bogdan Stanciu wrote:
> first, from the man, -w' Cause rpcbind to do a "warm start" by read a
> state file when rpcbind starts up. The state file is created when
> rpcbind terminates.

> therefore, the rpcbind throws a legitimate error when checking for non-
> existing state files. now, either it checks for wrong files (then where
> are the good ones) or the files should be there.

> by running rpcbind stop, the files do get written to /run/rpcbind
> folder. however, they disappear after reboot (not sure when).

> so, IMHO, either the files never get written on shutdown, or they get
> deleted sometimes between shutdown and boot (I doubt).

The files are of course deleted between shutdown and boot. If the system is
rebooted, it's no longer a warm start. That's why they're written to /run,
which is not persistent across reboots.

> if the -w option was meant to be there, niether the patch nor the
> suppresion of the error message are valid solutions.

I think -w being a separate option to rpcbind, and throwing a warning when
the file is not found, are both silly and this should be corrected upstream,
not worked around in the upstart job.

Juan Simón (simonbcn) wrote :

The problem still presents in Ubuntu 12.10...

Juan Simón (simonbcn) wrote :

I've tested the patch in #24 but it doesn't work. Still it shows the warning/error.

jth (jth) wrote :

Sorry to reply to everyone but the mail to Simon is no longer working. Also a note to Steve L.

Delivery to the following recipient failed permanently:
--[cut]--@j1s.es DNS Error: Domain name not found

> I've tested the patch in #24 but it doesn't work. Still it shows the warning/error.

>both folders are empty. In my Ubuntu (12.10) the folder "/var/run" is a link of "/run/".
>The init script creates the "/run/rpcbind" folder.
>/etc/default/rpcbind and /etc/rpcbind.conf don't exist.

Then I do not see why you got the error message that complain about an option you are no longer using. It works for me.

Check your init scipt..
w3:/etc/init# tail -n11 portmap.conf
script
        if [ -e /run/rpcbind/portmap.xdr ] || [ -e /run/rpcbind/rpcbind.xdr ] ; then
                OPTIONS="-w"
        fi
        if [ -f /etc/default/rpcbind ]; then
                . /etc/default/rpcbind
        elif [ -f /etc/rpcbind.conf ]; then
                . /etc/rpcbind.conf
        fi
        exec rpcbind $OPTIONS
end script

w3:~# ps aux | grep rpcbi
root 1886 0.0 0.0 19208 1068 ? Ss 08:11 0:00 rpcbind

To Steve Langasek how many are using and really need this warmstart compared to how many are getting this error message?
It is a nice feature if you often restart this service often on a file-server but far from everyone need to use warmstart and even less need to restart this service at all. If someone want this feature they can add it to the their configuration. Do not force it on everyone where it is not needed and also dispalys errors.

A better option is to just remove the -w in OPTIONS alltogether. No need to make global changes for everyone in corner cases. Please, note it in the NEWS and readme and upstream can fix this warmstart display issue when they want to.

--
Johan

sebastien.rey (reyman64) on 2013-04-08
tags: added: raring
richud (richud.com) wrote :

Bug still in 13.04 Raring Ringtail, from boot.log

fsck from util-linux 2.20.1
fsck from util-linux 2.20.1
rpcbind: Cannot open '/run/rpcbind/rpcbind.xdr' file for reading, errno 2 (No such file or directory)

rpcbind: Cannot open '/run/rpcbind/portmap.xdr' file for reading, errno 2 (No such file or directory)

techspotde (techspotde) wrote :

Having the same issue with raring aka 13.04.

Hoper (denispal) wrote :

I use NFS for keep maildir postfix (on other server).
I need to correct this probelmy for Ubuntu 12.04 LTS.

You need to press Ctrl+Alt+Del to pass the error message.

Then you can get into the login prompt.

Hi all!

Same error with Ubuntu 12.04.2 LTS (GNU/Linux 3.5.0-23-generic i686) at shutdown

Thomas Dreibholz (dreibh) wrote :

The problem still exists under Ubuntu 12.04.3 LTS.

p.tar (dap-chnual) wrote :

I'm not sure, if I'd found the reason for this bug being around in recent releases, but IMHO it is a remnant from a release update: I had it on two systems which I upgraded from 12.10 to 13.04

It's gone now on both systems after doing some de-/installing, including a complete deinstallation of all parts of KDE (w/ reboot) and the new installation of KDE 4.10

To repeat myself: I just guess the solution is related to the complete re-installation of KDE.
I'd done a lot of changes on the installed packages (to get rid of strange problems with dolphin and KDE-systemsettings in Ubuntu/Unity) and just saw afterwards, that, together with the strange problems, the rpcbind error was gone.

Hope this helps someone!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package rpcbind - 0.2.0-8.2ubuntu2

---------------
rpcbind (0.2.0-8.2ubuntu2) saucy; urgency=low

  * debian/rpcbind.rpcbind-boot.upstart: document that this job emits the
    start-rpcbind event. Thanks to Sebastian Audet <email address hidden>
    for the report. LP: #1222274.
  * Don't pass -w to rpcbind on boot up, since the files won't be there to
    be read. LP: #835833.
 -- Steve Langasek <email address hidden> Mon, 09 Sep 2013 02:38:53 +0000

Changed in rpcbind (Ubuntu):
status: Triaged → Fix Released
EvilSupahFly (seann-giffin) wrote :

This isn't much of a solution, but on 13.04, I simply created the two files manually as the superuser. They are empty, but it stopped the boot-screen complaining and there have been no negative side effects.

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.