network-manager preventing shutdown

Bug #875959 reported by rupert on 2011-10-16
50
This bug affects 11 people
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Network-Manager appears to be preventing shutdown on some machines, not sure what the common property is between the people mentioning the shutdown error here: http://ubuntuforums.org/showthread.php?p=11353570 but I am thinking it is down to Network-Manager, which is preventing the last stage of the shutdown, we get to the Plymouth screen and the harddisk stops, but the PC doesn't turn off and my wireless light stays on.

I managed to shutdown by killing Network Manager after seeing the error Killing All Remaining Processes [Fail] during shutdown, hence me thinking it is an issue with Network-Manager.

Essentially, if you kill Network Manager via sudo service network-manager stop first you can shutdown, without doing that, you can't shutdown.

rupert (r-plumridge) wrote :

This is on Ubuntu Oneric, upgraded from Natty.

rupert (r-plumridge) wrote :

Turns out my initial steps didn't fix the issue. So, I need to know, how can I debug a shutdown issue if the syslog facility is being killed before the issue occurs?

Changed in network-manager (Ubuntu):
status: New → Invalid
rupert (r-plumridge) wrote :

Well, this appears a bug to me, as a number of people are affected as evidenced by the linked ubuntuforum thread. I am thinking it is either a fault of network-manager or possibly modem-manager, which also seems to be killed successfully on the rare occassion when the computer does shutdown (by sudo service stopping random services).

rupert (r-plumridge) on 2011-10-27
Changed in network-manager (Ubuntu):
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Taylor Braun-Jones (nocnokneo) wrote :

This sounds like it could be the same issue I am having. In my case, switching to a non-graphical terminal allows the shutdown process to complete (e.g. Ctrl-Alt-F1). Same for everyone else here?

Taylor Braun-Jones (nocnokneo) wrote :

Hm, sounds like I may actually be affected by bug #567580.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers