Can't install Ubuntu 9.10, hangs before installing

Bug #459198 reported by Kamillus on 2009-10-23
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
Nominated for Karmic by Rostislav

Bug Description

Ubuntu 9.10 RC

I run the CD of Ubuntu 9.10 Karmic Koala, I choosed my language and to install Ubuntu but then I saw only black screen and the drive stoped reading CD. The same thing hapens when I choose to try without any changes.

My laptop is: HP Compaq 615

Rostislav (fsniper) wrote :

same problem with the same laptop with installed OS but I workaround it with change kernel line "...ro quiet usplash" to "...ro quiet vga=716" just one space between ro and quiet and for example vga=716....

to boot LiveCD you can press F4 and choose save graphics mode.....

I've completely don't know what to do with these bugs.

Rostislav (fsniper) wrote :

in this bug https://bugs.launchpad.net/ubuntu/+bug/454268 somebody said to use "noapic" option

Kamillus (kamil) wrote :

I will try both methods and see what happens. But first I will upgrade my BIOS.

Nevyn (nevyn-alive) wrote :

I have just tried to do a fresh install with the 9.10-rc 32 bit version. I can choose the language and if I choose run from disk or install It freezes.

this is new on the RC disk the previous beta I had installed although there were some missing files.

Niklas Kullberg (niklaskb) wrote :

Using 9.10RC LiveCD, Compaq 615 boots with the "noapic" option.
The "nolapic" did not work.

jason (jason-kim-jiho) wrote :

Using 9.10 released Live CD, HP DV2432CA hangs before installing, too. BIOS has been updated to latest version from HP.com, and tried both 'noapic' and 'nolapic' options, but still hanging.

Kamillus (kamil) wrote :

In my case both 'noapic' and 'nolapic' works for me. I also upgraded BIOS but it doesn't work without one of those two comands.

LittleMouse87 (littlemouse87) wrote :

First off, the "duplicate status" is wrong, since the issue here is that the installer hangs after selecting Language and saying Install, so I'm posting here.

My issue is exactly the same, so here's a little info, maybe you guys have a similar setup...

- I'm installing on an HP laptop (model:HDX9440ea) with the newest BIOS. It's a 64-bit PC.
- I checked the MD5 Sum of the ISO, so no download errors here. Also, I've burned the disk twice, so apparently no disk-burning issues either.
- I've burnt the issues to a rewritable DVD (that's DVD-RW), not a normal CD-R
- The BIOS has Hardware Virtualisation turned on (default would be off).

Anyone else who's experiencing this issue, care to see how your setup matches? Please post if you find a solution.

By the way, I get an eternally flashing underscore character in the top left corner of the otherwise black screen; I assume that it is the same for others? If not, there is a similar but different issue at http://ubuntu-ky.ubuntuforums.org/showthread.php?t=1305238 although there the Ubuntu graphic appears.

Strange issue; let's hope it gets resolved soon (No offense intended towards anyone, but it doesn't make a great first impression on newbies, after all, to have to make a hard reboot before even starting the installation procedure!)

I've got a Compaq 615 RM-74 and I was able after some reboots to launch the LiveCD and install Ubuntu.

However, since it's installed, it doesn't even show the white pulsing ubuntu logo screen. Everything just stops... the disk, etc.

I've tried adding noapic to grub using the inline editing option, I tried nolapic, nothing works.

I've got 9.10 32 bit LiveCD, md5 checksum fine, nicely burnt (I've used it to install ubuntu on 2 other laptops, just fine).

I just get a blank (backlight black) screen, no blinking underscore or anything...

I'm going to try and update BIOS, but I don't know if that'll help at all....

After BIOS update, the problem remains... It's so weird that I got the LiveCD to run once (after a lot of attempts), never more, and now it doesn't enter even in safe graphics mode. Neither the LiveCD nor the installed one. I'm gonna try 9.04 in the meanwhile...

I got it to boot... entered in recovery mode (only got it the second time, the first time it stopped somewhere, the second, it asked me what to recover and I said to resume normal boot), edited grub file to make the "normal" entry look like:
"linux (...) ro quiet noapic nolapic splash" (so basically added noapic and nolapic) and it worked.

You should check what's wrong and let us know when can we use all APIC and LAPIC functionalities.

I'm not sure if it's related, but my wireless card wasn't detected... I'm gonna check what's up....

TBarregren (thomas-barregren) wrote :

I encountered the same problem after updating from Intrepid to Karmic. The computer hangs immediately after Grub, with an underline cursor blinking at the top-left position A **workaround is to select version 2.6.28 of the kernel** in Grub instead of version 2.6.31.

I've also tried a fresh install, but as reported above, the installation hangs immediately after selecting the language.

TBarregren (thomas-barregren) wrote :

I upgraded from Jaunty (not Intrepid as I wrote above).

When booting in the recovery mode, the last message I see before the boot hangs is: "ACPI: EC: missing configuration, switch off interrupt mode."

In addition to all duplicates, I have found other reports that might have something to to with the problem: #338083, #454268.

TBarregren (thomas-barregren) wrote :

The workarounds 'noapic', 'nolapic' and 'vga=716', suggested above, don't work for me. Instead I found that 'acpi=off' works for me.

After updating Karmic I had to remove nolapic, maintaining noapic to get it to work (referring to comment #11).

I also had some trouble installing Broadcom wireless restricted drivers (it crashed and freezed on install) but I fixed it installing bcmwl-kernel-source ( $ sudo apt-get install bcmwl-kernel-source ).

I don't know how and if it's related to the module options I had to set and change above, just thought it was worth mentioning.

jan (janeser) wrote :

I am still fighting with this problem .ı had some succesful installs when checked efi , virtualization etc. section in bios but ı got bored . now ı use 7 because of this problem :( .I hopefully waiting for new LTS.

Kamillus (kamil) wrote :

Problem disappear when installing Broadcom STA wireless driver from repositories, don't think it's Bios fault, but rather kernel is the problem.

wrg (wrgarrett-gmail) wrote :

8.04 works fine, i'll stick with it untill this problem is solved. btw, I have same problem with Kubuntu 9.10! I am disappointed to say the least.

jan (janeser) wrote :

Someone says too '' it's about the 2.6.33
kernels link is here
http://<email address hidden>/msg28393.html

LittleMouse87 (littlemouse87) wrote :

The problem is that even if someone fixed the bug (and no-one seems to be interested in doing that, four months on from the original filing of the bug), there is no way to get the update, since the ISOs are never updated after the original release. Since we can't even boot into the LiveCD environment, we can't get the update, so we just end up waiting for the next release. Very disappointing indeed.

LittleMouse87 (littlemouse87) wrote :

This problem has been reported a number of times with computers from various manufacturers, and it is a major problem - the installer will not run! There doesn't seem to be a work-around and the (prospective) linux-adopter is left helpless (and disillusioned)! It is essential that this problem gets fixed as soon as possible, and definitely before the release of 10.04 LTS.

Changed in ubuntu:
status: New → Confirmed
Andrew Cartine (cartine) wrote :

I have the exact same problem with hp pav dv6-2162nr. I love Ubuntu but this is a big step backward, and super disappointing that after 3+ months the problem has no resolution.

Les Noland (lnoland) wrote :

I have the exact same problem. I had 9.10 on this machine before but it was an upgrade to 9.04. I had some problems with it and decided to reload from scratch only to find that I can't reload from scratch. It lets me choose the language and select the menu item to do the install, the CD spins for a bit and then just stops. I get a blank screen (save for a flashing cursor) which lasts a long time them finally, I get the message:

[ 200.938235] Kernel panic -- not syncing: Attempted to kill init!

Several people have registered their disappointment at how long ago this bug was reported and yet the problem is still not fixed. I'm more disappointed by the fact that it is not even assigned.

Kamillus (kamil) wrote :

I now know for sure that this is a problem with "b43" module that kernel loads. The walk through for me is boot installation with acpi=off parameter and after install another time and install "bcmwl" driver, this will ensure that "b43" won't get loaded at startup. As I see Ubuntu 10.04 will get shipped with this bug, also the kernel 2.6.33 so im waiting for 2.6.34

ps: sorry for my English :)

daviboy (david-davis-hotmail) wrote :

I too have had this problem and it was making me pull out what hair I have left. I uninstalled Ubuntu then when I tried to reinstall nothing but the BLINKING cursor in the left top hand corner. I came here and elsewhere but there were no solutions. In the end and for some unknown reason, I remounted the iso (ubuntu 9.10 amd 64) using nero rom but at 10X speed (i.e. low speed) - I honestly don't know why I did this but it's worked (I burnt on Verbatim CD-R using nero rom before as well!). I'm not saying it will help you guys but it's worked for me so I am duty bound to write to you - especially littlemouse whose comments I found on other sites. Please give it a go and If it does work for you please report back to help the likes of me who spent over 2 hours looking for solutions but did not find one decent explanation of help. Cheers

Hi all,
Installed Ubuntu latest version Lucid Lynx .64 on compaq 615 this is how :
In bios, put startup sequence with cd on top. (press f10 during startup and get to the startup sequence)
Start with cd inserted, a pink/violet screen appears for a few moments like 1_2 minutes with two icons on bottom of screen.
During this screen press F6
You will get to a menu with different options.
with first line "try ubuntu" selected press ok
when ubuntu started from disk, double click "install ubuntu" on desktop.
Go through all installation process.
After installation it will eject cd and restart but just once so do the following first thing after it has restarted :
go to System > Administration > Hardware drivers
Update all drivers (i had 3 : Broadcom B43 wireless driver and Broadcom STA wireless driver and ATI/AMD proprietary FGLRX graphics drivers) update by pressing the down right button after selecting driver in the list, one after the other.
Then restart.
Tadaaa. Done, works.

Thx Kamillus and everyone who posted on all forums I read.
Thx to everyone working to make Linux what it is : a positive revolution.

ps tried the .64 version because of a post on another forum, should try installing with .32 version later, because I think it's all about updating the drivers and the first install worked with the .32 cd I tried at first.
 Except I did not update drivers at the time when it restarted just once.

The last commenter said he could install Lucid without any problems, so marking this as fixed.

Changed in ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers