The notification area whitelist is missing from 13.04, making some applications unusable

Bug #1119420 reported by Paddy Landau on 2013-02-08
This bug affects 210 people
Affects Status Importance Assigned to Milestone

Bug Description

Unity has a whitelist option for the systray. For example, I can use the following to whitelist everything:

gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"

Selective choices are also possible.

However, that option has disappeared from 13.04. This is a serious omission, as some applications (such as TrueCrypt) use it extensively, and others (such as SpiderOak) actually require it for some of their critical functionality.

The ability to whitelist selected or all applications is vital for a functioning system. Please replace it.

EDIT: Discussion on the Ubuntu Forums:

dino99 (9d9) on 2013-02-08
tags: added: raring

As of today, no icons for ktorrent and truecrypt.

This is really bad for truecrypt, because you can't bring the mount/dismount dialog up again (relaunching the app gets you a 'Truecrypt is already running!" error). You have to dismount everything from the command line and kill the app if you want to get back to the GUI.

description: updated
dino99 (9d9) on 2013-02-08
Changed in unity:
status: New → Confirmed
dino99 (9d9) wrote :

AS the indicators are based on KDE technology, most of the reason for moving to indicators was for a common spec that can be shared, and the systray has been deprecated since 10.04 and left in for 3 years for apps to catch up; that still makes a long list of apps needing to update their design.

Unless I misinterpret the action, the disabling of whitelisting seems to be a move to force developers to support appindicators. But some developers, like the truecrypt guys, don't look like they ever will, so it only ends up hurting the users (since whitelisting worked fine).

If whitelisting were going to be completely removed, I could understand all this... but since it's still supported for Wine and Java, I don't get why the Unity devs want users to run into broken programs and switch desktops.

V字龍(Vdragon) (vdragon) wrote :

This bug blocks any input method users from accessing the input method icons not based on appindicator.
Ibus is still buggy and unusable to zh_TW users.

maxroby (maxroby) wrote :

Also skype, liferea, gnote indicators... no wayu in 13.04

Daniel Hurtado (dhurtado) wrote :

The problem also appears with cryptkeeper, which is quite important for me!

I guess it reads some kind of configuration at start. I can see skype icon (previously, 12.10, visible), but not gnote icon (just started to use it)

There is an hack? a workaround?

What kind of answer is "don't want to support broken apps"? why do I see skype icon? skype is or is not broken?

If this is open source based, I would like to read explaination and refer to code, or is not?

Not political like reply, be tech please.

Paddy Landau (paddy-landau) wrote :
chili555 (wrweston) wrote :

Also blocks Pidgin.

janevert (j-e-van-grootheest) wrote :

Also davmail

maxroby (maxroby) wrote :

also gnote

Borivoje Petrovic (borivoje) wrote :


Jeremy Collins (jeremy+ubuntu) wrote :

Also blueproximity

Kirill Kabardin (kkabardin) wrote :

Also Thunderbird FireTray addon.

Paulo Matias (paulo-matias) wrote :

Sorry, but this is simply lack of respect to users.

Paul Csiki (paulcsiki) wrote :

I require the Pidgin icon to be shown. This is a show stopper for me as I used the tray icon a lot.

@Paul i used Pidgin for pretty much 13.04 dev cycle and didnt miss the icon a single bit. it's always present on Unity bar anyway.

Paul Csiki (paulcsiki) wrote :

I use Pidgin 2.10.7 (libpurple 2.10.7) and the systray option is set to Always. Before the update the icon was there, after the update the icon disappeared.

dino99 (9d9) wrote :

note to those logged as gnome (shell):
 dont forget to install "TopIcons" from to get some app's icon to be displayed

Sorry i'm not using unity, so i cant say more.

David R. Hedges (p14nd4) wrote :

As I'm sure is the case with many other users and applications, this causes a regression / loss of previous functionality for Pidgin (despite some integration with the messaging app indicator, or whatever they call it): .

I acknowledge that some people don't use a particular tray icon, or features from it, but that doesn't diminish the validity of the use case held by many others who do utilize them, and have diminished functionality (or complete inoperability in some cases) as a result of this.

That said, I fear Canonical is taking the approach that our loss is inconsequential, and abandoning these icons provides a greater benefit. The two "benefits" I can see them arguing for are:
1. Less code provides less of a maintenance burden for future changes and less opportunity for bugs.
2. Eliminating all those crufty old apps that don't want to fall in line with Canonical's new appindicator approach makes the system "cleaner" and more "unified."

While either of those is arguably true in its own right, I have trouble imagining that this particular code (a mere 42 lines pulled out, by my count) would impose an undue maintenance burden, particularly considering they're retaining a hard-coded whiltelist for wine and java and will continue to support the dconf whitelist for years in 12.04 LTS. And, since this already required a user to modify a dconf setting to expose this functionality, those users are more likely to be aware of the caveats for 'legacy' icons versus appindicator icons, and at the very least should prefer having the functionality at all, even if inconsistent, compared to none.

George Doukas (geoduke) wrote :

Apart from truecrypt, cryptkeeper and pidgin, keepassx is also affected.
Please give us back the systray whitelist!

Fabio Hecht (fabiovh) wrote :

Wuala icon also

Timse (timshel86) wrote :

Vuze and checkgmail too.

Beowulf (s-highlander) wrote :

Canonical stated that Wine and Java apps will still be seen in the system tray. Vuze is a java app, and Skype for Linux is based on Wine, so this is definitely a bug.

Timse (timshel86) wrote :

I see Skype system tray icon working perfectly in Raring. It does have an AppIndicator menu, or automatic migration is very good.
My skype version is

Beowulf (s-highlander) wrote :

I depends. I have two workstations and one notebook. After upgrading them to 13.04, Skype is in the systray on the notebook, but is not in the systray on both workstations.

Nikke (nmellegard) wrote :

Running DavMail (an SWT java app) on 13.04 also does not show the tray icon. Although working, there is no way to interact with Davmail on 13.04 -- thus no way to change any settings or any of that (thankfully I upgraded from 12.10 in which Davmail was properly configured).

When started, Davmail shows a popup tooltip which should be aligned with the position of the tray icon. The popup is shown to the far left of the top panel (just above the BFB).

If I can submit log files or anything that can be of help, just let me know!

All the best

Aixa Ardin (aixaardin) wrote :

Also affects the hovering upon tray icon functionality on Gmusicbrowser. Come on guys don't be stubborn for just the sake of it. Give us back control of our operating system, now was not that the whole point?

Michael Dougherty (maackle-d) wrote :

Also prevents usage of entirely, which runs exclusively from the systray

HF (hf-t) wrote :

I'd like to see KeepassX and Cryptkeeper in the systray again

hgre (hendrik-grewe) wrote :

jeah want Cryptkeeper back...

Morten Jensen (jensenmo) wrote :

JungleDisk is also affected

amalgamas (bforbord) wrote :

I use gnote a lot and CryptKeeper for work. I may have to go back to 12.04 LTS. To bad!

On 05/23/2013 08:22 PM, amalgamas wrote:
> I use gnote a lot and CryptKeeper for work. I may have to go back to
> 12.04 LTS. To bad!
there is a working solution that i have applied on my raring installation

Yes, I saw that right after I posted my comment. It solved the issue, thanks to the developer!

Martin (cyderia8530) wrote :

CryptKeeper with appindicator:

KeePass2 with appindicator and appmenu support:

Thank you for the link for the patched Cryptkeeper, Martin. Works very well for me and provides a nice solution to a big headache...

As of yesterday, the patched Cryptkeeper provided by Alberto Milone (which was a nice solution for integrating Cryptkeeper to the Unity Appindicator) is not working anymore :-(
Surely must be a recently updated package which causes the regression - but I was not able to pinpoint which one exactly.
Can anyone confirm this regression?
I had to revert to the webupd8 "how-to-get-systray-whitelist-back-in" solution, but it is less convenient because it taints the Unity Desktop.

Also blocks ekiga

Stefan Sundin (stefansundin) wrote :

For TrueCrypt, see ppa:stefansundin/truecrypt

Chrome (and chromium)'s background applications have no icons with this change (gmail offline, hangouts etc) in addition to the chrome background application.

Tony (tnuk) wrote :

also claws-mail mail indicator blocked. plus the native mail notification in the system tray seems to not support claws-mail or is there a way?

Temujeen (temujeen) wrote :


Henning Sprang (henning) wrote :

It seems, like we(as Ubuntu Users) whould all be aware that we're just victims of a bigger standards war...

I searched a bit, as I was wondering if the whole problem is really that there is actually a new Standard everybody should adopt and Ubuntu just forcing this by stopping to support the old one, which is not a totally bad idea.
But ten it turns out that there is a whole big story of standard wars between multiple parties like GNOME, KDE, Freedesktop, Canonical, Ubuntu...

rajchinna (rajendran-bits) wrote :

Is there any update on this bug, i tried the fix from timekiller and that is not working since the recent update to the Unity in Ubuntu 13.04....

I have followed the instructions from

and it did not work out..

Paddy Landau (paddy-landau) wrote :

@rajchinna — Despite repeated complaints, nothing is happening. Mark Shuttleworth has decided to implement this and will not be swayed regardless of the problems it causes the users. Such a shame. The original is Bug #974480.

Paddy Landau (paddy-landau) wrote :

This problem is still occurring in 13.10.

Stephen M. Webb (bregma) wrote :

Unity does not have a system tray.

Not all applications are designed to work with Ubuntu. We respect the developer's choices, but stress that a user's experience may be suboptimal should they still choose to run such programs.

Changed in unity:
importance: Undecided → Wishlist
status: Confirmed → Won't Fix
summary: - The systray whitelist is missing from 13.04, making some applications
- unusable
+ The notification area whitelist is missing from 13.04, making some
+ applications unusable
Paddy Landau (paddy-landau) wrote :

@bregma: OK, not the systray, the notification area. I've changed the title to reflect this. Please don't call us up on using an incorrect name — I'm not a programmer with intimate details of the jargon.

We need the whitelist back, because this change has broken too many applications and has made Unity unusable for some people (literally; that's not an exaggeration). I know that we can choose to use Kubuntu, Xubuntu, etc., instead, but Unity is great and I really would love to continue to use it.

I understand that you have a reason for this (although the reason has been hidden from us), but please, your job is not to break things unnecessarily. Just add the whitelist back, that's all we're asking!

If a user's sexperience is suboptimal, well, that's better than being unusable, isn't it? A car that goes slow is better than a car that won't start.

You should not put this bug report as a Wishlist, because it is a reversion. The "fix" fixed nothing whatsoever, and broke several applications. It is making people's lives difficult. This is not a wishlist, but a requirement.

If you will not provide a whitelist, at least provide an alternative for those applications.


We're begging you.

Paddy Landau (paddy-landau) wrote :

Sorry, I meant "user's experience" — embarrassing typo!

tags: added: area notification
w-sky (w-sky) wrote :

13.04 is obsolte soon, but there is the same problem with 13.10, and as officially it is not a bug, but a so-called feature (or rather a totally wrong decision by Canonical), it can be resolved with a custom PPA that changes the panel to enable whitelisting again.

More info on this here:

Andreas Jonsson (sonofjon) wrote :

Also affects AutoKey.

manfreed (manfreed) wrote :

Also affects Google Chrome, and every chrome application that might add a tray icon. Still presents in Ubuntu 13.10.

NickNackGus (nicknackgus) wrote :

This bug is to readd whitelisting to the system tray, reverting the "bug" found here:

Let's compare some statistics as of January 19th, 2014:

People affected:
against whitelisting: 55
for whitelisting: 154

Bug heat:
against whitelisting: 284
for whitelisting: 684

I'd list statistics for the comments (seperately for applications affected and user opinions), but I lost count and the counting widget I wrote in the last half hour didn't work. There's surely an app for that, but hey, I'm a programmer.

Kurt Huwig (k-huwig-f) wrote :

This bug also affects multiget. See bug 850530

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Paddy Landau (paddy-landau) wrote :

Also affects Viber. It has its own solution , but that solution is non-standard and gets in the way of the desktop.

Jim Hurne (hurne-jim) wrote :

Is there a way to collect statistics on how popular the "fix" PPA's are? For example, it would be interesting to know how many downloads per month each PPA experiences. Such statistics might suggest just how important "fixing" this is for the community.

(My personal opinion is that the whitelist should officially be added back in. Does it really cause that much more maintanance work? Unfortunatly, many applications and application developers have not and probably will not provide appindicators for their apps. I think this is a fight that Cononical has lost. It has almost been a year since this bug was filed and it is clearly still an issue.)

Doug McMahon (mc3man) wrote :

For saucy in 2 ppa's (one orig., 1 a temp till orig. got saucy going), current # for amd64 -
2698 + 528 = 3226
Don't think such stats matter though..

Stats, community comments and user's wishes don't matter to Canonical nowadays. For all the recent decisions they have taken unilaterally which caused big turmoil among the community, they have never backed out because of the noise or widespread disagreement from its user base...
As it has always happened in history, when a financial or political power, organisation or group gains more leverage, they can impose their own views and they don't need to be "collaborative" anymore...

Michel-Ekimia (michel.ekimia) wrote :

@Stephen M. Webb (bregma) : I just cannot believe that you flagged this won't Fix.

GNU/Linux is also about supporting other and that attitude will again push people away from Ubuntu sayin' " My goddam icon does not appear like when when I was on Win , that os is sh*t ""

Because that's a Huge regression against the aim #1 of Ubuntu

Paddy Landau (paddy-landau) wrote :

Please see both bug #1305816 and bug #1305835 and click the green "Does this bug affect you?" (at the top of the report) if this bug affects you.

Anis Elleuch (vadmeste) wrote :

Canonical made exception for Java & Wine ??

Hey Canonical developers, are you applying Scrum method ?

goodknight (rememberthehill) wrote :

As a korean user, I use 'nabi' input method instead of the in-house 'iBus' input method: this is because, for some laptops like samsung nc 10, iBus won't notice korean/english keyinput, which has always been a problem since I first used Ubuntu back in 2005. And 'nabi' has a small panel that could go into the notification area. But now it can't. It's really bugging me because the screen is so small and I'll always see this panel.

Eugene Romanenko (eros2) wrote :

Indicators are extremly uncomfortable for instant messaging applications, please enable notification area in unity!

Changed in xpad:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 4.4
Adolfo Jayme (fitojb) on 2014-07-22
no longer affects: ubuntu
Karol Stasiak (stasiu88) wrote :

Meanwhile, programs written for Windows 95 still display in system tray in Windows 8.1.

Paddy Landau (paddy-landau) wrote :

@fitojb — Why "no longer affects: ubuntu"? It most certainly affects Ubuntu!

andi (andidechigora) wrote :

This problem is a real showstopper for me - happening on Trusty (14.04. LTS) for the Autokey package which is in the Ubuntu standard repositories.

Autokey is not startup up automatically and not showing in the notification area after reboot.

Please give us the whitelistss back!!!!!

Matt Hoover (the-one-eleven) wrote :

I have a pretty hacky workaround for this, my example is using autokey as mentioned by andi above. I added the following lines to a script in my ~/.kde/Autostart dir:

pkill autokey
sleep 10
nohup autokey-qt >&/dev/null & # runs in background, still doesn't create nohup.out

Basically autokey starts automatically, and I have no idea where to disable that, but I have noticed that the errors only occur when it starts right away. If I kill it manually and restart it after logging in, it works fine. So the script, since I don't know how to stop the autostart, just kills it right away (hacky), then waits 10 seconds and restarts it. It is working so far!

Changed in xpad:
milestone: 4.4 → 4.5
dino99 (9d9) on 2014-11-22
Changed in ayatana-ubuntu:
status: New → Invalid
dino99 (9d9) wrote :

hi all,

Comments to those complaining about the 'missing' whitelist:

- read again post #2
- the whitelist NEVER comes back: it's an Ubuntu's design decision (Mark itself) and hugely debated at time.
- it's up to each app designer/maintainer to adapt it to the actual design; there is no hope to get the whitelist back.

So report bug for each app still concerned, and ask their maintainer to do the required change(s)

no longer affects: unity
Changed in xpad:
milestone: 4.5 → 4.7
eridal (eridal) wrote :

Please make system-tray icons behave normal. Non-technical users are expecting to see them there, and some of them appear there, and can't understand why their applications wont show there.

eridal (eridal) on 2015-05-05
affects: ayatana-ubuntu → ubuntu
Changed in ubuntu:
status: Invalid → Confirmed
dino99 (9d9) wrote :

All the apps tweaks should have been made now to adapt the canonical design. So its time to close that report.

Changed in ubuntu:
status: Confirmed → Invalid
Changed in xpad:
status: Confirmed → Invalid
Paddy Landau (paddy-landau) wrote :

Why has this been changed to invalid?

The bug remains; some applications are still unusable.

Saying that the app tweaks "should" have been made is wishful thinking. I have already reported the relevant apps that I use, and of course nothing has been done about them.

Changed in xpad:
milestone: 4.7 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers