Ubuntu.com needs improved link to new Community Site

Bug #1172422 reported by Benjamin Kerensa on 2013-04-24
374
This bug affects 86 people
Affects Status Importance Assigned to Milestone
ubuntu-website-content
Wishlist
Unassigned

Bug Description

The Ubuntu Community link [1] is not prominently listed on Ubuntu.com [2] but instead has been left at the bottom of the site which gets the least amount of viewing and clicks (according to studies by Amazon, SeoMoz, Nielsen Research)

The Ubuntu Community is the core of the Ubuntu Desktop software and without the Community there is no Ubuntu. We should always keep the Ubuntu Community prominently displayed on Ubuntu.com and not kick it to the bottom so that more enterprise related sections can be highlighted.

Members of our community who knew the link was removed from the top said they had spent over twenty seconds looking for the new placement of the link... We cannot expect that regular visitors will spend that much time.

[1] http://www.ubuntu.com/community
[2] http://www.ubuntu.com

UDS-1305 Blueprint:
https://blueprints.launchpad.net/ubuntu/+spec/community-1305-ubuntu-website-planning

Misc: Pageviews drop-off 32% after clean up

information type: Proprietary → Public
tags: added: bitesize
description: updated
description: updated
Chris Johnston (cjohnston) wrote :

Based on Jono's feedback, I am marking this as incomplete until the section is ready.

Changed in ubuntu-website-content:
status: New → Incomplete
Sergio Meneses (sergiomeneses) wrote :

We can add contents from http://pad.ubuntu.com/communitywebsite-help-meeting-locos we have a lot of information in pads

Michael Hall (mhall119) wrote :

Anybody who wants to help get this bug fix released ASAP should go to https://wiki.ubuntu.com/CommunityWebsite , find a section of the new site that still needs help with content, and contribute to it. The sooner we turn it all green, the sooner we can publish it.

Benjamin Kerensa (bkerensa) wrote :

@chrisjohnston: The bug is valid because it affects multiple people. At most it could be marked opinion or even in progress but it meets the criteria for confirmed status. https://wiki.ubuntu.com/Bugs/Status

@mhall119: My understanding is that even when the new community site is finished that it may be awhile since design would have to agree to re-add it. My understanding is the removal was not because the new site was finished but instead to focus on certain content that are more of a priority.

From the Design Team's Announcement:
"By focusing our site navigation on the products themselves, we aim to make it clear for someone who is new to the site that Ubuntu is about all of these things: PCs, phones, tablets — you name it."

@SergioMeneses: Sure we can add content there but thats going to be a seperate site. My understanding is it will be http://community.ubuntu.com the issue is about making people clear that Ubuntu is about Community just as much as it is about Mobile, Cloud, Desktop and Server.

Changed in ubuntu-website-content:
status: Incomplete → Confirmed
Chris Johnston (cjohnston) wrote :

Ask the submitter to provide any necessary information in a comment, and make sure you subscribe yourself to the bug report so you will get any updates to the bug via e-mail.

n, you have been asked for more information (provide data and info to finish the community section of the website). That information has not been provided, so it meets incomplete.

Benjamin Kerensa (bkerensa) wrote :

@chrisjohnston: Thats actually a seperate issue that being creating a totally new project which may or may not be linked depending on design team and higher ups decision.

The Kubuntu Community maintains http://www.kubuntu.org/ along with our flavor of Ubuntu. Links to the community pages are prominent, right up top: both Find Help which points at http://www.kubuntu.org/support, and Contribute > http://www.kubuntu.org/community/contribute.

Finally, at the bottom of the short page, there is a direct link: Community > http://www.kubuntu.org/community/.

Without our community, we would disappear.

Courtenay Blackburn (cgbbfp) wrote :

it is sad to say but when i go to the http://www.ubuntu.com/ the first thing i see is a Advert for Landscape witch is far from what i see on http://lubuntu.net/ http://www.kubuntu.org/ http://xubuntu.org/

Tanya Edwards (tanya-edwards) wrote :

The removal of 'Community' from the top nav of the site was a decision by the business to make 'the primary ubuntu.com site navigation' more product focused. The decsion to move it to the footer fits in line with future plans for the site, and in testing the footer has always tested well.

We have not forgotten nor discount the importance of the community to ubuntu. The web team have a few other projects in progress, one being the above mentioned Community site, another being an improvement across all sites where the link to community information has more prominence. However, we are a team of 5 at the moment and therefore our work and release of site improvements are staggered.

We ask for your patience while we make these improvements to the ubuntu sites.

s.fox (silver-fox) wrote :

I am concerned that "testing" had only 12 participants [1]. It does not reflect well on a community our size, and would say the sample size is flawed if you are trying to draw conclusions from it.

[1] http://design.canonical.com/2013/03/three-main-types-of-user-behaviour-found-in-ubuntu-com-testing/

Tanya Edwards (tanya-edwards) wrote :

Thank you s.fox. We will bear that in mind in the future.

Benjamin Kerensa (bkerensa) wrote :

@Tanya Edwards: "was a decision by the business to make 'the primary ubuntu.com site navigation' more product focused."

That is exactly what the problem is.... Ubuntu.com is not Canonical.com it is the Ubuntu Website which is the web presence of a Community based desktop/server/mobile operating system.

Jono who leads Canonical's Community Team recently blogged about how decisions like this and communication would improve but it seems the design team did nothing to communicate this to the community.

"one area where I want to drive some improvements is making it easier for people to join the community. " [1]

"our engineers at Canonical are expected to openly and transparently perform all work that is not considered customer/company confidential."[1]

"we want to improve how we plan the delivery of work items, and make that planning more nimble. While the major decisions are reserved for primary discussion at UDS, we want to regularly and transparently checkpoint progress on those projects, and ensure things are moving along. To do this the engineering managers at Canonical will perform this planning on a monthly basis with our community. "[1]

So the main issues are:
 * Design Team did not conduct the work openly and in a transparent manner since the Community and its governance was not aware that this was planned.

* Design Team did not feel it neccesary to notify even its own Community Team at Canonical to inform them they were removing the link so it could be communicated to the Community and its Governance.

* Design Team is allowing a business decision to take priority over community yet Canonical Community Team Lead said he wants specifically to make it easier for people to join the community.

* Design Team did not even use Community Members to test but instead picked random people from a support mailing list (https://lists.ubuntu.com/mailman/listinfo/ubuntu-users) who may have no interest in the overall health of the community.

[1] http://www.jonobacon.org/2013/03/18/recent-ubuntu-community-refinements/

Changed in ubuntu-website-content:
status: Confirmed → Won't Fix
Mark Terranova (markdude) wrote :

Ubuntu ia *KNOWN* for it's awesome Community. Ask ANYONE in FOSS. All but the most extreme of ideologues will (possibly begrudgingly) will admit the wonderful Community they have formed is second to none. This bug is different than others marked *wont fix*. Most of them have been based on Canonical's long term vision. The idea of making this a *wont fix* BEFORE discussion takes place is horrid. Even more so since discussion and engaging the community was said to be important :(

s.fox (silver-fox) wrote :

It saddens me deeply when I read Won't Fix without a follow up comment. Canonical does not appear to value the ubuntu community, and to go further I fear it will not have one if this decision is not reversed.

Ms_Angel_D (mrsangeld) wrote :

It's ridiculous that this even has to have a bug report. The Community is a good part of the reason Ubuntu is where it is today. I'm very disturbed that this decision was made, and it that there seems to be no intention to change it.

Paul Tagliamonte (paultag) wrote :

Disappointing, but alas.

Linux was removed a while back, it wasn't trendy enough -- I s'pose Community has gone that way as well.

Warren Hill (warren-hill) wrote :
Download full text (3.2 KiB)

A Gentle Reminder

----------------------------

Ubuntu: "I am what I am because of who we all are." (From a definition offered by Liberian peace activist Leymah Gbowee.)

Archbishop Desmond Tutu offered a definition in a 1999 book:

    A person with Ubuntu is open and available to others, affirming of others, does not feel threatened that others are able and good, based from a proper self-assurance that comes from knowing that he or she belongs in a greater whole and is diminished when others are humiliated or diminished, when others are tortured or oppressed.

Tutu further explained Ubuntu in 2008:

    One of the sayings in our country is Ubuntu – the essence of being human. Ubuntu speaks particularly about the fact that you can't exist as a human being in isolation. It speaks about our interconnectedness. You can't be human all by yourself, and when you have this quality – Ubuntu – you are known for your generosity. We think of ourselves far too frequently as just individuals, separated from one another, whereas you are connected and what you do affects the whole World. When you do well, it spreads out; it is for the whole of humanity.

Nelson Mandela explained Ubuntu as follows:

    A traveller through a country would stop at a village and he didn't have to ask for food or for water. Once he stops, the people give him food, entertain him. That is one aspect of Ubuntu, but it will have various aspects. Ubuntu does not mean that people should not enrich themselves. The question therefore is: Are you going to do so in order to enable the community around you to be able to improve?

-------------------------
Source Wikipedia: http://en.wikipedia.org/wiki/Ubuntu_(philosophy)

I thought this was what we belived, and I hope we still do. The Ubuntu Community is at the heart of this; at least it should be;
and deserves more prominece.

================

From the Design Team's Announcement:
"By focusing our site navigation on the products themselves, we aim to make it clear for someone who is new to the site that Ubuntu is about all of these things: PCs, phones, tablets — you name it."

===============

No, Ubuntu is about the people: those of us who can design OS - And those who need their hands held. Personally I'm somewhere between the two: I help where I can but freely admit I still have a lot to learn: most of us do. The more you learn the more you realise you don't fully understand.

We are creating the products to benefit the community. Those we already have, and those who are yet to join us.

Our strength should be that "We are here to help, each other".

I have never felt that the Ubuntu family is, in any way, "us and them" even where there have been disagreements. Im sure these have always been a genuine misunderstanding as power users, developers and casual users have different outlooks. We all want the same thing: great products and great support. Most of us: all of us that contribute to:
    Ubuntu Forums,
    Launchpad,
    Ask Ubuntu,
    the community web sites,
    Development,
    etc.
are happy to give up our own time and expertise to keep this going.

Please Change the status of the bug from "Wont Fix" to "Co...

Read more...

QIII (qiii) wrote :

I realize it's a little late when the decision is already made, but ...

The "Focusing on the product" excuse is lame.

With a name like "Ubuntu", community is part and parcel of the "product". Leaving that defining component out of the "product description" is flying in the face of the name of the product and the meaning of the very word itself.

"Three clicks and out". If it takes more than three clicks to find something, most people will move on -- especially if they have to figure out the path of those three clicks by searching all over a page. If someone who is exploring Ubuntu doesn't see "Community" prominently displayed, they'll go to Fedora. Look at fedoraproject.org where "Community" is prominently displayed in the top menu. The page it leads to is simple: Links to the various community activities. The content is simple.

Fedora is going to out-compete Ubuntu in "Community". Strange, when Canonical delivers a product called "Ubuntu".

It's madness.

description: updated
Jono Bacon (jonobacon) wrote :

Folks, hold your horses.

The position or prominence of the word 'Community' on ubuntu.com does not have a direct correlation to the importance of the community in the eyes of Canonical or Ubuntu leadership. In other words, just because you don't see Community in the header doesn't mean we suddenly don't care about the community any more. Look at our work, I think it is a testament to the care we have about our community.

I do however think that the position and prominence of the word 'community' on ubuntu.com is an important discussion that we should have, but discussions about how we balance the needs of the dominant demographic and target audience on ubuntu.com (people who want to find out about the product) with the needs of our community and growing our community, is a discussion that we need to have at the next UDS; the very place designed to have those discussions.

For those who are passionate about the topic, please schedule a session, and lets get together with the web team to discuss a path forward. Emotive ranting about Canonical's intentions in a bug report is not the solution and just causes yet more bickering that gets in the way of us solving problems.

Finally, don't get too wrapped up on 'Won't Fix': people always flip out about 'Won't Fix'. This bug report is not actually about a bug, it is about a decision, and a decision you disagree with is not necessarily a bug, but a decision you disagree with is often a worthy point of further discussion, hence, lets please wrap this up here and discuss this at UDS in May.

description: updated
Jono Bacon (jonobacon) wrote :

Incidentally, one final point, I think a more accurate status for this bug is 'Opinion'. Let's set it to that in lieu of the discussion at UDS. Ben, can you do that; I don't have access.

description: updated
information type: Public → Private
summary: - Ubuntu Community lacks its historically prominent placement on
- Ubuntu.com
+ Gone
summary: - Gone
+ Ubuntu.com needs improved link to new Community Site
description: updated
Benjamin Kerensa (bkerensa) wrote :

I'm proposing a session at UDS to bring the community, web team, design team and Jono's team together to discuss this and find a good solution that achieves the need of having community highlighted on the Ubuntu.com frontpage while also taking into account the need to showcase other content.

description: updated
information type: Private → Public
affects: ubuntu-website-content → ubuntu-docs
Changed in ubuntu-docs:
importance: Undecided → Wishlist
status: Won't Fix → Opinion
affects: ubuntu-docs → ubuntu-website-content

@Jono (#19) ... I think you might be missing the point. While it's fine to say "The position or prominence of the word 'Community' on ubuntu.com does not have a direct correlation to the importance of the community in the eyes of Canonical or Ubuntu leadership," remember that perception matters. People are not rational. They make snap decisions based on instant visual cues. Community used to be up top, now it isn't. "Huh," says J. Random CommunityMember, "I guess my contributions aren't so important anymore."

This is one of the things you learn in media training. No amount of "Wait, what we really mean is..." or "Certainly our position hasn't changed, it remains..." can fix the damage done by seemingly innocuous visual (mis)placements. This small change is likely going to generate a round of negative press, distracting Canonical into a bit of damage control mode, and leaving folks feeling all-around a little less valued.

Jono Bacon (jonobacon) wrote :

@Steve I agree that people are not rational, but I am not interesting in having a discussion with irrational people; I am interested working with rational people to discuss the problem in the most appropriate venue, define solutions, document those solutions, and drive that work forward.

Warren Hill (warren-hill) wrote :

@Jono we are all irrational to an extent. I don't suppose for one second you did a cost/ benefit analysis before deciding who to love; and I don't believe those that love you do on that basis either.

I wouldn't expect you to want to talk to idiots, or those advocating stupid ideas but I have not seen any evidence of that here, from any individual.

Perceptions are important and if a section of the Ubuntu family feel less appreciated they will be less willing to contribute. Even if you still want them too.

I trust we all want the same thing here and that our differences are not fundamental but priority and emphasis. I trust we can move forward from here in a way we can all support.

John McCourt (butterman) wrote :

We're just the peasants. Our opinions don't really matter to them.

Jason D. Cupp (forrestcupp-s) wrote :

If UDS is the proper place to discuss having Community put back into the header, then maybe they should have waited for UDS to discuss taking it out in the first place. This is the classic Management vs Labor argument, and neither side has any understanding of the other. I know that Jono Bacon appreciates the community, and I've seen him stand up for us before. But I also know that he wants to keep peace with his coworkers, which I can understand.

Based on several actions by Canonical, it's not unreasonable or irrational for the community to feel like Canonical doesn't care about us at all, even if it's not the case. I agree with a point that Benjamin Kerensa made earlier, when he said that this isn't Canonical's web site; it is Ubuntu's web site. Ubuntu isn't selling any products; Canonical is. The community is what makes Ubuntu what it is. Canonical does a great job of packaging a great distro, but if it weren't for the support of a massive community, I doubt if Ubuntu would be anywhere near being market-worthy.

At the very least, doesn't it make sense to promote the fact that you have support options. Right now, you have to look at the fine print in the footer to see that Ubuntu even has support options. If I was checking out Ubuntu for the first time, and I didn't see "Support" glaring in my face, I think I'd look elsewhere. I don't want to use a relatively obscure OS without knowing I can get support for it. Guess where most of the support comes from? The Community.

Take a good, close look at this screenshot collection. One of these is not like the others. Can you see which? I've even added some cues.

http://i.imgur.com/cjvdBF4.jpg

Benjamin Kerensa (bkerensa) wrote :

@Steve Riley: great screenshot.

@Jason Cup: Per discussions with folks at Canonical they do not feel like they had any obligation to inform the community in advance of taking the community link off. I explained that this not canonical.com were talking about but instead Ubuntu.com the website of a community maintained operating system.

Dylan McCall (dylanmccall) wrote :

Jono, you mention we need to 'balance the needs of people who want to find out about the product with the needs of our community and growing our community.' I think that speaks to where we're misunderstanding each other, here. I think for a lot of people, that a software product _has_ a thriving community is in fact a very important selling point. That is, these things are completely not at odds. I imagine you have a similar view, seeing as you're the awesome community guy and all, so while I'm a fan of even spacing and not wandering off on a tangent, I'm a bit puzzled by the extent to which this is "balanced" at the present time.

I'm sure it'll all make more sense with a UDS session, but for a head start maybe it would help to feel out where the product thing conflicts with the community thing. How much community is too much community, and are there particular aspects of community that are seen as actively at odds with 'selling' a product?

Codingman (codingmanuf) wrote :

How sad. Come on guys! Ubuntu is an OS, not a TV! How come the community gets no recognision of what they do on the Ubuntu site? This saddens me that Ubuntu takes TV and tablet before the community which does so much for the development of what Ubuntu was 3 years ago, an OS. Sorry if you found this comment a waste of time to read, but I'm just giving my honest opinion.

description: updated
Jono Bacon (jonobacon) wrote :

Folks, I don't know how many time I need to say this, this is going to be fixed soon. We are planning on having the black bar at the top of the site and there will be a link to community.ubuntu.com when it goes live, which Daniel is comitted to by the end of May.

Benjamin Kerensa (bkerensa) wrote :

@Jono: This still does not address why it was removed with out discussion at UDS which was just weeks away and without notification to at the very least the community council. I have personally spoken with two members of the CC who thought they should have been notified especially since this had nothing that could affect Canonical from a competitor.

If the plan all along was to re-add it in some other element why was the link not left? It worked for years and could have remained or been transitioned to this "black bar" and the link could have been swapped out when the new community site was done. H

And finally even if Daniel has the new community site finished by may that doesn't mean the black bar will be up by then since thats a decision made by design team. So far this has actually impacted traffic for those who might come and start contributing... Canonical released analytics showing a 1/3rd drop in pageviews after it was removed https://blueprints.launchpad.net/ubuntu/+spec/community-1305-ubuntu-website-planning

description: updated
Peter Mahnke (peterm-ubuntu) wrote :

Ben,

The web team values the community, no matter what you say. One of the reasons we all work at the company is because of it. We never would intensionally hurt it. Your comments suggest that we just don't care -- that's not true. It really hurts us to read this thread.

I posted the stats this morning to help people understand the scope of change and perhaps guide the development of the new site - not to have you use it against us. We have a plan. It was and is a lot of work. We had to do it in phases. This was the best path forward. Design by committee at UDS wouldn't be the right way forward either.

We moved www.ubuntu.com to a product led IA, the community link (and the business link) had to go. We also knew, and are helping with the new community site and that partially allowed the change to the product-led IA. The 'black bar' or global nav as we call it, is closer than you think. Let's get the community.ubuntu.com site ready!

Peter

Benjamin Kerensa (bkerensa) wrote :

@Peter Just after this whole thing happened at least one Canonical employee (I won't name drop as not to throw him under the bus) told me flat out it would not go back and that it was staying in the footer. Then another even marked this bug as wontfix and then now that there has been people in the community and governance who are upset all of a sudden today there is talk about a 'black bar' as if we had been told this all along.

Seems like backpedalling a bit? Why would this not be appropriate for discussion at UDS? Because the community might then have a say in things?

Benjamin Kerensa (bkerensa) wrote :

This now meets the criteria for Confirmed with High Priority since it is confirmed by 46 people and growing and "Has a moderate impact on a large portion of Ubuntu users"

https://wiki.ubuntu.com/Bugs/Status
https://wiki.ubuntu.com/Bugs/Importance

Changed in ubuntu-website-content:
status: Opinion → Confirmed
Jono Bacon (jonobacon) wrote :
Download full text (4.0 KiB)

@Ben it seems apparent to me that this has stopped being about a bug and started becoming more of an axe to grind.

As we have mentioned multiple times, the blocker for this work is finishing community.ubuntu.com (tracked openly at https://wiki.ubuntu.com/CommunityWebsite) - a project that has been discussed at multiple UDSs, in which you have been in the sessions, and a project that I have asked Daniel Holbach to drive to completion.

We started the community.ubuntu.com project specifically in response to community feedback that the community pages on ubuntu.com did not serve the community well (particularly new community members), and we identified a clear set of work items that needed to be completed to deliver a better experience. With a crisp blueprint defined, we coordinated an open community docs jam, and with a few exceptions, we saw a lot of people sign up to work, and very few folks actually come through and deliver what they agreed to. Everyone agreed on the problem, but relatively few were committed to solving it. As such, I asked Daniel to work to get these folks to contribute their assigned work, and it has been nothing but an uphill struggle to bring this to completion.

I know you are aware of these challenges in bringing the project to completion, as we have discussed this previously, but in the midst of all of your complaints, interestingly, I don't see your name anywhere on that project page. Since this problem was raised I have asked you specifically if you would be happy to contribute to finish community.ubuntu.com, thus solving this problem (and actually making a better set of pages about our community) and being linked from ubuntu.com, and so far you have not demonstrated any interest in joining this effort to bring community.ubuntu.com to completion.

I find this saddening as I have seen you invest significant effort in highlighting this problem across social media, your blog, forums, news comments, and this bug. I have also see you extend significant effort in persistently questioning the web team and my team about why "community" was left off in the first place (to which I feel Peter and myself have both provided sufficient answers).

I can't help but think that if you had invested this effort instead in helping us to finish community.ubuntu.com, we would be much further along and would likely have community.ubuntu.com linked on ubuntu.com already.

Ubuntu is not a community defined by rallying ill will to solve problems, we are a completely that problem solves together and delivers solutions together. Unfortunately I have really seen here is you stirring the pot to make this more of an issue than it really is, with the seeming goal to force out a solution as a result of this ill well; a solution that is already in progress, a solution *you* can help us to deliver.

Also, I have seen you in many circumstances, typically when complaining about something, say "someone internally in Canonical told me X off the record". I have shared this feedback to you privately before, but this is nothing but stirring the pot; if you have some evidence to suggest that a someone is contradicting themselves, either come out and say it o...

Read more...

description: updated
Adam Porter (alphapapa) wrote :
Download full text (4.6 KiB)

> it seems apparent to me that this has stopped being about a bug and started becoming more of an axe to grind.

Danger, danger! Hypocrisy incoming!

> Everyone agreed on the problem, but relatively few were committed to solving it. As such, I asked Daniel to work to get these folks to contribute their assigned work, and it has been nothing but an uphill struggle to bring this to completion.

So some volunteers over-promised and under-delivered. This happens in every FOSS project, especially large, amorphous ones like Ubuntu. Was this not anticipated?

> but in the midst of all of your complaints, interestingly, I don't see your name anywhere on that project page. Since this problem was raised I have asked you specifically if you would be happy to contribute to finish community.ubuntu.com, thus solving this problem (and actually making a better set of pages about our community) and being linked from ubuntu.com, and so far you have not demonstrated any interest in joining this effort to bring community.ubuntu.com to completion.

Now it begins. Ubuntu creates a problem and then won't accept criticism from anyone who isn't working to fix the problem Ubuntu created. "We broke it; you fix it."

> I find this saddening as I have seen you invest significant effort in highlighting this problem across social media, your blog, forums, news comments, and this bug. I have also see you extend significant effort in persistently questioning the web team and my team about why "community" was left off in the first place (to which I feel Peter and myself have both provided sufficient answers).

The community finds it saddening that Ubuntu publicly de-linked itself from the community because of "design" issues. Now the community is told to attend an event and argue their position; but why was a meeting not held before removing the link?

Ben is not the bad guy here, he is simply one who is standing up and speaking out. Is it not possible that this decision made by these teams was a mistake? Is there a reason it can't be temporarily reverted (not the whole design, just the link) other than dogma?

Let me restate the question: which will do more damage to Ubuntu, having the community link on the page before its fancy new black bar is ready, or not having the link on the page before its fancy new black bar is ready? Which will generate goodwill, and which will generate the opposite? Which damages Canonical's relationship with the Ubuntu community? Will anyone be less likely to buy a hypothetical Ubuntu device because they saw a "Community" link at the top of the page?

After answering those questions, the right choice seems obvious to me. The sad part is that damage has already been done.

> I can't help but think that if you had invested this effort instead in helping us to finish community.ubuntu.com, we would be much further along and would likely have community.ubuntu.com linked on ubuntu.com already.

This is a nasty, underhanded card to play. Ben's criticisms are valid. He is not obligated to fix a problem he did not create, and he is not ineligible to point out problems just because he isn't doing what you or anyone else want him to do.

>...

Read more...

Chris Johnston (cjohnston) wrote :

Ben, you were told on April 17 (1 week before you created this bug) by Jono that after the new community site was done, the link at the top of the page would be back. You were also told by Inayaili on the 17th that there were more improvements coming to the navigation, to include community. Two times by two separate people you were told that the link would be put back before you filed this bug. To now state "all of a sudden today there is talk about a 'black bar' as if we had been told this all along" and "Seems like backpedaling a bit" is absolutely wrong. The only thing different is that now what they told you on the 17th has a name.

Adam, no one has told you to "argue" your position. As I have stated above as have multiple others. There will be a link again, but it will take a little bit of time. Not everything happens over night. It sounds to me today, just as it has all along, that Canonical plans on having a link to the community site in a predominate place. Because people from Canonical have stated that, you have no point to argue. They agree with you. What are you going to convince anyone of by arguing? You may disagree with the fact that the link was removed before the new one was added. Unfortunately it wasn't. But from day 1, it has been stated that links will be put back, just give it some time. Maybe if less time was focused on this bug, social media, blog posts, etc, more work could be done to prepare the new "black bar."

Adam Porter (alphapapa) wrote :

Chris,

> no one has told you to "argue" your position.

But Jono said:

> I do however think that the position and prominence of the word 'community' on ubuntu.com is an important discussion that we should have, but discussions about how we balance the needs of the dominant demographic and target audience on ubuntu.com (people who want to find out about the product) with the needs of our community and growing our community, is a discussion that we need to have at the next UDS; the very place designed to have those discussions. For those who are passionate about the topic, please schedule a session, and lets get together with the web team to discuss a path forward.

People keep complaining that people are complaining about this; people keep saying it's a non-issue because the link will eventually be put back.

These people are missing the point. There's no good reason to have removed the link before its replacement was ready. "It doesn't fit our design goals" is not a valid reason--that's dogma. That's putting "pretty" over people. This is like the KDE 4 debacle: KDE 3.5 was replaced with KDE 4 before KDE 4 had feature parity. (Whether this was KDE's fault or distros' fault is beside the point. The outcome is the point.)

People keep saying, "Come finish our new design and the problem will be solved!" But again, this is missing the point: it's not a technical problem! This is a people problem, a community problem, and a PR problem. Ultimately it is a symptom of a deeper problem that needs to be addressed, otherwise Ubuntu's future is at risk.

Here's what needs to happen:

1. Canonical needs to admit its mistake and apologize to the community for removing the link prematurely.
2. Canonical needs to put the link back now, regardless of any new design's status.
3. Canonical needs to finish their design before removing the link again. If Canonical insists on the new design, it needs to take full responsibility for it, and not complain that others aren't doing the work.
4. Perhaps most importantly, Canonical needs to do some serious reflection on its stance toward the community and the future of Ubuntu as a project.

This is not the first symptom, and we are not the first to notice the problem. I feel like our words are falling on deaf ears, though. I'm glad Debian is soldiering on, but it would be a shame if Ubuntu's community fell apart, because Ubuntu has done a lot of good for a lot of people, and for Linux as a whole. But when Canonical's leadership starts to lose appreciation and respect for the community, it's a very bad sign.

And that's what this bug is ultimately about: regardless of Canonical's intentions, feelings, or roadmaps, removing the link was like a slap in the face to the community. But rather than recanting and apologizing, Canonical has become defensive and has blamed the *community.* This is the worst sign of all.

Canonical, please do the right thing.

Jono Bacon (jonobacon) wrote :

@Adam Canonical is doing the right thing; as has already been clarified, the issue is being resolved, and members of the Web, Community, Design, and QA teams have all responded. This is a huge multi-team design and engineering project to deliver our web presence - adding a 'Community' link is not as simple as editing a source file. Our website used to be hacky back in the early days, but every decision now goes through design and engineering to stop it being hacky and instead provide a high quality experience.

I agree that the way this turned out was sub-optimal, but I also feel that Canonical have been very responsive in responding: there is an agreement from *everyone* that the link needs to return, an assurance it is coming back, and there is already significant Canonical investment from my team to make a *better* set of community pages.

This is not the case that Canonical doesn't care about the community and wants to demote the community; do you really think I would be happy with that? I assure you I would raise holy hell if I felt the community was being demoted by Canonical.

Our goal, and the goal with the new community website to provide a significantly better set of community documentation and on-ramps for folks who go to ubuntu.com and want to participate.

I assure you, our hearts are in the right place, and ultimately we will end up with a better solution for community members. We will discuss this more at UDS this week - be sure to join us.

Jono Bacon (jonobacon) wrote :

More context from the design/web team - http://design.canonical.com/2013/05/ubuntu-com-update/

QIII (qiii) wrote :

In the hearts of many, I fear, this comes too late, Jono. To many, and to me, it looks like "Oh, uh, yeah. We, uh, planned to put it back. Honest!"

Until I read Alejandra's message, I had pretty much held my tongue. This, however, is further insult to injury. There is not even the slightest hint from Alejandra that she, as the design team representative, felt any sense of contrition or understanding that this went far beyond "recent concerns".

We have an expression in the US about this sort of thing. It's vulgar for the intestinal waste products of male domestic bovines. If you don't mind, I wouldn't be unhappy if you carried that message to Alejandra.

Do you all really take the community for such easily duped imbeciles, Jono? My children would have seen through that before they had reached their 10th birthdays.

This needn't have taken a convocation of Nobel Laureates, Bishops from Rome and Heads of State to solve. This needn't have taken the mutinous uprising of the rabble. This needn't have awaited the eve of the UDS.

That the Community page was not done is a hollow, void and utterly childish excuse. In 35 years of professional life, I have never seen any project fully complete and perfect before roll-out. If things were done that way, nothing would ever happen.

This was not, at its heart, a "design issue". If not an overt slight, then at best a thoughtless oversight that should have been rectified immediately when it was pointed out. It should never have been any kind of "issue". There should never have been "recent concerns."

Someone with some guts and spine just needed to say "Hey, it's just a link. Put it back."

I'm gravely disappointed in a company that produces something called "Ubuntu" and sets community aside only to backpedal and present such nonsense when called out.

Sorry, Jono. Sorry, Alejandra. Sorry, Chris. I don't buy it. What I see is a callous, intentional move that only drew attention when the peasants threatened to revolt.

QIII (qiii) wrote :

By the way, Chris, it was you whose hypocrisy gave you all away:

"Confirmed → Won't Fix "

This doesn't sound like it was planned all along.

Shame on you all.

Benjamin Kerensa (bkerensa) wrote :

Hello Everyone,

So it does appear that emotions are still high for some of us over this issue but lets not let that push us to grab pitchforks and call Canonical evil because that was never my intention with this bug report. I think what has happened here is miscommunication and all of this could have been avoided had there been better communication while at the same time I do not believe its feasible for Canonical to run every little decision they make as a company.

I spoke with Jono this evening and we discussed the timeline of all of this and I'm convinced that the solution the design team announced is top notch and in fact it actually would place the new community link (which will point to the new improved community site) much higher then it was in the previous design which I believe is a major win for the community.

That being said I do think its important for us all to be able to share our opinions and I have shared mine on my blog and that opinion has also evolved now that there has been more info on the design provided and I'm quite satisfied with the proposed design "global nav bar" that will be added.

With UDS being just hours away lets all come together to work on the sauciest salamander we possibly can!

Elfy (elfy) wrote :

Of course there should have been better communication.

That's nothing new, in fact the 'community' team leader blogged about much the same thing a couple of months ago, shame it wasn't more than a blog.

There have been comments within this bug report that all of this had been talked about - obviously so much and with such clarity that people in the community must have been looking the other way.

It's another example of the community in Ubuntu being ignored - all the blogs in the world will make no difference when something as important as community is the last thought.

It's about respect - it's quite obvious that parts of the community feel they have no respect.

What is more telling is that the Community Council is not taking part in this discussion.

Or that the 'community team' haven't called a meeting with the community to discuss the way that they're failing to engage with the greater community.

But those are all things that can be marked as 'Won't Fix' elsewhere.

Benjamin Kerensa (bkerensa) wrote :

@Elfy: I do not dispute any of your points and I feel the same way and its good to know you and the other members of the forum council value the community just as much as I do. I know your eager to see improved communication between Canonical and the community and I would encourage you to provide feedback as to that in the Community Roundtable at UDS.

Additionally, I would say that although the Community Council is not engaged in the discussion there has been at least one or two members of the CC who were vocal about their disappointment but I think now that there is a better understanding of whats going on we have a real solution and should perhaps focus our energy on just trying to improve communication and planning so that everyone can feel respected.

I'm personally going to spend some time this upcoming cycle trying to see about getting some kinks in communication/planning improved and I do really think their are solutions out there.

varunendra (varunendra) wrote :

Ben,

> I think what has happened here is miscommunication and all of this could have been avoided had there been better communication

I don't believe it was just "miscommunication", it was ignorance. That does not make me call Canonical evil, but it was, and still is ignorant of community - is a fact clearly visible here. I appreciate what they have done with Ubuntu and with Linux in general, but I do not appreciate when they ignore what was a greater reason why I chose Ubuntu.

> I'm convinced that the solution the design team announced is top notch and in fact it actually would place the new community link (which will point to the new improved community site) much higher then it was in the previous design which I believe is a major win for the community.

I don't see anything new in it than what has already been promised consistently after a certain point on this page, while constantly missing (or ignoring) the point of this bug report. The original question remains - "Why was the need felt to move the link to the most ignored area of the homepage ?" And whatever 'answers' have been provided do not convince me that it was necessary.

The link is still where it was when the bug was reported, I do not see a 'win'.

And even if 'you' consider it a victory, I don't see how it can be pleasant. Are we contesting with Canonical team where we should have been working together, while appreciating each other's work?

I do not need a 'win'. I do not want the link back in a way that says - "ok, here we put it back. Now shut up !". I want an immediate action that shows an honest acceptance of a big mistake they made, and that shows a real care for community's feelings.

For me, the bug is still not 'fixed'.

QIII (qiii) wrote :

It's a terrible thing when you catch someone who, hand still in the cookie jar, says "It's not what it looks like. I'm going to talk to my friends about maybe putting them back after we see each other this weekend. Oh. Urm. That's not it. I had planned to put the cookies back. That's it! Yeah. Honest!"

QIII (qiii) wrote :

I have to agree with verunendra.

This bug is not fixed simply by making sure the link is restored.

An apology to the community is a necessary component of the fix.

Jono, Chris, Alejandra ... are you listening to those who do not exist to give you a job, but for whom your job is to provide a product?

varunendra (varunendra) wrote :

I think we made clear that we are hurt and sad, and that we are not a bunch of fools who can be manipulated anytime using weak excuses. Now let's not push for an apology. Respect comes naturally, or not at all.

I still love Ubuntu and am proud to be a part of the community. But I am also proud of what I have to offer to the community. I'm just confused at the moment if I'm offering it at the right place, for right people.

What is happening here (apparently happening for quite some time), is nothing new in the FOSS world. It is just so painful that people can be so easily overwhelmed by little success and recognition that they start finding it easier to make mistakes but too hard to make an apology. They totally forget the simple truth that it is just the opposite that actually earns them trust and respect.

Heck, this 'discussion' dragged to 50 comments and continuing when it shouldn't have existed in the first place! If it kept dragging like this, soon the point will become moot when a said 'fix' or a 'convincing version' of it will be applied. But I know that in that case, I'd still be confused even it they covered the whole page with the said 'black bar'. Confusion that am I contributing my time and efforts in the right place? Confusion that is there a guarantee that I will not be slapped in the face again, just because they will have a compensation for it?

Sure there is a wider community out there and I'm free to join any or all of those I like. But... really? Have they gone insane to drive people away like this? I don't see the original mistake (the removal, yes, removal of the link) as a small one. But now they are making it even bigger by trying to 'patch' it.

Why is it so difficult to accept a mistake when everyone has recognized it. And then why is it so difficult to stop making excuses and show some real respect to your own people who are only helping you to shine more? Oh I see - the plan about the 'compensation'. But you guys need to see - that's not going to work out for everyone here. The real 'fix' is real simple and there is no shame in it. I can't think what is making it difficult to be applied.

Guess now I am pushing too... stupid me!

asm (asm666) on 2013-05-15
description: updated
Adolfo Jayme (fitojb) wrote :

Wow, what a shitstorm over a single link! Wow!

Benjamin Kerensa (bkerensa) wrote :

@fitoschido: To maintain a respectful atmosphere, please follow the code of conduct - http://www.ubuntu.com/project/about-ubuntu/conduct . Bug reports are handled by humans, the majority of whom are volunteers, so please bear this in mind.

varunendra (varunendra) wrote :

fitoschido,

Think of it like the organizers of the Olympics 'forgetting' to hoist your country's flag in the Olympics stadium. After all, it's "just a piece of cloth they forgot to hang...., and they've already 'promised' to 'hang it soon', 'after being reminded'..."

Or think of it like the organizers of a "General Meeting of Shareholders" forgetting to reserve a seat for you when you are one of the top shareholders. After all, it's "just a seat.., they've already ordered one 'after being reminded'..."

You wonder about perception of such people about these things and events when they make such remarks !

quequotion (quequotion) wrote :

I think varunendra has put it very well, so I'll skip giving my take on how offensive this has been.

I would like to point out that sadly, it doesn't surprise me. There have been a number of issues over the last few years where Canonical has made it abundantly clear that they will not commit resources to community demands nor will they accept changes contrary to their in-house development (NotifyOSD stands out in memory as an example of both). The community of developers and users are being excluded one step at a time, and it isn't hard to see why.

Ubuntu is being driven toward a commercial product. The priorities for Canonical are branding and monetization--not karma or community. The goal here is to take the work of all these people and sell it to people who won't be interested in getting involved. Google's already proven that it can be done and now Canonical wants their share.

I find this deplorable. First of all the strategy is full of holes: the best product in the lineup is the Ubuntu phone; but what chance does it really have against Android's market share? The rest of cannonical's innovations are mythical creatures: Ubuntu TV is redundant at best and not happening at worst. The only really viable "markets" for Ubuntu right now are desktops, laptops, and tablets. Second, Ubuntu is supposed to stand for something: it may not be as purely free as Debian, but it does inherit the work and spirit of people who want the best operating system they can make without the hassle or costs of a corporation pulling the strings. Bug #1 is not going to be resolved by ditching the most loyal "customers" Canonical has. Finally, they've shown that they'll take action against the community without notice: suckerpunching the very people their products are built for and by.

If I may bring this all to a point: I want more than a new menu and an apology; I want Canonical to promise, publically, that it will respect and respond to the community that supports it.

Peter Mahnke (peterm-ubuntu) wrote :

On the 31 May 2013, the new Community website (http://community.ubuntu.com) was released and the new global nav was released across five sites (more to come). The community site is a word press site, and the community can manage the content directly. The global nav makes this site far more prominent than previously on www.ubuntu.com and across other sites in the Ubuntu family of websites.

Changed in ubuntu-website-content:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers