Automatic change of landscape on planet change

Bug #1173254 reported by Pierluigi Panunzi on 2013-04-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stellarium
Fix Released
Wishlist
Alexander Wolf

Bug Description

I'm using "guereins" as a landscape (I like that ocean of grass!), but if I want to change my point of view, this landscape remains for all the other objects of the solar system...
If you open the "Location window" (key F6) you can change your position from the list box named "Planet:" ...
so you can "go to" Saturn but unfortunately the default landscape remains, giving us an excellent photograph of a terraphormed Ringed Planet !!

:-)

I know it's trivial to change landscapes, but I'd like to see a minimum level of authomatism in my favorite Astronomical program!!
 ;-)

BTW Starry Night Pro Plus changes landscape according to the chosen object...

Thanks
Pierluigi

Related branches

Changed in stellarium:
importance: Undecided → Wishlist
status: New → Confirmed
Alexander Wolf (alexwolf) wrote :

A fix has been committed as revision 5997 of the trunk branch in Stellarium's Bazaar repository at Launchpad:
http://bazaar.launchpad.net/~stellarium/stellarium/trunk/revision/5997

Changed in stellarium:
status: Confirmed → Fix Committed
assignee: nobody → Alexander Wolf (alexwolf)
milestone: none → 0.12.2
Bogdan Marinov (daggerstab) wrote :

I have the feeling that the "fix" is going to explode under a certain condition. Testing...

And if it does, I wonder who should I shoot first - the one who requested it or the one who implemented it.

summary: - wrong landscape for solar system objects
+ Automatic change of landscape on planet change
Bogdan Marinov (daggerstab) wrote :

OK, for a moment I was afraid that this would create an endless loop if the "use landscape location" option was checked, but it won't - it's in the wrong place for that. I'm still not certain that it won't create problems, though.

Anyway, the "fix" won't do:
- while it addresses the specific use case described in the original report (picking a planet from the menu in the Location window), it doesn't affect the other ways of changing planets (such as scripts and Ctrl+G "jumps").
- it assigns a landscape only to those SSOs that have landscapes named after them (Moon, Mars and Saturn)
- the location/landscape interaction is already a mess (thanks to "use landscape location"), no need to add to it. (I still haven't gotten over the "goHome()" method.)

In theory, such a feature could be implemented. But it will require more work and careful planning.

There have been discussions about doing something similar in the past (there is a "landscape" parameter left over in the ssystem.ini file from that period). I'll try to find them.

Bogdan Marinov (daggerstab) wrote :

The combination of the "fix" and the "use landscape location" feature _does_ create some kind of problem. I'm getting this in the log:

"Can't create StelObserver on planet SpaceShip because it is unknown. Use Earth as default."
"Can't move from planet SpaceShip to planet Mars because it is unknown"

I think that the planet selections triggers an observer location change, perhaps twice - the second time interrupts the progress of the first transition. I need to test this, but I wonder if there is a point. I still haven't decided whether I should revert the change.

By the way, I found a localization bug that hasn't been detected before.

Changed in stellarium:
status: Fix Committed → Fix Released
Pierluigi Panunzi (piellepi) wrote :

I'm testing this bug in the new version (0.12.2 - 32 bit - Windows 7), but unfortunately it seems to me it doesn't work...

these are my testing steps:
- I start stellarium with Guereins as default landscape
- I search Jupiter and go there (Ctrl-G) : the landscape remains
- I change the landscape to Saturn's one
- I return back to the Earth (pressing "Return to default" in the location page) but I find myself on a cloudy planet: no Guereins...

For me the bug still remains... :(

Thanks !!
Pierluigi

Alexander Wolf (alexwolf) wrote :

In original report you say about Location window (access via F6) but why you test it via Space Ship (Ctrl+G) now?

when I wrote
..."go to" Saturn...
I was referring to the Ctrl-G command that even in the Help page is described as
Set home planet to selected planet Ctrl+G
Is it important to distinguish Ctrl-G from the "F6 method"?
I always supposed it's the same to use ctrl-G or change location via F6: why wouldn't it be so?!
I always use Ctrl-G as a shortcut to F6-choiceoflocation-choiseofplanet-enter and so on...
and in this situation I discovered that the landscape doesn't change

so, what is the difference between Ctrl-G and "F6 long method", if any??
why "Ctrl-F method" wouldn't work as the "F6 method"?

But now the problem is that even if you choose Jupiter via "F6 method", there's no change in the landscape :(

________________________________
 From: Alexander Wolf <email address hidden>
To: <email address hidden>
Sent: Saturday, August 10, 2013 7:42 PM
Subject: [Bug 1173254] Re: Automatic change of landscape on planet change

In original report you say about Location window (access via F6) but why
you test it via Space Ship (Ctrl+G) now?

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1173254

Title:
  Automatic change of landscape on planet change

Status in Stellarium:
  Fix Released

Bug description:
  I'm using "guereins" as a landscape (I like that ocean of grass!), but if I want to change my point of view, this landscape remains for all the other objects of the solar system...
  If you open the "Location window" (key F6) you can change your position from the list box named "Planet:" ...
  so you can "go to" Saturn but unfortunately the default landscape remains, giving us an excellent photograph of a terraphormed Ringed Planet !!

  :-)

  I know it's trivial to change landscapes, but I'd like to see a minimum level of authomatism in my favorite Astronomical program!!
  ;-)

  BTW Starry Night Pro Plus changes landscape according to the chosen
  object...

  Thanks
  Pierluigi

To manage notifications about this bug go to:
https://bugs.launchpad.net/stellarium/+bug/1173254/+subscriptions

Alexander Wolf (alexwolf) wrote :

Pierluigi, please read comments by Bogdan Marinov.

Pierluigi Panunzi (piellepi) wrote :

oh yes!
so I think the best solution is to search/create a landscape for
- rocky asteroids and moons,
- gaseous planets,
- the sun
- other objects (icy satellites for example)
and then associate this landscape in the relevant item in "ssystem.ini" adding the keyword "landscape= name"...

I think that the one for rocky asteroids and moons should be set as the default, as the number of such objects is great ...

I think that "saturn" landscape (by Michael Smith) could be adapted (by means of PhotoShop work) for Jupiter, Uranus and Neptune, while something like "moon" (taken from the Apollo mission, NASA) could be adapted to obtain something useful for rocky asteroids and moons...
I guess that the most difficult could be the default landscape for Io, the famous Galilean Moons!

thanks
Pierluigi

________________________________
 From: Alexander Wolf <email address hidden>
To: <email address hidden>
Sent: Sunday, August 11, 2013 12:43 PM
Subject: [Bug 1173254] Re: Automatic change of landscape on planet change

Pierluigi, please read comments by Bogdan Marinov.

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1173254

Title:
  Automatic change of landscape on planet change

Status in Stellarium:
  Fix Released

Bug description:
  I'm using "guereins" as a landscape (I like that ocean of grass!), but if I want to change my point of view, this landscape remains for all the other objects of the solar system...
  If you open the "Location window" (key F6) you can change your position from the list box named "Planet:" ...
  so you can "go to" Saturn but unfortunately the default landscape remains, giving us an excellent photograph of a terraphormed Ringed Planet !!

  :-)

  I know it's trivial to change landscapes, but I'd like to see a minimum level of authomatism in my favorite Astronomical program!!
  ;-)

  BTW Starry Night Pro Plus changes landscape according to the chosen
  object...

  Thanks
  Pierluigi

To manage notifications about this bug go to:
https://bugs.launchpad.net/stellarium/+bug/1173254/+subscriptions

Bogdan Marinov (daggerstab) wrote :

The solution to __what__ exactly? I did mention the lack of default
landscapes for other bodies in my comment, but I find it a really
minor issue, if it is an issue at all.

Pierluigi Panunzi (piellepi) wrote :

sorry, but I definitely don't understand...
is Ctrl-G a shortcut to the "F6 method" ?
if yes, the landscape should change accordingly (as in "F6 method")
if not, what are the differences?

The fact is that "going to" Saturn, Mars or the Moon with the direct mode (Ctrl-G) , does NOT change the landscape at all, even if those objects have a default landscape in ssystem.ini: THIS is the real bug... ;)

Please don't abandon the Ctrl-G key!! :)
it's really fantastic, fast, consistent with Celestia, but unfortunately doesn't change the landscape

Pierluigi

________________________________
 From: Bogdan Marinov <email address hidden>
To: <email address hidden>
Sent: Sunday, August 11, 2013 3:14 PM
Subject: Re: [Bug 1173254] Re: Automatic change of landscape on planet change

The solution to __what__ exactly? I did mention the lack of default
landscapes for other bodies in my comment, but I find it a really
minor issue, if it is an issue at all.

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1173254

Title:
  Automatic change of landscape on planet change

Status in Stellarium:
  Fix Released

Bug description:
  I'm using "guereins" as a landscape (I like that ocean of grass!), but if I want to change my point of view, this landscape remains for all the other objects of the solar system...
  If you open the "Location window" (key F6) you can change your position from the list box named "Planet:" ...
  so you can "go to" Saturn but unfortunately the default landscape remains, giving us an excellent photograph of a terraphormed Ringed Planet !!

  :-)

  I know it's trivial to change landscapes, but I'd like to see a minimum level of authomatism in my favorite Astronomical program!!
  ;-)

  BTW Starry Night Pro Plus changes landscape according to the chosen
  object...

  Thanks
  Pierluigi

To manage notifications about this bug go to:
https://bugs.launchpad.net/stellarium/+bug/1173254/+subscriptions

Alexander Wolf (alexwolf) wrote :

Ctrl-G is NOT a shortcut to the "F6 method". Ctrl-G is a SpaceShip - it's a very different method for change of the planet.

Alexander Wolf (alexwolf) wrote :

I added new option for auto selection of landscapes of planets when planet is changed: http://bazaar.launchpad.net/~stellarium/stellarium/trunk/revision/6184

Pierluigi Panunzi (piellepi) wrote :

sorry, but I don't understand the difference between Ctrl-G and the "F6 method" to change the location...
:(
Ctrl-G is called "Set home planet to selected planet" in the help (F1), so what is the "StarShip" you mentioned?
could you kindly explain me, so I can understand and explain to my friends who use Stellarium!?  :)

Thanks
Pierluigi

________________________________
 From: Alexander Wolf <email address hidden>
To: <email address hidden>
Sent: Monday, August 12, 2013 7:21 PM
Subject: [Bug 1173254] Re: Automatic change of landscape on planet change

Ctrl-G is NOT a shortcut to the "F6 method". Ctrl-G is a SpaceShip -
it's a very different method for change of the planet.

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1173254

Title:
  Automatic change of landscape on planet change

Status in Stellarium:
  Fix Released

Bug description:
  I'm using "guereins" as a landscape (I like that ocean of grass!), but if I want to change my point of view, this landscape remains for all the other objects of the solar system...
  If you open the "Location window" (key F6) you can change your position from the list box named "Planet:" ...
  so you can "go to" Saturn but unfortunately the default landscape remains, giving us an excellent photograph of a terraphormed Ringed Planet !!

  :-)

  I know it's trivial to change landscapes, but I'd like to see a minimum level of authomatism in my favorite Astronomical program!!
  ;-)

  BTW Starry Night Pro Plus changes landscape according to the chosen
  object...

  Thanks
  Pierluigi

To manage notifications about this bug go to:
https://bugs.launchpad.net/stellarium/+bug/1173254/+subscriptions

gzotti (georg-zotti) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers