Particular configuration prevents selecting Earth landscapes

Bug #1700199 reported by R Rieffel on 2017-06-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Stellarium
Fix Released
Low
gzotti

Bug Description

I believe I found a configuration that prevents Earth-assigned landscapes from being selected in version 0.16.0 (Windows x64).

BRIEF DESCRIPTION OF ERROR:

If "Auto select landscapes" ("flag_landscape_autoselection") and "Use associated planet and position" ("flag_landscape_sets_location") are both enabled, it is not possible to change to any landscape assigned to Earth. The only way an Earth-assigned landscape can be displayed is if the landscape happens to be the default landscape. Any non-Earth landscape can always be selected and displayed regardless of the two settings above.

HOW TO REPRODUCE THE ERROR:

1. Start with a default Stellarium configuration.
(Delete "%APPDATA%\Stellarium" directory prior to starting Stellarium.)
2. Open "Configuration window" ([F2]).
3. Go to "Tools" tab.
4. Check: "Auto select landscapes".
5. Close the "Configuration" window.
6. Open "Sky and viewing options window" ([F4]).
7. Go to "Landscape" tab.
8. "Guereins" should be the selected default landscape.
9. For this example, select the "Hurricane" landscape.
10. Select the default "Guereins" landscape again.
11. Check: "Use associated planet and position".
(At this point, nothing out of the ordinary has happened.)
12. Select "Hurricane" again.
(At this point, the error has revealed itself.)

DESCRIPTION OF THE ERROR:

The Hurricane landscape appears for about 1 second before Stellarium quickly returns to the default Guereins landscape. Changing to any other landscape that is assigned to Earth by its "landscape.ini" file will fail in the same manner. Any landscape not assigned to Earth (e.g. Jupiter, Mars, Moon, Neptune, Saturn, Uranus) can always be displayed.

I manually deleted "planet = Earth" from Hurricane's "landscape.ini" file under the [location] section, but the error still occurred. After further investigation, I realized that Stellarium will automatically assign the landscape to Earth if any other [location] parameter is present in the "landscape.ini" file and the "planet" parameter is missing. After deleting all of the [location] parameters from Hurricane's "landscape.ini" file, and repeating the steps above, Hurricane can now be displayed regardless of the settings.

OTHER NOTES:

I uninstalled version 0.16.0 (Windows x64), and installed version 0.15.2 (Windows x64), and I found the same error present in version 0.15.2. I have not tested any other older version.

I did some further testing, and found something interesting. If I change the default landscape to the Moon, and select an Earth landscape such as Garching, and then VERY QUICKLY select another Earth landscape such as Geneva, I can get Geneva to display. However, if I am not quick enough to select Geneva after selecting Garching, Stellarium will return to the Moon landscape.

MY SYSTEM:

Although, I do not believe this is a system dependent issue, I will give a few specs here of my laptop:

Windows 7 Ultimate SP1 (x64)
CPU: AMD E2-1800
GPU: AMD Radeon HD 7340 Graphics
Driver: 13.152.1.8000 (Catalyst 13.9) WHQL
OpenGL 4.2

Related branches

gzotti (georg-zotti) wrote :

Thanks for reporting. I never use select auto landscape, but of course this should work.

Changed in stellarium:
status: New → Confirmed
importance: Undecided → Low
milestone: none → 0.16.1
gzotti (georg-zotti) on 2017-07-04
Changed in stellarium:
assignee: nobody → gzotti (georg-zotti)
status: Confirmed → In Progress
gzotti (georg-zotti) wrote :

This seems to be a result of https://bugs.launchpad.net/stellarium/+bug/1173254

r9605 should solve it.

Changed in stellarium:
status: In Progress → Fix Committed
Changed in stellarium:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers