Writer crashes on Tools->Bibliography without libreoffice-base

Bug #527938 reported by Martin Horseling on 2010-02-25
602
This bug affects 130 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Medium
OpenOffice
Invalid
Undecided
Unassigned
libreoffice (Debian)
Fix Released
Unknown
libreoffice (Ubuntu)
Medium
Björn Michaelsen
Precise
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu4
  Candidate: 1:3.3.2-1ubuntu4
  Version table:
 *** 1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in LibreOffice Writer via the Terminal:

lowriter -nologo

click Tools -> Bibliography Database is that it does not crash.

4) What happens instead is it crashes every time. This is a default install with no extra extensions installed.

WORKAROUND: Installing libreoffice-base makes the issue go away.

Original Reporter Comments: The message on the console is: terminate called after throwing an instance of 'com::sun::star::loader::CannotActivateFactoryException'
Reproduced also with 3.2.0rc4-1ubuntu

ProblemType: Bug
Architecture: i386
Date: Thu Feb 25 20:33:28 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: openoffice.org-core 1:3.1.1-5ubuntu1.1
ProcEnviron:
 LANGUAGE=en_GB.UTF-8
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-19.56-generic
SourcePackage: openoffice.org
Uname: Linux 2.6.31-19-generic i686

John Church (sleeveroller) wrote :

Confirmed using:
DistroRelease: Ubuntu 9.10
Package: openoffice.org-core 1:3.1.1-5ubuntu1.1

However, could not reproduce with the latest daily build of lucid 10.4 (2010-02-24) and package openoffice.org-core 1:3.2.0rc4-1ubuntu1. The problem appears to be fixed there.

Changed in openoffice.org (Ubuntu):
status: New → Confirmed
Dimitrios Symeonidis (azimout) wrote :

Can still reproduce with 3.2.0rc4-1ubuntu1

The message on the console is:
terminate called after throwing an instance of 'com::sun::star::loader::CannotActivateFactoryException'

Dimitrios Symeonidis (azimout) wrote :

Confirmed that installing openoffice.org-base (the database component of oo.o) makes the problem go away.

Added upstream bug watch, updating also the description

description: updated
Changed in openoffice:
status: Unknown → Confirmed
gianfilippo (gianfi) wrote :

The issue is present also in Lucid Lynx. Openoffice crashes when opening Bibliography Database.

Chris Cheney (ccheney) on 2010-05-13
tags: added: karmic
Chris Cheney (ccheney) wrote :

This should get fixed in upstream but I am not sure why you are still seeing the crash on Ubuntu 10.04. We have split out the libraries needed to keep it from crashing, some time ago, into openoffice.org-base-core which is now depended on by openoffice.org-writer. I uninstalled openoffice.org-base on my system and was not able to make it crash even though the Bibliography part didn't actually work without the rest of Base being installed it did show the dialog box.

Changed in openoffice.org (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
summary: - Open office crashes when trying to set up Bibliography Database
+ [upstream] Open office crashes when trying to set up Bibliography
+ Database

I have just had this problem using Ubuntu Lucid Lynx. As Dimitrios says installing the openoffice.org-base package using the Synaptic package manager or via the command line solves the problem.

Iuri Diniz (iuridiniz) wrote :

We have to wait for mainstream solution, IMHO if the base component is not installed, Biblio should be disabled.

I can confirm that problem goes out after installing the openoffice.org-base package

zob (zob) wrote :

I also reported this bug here: https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/588306
Same symptoms and solution.

Mike Bridge (mike-dynaleet) wrote :

I can confirm this still exists with openoffice.org-writer 3.2.0-7ubuntu4.1 on Kubuntu Lucid Lynx.

Can we make it check for the component and throw a dialog box recommending install of -base for the biblio functionality instead of the scary crash, fifteen pages into what I was doing? (Thankfully, I'm a bit retentive and had saved on an external drive recently!)

eneimi (eneimi) wrote :

"Can we make it check for the component and throw a dialog box recommending install of -base for the biblio functionality instead of the scary crash, fifteen pages into what I was doing? (Thankfully, I'm a bit retentive and had saved on an external drive recently!)"

I agree completely.

David Tomaschik (matir) wrote :

Still present as of today in Maverick.

Tory (tory-andrew-law) wrote :

Yep, openoffice writer crashed for me when trying to access the bibliography database with ubuntu 10.10beta... installing openoffice.org package as mentioned in another bug report did the trick for me.

I understand that we're waiting for upstream, though I'm on-board with Mike Bridge's dialog suggestion. When I attempted to use the help functionality, openoffice.org informed me that I needed to install the appropriate help package. However, had I not found this bug report, it would have never dawned upon me that 1) I need to install a package named "base" - not "bib" or similar and 2) that the openoffice.org-base package isn't something installed with openoffice.org out of the box. It seems like something called "base" is rather "basic" and should be part of the "base" install. :)

Konstantin Ivanov (liner.mgn) wrote :

ubuntu 10.10beta, all updates for today - bug still present

Victor Vargas (kamus) wrote :

I have attached the Backtrace from my session (running Ubuntu Maverick up to date)

I have same problem. Using Ubuntu 10.10

OpenOffice.org OpenOffice.org 3.2.1
OOO320m19 (Build:9505)
ooo-build 3.2.1.4, Ubuntu package 1:3.2.1-7ubuntu1

And kernel 2.6.35

More details:

oowriter (click on Database Bibliographic)

terminate called after throwing an instance of 'com::sun::star::loader::CannotActivateFactoryException'

Jeroen Hoek (mail-jeroenhoek) wrote :

This bug bit me today when trying out submittable forms in OOWriter. Clicking a button on a form, set to submit data over HTTP makes OpenOffice.org crash with the above message:

terminate called after throwing an instance of 'com::sun::star::loader::CannotActivateFactoryException'

Here too, installing Base turned out to solve the issue.

It looks like the same issue, from a glance. I suspect that it isn't a Bibliography-specific issue.

tags: added: amd64 lucid maverick

Steps to reproduce

- Install LO without Base
- Open Writer
- Select Tools -> Bibliography Database
- LO crash

*** Bug 33506 has been marked as a duplicate of this bug. ***

Confirmed.
Experienced this as well.
Win7 x64.

as it’s not only in RC, but also stable I changed the version up,
as it's not only x86 but also x64 I changed it to All,
as it’s a crash with potential data-loss I changed importance and severity up to max. After all, crashes are no-goes, top-prio.

Does this still happen in 3.3.1 final ?

Alex

Yes, Alex. Still crashing in 3.3.1 final.

Hmm, I was just wondering whether you could delete the bibliography db entry via the Tools > Options > LibreOffice Base > Databases menu entry, and see whether that made any difference ?

As I don't have a Windows system on which to test, I don't know. On Mac, you don't get the choice of not installing one or more of the components, it is all or nothing. On Linux, the official debs install everything too. Someone with a Linux distribution package set would have to try to see if not installing the Base packet causes the same behaviour on Linux.

Failing that, I agree that the bibliography db should be deactivated or unregistered by the Windows installer if the user decides not to use Base (although to be fair, it doesn't take up a lot of space). Whether that is seen as vitally important to the development team is another matter. Data loss might, and I say might, only occur in the particular circumstances you have set out, and if the user has willingly decided not to install the Base module, why on earth would he or she go looking for the bibliograhphy db ?

Alex

Yes, confirmed with 3.3.1 stable on a Win7 x64

(In reply to comment #6)
> Hmm, I was just wondering whether you could delete the bibliography db entry
> via the Tools > Options > LibreOffice Base > Databases menu entry, and see
> whether that made any difference ?

After deleting, still crashes.

(In reply to comment #6)
> and if the user has willingly decided not to install the Base module, why
> on earth would he or she go looking for the bibliograhphy db ?

I was not aware Base is used for the bibliography db, or rather, for using the references and index tables for my sources when writing a doc in writer.
When installing, I thought it was more of a DB backend if I want to use it as a DB for other data. More like scripting or coding something.

@kissaki :

Yes, unfortunately, the entry points for database functionality within the application suite is spread everywhere and not just in the Base module, but the Base module kind of pulls them altogether. Without it, the database things work rather unpredictably in my experience, or even not at all. If you want to use database functionality in LibreOffice, you have to install the Base module. However, I do agree that if you do not install the module, you should not be able to see the Bibliography database at all.

Alex

The easiest way would be to make the Base package in the installer a dependency of the Writer and other packages using Base.
That way it is clear that Base is a dependency for the other packages,
and the crash-issue is solved as well for now, without much coding work on every place using Base.

Daniel Kulesz (kuleszdl) wrote :

I can confirm that the bug is still present in 10.04.2 LTS as of today.

I would prefer to just not make it possible any more to install just parts of the LibreOffice "modules". I.e. Writer, Calc, Impress, Draw, Base and Math (did I fotget any?) would always be installed. We have enough bugs elsewhere to fix, we don't want to have to debug weird border conditions in the installer that affect only a small part of the users. Sorry. See also bug #33798 .

So you can't simply test for installation of Base on startup and if it's not installed then grey out the Bibliographic Database menu item? Are there additional points of entry to the db that are active in the interface and will crash if clicked when Base was not installed? If the latter, I agree forcing Base install is reasonable.

(In reply to comment #12)
> I would prefer to just not make it possible any more to install just parts of
> the LibreOffice "modules". I.e. Writer, Calc, Impress, Draw, Base and Math (did
> I fotget any?) would always be installed. We have enough bugs elsewhere to fix,
> we don't want to have to debug weird border conditions in the installer that
> affect only a small part of the users. Sorry. See also bug #33798 .

Yes, personally, I would agree with that too, but apparently, there is still a demand for the possibility of separate module installation...I remember when StarOffice was a single "unified" (I use that word lightly) app with a StarDesktop component :-)))

Alex

(In reply to comment #13)
> installed then grey out the Bibliographic Database menu item? Are there
> additional points of entry to the db that are active in the interface and will
> crash if clicked when Base was not installed? If the latter, I agree forcing
> Base install is reasonable.

How about Calc data ranges and the datapilot ? I seem to recall there's a hook to db functionality there too ?

Alex

But is that "demand" there only because "it has always been like that"? Sometimes we just have to take the risk that somebody is offended.

Hi Tor,

You're preaching to the converted as far as I'm concerned :-) The separation was introduced, if memory serves me correctly, after OOo was born, possibly around version 1.1.x, and after Sun had carried out a "survey". Obviously, that was nearly 10 years ago, and opinions and expectations may have changed since then.

Alex

(In reply to comment #18)
> Hi Tor,
>
> You're preaching to the converted as far as I'm concerned :-) The separation
> was introduced, if memory serves me correctly, after OOo was born, possibly
> around version 1.1.x, and after Sun had carried out a "survey". Obviously, that
> was nearly 10 years ago, and opinions and expectations may have changed since
> then.
>
> Alex

If correct, another survey must be carried out again to make it impossible to install modules separately. there's no other way than make a new convention in order to justify that.

OK, so feel free to use the ten year old software then, clearly we have been missing a survey for each and every functionality change / addition!

Sheesh.

(In reply to comment #20)
> OK, so feel free to use the ten year old software then, clearly we have been
> missing a survey for each and every functionality change / addition!
>
> Sheesh.

If you do have a right to make it impossible any more to install just parts of
the LibreOffice modules, please go ahead.

Personally, I like to be able to only install what I really want and need.
I can very well imagine ppl. only need writer,
or ppl not needing and wanting Math or Draw.

Modules should enforce installation of depended on modules, but just forcing everyone to install everything is too much IMO.
Why not keep the option? Other then with this Base issue (and other potential issues as Base is used as DB for things) there have not been others I presume?

So again, a module dependency when installing would be enough.

> I like to be able to only install what I really want and need.

But why draw the line at the somewhat random division into "modules" then? (Which, as this bug shows, leads to unexpected problems because of inter-dependencies.)

If that possibility had not been there earlier, would you be asking for it? You don't ask "I never use the Drop Caps feature for paragraphs, why can't I leave that code uninstalled", do you?

I.e. you shouldn't assume that the current situation is "natural" and anything else is "unnatural".

> Modules should enforce installation of depended on modules,

So you prefer to risk having bugs like this as long as you can save some tens of megabytes of disk space? The most precious resource we have is developer time. I don't see anybody jumping up and offering to fix this bug... Why intentionally keep doing stuff in a way that causes problems and requires developer time to fix, instead of making stuff cleaner, simpler, and less error-prone?

(In reply to comment #23)
> > I like to be able to only install what I really want and need.
>
> But why draw the line at the somewhat random division into "modules" then?
> (Which, as this bug shows, leads to unexpected problems because of
> inter-dependencies.)
>
> If that possibility had not been there earlier, would you be asking for it? You
> don't ask "I never use the Drop Caps feature for paragraphs, why can't I leave
> that code uninstalled", do you?

Are you trolling?
You can’t seriously compare a software with it’s own executable and own focus and features to using or not a single feature of one of those apps.

> > Modules should enforce installation of depended on modules,
>
> So you prefer to risk having bugs like this as long as you can save some tens
> of megabytes of disk space? The most precious resource we have is developer
> time. I don't see anybody jumping up and offering to fix this bug... Why
> intentionally keep doing stuff in a way that causes problems and requires
> developer time to fix, instead of making stuff cleaner, simpler, and less
> error-prone?

As I pointed out my point is that when there were no problems in the other areas before and are not now, why merge them? One could as easily just keep it the way it is.
Where dependencies come in (writer -> base) you’ll make them dependent on installation as well.

I get your point, but you should be able to get mine as well.

Whenever I install for my own use, I always do a custom install and only install Writer and Calc. I never use the others. So enforcing install of all components would be a waste of disk space in my case. I've no idea if I'm typical or not. We'd need a survey to find out ;-)

Johannes Storm (jo-master) wrote :

confirme for 10.10 (and installing openoffice-base workaround works here)

Lowering importance and priority, I don't seriously think anything is going to happen to this any time soon, unless someone steps up to the mark.

Alex

Ah, this flame war, thanks for reminding, I have a reply to comment #24 to add:

> You can’t seriously compare a software with it’s own executable and own focus

Ha ha. Note that the "own executable" for Base is just a minimal wrapper that starts the very same soffice.bin executable that handles *all* LibreOffice aspects: Writer, Calc, Base, etc. In fact I don't even know why we bother to ship a separate Base "executable" (sbase.exe) on Windows. As far as I understand, we could instead just have the Start Menu entry for Base run soffice.exe with the appropriate command-line option to make it start as Base, or have an already running soffice.bin open up a new empty Base document, or something.

(On Unixes, it is a bit different, there people might be used to start Base by entering an explicit oobase or sbase command.)

Folks, this problem happens to me too.
I just wanted to say that obviously I disagree with the idea of forcing the install of Base just to avoid this kind of bugs with Writer/Calc.

Like most people, I prefer customs installations.

Like "most" people, eh? Do you have some reliable proof for that? I think it is overwhelmingly clear that too many options just confuse real end-users. Geeks and "freedom-lovers" are not "most people".

(But of course, I don't have any proof either. I don't care that much personally, I just work here. I do whatever my boss(es) tell me to do.)

zob (zob) wrote :

Confirmed for libreoffice 3.3.2 on ubuntu 11.04. (I know this thread is about OO, but as it has nothing to do with the application, only with the packaging, I will mention it here).
Crashes because libreoffice-base is not installed by default.
I think that either libreoffice-base should be installed by default (if there is space on the CD) or the option to select bibliography database should be grayed out.

Flemming Christensen (laoshi) wrote :

Could I suggest that this bug be given higher priority? It is an unneeded annoyance, it affects a lot of users, and it is easily solved.

summary: - [upstream] Open office crashes when trying to set up Bibliography
- Database
+ [upstream] Writer crashes when trying to set up Bibliography Database
+ soffice.bin crashed with SIGABRT in __kernel_vsyscall()
Changed in libreoffice (Ubuntu):
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)
status: New → Confirmed
tags: added: lo33
description: updated
tags: added: metabug
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
tags: added: natty
zob (zob) wrote :

stevr1it, if you're just looking for a fix, it's easy:
sudo apt-get install libreoffice-base

Problem gone!
It's written all over this thread btw.

This bug is affecting me on 11.10 with latest updates,
libreoffice-writer:
  Installed: 1:3.4.3-1ubuntu2
  Candidate: 1:3.4.3-1ubuntu2
  Version table:
 *** 1:3.4.3-1ubuntu2 0
        500 http://ir.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status

Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix
Changed in libreoffice (Ubuntu):
status: Confirmed → Triaged
Changed in df-libreoffice:
importance: Undecided → Unknown
status: New → Unknown

Same problem LO 3.4.4. The program just closes. Threre should at least be a information dialog and no closing. A bit sad that nothing has happend in 10 month on this.

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

Confirming that this is still happening with LibreOffice 3.4.4 OOO340m1 (Build:402) under Ubuntu 11.10. The fix of installing openoffice.org-base still works. I agree, I'm also sad to see that nothing seems to have happened in 10 months. Maybe it should just be set as a dependency until the bug can be fixed?

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

description: updated

new->confirmed by downstream bugs

*** Bug 46298 has been marked as a duplicate of this bug. ***

*** Bug 43207 has been marked as a duplicate of this bug. ***

Changed in libreoffice (Debian):
status: Unknown → Confirmed

Bjoern Michaelsen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1889c1af41650576a29c587a0b2cdeaf0d297587

lp#527938, debian#602953, fdo#33266, i#105408: do not crash on clicking bibliography when base isnt installed

Bjoern Michaelsen committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=33ef1ffbd15994ec71be99d38c0d5171c63344a2&g=libreoffice-3-5

lp#527938, debian#602953, fdo#33266, i#105408: do not crash on clicking bibliography when base isnt installed

It will be available in LibreOffice 3.5.2.

At http://opengrok.libreoffice.org/xref/core/forms/source/component/DatabaseForm.cxx#429 libfrmlo.so tries to create a instance of com.sun.star.sdb.RowSet which has no implementation without base being installed.

Changed in libreoffice (Ubuntu):
status: Triaged → In Progress
Changed in libreoffice (Ubuntu):
status: In Progress → Fix Committed
Leo Arias (elopio) wrote :

Thanks for working on this Björn. A hug.

Changed in libreoffice (Ubuntu):
milestone: none → ubuntu-12.04
summary: - [upstream] Writer crashes when trying to set up Bibliography Database
- soffice.bin crashed with SIGABRT in __kernel_vsyscall()
+ Writer crashes when trying to set up Bibliography Database soffice.bin
+ crashed with SIGABRT in __kernel_vsyscall()
Martin Pitt (pitti) on 2012-03-07
tags: added: bugpattern-written
Changed in df-libreoffice:
status: Confirmed → Fix Released
Changed in libreoffice (Debian):
status: Confirmed → Fix Released
summary: - Writer crashes when trying to set up Bibliography Database soffice.bin
- crashed with SIGABRT in __kernel_vsyscall()
+ Writer crashes on Tools->Bibliography without libreoffice-base
Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package libreoffice - 1:3.5.1-1ubuntu1

---------------
libreoffice (1:3.5.1-1ubuntu1) precise; urgency=low

  * new upstream release
    - fixes crash in QCoreApplication::notifyInternal() (LP: #925049)
    - fixes Writer crashes on Tools->Bibliography without libreoffice-base
      (LP: #527938)
    - fixes crash in SwTxtFrm::HideAndShowObjects() (LP: #872716)
    - fixes recent documents list is always empty (LP: #950071)
  * merge from debian-experimental-3.5
  * fail gracefully in -common postinst (LP: #916291)
  * kde4libs update breaks LibreOffice (LP: #958781)
  * exchange firefox-dev and xulrunner-dev order in rules rules

libreoffice (1:3.5.1-1) experimental; urgency=low

  [ Rene Engelhard ]
  * new upstream release
    - fixes up excessive numbers of "JRE is defective" messages
      (closes: #602127)
    - fixes populating "Recent Documents" after a profile upgrade
      (closes: #660185)
    - fixes nsplugin to create a correct
      com.sun.star.ucb.SimpleFileAccess instance (closes: #661747)

  * debian/patches/armhf-bridges-doubles.diff: some more armhf fixes
    (+ testcase) from master
  * debian/patches/debian-hardened-buildflags.diff: use hardened
    buildflags from dpkg-buildflags (closes: #656643)
  * debian/patches/debian-opt.diff: fix to actually make test and grep
    work
  * debian/patches/bibliography-no-crash-if-no-base.diff: backport fix
    from libreoffice-3-5 to not crash Tools -> Bibliography if -base isn't
    installed (closes: #602953, #598809)
  * debian/patches/pyuno_fix_python2.diff: backport from libreoffice-3-5.
    As name says, fix breakages in python2 after python3 fixes

  * debian/rules: rename ext-sources to src, as done upstream
  * debian/control.fonts.in: make ttf-opensymbol Priority: extra, thanks
    lintian
  * debian/rules:
    - --with-mingw -> --with-mingw-cross-compiler; remove obsolete
      "export MINGWSTRIP" hack
    - don't set ENABLE_SDBC_POSTGRESQL=n when building no extensions, as
      this isn't an extension anymore
    - remove obsolete "export MINGWSTRIP" hack
    - fix (>= 1.1.9) for libcommons-logging-java to actually work, thanks
      Rico Tzschichholz
    - chmod 755 setsdkenv_unix
    - also disable graphite on alpha (closes: #661294)
    - actually filter-out also armhf and powerpc powerpcspe ppc64 s390x for
      OOO_REPORTDESIGN_ARCHS
    - remove -O0 setting via ARCH_FLAGS, already handled by debian-opt.diff
  * debian/control.in: build-conflict against
    libc0.1-dev (= 2.13-26) [kfreebsd-i386 kfreebsd-amd64]
  * debian/control.mozilla.in: stricten dependencies to 3.5, thanks
    Mario Holbe for the observation
  * debian/rules, debian/control.mozilla.in: update nsplugin conditional
    to actually disable nsplugin build (and get rid of xulrunner-dev build-dep)
    if disabled
  * debian/*.triggers, debian/*.prerm.in:
   - add activate triggers for /usr/lib/libreoffice/share/extensions to
     the respetive extensions. Run sync_extensions after rm -rf'ing the
     dir already in preinst (upgrade) (closes: #658646)

  [ Bjoern Michaelsen ]
  * debian/patches/fix-quickstart-shutdown.diff: fix logout with
    quickstarter (closes: #63292...

Read more...

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
zob (zob) wrote :

I can still make it crash in ubuntu 12.04 beta i386, with libreoffice 1:3.5.1-1ubuntu1.
To reproduce: try to make bibliography.
Only difference from the old crash is that the old crash happened instantly. This time it hangs for a while (greyed out) and then crashes.

I wanted to copy-paste from the ubuntu-bug report, but that doesn't seem to be possible.
I doesn't allow me to file a new bug, because it's already here.

I added Fix submitter as assignee because this will ease queries and bug tracking.

Hello Martin, or anyone else affected,

Accepted libreoffice into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

no longer affects: openoffice.org (Ubuntu Precise)
Changed in libreoffice (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (7.3 KiB)

This bug was fixed in the package libreoffice - 1:3.5.3-0ubuntu1

---------------
libreoffice (1:3.5.3-0ubuntu1) precise-proposed; urgency=low

  * bump version to final, use debian tarballs

libreoffice (1:3.5.3~rc2-0ubuntu1~ppa2) precise; urgency=low

  * reduce l10n set for ppa builds

libreoffice (1:3.5.3~rc2-0ubuntu1~ppa1) precise; urgency=low

  * cherry-pick 496346c9e692b7ba8ec0aa78c78cac7b71d830a5 from
    debian (LP: #986205)
    - guard libdbalo.so mv with feq PACKAGE_BASE=y...
  * upstream bugfix release 3.5.3:
    - fix colorspace conversion for greyscale bitmaps fdo#34324 [Michael Meeks]
    - cache calls to mdds:mixed_type_matrix::size, related fdo#47299 [Markus Mohrhard]
    - clrContourCache for SwAnchoredDrawObjects fdo#45376 [Andreas Schierl]
    - copy column privileges into table privileges fdo#47937 [Lionel Elie Mamane]
    - cppcanvas: processEMFPlus: fix valgrind warning: fdo#42252 [Michael Stahl]
    - disable cairo canvas on Windows fdo#46532, fdo#46901, fdo#45584 [Michael Meeks]
    - do not increase height of checkboxes fdo#47963 [David Tardon]
    - do not play sound in presenter console fdo#33914 [David Tardon]
    - docx, no mso-fit-shape-to-text means the textbox size is fixed bnc#751573 [Cédric Bosdonnat]
    - export all style information to xls/xlsx, fdo#46738 [Markus Mohrhard]
    - fdo43752: PPTX import fix affected odp imports. bnc#719989, bnc#719997 [Muthu Subramanian]
    - find install location during help pack install fdo#48411 [Andras Timar]
    - fix - edge-case trans gradients came out empty fdo#33591 [Thorsten Behrens]
    - fix - use older ODF encryption by default fdo#47484 [Thorsten Behrens]
    - fix RTF import of \page in inner groups fdo#48104 [Miklos Vajna]
    - fix RTF import of all capitals char prop fdo#46955 [Miklos Vajna]
    - fix RTF import of character encoding in footnotes fdo#45182 [Miklos Vajna]
    - fix RTF import of custom fonts in substreams fdo#45394 [Miklos Vajna]
    - fix RTF import of mixed super/nonsuper text fdo#47326 [Miklos Vajna]
    - fix RTF import of multi-paragraph exact height textboxes fdo#47036 [Miklos Vajna]
    - fix RTF import of shapes inside text frames at the start of the doc fdo#47036 [Miklos Vajna]
    - fix RTF import of tables with empty first row fdo#45394 [Miklos Vajna]
    - fix RTL menu rendering on Windows fdo#42537 [Ivan Timofeev]
    - fix border printing: fdo#38635 [Michael Stahl]
    - fix crash on RTF import of shapes inside tables fdo#47802 [Miklos Vajna]
    - fix the fix so it doesn't crash lp#905355, fdo#43895 [Michael Stahl]
    - fix vcl alpha blending bnc#714787 [Thorsten Behrens]
    - fix vertical align when switching mode in multibar fdo#44140 [Noel Power]
    - fixed pdf export (of images). bnc#717947 [Muthu Subramanian]
    - handle various busted rtf docs without hanging fdo#48640 [Caolán McNamara]
    - improved label/BC wizard - set paper size fdo#44516 [Winfried Donkers]
    - increase nCol before next iteratation to prevent loop, fdo#46220 [Markus Mohrhard]
    - macros: Macro to set filter in Calc does not work with .StringValue fdo#46983 [Takeshi Abe]
    - make "Replace All" work with REs fdo#44861 [David Tardon]
    - ...

Read more...

Changed in libreoffice (Ubuntu Precise):
status: Fix Committed → Fix Released
zob (zob) wrote :

I can still crash version 3.5.3-0ubuntu1. I have attached the /var/crash file.
Thanks for looking into this.

zob, please do not attach your crash files to this report. Please report this as a separate bug via the Terminal and feel free to subscribe me to it:
ubuntu-bug _usr_lib_libreoffice_program_soffice.bin.1000.crash

Thanks!

zob (zob) wrote :

Sorry Christopher.
I was trying to give you as much information as possible to work with.
So best practice with crash files is always to make a separate bug report, unless I am the OP, is that it?
Thanks again.

wlx (wangliangxu) wrote :

Same problem happened in ubuntu 12.04, install the libreoffice-base package could solve this problem too.

Danilo Silva (danilocsilva) wrote :

Yeah.
sudo apt-get install libreoffice-base
Work just fine now on Precise 12.04 x64 and LO 3.5.4.2

This crash is still happing with Quantal Quetzal. I'm seeing this crash when I try to invoke Tools / Bibliography Database. Installing LibreOffice Base fixed it, just as described here.
Ubuntu Software Centre reports that I have libreofficebase 1:3.6.1~rc2-1ubuntu3 installed, which appears to be to be more recent than the 1:3.5.3-0ubuntu1 version where it was apparently fixed.

Jim Patterson, please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer. One may execute at the Terminal:
sudo apt-get update && sudo apt-get -y upgrade && sudo apt-get -y install libreoffice-dbg uno-libs3-dbg ure-dbg && sudo service apport start force_start=1

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

Now reproduce the crash, then open your file manager, navigate to your /var/crash directory and open the crash report you wish to submit.
If this fails you will have to open a terminal and file your report with 'ubuntu-bug /var/crash/_my_crash_report.crash' where _my_crash_report.crash is the crash you would like to report. If you get an error that you aren't allowed to access this report you will have to file it with 'sudo ubuntu-bug /var/crash/_my_crash_report.crash'. Please follow https://wiki.ubuntu.com/LibreOfficeBugWrangling when you file this crash report so the necessary information is provided.

Thank you for your understanding.

Helpful Bug Reporting Links:Helpful Bug Reporting Links:
https://help.ubuntu.com/community/ReportingBugs#Bug_Reporting_Etiquette
https://help.ubuntu.com/community/ReportingBugs#A3._Make_sure_the_bug_hasn.27t_already_been_reported
https://help.ubuntu.com/community/ReportingBugs#Adding_Apport_Debug_Information_to_an_Existing_Launchpad_Bug
https://help.ubuntu.com/community/ReportingBugs#Adding_Additional_Attachments_to_an_Existing_Launchpad_Bug

Perhaps "crash" is the wrong word. The behaviour I see is that libreoffice abruptly exits, with no information given to the user. There is a bit of information on stdout (usually not seen, of course):

terminate called after throwing an instance of 'com::sun::star::loader::CannotActivateFactoryException'

I've followed your instructions but don't see a "crash" file. I can upload a debug log, though, which I think will help pinpoint the point of failure.

Clearly, I haven't followed the reporting instructions from LibreOfficeBugWrangling entirely (installing 'libreoffice' will install 'libreoffice-base', avoiding this failure), but I think you'll agree the behaviour on what is after all a legitimate product install is not very user friendly.

Thanks.

*** Bug 54479 has been marked as a duplicate of this bug. ***

Still [Reproducible] with parallel installation of "LOdev 4.0.0.0.beta2 - GERMAN UI / German Locale [Build ID: 4104d660979c57e1160b5135634f732918460a0)]" {tinderbox: @6, pull time 2012-12-20} on German WIN7 Home Premium (64bit) with subsequnetly removed Database modul and with separate /4 User Profile for Master Branch.

Further Results coming soon

Denis Washington (dwashington) wrote :

This also happens for me with Ubuntu raring (fully updated as of Feb 7 2013).

Denis Washington, please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer. First, execute at a terminal:
cd /var/crash && sudo rm * ; sudo apt-get update && sudo apt-get -y upgrade && sudo apt-get -y install libreoffice-dbg uno-libs3-dbg ure-dbg && sudo service apport start force_start=1

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

Now reproduce the crash, then open your file manager, navigate to your /var/crash directory and open the crash report you wish to submit.
If this fails you will have to open a terminal and file your report with 'ubuntu-bug /var/crash/_my_crash_report.crash' where _my_crash_report.crash is the crash you would like to report. If you get an error that you aren't allowed to access this report you will have to file it with 'sudo ubuntu-bug /var/crash/_my_crash_report.crash'. If you run the command against the crash report and it does nothing, you may be affected by https://bugs.launchpad.net/ubuntu/+source/apport/+bug/994921 . In order to WORKAROUND this, one would need to open the following file via a command line:
gksudo gedit /etc/apport/crashdb.conf

and comment out the line:
'problem_types': ['Bug', 'Package'],

Save, close, and try to file the crash report again via:
ubuntu-bug /var/crash/_my_crash_report.crash

Please follow https://wiki.ubuntu.com/LibreOfficeBugWrangling when you file this crash report so the necessary information is provided.

Thank you for your understanding.

Helpful bug reporting tips:
https://help.ubuntu.com/community/ReportingBugs

no longer affects: openoffice.org (Ubuntu)
Changed in openoffice:
importance: Unknown → Undecided
status: Confirmed → New
status: New → Invalid

I've followed the instructions on #91 and it took me here, so it is still happen.
Had to manually install libreoffice-base with apt-get
just installing libreoffice-writer going to Tools/Bibliography just throw a non-userfriendly error:

terminate called after throwing an instance of 'com::sun::star::loader::CannotActivateFactoryException'

lsb_release -rd
Description: Ubuntu 12.10
Release: 12.10

libreoffice-writer:
  Installed: 1:3.6.2~rc2-0ubuntu4
  Candidate: 1:3.6.2~rc2-0ubuntu4
  Version table:
 *** 1:3.6.2~rc2-0ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ quantal-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.6.2~rc2-0ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ quantal/main i386 Packages

I installed LibreOffice v4.0.1.2 on Windows XP and the crash still appears as described in bug report (first post). I am settings Status to: REOPENED.

Most probably the correct solution would be to grey out Bibliography Database if LibreOffice Base is not installed.

@grofaty
<https://wiki.documentfoundation.org/BugReport_Details#How_to_reopen_Bugs>!
What tests did you to to make sure that your current problem is not "Bug 62478 - CRASH when FILEOPEN Tools - Options - Base - Databases"?

@Rainer Bielefeld, retested on LibreOffice v4.0.2.2 on Windows XP on both bugs suggested.

First post from this 33266 bug is:
========================================
Steps to reproduce

- Install LO without Base
- Open Writer
- Select Tools -> Bibliography Database
- LO crash
========================================
Crashes with "Microsoft Visual C++ Runtime Library. Runtime Error! Program: C:\Program Files\LibreOffice 4.0\program\soffice.bin abnormal program termination".

I have tested this on two computers. In one crashes with above error and on another computer works fine. The difference is that LibreOffice crash computer there is no LibreOffice Base installed. So my suggestion is to gray out the Tools | Bibliography Database if LibreOffice Base is not installed.

First post from bug report 62478 bug is:
========================================
1. Launch LibO
2. From LibO Start Center: Menu 'Tools -> Options -> Expand LibreOfficeDev Base'
3. Click 'Databases'
   > Crash
========================================
Tested on LibreOffice 4.0.2.2 on Windows XP on two computers. Crash does not appear in my case.

So in my humble opinion I have commented on correct bug.

NOT reproducible with reduced user installation (without Base) of "LibO 4.0.2.2 rc - German UI / German Locale [Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3)]" {tinderbox: @6, pull time 2013-03-26 12:00(?)} on German WIN7 Home Premium (64bit) with newly created own user profile.
As Expected
* When I launch LibO Database button is greyed out in LibO Start Center
* When I try to open an arbitrary.odb File type filter dialog opens
* When I do menu 'Tools -> Options -> LibO Base Database' no crash

@grofaty:
I agree, your problem obviously is not Bug 62478 (does not match with date of appearance and observation in other 4.0.2.2 installations).
But I doubt that your problem has to do with Bug 33266. Same symptoms, but probably different roots. If the problem persists after usual repair attempts please report a new bug with very precise information concerning your installation.

Closing this one again.

*** Bug 58564 has been marked as a duplicate of this bug. ***

David Freitas (jddcef) wrote :

Affects me on Windows 8.1, LibreOffice Version: 4.4.0.3, Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7, Locale: en_AU

Bjoern Michaelsen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=76c61ced4eaa5f69b948dca7537028eaa88225b3

check for and handle missing base in mail merge (related: fdo#33266)

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

To post a comment you must log in.