OpenERP Addons (modules)

stock inventory

Reported by Bruno Hostalery on 2010-02-08
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenERP Addons
Status tracked in Trunk
5.0
Low
Jay Vora (Serpent Consulting Services)
Trunk
Undecided
OpenERP R&D Addons Team 2

Bug Description

To my mind, when i make a stock inventory without recursive data, i must have amount of all sub-location, and when i use recursive, i must have only stock in the location.

example : Actually, if we have in stock location :

stock nothing
stock->magasin product1 : 150

and we ask inventory of stock :
without recursive check : no products found
with recursive check : stock product1 : 150
                                     stock-> magasin product1 : 150

in place of (to my mind) :
without recursive check : stock product1 : 150
with recursive check : stock-> magasin product1 : 150

line :
        context.update({'compute_child':False})
in stock - wizard_inventory.py must be line 62 and no 67.

Please report this at the proper location.

affects: account-banking → openobject-addons
gpa(OpenERP) (gpa-openerp) wrote :

Hello,

Can you provide me more information,the exact structure (parent/child)of location you followed with example?

Thanks.

Changed in openobject-addons:
status: New → Incomplete
Bruno Hostalery (istf) wrote :

Just see attachment

Hello Bruno,
Talking about the Fill Inventory wizard:
If you select any parental location and mark the checkbox of children to be TRUE,it will list out the parent itself and its recursive children upto bottom,with their concerned QTYs. Observe here that parent has the cumulative sum of its children.

Example: If location X has parent Y and Y has 0 quantity.location X has 10 qty,so Y will have 10 too.

Either way, if you do not check the checkbox of that wizard;it will only look for the supplied location,not its children.

All your screenshots are quite obvious.

Can you tell me about the extreme last screenshot? It seems like you have modified it.

Thanks.

Changed in openobject-addons:
status: Incomplete → Invalid
Bruno Hostalery (istf) wrote :

Never mind, it's always another way of working that mine.

When i make an inventory, i always have (5 industrial groups) the quantity by location and never the summary, because when we sold the inventory, we always give all the quantity by location.

In your modified example, if location X has parent Y and Y has 10 quantity.location X has 10 qty,so Y will have 20.
What have i to indicate when i make the inventory :
10 in X and 10 in Y (the physical values), 10 in X and 20 in Y (cumulative values to made no stock modification).

And if you think that in fact i have near 2000 locations, organize by batiment / line / level, calcul of cumulative location will be very hard.

The last three windows are when you uncheck recursive. If i have to do it with all my location just to have right value ... no i can't imagine.
The last screen is with my modification and i have cumulative stock from the location i choose.

As i write before, it's just because i never make inventory like you.
It's not a problem, i will modify source.

gpa(OpenERP) (gpa-openerp) wrote :

Hello Bruno,

I set the bug incomplete because more discussion needed in this bug.

Thanks

Changed in openobject-addons:
status: Invalid → Incomplete
Bruno Hostalery (istf) wrote :

More important :
i do inventory with several negativ values (i think due to force assigned, but it's not the problem)
When i make inventory and try to put 0 in stock location quantity, there are several cases in which stock is not set to 0, but other value (i don't find where is the error, seems to be in amount calcul).

To force this and have more information, i add a field with initial value and use this to make move.
That permit to modify tree to put color on modification.
People say me it's most attractive for worker.
All is good now, but with my modifications. if i have time, i will have a look to use openerp wizard and not mine.

The second point, it's with production lot and tracking. Actual inventory is unuseable as it.

I just think you are not operating right way.

On inventory you should just include the right quantity of product. System will do the needed adjustements and it will move the correct quantity of products to obtain that quantity.

If you need specifying product quantity = 0 , you just have to put 0, never a negative or positive quantity.

Example:

product A: Actual quantity -2
inventory product A, you set 0
System will make a movement from virtual stock location "inventory lost" to phisical stock location "stock" of quantity 2, so -2 + 2 = 0

Another example:
product A: Actual quantity 10
inventory product A: You set 5
System will make a movemente from stock to "inventory lost" of quantity 5, so 10 - 5 = 5 quantity for product A after confirming inventory.

This movements will be done ONLY in case you confirm inventory, never before.
Wishing this helps:

Ana

About lot and tracking, is correct. The actual inventory form does not fill this test case. A few weeks ago it was reported as a blueprint and there is a new "bug" fix released here where functionality has been added on trunk:

https://bugs.launchpad.net/openobject-addons/+bug/506294

Bruno Hostalery (istf) wrote :

Yes i know we just have to put value in stock.
But when i set 0 in value with original value (actual stock) negative,
more than one time of two, new stock value is not 0.

Numérigraphe (numerigraphe) wrote :

I humbly suggest you set the status of this bug to "new" if it's not fixed, otherwise Launchpad will drop it next month.

Bruno Hostalery (istf) on 2010-03-25
Changed in openobject-addons:
status: Incomplete → New
Nicolas Vivier (nvivier) wrote :

I confirm that, on my odoo instance, if I set the quantity of products to 0 about 50% of the products are not correctly managed. The stock move created is not correct and the resulting amount is false. I can not findwhat happens and where it comes from.

Changed in openobject-addons:
milestone: none → 5.0.11
Nicolas Vivier (nvivier) wrote :

You can easily repeat this problem with the manufacturing demo :
- create a new inventory
- use fill inventory wizard without childs for stocks locations
- modify stock to 0
- confirm inventory
- check Posted Inventory anc ckeck that moves have strictly no sense...

Nicolas Vivier (nvivier) wrote :

I have understood something : OErp adjusts the inventory so that the total amount of stock and childs is null. It is not consistent with the fact that I asked to fill inventory without childs.

Changed in openobject-addons:
milestone: 5.0.11 → 5.0.12

We Let the addons2 team decide.

Thanks.

Hello,
I have checked your bug specification with latest code but the problem does not reproduced at my end.
Would please elaborate more.
Thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers