OEM Priority Project

[regression] Unity launcher on-screen corruption on resume from suspend with nVidia proprietary driver

Reported by Steve Magoun on 2012-01-12
216
This bug affects 41 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
James M. Leddy
Oneiric
High
James M. Leddy
Precise
Medium
James M. Leddy
Unity
High
Tim Penhey
6.0
High
Daniel van Vugt
Unity Distro Priority
Undecided
Unassigned
unity (Ubuntu)
High
Marco Trevisan (Treviño)
Oneiric
Undecided
Marco Trevisan (Treviño)
Precise
High
Marco Trevisan (Treviño)

Bug Description

[Impact]
This bug basically makes NVidia machines unusable after suspend. This is causing problems for users and OEMs that want to use 11.10 alike.

[Development Fix]
https://bazaar.launchpad.net/~unity-team/unity/trunk/revision/2205

[Test Case]
.
To reproduce:
1) Suspend
2) Resume
2a) login, if necessary. Note that the login screen (lightdm) displays properly
3) Notice the corrupted launcher
4) Mouse over the launcher; the launcher redraws and the corruption goes away

[Regression Potential]

Low. We have tested the fix in the development version that we're planning on releasing in April 26th and have found no problems.
With the big diff, the regression potential might be a bit bigger for precise.

== Original Report ==

The unity launcher is reliably corrupted upon resume from suspend with some (all?) NVidia hardware with the proprietary NVidia driver. All other visual elements seem to draw correctly, it's just the unity launcher that has this problem. The launcher looks fine after it redraws (for example, if you mouse over it).

The problem is not reproducible on Intel or AMD graphics hardware, and I'm told (by Ted Gould) that it doesn't affect the nouveau driver. I have not tested the nouveau driver myself.

This problem been reported several times in the comments of bug 676166, I'm filing this separate bug for clarity since 676166 is overloaded.

To reproduce:
1) Suspend
2) Resume
2a) login, if necessary. Note that the login screen (lightdm) displays properly
3) Notice the corrupted launcher
4) Mouse over the launcher; the launcher redraws and the corruption goes away

The problem affects 11.10, and is not fixed by upgrading to more recent unity, compiz, or nvidia drivers from oneiric-updates or even the most recent SRU candidates not yet in oneiric-proposed. Currently I have the following installed and the problem still exists:

ii nvidia-common 1:0.2.35.1 Find obsolete NVIDIA drivers
ii nvidia-current 280.13-0ubuntu6 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-current-updates 285.05.09-0ubuntu0.1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 280.13-0ubuntu2.1 Tool of configuring the NVIDIA graphics driver
ii nvidia-settings-updates 285.05.09-0ubuntu0.1 Tool of configuring the NVIDIA graphics driver

Unity SRU candidate (not yet in -proposed):
ii unity 4.28.0-0ubuntu1~ppa1 Interface designed for efficiency of space and interaction.

Compiz SRU candidate (not yet in -proposed):
ii compiz 1:0.9.6+bzr20110929-0ubuntu6.1~oneiric1 OpenGL window and compositing manager
ii compiz-core 1:0.9.6+bzr20110929-0ubuntu6.1~oneiric1 OpenGL window and compositing manager

Hardware is a MacbookPro 3,1 w/ NVidia 8600M GT. I'm using the amd64 build of 11.10.

lspci -vvnn output for graphics card:

01:00.0 VGA compatible controller [0300]: nVidia Corporation G84 [GeForce 8600M GT] [10de:0407] (rev a1) (prog-if 00 [VGA controller])
 Subsystem: Apple Computer Inc. Device [106b:00a0]
 Physical Slot: 1
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 16
 Region 0: Memory at d2000000 (32-bit, non-prefetchable) [size=16M]
 Region 1: Memory at c0000000 (64-bit, prefetchable) [size=256M]
 Region 3: Memory at d0000000 (64-bit, non-prefetchable) [size=32M]
 Region 5: I/O ports at 5000 [size=128]
 [virtual] Expansion ROM at d3000000 [disabled] [size=128K]
 Capabilities: [60] Power Management version 2
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
  Address: 0000000000000000 Data: 0000
 Capabilities: [78] Express (v1) Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <4us
   ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd+ ExtTag+ PhantFunc- AuxPwr- NoSnoop+
   MaxPayload 128 bytes, MaxReadReq 512 bytes
  DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
  LnkCap: Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Latency L0 <512ns, L1 <4us
   ClockPM- Surprise- LLActRep- BwNot-
  LnkCtl: ASPM L0s L1 Enabled; RCB 128 bytes Disabled- Retrain- CommClk+
   ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed 2.5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
 Capabilities: [100 v1] Virtual Channel
  Caps: LPEVC=0 RefClk=100ns PATEntryBits=1
  Arb: Fixed- WRR32- WRR64- WRR128-
  Ctrl: ArbSelect=Fixed
  Status: InProgress-
  VC0: Caps: PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
   Arb: Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
   Ctrl: Enable+ ID=0 ArbSelect=Fixed TC/VC=01
   Status: NegoPending- InProgress-
 Capabilities: [128 v1] Power Budgeting <?>
 Capabilities: [600 v1] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
 Kernel driver in use: nvidia
 Kernel modules: nvidia_current, nvidia_current_updates, nouveau, nvidiafb

Related branches

lp:~jassmith/unity/unity.redraw-on-resume
Merged into lp:unity at revision 2205
Tim Penhey (community): Approve on 2012-04-01
Marco Trevisan (Treviño): Needs Information on 2012-03-06
Gord Allott: Pending requested 2012-03-05
Gord Allott (community): Approve on 2012-03-05
Unity Team: Pending requested 2012-03-04
lp:~thumper/unity/regional-damage-sru
Merged into lp:unity/5.0 at revision 2394
Łukasz Zemczak: Approve on 2012-08-02
Marco Trevisan (Treviño): Approve on 2012-08-01
Daniel van Vugt: Approve on 2012-07-27
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
watgrad (watgrad) wrote :

I get a strange looking launcher bar - looks lie static - when I resume - see pic

watgrad (watgrad) wrote :

Sorry - should also give some info about system:
Ubuntu 11.10 - fully updated
Linux 3.0.0-15-generic #25-Ubuntu SMP Mon Jan 2 17:44:42 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Gfx Card: nVidia (version current) [Recommended] - [GeForce 8400 GS]

3Gig Ram, intel core 2 quad processor

Bolick (alexey-brodkin) wrote :

Still persists in 11.10 32-bit (3.0.0-15-generic-pae) even with:
nvidia-current 290.10-0ubuntu1~oneiric~xup1 from "ppa:ubuntu-x-swat/x-updates" for nVidia Quadro 1000M
unity 5.0.0~+bzr1825ubuntu0+611 from "ppa:unity-team/ppa"

Omer Akram (om26er) on 2012-01-17
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Changed in nvidia-graphics-drivers (Ubuntu):
importance: Undecided → Medium
Kent Baxley (kentb) on 2012-01-19
Changed in oem-priority:
importance: Undecided → Medium
Chris Van Hoof (vanhoof) wrote :

Alberto -- Mind taking a peek at this one to see if we are dealing with a pure nvidia driver issue or some other interaction with Unity and/or Compiz?

Cheers,
Chris

Changed in nvidia-graphics-drivers (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in oem-priority:
assignee: nobody → Chris Van Hoof (vanhoof)
status: New → Confirmed
Alberto Milone (albertomilone) wrote :

FBO textures are not preserved after suspend. For this reason we should redraw the launcher on resume. This is a bug in Unity, not in the Nvidia driver.

According to Jason Smith, we should call QueueDraw() (in Unity) to redraw the launcher on resume. The main problem here is that, as far as I know, there's no such thing as a handler which reinitialises Unity's components on resume.

Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Invalid
Alberto Milone (albertomilone) wrote :

subscribing Jason to further investigate the launcher issue.

Didier Roche (didrocks) on 2012-01-23
Changed in unity-distro-priority:
status: New → Fix Committed
Omer Akram (om26er) on 2012-02-04
no longer affects: nvidia-graphics-drivers (Ubuntu)
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Omer Akram (om26er) wrote :

To add more context to the bug previosuly Jason Smith fixed bug 676166 which was a worse type of corruption only limited to nvidia binary driver users. After that bug was fixed this issue have been there since.

Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
Gord Allott (gordallott) on 2012-03-07
Changed in unity:
status: Triaged → In Progress
assignee: nobody → Jason Smith (jassmith)
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
milestone: none → 5.8.0

Changed title to make it clear that "corruption" is on-screen (visible noise) not in memory (bad behavior / crash). That was clear in #854347, not here.

summary: - Unity launcher corruption on resume from suspend
+ Unity launcher on-screen corruption on resume from suspend with nVidia
+ proprietary driver
tags: added: rls-p-tracking
Chris Van Hoof (vanhoof) on 2012-03-19
Changed in oem-priority:
status: Confirmed → In Progress
no longer affects: oem-priority/oneiric
Omer Akram (om26er) on 2012-03-20
Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Medium → High
assignee: nobody → Jason Smith (jassmith)
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
tags: added: blocks-hwcert-enablement
Omer Akram (om26er) on 2012-03-27
Changed in unity (Ubuntu Oneiric):
status: New → In Progress
Changed in oem-priority:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-04-02
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in unity (Ubuntu Oneiric):
status: In Progress → Confirmed
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2012-04-06
Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Confirmed
Anthony Wong (anthonywong) wrote :

May I request this fix be backported and SRU to Oneiric? The patch (http://bazaar.launchpad.net/~unity-team/unity/trunk/revision/2205) seems small enough and doable.

Changed in oem-priority:
importance: Medium → High
Hao-Ran Liu (hzliu123) wrote :

I also request this bug to be fixed in oneiric. It affects most recent Sandy/Ivy bridge platforms with new Nvidia cards.

Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Changed in oem-priority:
assignee: Chris Van Hoof (vanhoof) → James M. Leddy (jm-leddy)
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-04-17
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
James M. Leddy (jm-leddy) wrote :

[Impact]
This bug basically makes NVidia machines unusable after suspend. This is causing problems for users and OEMs that want to use 11.10 alike.

[Development Fix]
https://bazaar.launchpad.net/~unity-team/unity/trunk/revision/2205

[Test Case]
.
To reproduce:
1) Suspend
2) Resume
2a) login, if necessary. Note that the login screen (lightdm) displays properly
3) Notice the corrupted launcher
4) Mouse over the launcher; the launcher redraws and the corruption goes away

[Regression Potential]

Low. We have tested the fix in the development version that we're planning on releasing in April 26th and have found no problems.

description: updated
James M. Leddy (jm-leddy) wrote :

I took a stab at backporting. I'll talk to the Jason tomorrow to see if this fix is valid, but it's possible it works so I'm putting it out there for nVidia users to test.

https://launchpad.net/~jm-leddy/+archive/915265/+packages

Changed in oem-priority:
status: Fix Committed → In Progress
Hao-Ran Liu (hzliu123) wrote :

I tested today on a machine with a GT640 card.
Packages provided in comment #15 does not fix this issue.

James M. Leddy (jm-leddy) wrote :

I just talked with Jason about this. He said he'll look into it once is nvidia machine is running again.

Changed in unity (Ubuntu Oneiric):
assignee: nobody → Jason Smith (jassmith)
Hao-Ran Liu (hzliu123) wrote :

I am not sure why this issue would take forever to fix for oneiric.

This issue is not fixed yet for Unity in Precise.
Launcher corruption is confirmed with these drivers:

GT520 card
nvidia-current: 295.40-0ubuntu1
unity: 5.12-0ubuntu1.1

Hao-Ran Liu (hzliu123) wrote :

Unity Launcher corruption in 12.04 is also reported in bug 975332

Hao-Ran Liu (hzliu123) wrote :

Reopened OEM-priority precise bug since the issue is not completely fixed.

James M. Leddy (jm-leddy) wrote :

Likewise, reopening precise series on unity.

Changed in unity (Ubuntu Precise):
status: Fix Released → Confirmed
tags: added: regression-update
Hao-Ran Liu (hzliu123) wrote :

1) Steps to reproduce
Either a switch between text console and graphic console or a suspend/resume can reproduce this issue.

2) Frequency of the problem (always, 1/10 times, etc)
Always

3) Is it more common on some platforms?
I believe this issue is not related to platforms.

4) Is it more common with some GPUs?
This issue can always be reproduced on GT520, GT640, and Quadro K3000M (N14E-Q1)

5) Are there some NVIDIA platforms or GPUs that never show the problem?
No, for the 3 platforms I tested, they all have the same issue.

Hao-Ran Liu (hzliu123) wrote :

pm-suspend or fwts is used to produce the screen corruption in unity when computer suspends and resumes.

Omer Akram (om26er) wrote :

that is a regression since it was clearly fixed at one stage

summary: - Unity launcher on-screen corruption on resume from suspend with nVidia
- proprietary driver
+ [regression] Unity launcher on-screen corruption on resume from suspend
+ with nVidia proprietary driver
Changed in unity:
milestone: 5.10.0 → 6.2
status: Fix Released → Confirmed
Changed in unity (Ubuntu Oneiric):
status: Confirmed → Won't Fix
Changed in unity (Ubuntu Precise):
assignee: Jason Smith (jassmith) → nobody
Changed in unity (Ubuntu Oneiric):
assignee: Jason Smith (jassmith) → nobody
Changed in unity (Ubuntu):
assignee: Jason Smith (jassmith) → nobody
Changed in unity:
assignee: Jason Smith (jassmith) → nobody
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Changed in unity (Ubuntu Oneiric):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu Precise):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → In Progress
Daniel van Vugt (vanvugt) wrote :

3v1n0, wouldn't this bug fixed by the fix for bug 1016430?

Daniel, as I've written on the merge propsal for lp:~thumper/unity/regional-damage-sru/+merge/116796, that seems to fix the issue, however with that branch I have the PC hanging after few seconds (when it works), or lots of crashes on startup.
The backtrace looks similar to bug #982626

Changed in unity:
milestone: 6.2 → 5.16.0
Changed in unity:
assignee: Marco Trevisan (Treviño) (3v1n0) → Tim Penhey (thumper)
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:unity/5.0 at revision 2394

Changed in unity:
status: In Progress → Fix Committed
Changed in oem-priority:
status: In Progress → Fix Committed
James M. Leddy (jm-leddy) wrote :

Hi Tim, When of SRU-2 expected to land?

description: updated

Hello Steve, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.16.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Taiten Peng (taitenpeng) wrote :

Verified unity 5.16.0-0ubuntu1 with nVidia graphic card, device id: "10de:1058"

lspci -nnvv output for the graphic card --

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:1058] (rev a1) (prog-if 00 [VGA controller])
 Subsystem: Hewlett-Packard Company Device [103c:2aed]
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0
 Interrupt: pin A routed to IRQ 16
 Region 0: Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
 Region 1: Memory at e8000000 (64-bit, prefetchable) [size=128M]
 Region 3: Memory at f0000000 (64-bit, prefetchable) [size=32M]
 Region 5: I/O ports at e000 [size=128]
 [virtual] Expansion ROM at f7000000 [disabled] [size=512K]
 Capabilities: [60] Power Management version 3
  Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
  Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
 Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
  Address: 0000000000000000 Data: 0000
 Capabilities: [78] Express (v2) Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s unlimited, L1 <64us
   ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd+ ExtTag+ PhantFunc- AuxPwr- NoSnoop+
   MaxPayload 128 bytes, MaxReadReq 512 bytes
  DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
  LnkCap: Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Latency L0 <256ns, L1 <4us
   ClockPM+ Surprise- LLActRep- BwNot-
  LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
   ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed 2.5GT/s, Width x16, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
  DevCap2: Completion Timeout: Not Supported, TimeoutDis+
  DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-
  LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-, Selectable De-emphasis: -6dB
    Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
    Compliance De-emphasis: -6dB
  LnkSta2: Current De-emphasis Level: -6dB
 Capabilities: [b4] Vendor Specific Information: Len=14 <?>
 Capabilities: [100 v1] Virtual Channel
  Caps: LPEVC=0 RefClk=100ns PATEntryBits=1
  Arb: Fixed- WRR32- WRR64- WRR128-
  Ctrl: ArbSelect=Fixed
  Status: InProgress-
  VC0: Caps: PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
   Arb: Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256-
   Ctrl: Enable+ ID=0 ArbSelect=Fixed TC/VC=01
   Status: NegoPending- InProgress-
 Capabilities: [128 v1] Power Budgeting <?>
 Capabilities: [600 v1] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
 Kernel driver in use: nvidia
 Kernel modules: nvidia_current_updates, nouveau, nvidiafb

tags: added: verification-done
removed: verification-needed
Taiten Peng (taitenpeng) wrote :

Hi,

Do we have a ETA for moving the pacakge to -update after tag changed to verification-done
We have couple of customer's system is effected by this

Thanks

Omer Akram (om26er) wrote :

Taiten, we are working to ensure we didn't introduce any regressions, once we are sure about that we will release it to proposed. It could be as early as the coming week.

Taiten Peng (taitenpeng) wrote :

Omer,

I though 5.16.0-0ubuntu1 is in -proposed archive already?
can you confirm which archive the update package will be in?
Thanks.

Omer Akram (om26er) wrote :

Yes its in -proposed. What I said is we are very careful to release it to precise-proposed since there the number of users is much larger (no everyone have -proposed enabled)

Hao-Ran Liu (hzliu123) wrote :

Tested on a GeForce GT 520 [10de:1040] from MSI, unity 5.16.0-0ubuntu1 has fixed this issue.

02:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119 [GeForce GT 520] [10de:1040] (rev a1) (prog-if 00 [VGA controller])
 Subsystem: Micro-Star International Co., Ltd. Device [1462:2630]
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at fb000000 (32-bit, non-prefetchable) [size=16M]
 Memory at d8000000 (64-bit, prefetchable) [size=128M]
 Memory at e6000000 (64-bit, prefetchable) [size=32M]
 I/O ports at ac00 [size=128]
 [virtual] Expansion ROM at e0000000 [disabled] [size=512K]
 Capabilities: [60] Power Management version 3
 Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
 Capabilities: [78] Express Endpoint, MSI 00
 Capabilities: [b4] Vendor Specific Information: Len=14 <?>
 Capabilities: [100] Virtual Channel
 Capabilities: [128] Power Budgeting <?>
 Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
 Kernel driver in use: nvidia
 Kernel modules: nvidia_current, nouveau, nvidiafb

Changed in unity:
status: Fix Committed → Fix Released
Changed in oem-priority:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Omer Akram (om26er) on 2012-09-25
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.16.0-0ubuntu1

---------------
unity (5.16.0-0ubuntu1) precise-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * debian/control:
    - Update libgeis-dev and libgrail-dev dependencies in debian/control
  * New upstream release.
    - launcher is not refreshed after user session switch (LP: #1016430)
    - Dragging windows around is slow/sluggish/laggy when multiple monitors
      are enabled (LP: #874619)
    - Dragging icons to reorder -away from launcher causes the dragged icon
      image edges to fade away(cut off) (LP: #1026247)
    - Arrow for indicating lenses points empty space on alt+F2 (LP: #998752)
    - Tooltips backgrounds are not refreshed (no active blur) (LP: #967112)
    - [regression] Unity panel transparency (active blur) not updating properly
      (LP: #865006)
    - [Regression] Hideous low-res icon when using the HUD with autohide
      enabled. (LP: #1035951)
    - Launcher dragged icon is not redrawn when the mouse pointer is not moved
      (LP: #1032700)
    - Black background around after dash is restored (LP: #992516)
    - Refreshing active blur makes the dash painfully slow (LP: #874230)
    - [SRU regression] alt-grave not switching to next window unless 'grave'
      pressed twice (LP: #1035668)
    - [SRU Regression] Unity 5.14 + Nux 2.14: Launcher tooltips are
      incomplete/missing (LP: #1034164)
    - [nvidia] unity crashed in
      nux::GraphicsEngine::QRP_GLSL_1Tex (glDrawArrays) (LP: #1031554)
    - compiz crashed with SIGSEGV in
      unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()
      (LP: #1020075)
    - Much slower OpenGL frame rates with unityshell loaded, than plain compiz
      (LP: #988079)
    - Compiz won't start if "unredirect fullscreen windows" is enabled
      (LP: #980663)
    - [regression] Unity launcher on-screen corruption on resume from suspend
      with nVidia proprietary driver (LP: #915265)
    - Desktop, Launcher and menu bar still visible when screen locked
      (LP: #886605)
    - Unity is visible on top of fullscreen apps (LP: #734908)
    - [nvidia] compiz crashed with SIGSEGV in
      nux::BasePainter::PaintBackground (LP: #982626)
    - Update dependency on the renamed libgeis

  [ Didier Roche ]
  * debian/control:
    - build-dep on latest nux as libgeis-dev and libutouch-geis-dev are
      conflicting (LP: #1047385)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 11 Sep 2012 10:53:17 +0200

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Ingo Gerth (igerth) wrote :

The issue is back in 14.04. This is a regression from 13.10, where the problem did not occur.

See the attached screenshot.

Requesting to re-open this bug.

Alberto Milone (albertomilone) wrote :

@Ingo: we're tracking this issue in LP: #1210077

Hello,

Just looked at screenshots from #1210077 .
They show corruption on screen background and some window content.

The bug I originally experienced shows on-screen corruption of launcher only, as confirmed by original description of this bug : "The unity launcher is reliably corrupted ...".

Since symptoms of the two bugs are different, the two bugs may or may not be actually from the same cause.

I can confirm that previous comment. On my hardware with 108 I see the
launcher as either gone (transparent textures) or partially corrupted.
Various other textures are sometimes broken but the launcher is
consistently affected.

On Tue, Mar 18, 2014 at 11:59 AM, gouri <email address hidden>wrote:

> Hello,
>
> Just looked at screenshots from #1210077 .
> They show corruption on screen background and some window content.
>
> The bug I originally experienced shows on-screen corruption of launcher
> only, as confirmed by original description of this bug : "The unity
> launcher is reliably corrupted ...".
>
> Since symptoms of the two bugs are different, the two bugs may or may
> not be actually from the same cause.
>
> --
> You received this bug notification because you are a member of Canonical
> Hardware Enablement Team, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/915265
>
> Title:
> [regression] Unity launcher on-screen corruption on resume from
> suspend with nVidia proprietary driver
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/oem-priority/+bug/915265/+subscriptions
>

Alberto Milone (albertomilone) wrote :

They are really two separate issue which, nonetheless, we're tracking in LP: #1210077, and I think it makes sense to do so because the code to handle resume is already in place in Unity (which is what this bug report was about).

It is true that one issue was in the nvidia driver (now fixed), however the other issue is in Unity. The latter, though, is really Upower not emitting the event on resume. This is why I suggested that we rely on Logind instead.

Zygmunt Krynicki (zkrynicki) wrote :

Those interfaces were removed from upstream upower so relying on them is
probably not the best idea now.

Thanks
ZK

On Thu, Mar 20, 2014 at 11:00 AM, Alberto Milone <
<email address hidden>> wrote:

> They are really two separate issue which, nonetheless, we're tracking in
> LP: #1210077, and I think it makes sense to do so because the code to
> handle resume is already in place in Unity (which is what this bug
> report was about).
>
> It is true that one issue was in the nvidia driver (now fixed), however
> the other issue is in Unity. The latter, though, is really Upower not
> emitting the event on resume. This is why I suggested that we rely on
> Logind instead.
>
> --
> You received this bug notification because you are a member of Canonical
> Hardware Enablement Team, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/915265
>
> Title:
> [regression] Unity launcher on-screen corruption on resume from
> suspend with nVidia proprietary driver
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/oem-priority/+bug/915265/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers