Mir

[testfail] Intermittent failure in TestClientInput.clients_receive_pointer_within_coordinate_system_of_window

Bug #1523965 reported by Alberto Aguirre on 2015-12-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mir
Fix Released
Medium
Alberto Aguirre
mir (Ubuntu)
Undecided
Unassigned

Bug Description

[ RUN ] TestClientInput.clients_receive_pointer_within_coordinate_system_of_window
/home/alberto/source/mir/trunk/tests/acceptance-tests/test_client_input.cpp:503: Failure
Actual function call count doesn't match EXPECT_CALL(first_client, handle_input(mt::PointerEnterEvent()))...
Expected: to be called once
Actual: never called - unsatisfied and active
[ FAILED ] TestClientInput.clients_receive_pointer_within_coordinate_system_of_window (2229 ms)

Repro with:

../tools/detect_fd_leaks.bash "/usr/bin/valgrind" "--error-exitcode=1" "--trace-children=yes" "--leak-check=full" "--show-leak-kinds=definite" "--errors-for-leak-kinds=definite" "--track-fds=yes" "--num-callers=128" "--suppressions=../tools/valgrind_suppressions_generic" "--suppressions=../tools/valgrind_suppressions_glibc_2.21" bin/mir_acceptance_tests --gtest_filter=TestClientInput.clients_receive_pointer_within_coordinate_system_of_window --gtest_repeat=100

Related branches

Daniel van Vugt (vanvugt) wrote :

Another test failure that might be caused by pointer acceleration (new with libinput support).

tags: added: testsfail
tags: added: pointer-events
summary: + [testfail] Intermittent failure in
TestClientInput.clients_receive_pointer_within_coordinate_system_of_window

TestClientInput is not using libinput. So no acceleration

Alberto Aguirre (albaguirre) wrote :

The root cause is a race between emitting the event and the surface becoming exposed, so the surface input dispatcher occasionally did not find the topmost surface to dispatch to while doing Scene::for_each.

This can be fixed by changing the TestClientInput setup to wait for the surface exposed event before executing the rest of the test.

Changed in mir:
assignee: nobody → Alberto Aguirre (albaguirre)
status: New → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:mir at revision 3186, scheduled for release in mir, milestone 0.19.0

Changed in mir:
status: In Progress → Fix Committed
tags: removed: pointer-events
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mir - 0.19.0+16.04.20160128-0ubuntu1

---------------
mir (0.19.0+16.04.20160128-0ubuntu1) xenial; urgency=medium

  [ Brandon Schaefer ]
  * New upstream release 0.19.0
    - API summary:
      . mirclient abi unchanged at 9
      . mirserver abi bumped to 37
      . mircommon abi unchanged at 5
      . mirplatform abi unchanged at 11
      . mirprotobuf abi unchanged at 3
      . mirplatformgraphics abi bumped to 7
      . mirclientplatform abi bumped to 4
      . mirinputplatform abi bumped to 5
      . mircookie abi bumped to 2
    - Bug fix:
      . Mir servers crash on mouse input (LP: #1528438)
      . Pinch to zoom not working reliably (LP: #1531517)
      . Passing DisplayConfiguration scale property from
        nested server to host appears to not work (LP: #1535780)
      . Various TSan reports when running test suite
        on a mir tsan enabled build (LP: #1523647)
      . Buffer leak during repeated mirscreencasts
        causes server to be killed (LP: #1523900)
      . Cursor now displays correctly (LP: #1526779)
      .ProgramOption::parse_file() reports problems to cerr (LP: #1190165)
      . Nested servers can select wrong platform (LP: #1515558)
      . There seems to be missing RTTI information
         when linking with UBSan enabled (LP: #1521930)
      . Mir threadsanitizer build fails with GCC (LP: #1522581)
      . After "make install" mir_demo_server cannot
        find shared object file in /usr/local/lib (LP: #1522836)
      . Fixed a test in TestClientInput (LP: #1523965)
      . Mir servers choose graphics-dummy (or no driver at all)
        over mesa-kms on a desktop (LP: #1528082)
      . Function mir_event_get_close_surface_event is never used (LP: #1447690)
      . mir::input::Surface::consume(MirEvent const& event)
        should not take a reference to an opaque type (LP: #1450797)
      . lintian: E: mir-doc: privacy-breach-logo (LP: #1483471)

  [ CI Train Bot ]
  * No-change rebuild.

 -- Brandon Schaefer <email address hidden> Thu, 28 Jan 2016 12:19:47 +0000

Changed in mir (Ubuntu):
status: New → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers