Maverick Backports (obsolete)

Please back port Evolution 2.32 to lucid LTS and maverick

Reported by Larry Reid on 2010-10-02
166
This bug affects 27 people
Affects Status Importance Assigned to Milestone
Lucid Backports
Undecided
Unassigned
maverick-backports
Won't Fix
Undecided
Unassigned

Bug Description

There are significant bug fixes in Evolution 2.32 that are needed if Evolution is to be considered a serious business e-mail client, e.g. https://bugzilla.gnome.org/show_bug.cgi?id=590976. I expect there are significant product feature advances as well, but I haven't figured out how to navigate the Gnome Evolution project history to identify them.

I will happily test the backport as I use Evolution constantly.

Omer Akram (om26er) on 2010-10-02
Changed in lucid-backports:
status: New → Confirmed
Omer Akram (om26er) wrote :

sorry about that but I thought it was a backport request for Maverick.

Changed in lucid-backports:
status: Confirmed → New
bojo42 (bojo42) wrote :

yes we're really should have a clean and official backport. so far Jacob has done a backport attempt at https://launchpad.net/~jacob/+archive/evo230

Manveru (manveru) wrote :

My vote.

tags: added: mail
summary: - Please back port Evolution 2.32 to lucid LTS
+ Please back port Evolution 2.32 to lucid LTS and maverick
Omer Akram (om26er) wrote :

not sure about 10.04 but 10.10 certainly deserves evo2.32

Manveru (manveru) wrote :

Why not sure about 10.04? This is LTS distribution which I do not plan to upgrade fast. As plenty of others I think.

Leon (leonbo) wrote :

Maverick without evolution 2.32 is a pitty.

Konstigt (konstigt) wrote :

Maybe the right people could be attracted to creating a PPA.

I created a thread on Ubuntu Forums: http://ubuntuforums.org/showthread.php?p=10058539

@Leon
Even more so for Lucid - just remember that Lucid is the "Ubuntu" for the business market. _Official_ backport for Lucid is a need there. Lucid is still stuck at 2.28 !!!

On the other hand an official backport for Maverick is just a convenience - Jacob's PPA is OK for most casual users.

Steve Jackson (aearenda) wrote :

Jacob's PPA only has 2.30, not 2.32.

@Steve
You seem to be correct, I was confused by 2.32 listed as submitted for Maverick on 2010-10-16:
https://launchpad.net/~jacob/+ppa-packages

I's venture to guess 2.32 is still unstable so he limited public access or so.

Philip Muškovac (yofel) wrote :

Marking this incomplete as Evolution 2.32 isn't available in any Ubuntu Release yet (not even Natty), so this is postponed until there is something to backport.

Changed in lucid-backports:
status: New → Incomplete
Changed in maverick-backports:
status: New → Incomplete
Omer Akram (om26er) wrote :

evolution 2.32 is now in natty

Changed in lucid-backports:
status: Incomplete → New
Changed in maverick-backports:
status: Incomplete → New
Leon (leonbo) wrote :

Woohoo :)

Enbie (noelb-ausics) wrote :

+1 for:

https://bugzilla.gnome.org/show_bug.cgi?id=621839
It really is terrible in 2.28, was fine in earlier,

miroj (j-miroslav) wrote :

Lucid as LTS release for sure need constant official updates of crucial parts of the system as Evolution suite. Any progress on that field is more than welcomed, since for me Lucid means that I'm not upgrading my production system until the next LTS system. I do really appreciate any improvements in that area.

Mengxuan Xia (xiamx) wrote :

+1 for backport to lucid

Larry Reid (lcreid) wrote :

Over in the forums there's a reference to a PPA for Evolution 2.30 on Lucid: http://ubuntuforums.org/showpost.php?p=9736019&postcount=5. I haven't tried it yet myself, but I'm tempted.

2011/1/16 Larry Reid <email address hidden>:
> Over in the forums there's a reference to a PPA for Evolution 2.30 on
> Lucid: http://ubuntuforums.org/showpost.php?p=9736019&postcount=5. I
> haven't tried it yet myself, but I'm tempted.

Once again: That is only 2.30, not 2.32. Now it is even 2.32.1.

--
Manveru
jabber: <email address hidden>
     gg: 1624001
   http://www.manveru.pl

MichaelB (mrbou) wrote :

+1 for backport to lucid

I use Lucid LTS in a company environnement and must to use thunderbird with davmail because evolution shipped with lucid don't work with exchange 2003.

Viser (viser-m) wrote :

+1 for backport to lucid

Jeremy Lakin (jaylakes) wrote :

+1 for backport to lucid and maverick.
This update (assuming that the bug fixes proved successful) will mean the difference between my running a windows VM for outlook, and finally removing the shackles and freeing myself of that closed source monstrosity.

Alkis Georgopoulos (alkisg) wrote :

I tried dual booting Natty with my main OS, Lucid.

Evolution 2.32 automatically and silendly migrated its data from ~/.evolution
to ~/.local/share/evolution and ~/.config/evolution.

So I cannot access my emails from Lucid anymore, and I can't revert the migration as it was splitted into 2 locations.

So +1 to backport 2.32 to Lucid, I won't be able to access my mails from Lucid otherwise.

And also please warn the users before doing irreversible file format or configuration changes. :)

Enbie (noelb-ausics) wrote :

Stop trying to be micro$oft and dictating how our systems should be!

i use 2.32 on other OS's and they ALL use ~/.evolution, leave the damn thing alone and stop butchering the christ out of it all the time changing things FFS.

Jeremy Lakin (jaylakes) wrote :

Please can we finally see some traction on this? It's been years already and I'm dying to get rid of this stupid VM.
Even a decision on the importance would be a glimmer of hope.

Enbie (noelb-ausics) wrote :

I agree, make a decision one way or the other, if its not going to be done, say so, and we can all move on, likely by dumping ubuntu's package and all of us installing from source so we can actually use it without its current bugs.

Konstigt (konstigt) wrote :

I have a PPA that has a working Evolution 2.32.2 for Maverick/10.10. It's really just a copy of Michael Kuhns PPA but without all other packages, just Evolution. Works nicely for me!

Check it out here, https://launchpad.net/~konstigt/+archive/evolution

Daniel (danielprakash) wrote :

I am using Thomas Novin ppa dont know why the calendar free/busy time doesn't work in mapi or how to make it work..

Also evolution-exchange doesn't show up in the server type also both these are badly broken

HX_unbanned (linards-liepins) wrote :

COme on!

Backport 2.32.x to Maverick at ONCE!!! I do not understand why sometimes Canonical devs IGNORES such obvious and needed steps to to.

Do not want to be rude, but these situations really makes me bloody angry ...

HelderPereira (pereira-helder) wrote :

Well, I never tought I would say this but change to Fedora...

After around 10 releases of Ubuntu I changed exactly because of this...

Helder Pereira @ GMail

On 13 March 2011 11:43, HX_unbanned <email address hidden> wrote:
> COme on!
>
> Backport 2.32.x to Maverick at ONCE!!! I do not understand why sometimes
> Canonical devs IGNORES such obvious and needed steps to to.
>
> Do not want to be rude, but these situations really makes me bloody
> angry ...
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/653619
>
> Title:
>  Please back port Evolution 2.32 to lucid LTS and maverick
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/lucid-backports/+bug/653619/+subscribe
>

Omer Akram (om26er) wrote :

Helder, please spam somewhere else

On Sun, Mar 13, 2011 at 8:23 PM, HelderPereira <email address hidden>wrote:

> Well, I never tought I would say this but change to Fedora...
>
> After around 10 releases of Ubuntu I changed exactly because of this...
>
>
> Helder Pereira @ GMail
>
>
> On 13 March 2011 11:43, HX_unbanned <email address hidden> wrote:
> > COme on!
> >
> > Backport 2.32.x to Maverick at ONCE!!! I do not understand why sometimes
> > Canonical devs IGNORES such obvious and needed steps to to.
> >
> > Do not want to be rude, but these situations really makes me bloody
> > angry ...
> >
> > --
> > You received this bug notification because you are a direct subscriber
> > of the bug.
> > https://bugs.launchpad.net/bugs/653619
> >
> > Title:
> > Please back port Evolution 2.32 to lucid LTS and maverick
> >
> > To unsubscribe from this bug, go to:
> > https://bugs.launchpad.net/lucid-backports/+bug/653619/+subscribe
> >
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/653619
>
> Title:
> Please back port Evolution 2.32 to lucid LTS and maverick
>
> Status in Lucid Backports:
> New
> Status in Maverick Backports:
> New
>
> Bug description:
> There are significant bug fixes in Evolution 2.32 that are needed if
> Evolution is to be considered a serious business e-mail client, e.g.
> https://bugzilla.gnome.org/show_bug.cgi?id=590976. I expect there are
> significant product feature advances as well, but I haven't figured
> out how to navigate the Gnome Evolution project history to identify
> them.
>
> I will happily test the backport as I use Evolution constantly.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/lucid-backports/+bug/653619/+subscribe
>

Omer Akram (om26er) wrote :

also backporting 2.32 to lucid I believe is not a simple task since it might
require the update for some other libraries too but for 10.10 its do-able.

So if you want to install evolution 2.30.3 in Lucid and 2.32.x in Maverick
please use this ppa https://launchpad.net/~jacob/+archive/evo230

On Sun, Mar 13, 2011 at 8:32 PM, Omer Akram <email address hidden> wrote:

> Helder, please spam somewhere else
>
>
> On Sun, Mar 13, 2011 at 8:23 PM, HelderPereira <email address hidden>wrote:
>
>> Well, I never tought I would say this but change to Fedora...
>>
>> After around 10 releases of Ubuntu I changed exactly because of this...
>>
>>
>> Helder Pereira @ GMail
>>
>>
>> On 13 March 2011 11:43, HX_unbanned <email address hidden> wrote:
>> > COme on!
>> >
>> > Backport 2.32.x to Maverick at ONCE!!! I do not understand why sometimes
>> > Canonical devs IGNORES such obvious and needed steps to to.
>> >
>> > Do not want to be rude, but these situations really makes me bloody
>> > angry ...
>> >
>> > --
>> > You received this bug notification because you are a direct subscriber
>> > of the bug.
>> > https://bugs.launchpad.net/bugs/653619
>> >
>> > Title:
>> > Please back port Evolution 2.32 to lucid LTS and maverick
>> >
>> > To unsubscribe from this bug, go to:
>> > https://bugs.launchpad.net/lucid-backports/+bug/653619/+subscribe
>> >
>>
>> --
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>> https://bugs.launchpad.net/bugs/653619
>>
>> Title:
>> Please back port Evolution 2.32 to lucid LTS and maverick
>>
>> Status in Lucid Backports:
>> New
>> Status in Maverick Backports:
>> New
>>
>> Bug description:
>> There are significant bug fixes in Evolution 2.32 that are needed if
>> Evolution is to be considered a serious business e-mail client, e.g.
>> https://bugzilla.gnome.org/show_bug.cgi?id=590976. I expect there are
>> significant product feature advances as well, but I haven't figured
>> out how to navigate the Gnome Evolution project history to identify
>> them.
>>
>> I will happily test the backport as I use Evolution constantly.
>>
>> To unsubscribe from this bug, go to:
>> https://bugs.launchpad.net/lucid-backports/+bug/653619/+subscribe
>>
>
>

HelderPereira (pereira-helder) wrote :

Spam? lol!

Your comment is really pathetic.

This lost, the Evolution one, it's simply a game changer in a
corporate environment. It's totally Ubuntu's fault since it's their
decision to be on the trailing side of things, and to my knowledge,
only from choice, not a technical problem.
There is nothing that justifies this.

And you say to me, a total Ubuntu user from the start, that I'm spamming?

Well, I have one thing you clearly don't, which is a the ability to
think for myself and not be a lamb that follows the herd, just
because...

Helder Pereira @ GMail

On 13 March 2011 15:32, Omer Akram <email address hidden> wrote:
> Helder, please spam somewhere else
>
> On Sun, Mar 13, 2011 at 8:23 PM, HelderPereira
> <email address hidden>wrote:
>
>> Well, I never tought I would say this but change to Fedora...
>>
>> After around 10 releases of Ubuntu I changed exactly because of this...
>>
>>
>> Helder Pereira @ GMail
>>
>>
>> On 13 March 2011 11:43, HX_unbanned <email address hidden> wrote:
>> > COme on!
>> >
>> > Backport 2.32.x to Maverick at ONCE!!! I do not understand why sometimes
>> > Canonical devs IGNORES such obvious and needed steps to to.
>> >
>> > Do not want to be rude, but these situations really makes me bloody
>> > angry ...
>> >
>> > --
>> > You received this bug notification because you are a direct subscriber
>> > of the bug.
>> > https://bugs.launchpad.net/bugs/653619
>> >
>> > Title:
>> >  Please back port Evolution 2.32 to lucid LTS and maverick
>> >
>> > To unsubscribe from this bug, go to:
>> > https://bugs.launchpad.net/lucid-backports/+bug/653619/+subscribe
>> >
>>
>> --
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>> https://bugs.launchpad.net/bugs/653619
>>
>> Title:
>>  Please back port Evolution 2.32 to lucid LTS and maverick
>>
>> Status in Lucid Backports:
>>  New
>> Status in Maverick Backports:
>>  New
>>
>> Bug description:
>>  There are significant bug fixes in Evolution 2.32 that are needed if
>>  Evolution is to be considered a serious business e-mail client, e.g.
>>  https://bugzilla.gnome.org/show_bug.cgi?id=590976. I expect there are
>>  significant product feature advances as well, but I haven't figured
>>  out how to navigate the Gnome Evolution project history to identify
>>  them.
>>
>>  I will happily test the backport as I use Evolution constantly.
>>
>> To unsubscribe from this bug, go to:
>> https://bugs.launchpad.net/lucid-backports/+bug/653619/+subscribe
>>
>
>
> ** Bug watch added: GNOME Bug Tracker #590976
>   https://bugzilla.gnome.org/show_bug.cgi?id=590976
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/653619
>
> Title:
>  Please back port Evolution 2.32 to lucid LTS and maverick
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/lucid-backports/+bug/653619/+subscribe
>

Enbie (noelb-ausics) wrote :

@HelderPereira Completely agree, the fanboi's really are boring aren't they

@Omer Akram Stop being a fanboi, if you have nothing worthwhile to contribute to this, which you don't by your comments, then please, will you stop spamming.

now, in general..
If it is added into backports with changes then people using backports are aware of the risks, its not like it is going in to the mainstream repo.

It is a bout time ubuntu lost the debian mentality of using outdated products for new releases, if oit works for RedHat, no need it wont work on ubuntu.

And yes, the number of severe problems known about 10.04's evolution, is large, and resolved upstream some time ago. It makes using it in commercial situations , well, not suitable.

Scott Kitterman (kitterman) wrote :

Backporting Evolution 2.32 to 10.04 requires backporting at least a dozen other packages - new GLib and Gtk+, few other libraries, e-d-s, modules that evolution uses to provide additional features like Exchange support, and most likely evolution-couchdb. This is far to invasive for an in archive backport. A PPA is the best way to support this.

Changed in lucid-backports:
status: New → Won't Fix

@Scott Kitterman
You do realize that Evolution is THE application on a corporate desktop? The only market where it is feasible for Linux to generate desktop revenue!

Backporting to Maverick is nice to have. Backporting to Lucid is essential.
Backporting essential apps via PPA's is ok for normal releases and casual users. Backporting via PPA is NOT acceptable for LTS and enterprise users.

With this kind of attitude, Ubuntu may as well drop the LTS release concept on Desktop.
If you are not willing to support LTS, better don't do it at all.

HelderPereira (pereira-helder) wrote :

@Enbie and Milan, in my country we have a saying that it's about what we
are doing with this problem and Ubuntu, which goes something like this
"It's like pouring a bucket of water in a rainy day.". Meaning, I
already accepted Ubuntu isn't going to do anything about this, no matter
what we say, so we have to remember what open source is all about and
... choose!

For the first time in some years, the next Fedora 15 release is going to
have a shoot at my corporate desktop. Ubuntu 11.04 probably wont... And
I assure you, I'm not happy with this, it's not something I will "enjoy"...

Thank you for your support.

Helder

On 03/14/2011 07:48 AM, Milan Niznansky wrote:
> @Scott Kitterman
> You do realize that Evolution is THE application on a corporate desktop? The only market where it is feasible for Linux to generate desktop revenue!
>
> Backporting to Maverick is nice to have. Backporting to Lucid is essential.
> Backporting essential apps via PPA's is ok for normal releases and casual users. Backporting via PPA is NOT acceptable for LTS and enterprise users.
>
> With this kind of attitude, Ubuntu may as well drop the LTS release concept on Desktop.
> If you are not willing to support LTS, better don't do it at all.
>

Krzysztof Klimonda (kklimonda) wrote :

To all people who are commenting on this issue, please try to understand that Backports project is not ran by Canonical, but by community, on the volunteer basis. Your negative comments are simply misplaced - we can do only that much given the time and resources on our hands. It is simply not feasible for us to prepare and test backports of all those packages before pushing them to each and every backports user out there, especially given that it's a one way trip - you can't go back to 2.28 easily. As the update is needed only by a small number of users, PPA is a much better choice to deliver it. It is not perfect, but at this time it is the best choice we have.

Also, the decision to stay with 2.28 for 10.04 wasn't easy but it has been based on technical merits - it wasn't a random decision as has been suggested in one of earlier comments.

@HelderPereira
Had one not voiced his opinion, shall he not have a voice in the matter.

@Krzysztof Klimonda
Well all here, while complaining ravishingly sometimes, very much appreciate the community effort going into Ubuntu.

What you have highlighted though, is the core of the issue: Backports are a community project with no real Canonical backing.
That is the problem. LTS without a real backporting effort is meaningless. And it is Canonical's job to make it happen.

I am not talking about back-porting every single app out there. Not by a long shot. But there are a _few_ mission-critical apps like Evolution or say Firefox that become useless unless regular functionality/compatibility updates are provided.
Debian does the heavy lifting to make it happen so there is no excuse for a commercial distro based on it not doing likewise.

Please do not take my postings as ranting. It saddening me that after 6 years on the market Canonical still does not get the point. Supportability and compatibility is key. And that is not possible without backport support for critical apps.
Bling stuff like Unity,Compiz, or the next great thing, is NOT a requirement for Linux distro to succeed in the volume/business/OEM market. Good app support is. And good app support in practice equals a major backporting effort.

/me throwing in the towel

The problem isn't directly with backporting Evolution (and yes I know how important it is) but with the required library updates. Doing this would have the potential to negatively affect every single desktop user that has backports enabled.

There is a technical board directed policy against library backports that there is no way we could do enough testing to merit an exception. The level of testing required would probably be similar to what's needed for a new Ubuntu release.

I think it makes more sense to finish the Natty release at this point than to delay it a month to update Evolution in Lucid.

Honestly, if it's that important to you and a PPA (which is being worked on) isn't sufficient, then you need to Update to a newer distro release. F15 this month or Natty next month is entirely up to you.

Enbie (noelb-ausics) wrote :

@HelderPereira You are correct, we do have that choice.. We used to use Fedora, the ONE and ONLY reason we switched to ubuntu was for LTS, updating desktops every three years is better than yearly, this policy will be changed when we return to Fedora as well.

Jeremy Lakin (jaylakes) wrote :

If the distro-war rhetoric is done, can we please have a definitive answer to whether this is actively being worked on for maverick?
I have my own reasons to staying with Ubuntu as my distro of choice. I won't bother fueling the fire with what those are, but I will ask that the developers please respond with a "yes, we're working on it, as demand has been deemed high enough to make this worthwhile" or a simple "Wait for the next Ubuntu release, as it simply isn't stable enough to introduce even into a non-LTS release"

I don't really need anything more than that. While additional explanations would be welcome, I just want to know if I'm waiting a few more months for a backport, or another year for the next LTS release.

Leaving the status as "Unassigned" and "Unknown" only leaves those of us looking for a hint at the outcome of this work frustrated at what we may be mistaking for complacency. I'm sure you're all well aware of what this backport could mean for those of us who are actively resisting a redmond OS, and wouldn't backburner this backport request without excellent reasons. But please, respect the devotion that so many on this thread have shown to Ubuntu by at least being honest and telling us if we're holding our breath for nothing.

Krzysztof Klimonda (kklimonda) wrote :

The short answer wrt official backport of Evolution 2.32 to maverick is that it's unlikely given the amount of work, a number of people who can do that work, and the proximity of 11.04 release which will ship with 2.32. The longer explanation is below.

The reason for not changing the status of the maverick task is that, when I've asked Scott to close the lucid one, I have not yet evaluated backporting of Evolution 2.32 to 10.10. It was a long night, I just did a bunch of testing and I simply didn't take a look. I haven't assigned myself to the bug, because it might have been read as the indication that I'm working on the backport through the -backports pocket - it hasn't been a case a week ago. Since then I've spent some time backporting 2.32 to 10.04 and kept the work in my PPA - that, and my work, didn't leave me much time to even take a look at maverick.

I've spent some more time tonight working on that and my current opinion is that the official backport to maverick is just not worth the work it would take. Just evolution requires backporting 2 other packages: evolution-data-server and gtkhtml3.14. Both Evolution and e-d-s ships libraries that other packages are depending on, and there was an ABI bump which means that those packages will require at least a rebuild.

The number, and nature of changes required to do an official backport of Evolution to maverick makes it impossible - they won't be accecpted by the archive admins, they are against the official policy.

That being said I will provide Evolution 2.32 in my PPA[1] as a part of the upgrade path from lucid to natty.

Also, if anyone is interested in starting testing Evolution 2.32 for 10.04 I've started uploading packages to this PPA: https://launchpad.net/~kklimonda/+archive/evo232 - they will never make it to lucid-backports but it is a solution for those who can't update to 11.04. If you don't like the idea of using PPAs for this (I don't) then start nagging Launchpad people to provide an official way for developers to provide some kind of thrusted repositories.

DISCLAIMER Those package were not thoroughly tested, and should not be installed on production systems, I expect that, with enough feedback, it will take at least a month to make them stable enough. Some really weird bugs may show up, I may end up backporting much more packages to make them work with new libraries from evolution and e-d-s, it is also possible that it will never get stable enough for broader audience DISCLAIMER

[1] Really, PPAs are the only sane way of doing such an update without throwing a team of dedicated developers who can spend time on both backporting and QA of the resulting packages.

ghomem (gustavo) wrote :

Short comment: while it is quite important to have these packages for LTS versions it is more than reasonable not backport them to non-LTS releases. LTS and non-LTS versions serve very different purposes.

Thanks for the update.

Evan Broder (broder) wrote :

I'm closing the maverick-backports task on this bug due to Ubuntu 10.10 (Maverick Meerkat) no longer being supported.

This bug is being closed by a bot. If you feel the change was made in error, please feel free to re-open the bug. However, backports requests for Ubuntu 10.10 (Maverick Meerkat) are no longer being accepted.

Changed in maverick-backports:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.