The Window Navigator Construction Kit: libwnck

cannot set number or name of workspaces from workspace switcher applet

Reported by Mark Sobell on 2007-07-30
118
This bug affects 2 people
Affects Status Importance Assigned to Milestone
libwnck
Confirmed
Medium
libwnck (Ubuntu)
Medium
Ubuntu Desktop Bugs
Nominated for Hardy by Prafulla Tekawade
Gutsy
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-panel

the workspace preferences dialog does not include options for changing the number of workspaces nor for naming workspaces.

ProblemType: Bug
Architecture: i386
Date: Sun Jul 29 16:44:06 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/gnome-panel
Package: gnome-panel 1:2.19.5-0ubuntu3
PackageArchitecture: i386
ProcCmdline: gnome-panel --sm-client-id default1
ProcCwd: /home/mark
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-panel
Uname: Linux tinygg 2.6.22-8-generic #1 SMP Thu Jul 12 15:59:45 GMT 2007 i686 GNU/Linux

Mark Sobell (mark-sobell) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug. Do you use compiz?

Changed in gnome-panel:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete

Nope, no compiz. Do you ask because you think it will cause or fix this
problem? Thanks.

Sebastien Bacher (seb128) wrote :

The set of bugs is not the same when using it. Could you make a screenshot of the dialog?

Mark Sobell (mark-sobell) wrote :

Here you go (screenshot attached)...

Sebastien Bacher (seb128) wrote :

Do you use the desktop effects option?

Mark Sobell (mark-sobell) wrote :

Problem is there with Normal effects and Extra effects.
The problem is not there with No effects.

That is, the Workspace Switcher Preferences window includes the Workspaces section (Number of workspaces and Workspace names) with No effects selected. The Workspaces section is missing when effects are selected.

Oded Arbel (oded-geek) wrote :

Its possible to set the number of workspaces for "desktop effects" mode by going into "Appearance" and disabling desktop effects, then right clicking the workspace switcher and changing the number of desktops and re-enabling the desktop effects. annoying but possible.

Bill Gjestvang (bgjestvang) wrote :

Also, when using desktop effects, if you try to put your workspaces in more than one row, it'll create more than one row, but put all the workspaces in the top row.

Changed in gnome-panel:
status: Incomplete → New
Changed in libwnck:
importance: Low → Medium
status: New → Triaged

I am having this problem also. I can set the number of workspaces and their names only when Desktop Effects are disabled. By default the desktop effects were set to "Normal effects".

I think I am running 7.10 tribe 4 or 5 (I installed 4 from CD and it did an upgrade last night which includes the new multiple monitor config tool).

Uname: Linux forrest-ubuntu 2.6.22-9-generic #1 SMP Fri Aug 3 00:50:37 GMT 2007 i686 GNU/Linux
gnome-panel is version 1:2.19.6-0ubuntu1

Changed in libwnck:
status: Unknown → Confirmed
stevecrozz (stevecrozz) wrote :

Same issue here with gutsy 7.10 with compiz-fusion.

Sebastien Bacher (seb128) wrote :

we need to use the libwnck upstream patch to add the new API and "changing num_rows_value_changed() and num_workspaces_value_changed() to detect that compiz is running (easy, check for pager->wm) and call the new API instead of doing something else" and "changing update_properties_for_wm() to not hide all widgets for compiz"

Martin Olsson (mnemo) wrote :

im also hitting this bug with gutsy tribe 5 (i've never installed any separate compiz download though, I only use the basic ubuntu stuff).

xspyderx (thiago-spina) wrote :

Well, when i use GL Desktop(gnome-settings-properties), it works perfectly.
I just installed it from gutsy repositories, and it solved my problems.
However, while using some Kde applications, such as Amarok and Kopete, the X
system crashed. So i installed compiz-kde, and run GL Desktop on KDE, until
now I haven't had problems.

Eric Jacobi (ericjacobi) wrote :

I too am experiencing this problem with Workspace switcher. I tried creating a new user account to see if it was leftover settings from Feisty but to no avail. I am using Extra Desktop effects with Nvidia propietary drivers installed. Please advise.

Rob Simpson (aspir8or) wrote :

Eric. I fixed mine by turning off desktop effects, then the workspace switcher works correctly. I set the number of workspaces I wanted and any other settings (name workspaces, view on n rows etc.) then turned on desktop effects and everything worked fine. I had to go back to the open source ATI drivers to get desktop effects working. You shouldn't have to with Nvidia drivers. The problem I had with the desktop flashing through any open windows every few seconds was caused by a system monitor utility called Conky updating every 5 seconds. Turned that off and no problems. I also installed compiz-settings-manager to give me full control over desktop effects.

Eric Jacobi (ericjacobi) wrote :

I tried this fix also to no avail. When I turn desktop effects back on, it resets to 2 workspaces again.

Soarer (mike-street) wrote :

Same as Eric Jacobi. I run the default nVidia drivers, and can change the desktop numbers & names when DT effects are off. Switching them on gives me 2 workspaces & no name change (and it forgets the names I gave them)

I had the same problem until today.

run
$ gnome-compiz-preferences
(also in System -> Preferences -> GL Desktop)

go to the workspaces tab and set the workspaces to the number you need.

This worked for me.

Rob Simpson (aspir8or) wrote :

Installed the latest updates 30 minutes ago. New kernel required reboot and now I am back to the same problems. If I turn on desktop effects I'm back to 2 workspaces and unable to change. Turn off desktop effects and I can add workspaces. This is all with open source ATI drivers. Using ATI proprietary drivers I cannot turn on desktop effects at all. Booting into older kernels makes no difference, so It's not the kernel. I'm not sure what got updated in todays update, but something in it broke desktop effects again.

Nearly forgot. After the first reboot into the new kernel post update, my screen resolution had been lowered from 1280x1024 to 1024x768.

Sebastien Bacher (seb128) wrote :

the bug is fixed in gutsy now, closing, feel free to reopen if you still get the issue though

Changed in libwnck:
status: Triaged → Fix Released
xspyderx (thiago-spina) wrote :

Thanks for the tip, I updated it and now it works perfectly.

On 10/7/07, Sebastien Bacher <email address hidden> wrote:
>
> the bug is fixed in gutsy now, closing, feel free to reopen if you still
> get the issue though
>
> ** Changed in: libwnck (Ubuntu)
> Status: Triaged => Fix Released
>
> --
> cannot set number or name of workspaces from workspace switcher applet
> https://bugs.launchpad.net/bugs/129152
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

--
Thiago "ASCII" Spina
CC06 - RA064761 - Unicamp

Brian Burger (bburger) wrote :

Note that this was NOT fixed when Ubuntu Beta ISOs were created - it's still very present in Beta LiveCD...

Brian,
this fix wasn't released in time for the beta!
just try the daily iso from: http://cdimage.ubuntu.com/daily-live/current/

nowashburn (nowashburn) wrote :

ok, well i just upgraded to the official release of gutsy and have the same problem. compiz fusion is installed and i can only have 2 workspaces when running. apparently this was not yet fixed. how can i fix it? - <email address hidden>

Cookie (a-cookie) wrote :

Same problem here -> using official release on an updated system. Tried all the fixes suggested above, none are working for me still only got 2 workspaces. Please let me know to fix as it!

Marco (mfj) wrote :

The solution is simple (and it works with ALL distros).
If you have compiz enabled (aka desktop effects), launch gconf-editor -> apps -> compiz -> screen0 -> options -> set hsize from 2 to 4. That's all! No reboot is necessary.

Marco

Cookie (a-cookie) wrote :

Hi Marco

I tried that as it was mentioned in the fixes above but still no joy! It'll work if I turn desktop effects off but not when enabled. Any ideas what I can do to fix?

Cheers
Cookie

Marco (mfj) wrote :

This "trick" works only for compiz's workspaces that it's indipendent from Ubuntu applet's workspaces.
You can change compiz's workspace with a rotation of mouse-wheel action (up/down), or ctrl+alt+left/right arrow or use CCSM to assign a personal keypressing sequence.

Marco

Cookie (a-cookie) wrote :

Being able to switch between workspaces still doesn't give me more than 2 workspaces! Anyone else able to help?

Oded Arbel (oded-geek) wrote :

Sorry guys, but currently it works for me - with current Gutsy and compiz desktop effects enabled, when I right click the workspace switcher and choose preferences I get a dialog that lets me change the number of columns and rows in my workspaces setup - and it works (at least the columns, I haven't tested more then one row - I don't like that).

At the time when that didn't work, I simply turned off desktop effects, used the workspace dialog to change the number of workspaces and turned desktop effects back on - and that kept the same number of workspaces that was set in the workspaces preference dialog when desktop effects was disabled.

Oded Arbel (oded-geek) wrote :

I forget to mention that I don't have the desktop cube enabled, but the default workspace switcher that Ubuntu ships with. I'm not sure if it matters.

Cookie (a-cookie) wrote :

In the end it was so easy... disabled effects, then re-enabled them. Still wasn't working so I went into Compiz general options and then into desktop size and set it 4 and lo and behold I have a cube again! Strangely enough this didn't work before.

Guys thanks for all your help and comments!

leaf (fourstorytantrum-) wrote :

Did I miss how to set the names for the workspaces?

I have CCSM enabled on Gutsy, using Custom desktop effects. The preferences for the workspaces enables me to set "columns" and "rows" but not names, unless I've got no desktop effects enabled. While I've been the solutions for the workspace numbers, I don't think I saw any replies to workspace names.

Inversions (scrmiller) wrote :

Hi,

I realise this is an old bug entry, however I recently noticed a similar issue with hardy install. There appears to be no problems with setting the number of desktops, rather the workspace name selection appears missing.

Right clicking on the workspace switcher gives options to set number of rows and colums but no options to apply names/labels to any workspaces.

I am running workspace switcher 2.22.2 with compiz (plugins: viewport switcher and desktop wall)

Disabling compiz seems to have no affect.

Hovering over one of the workspaces gives the tooltip "Desk 1"

attached screenshot

thanks.

King Oleg (kingoleg) wrote :

Same problem in Ubuntu 8.10 with compiz.

Bingo Tailspin (bingotailspin) wrote :

After enabling Compiz in 8.10, the Workspace Switcher app puts all the workspaces in the top row. Workaround: remove Switcher from panel, add it back and it's fixed!

This is a long, lingering bug though.

cogadh (cogadh) wrote :

Removing/re-adding the workspace switcher does not work for me with 8.10. Additionally, CCSM does not allow me to change the number of desktops (arrows are grayed out, manually typing a number does nothing), but it does let me change the horizontal and vertical virtual sizes, which does get the cube working, but at the same time, it makes the Workspace Switcher look like it has 2 rows of four desktops. When I then disable Desktop Effects (that's completely disable, not just switch window manager back to Metacity) and check the Workspace Switcher properties, it actually says I have 8 workspaces enabled. This should be something very simple to do, why has this bug lingered so long?

KentonS (smithek) wrote :

Well, apparently something's still wrong in Ubuntu Gutsy (Sysinfo shows lenny/sid release). I had previously uninstalled all compiz packages from my laptop. (Bad idea, as I later learned.) I reinstalled compiz-gnome and compiz-config-settings-manager with all their dependencies. All uninstallation and reinstallation was done via Synaptic Package Manager.

After installation, Visual Effects were as they were prior to my uninstallation - None. I can switch among workspaces with <CTRL><ALT><right arrow> and <CTRL><ALT><left arrow>. Right clicking on a taskbar button provides the option to move the app Right and/or left as appropriate or to a particular workspace.

When I set Visual Effects to Normal, any apps running in workspaces other than 1 are moved to workspace 1. If there are multiple occurrences of the same app, all but one are terminated. <CTRL><ALT><right arrow> and <CTRL><ALT><left arrow> do nothing.

In both cases, all settings are the same in gconf-editor and compiz-config-settings-manager: In gconf-editor, apps/metacity/num-workspaces=3. In apps/compiz/screen0/options, hsize=3, vsize=1, number_of_desktops=1. In compiz-config-settings-manager (System|Preferences|Advanced Desktop Effect Settings), Horizontal Virtual Size=3, Vertical Virtual Size=1, Number of Desktops=1.

What am I missing here?

KentonS (smithek) wrote :

After experimenting around for a while, I found that setting Horizontal & Vertical Virtual Sizes=1 and Number of Desktops=3 gives me 3 workspaces. I can switch among them by clicking on the appropriate thumbnail on the task bar. However, the keyboard shortcuts still don't work. I'm sure this isn't how things are supposed to work.

WubiNeophyte (wubibugs) wrote :

I'm still seeing what looks to be the same bug in Ubuntu 8.10. As the discussion here is mostly for older versions, and I want to report my specific issue, I'm planning to file a new bug, and reference this one. Will comment again when I do.

WubiNeophyte (wubibugs) wrote :

I've filed my issue as bug 355822.

Same bug in amd64 Ubuntu 9.04

Gnome panel 2.26.0

DrC (drcowsley) wrote :

Same bug back in Karmic alpha-5 default installation.

Changed in libwnck:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.