Person's related bugs pages do not show closed / duplicate bug reports

Bug #5977 reported by Dafydd Harries on 2005-12-20
534
This bug affects 50 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Low
Unassigned

Bug Description

Most people seem to expect their "Reported bugs", "Subscribed bugs", and "Commented bugs" lists -- unlike other bug lists -- to include Fix Released, Won't Fix, Invalid, and duplicate bug reports by default. Currently they do not.

In a pathological combination of this bug and bug 1357, sometimes even an open bug report does not appear in someone's +reportedbugs list by default, because it is open only for a project/package in which the reporter did not file it. (See bug 449785 for an example.)

All relevant bug reports should be shown in these listings (but not in the +assignedbugs listing) regardless of status or duplicate-ness. (The ideal sort order probably would be all bugs by newness. Even better for +reportedbugs would be listing Incomplete bugs first.)

The equivalent problem in Blueprints is bug 220486.

See also bug 576956 which notes that duplicates are not shown (regardless of open/closed status).

> User "hanneloredk" has filed this bug:
>
> https://launchpad.net/products/launchpad/+bug/3958
>
> However, when I go to their reported bugs page, it's not listed:
>
> https://launchpad.net/people/hanneloredk/+reportedbugs

That's because bug 3958 is rejected, and the +reportedbugs will, by default,
show only NEW and ASSIGNED bugs. If you do an advanced search including
rejected bugs you'll see bug 3958 there. Perhaps we need to make it clear that
by default that page will only list open bugs?

Björn Tillenius (bjornt) wrote :

On Tue, Dec 20, 2005 at 12:21:18PM -0000, Guilherme Salgado wrote:
> Public bug report changed:
> https://launchpad.net/malone/bugs/5977
>
> Comment:
> > User "hanneloredk" has filed this bug:
> >
> > https://launchpad.net/products/launchpad/+bug/3958
> >
> > However, when I go to their reported bugs page, it's not listed:
> >
> > https://launchpad.net/people/hanneloredk/+reportedbugs
>
> That's because bug 3958 is rejected, and the +reportedbugs will, by default,
> show only NEW and ASSIGNED bugs. If you do an advanced search including
> rejected bugs you'll see bug 3958 there. Perhaps we need to make it clear that
> by default that page will only list open bugs?

It should be clear to the user which bugs are shown. Ideally it would
also be possible to easily say "Show all bugs", I think it's quite
common that you want to see fixed and rejected bugs as well.

Oh, and "Needs Info" bugs should definitely be shown by default.

> Oh, and "Needs Info" bugs should definitely be shown by default.

Which is covered by bug 4201.

On Wed, Dec 21, 2005 at 08:08:11PM -0000, Diogo Matsubara wrote:
> Public bug report changed:
> https://launchpad.net/malone/bugs/5977
>
> Comment:
> > Oh, and "Needs Info" bugs should definitely be shown by default.
>
> Which is covered by bug 4201.

Yeah. But bug 4201 is going to require a lot of discussion, and will
take a while to resolve. I would say that no matter the outcome of that
bug, "Needs Info" should be seen as an open bug from the reporter's
point of view, so on the "Reported Bugs" page, they should be displayed
by default. On other pages it's not obvious that they should be shown
by default, though.

description: updated

Just in passing: I really like the approach used on GNOME Bugzilla (I don't know about other Bugzillas). Bugs related to you are shown in a number of categories on one page: assigned to me, bugs I reported that are NEEDINFO, new bugs I've filed, accepted bugs I've filed. I think something like this would be better than the multiple pages we currently have. Screenshot:

https://chinstrap.warthogs.hbd.com/~daf/my_bugzilla.png

Brad Bollenbach (bradb) wrote :

The GNOME example is a good source of ideas for displaying people's bugs.

Changed in malone:
status: Unconfirmed → Confirmed
description: updated
description: updated
description: updated

while I couldn't see Dafydd Harries screenie so can't comment on that but perhaps we could have some sort of checkbox either in preferences or right at the bug page so fix & rejected bugs are easily seen.

 Either way +1 from my side.

description: updated
description: updated

+1 for my side
Think I should be able to see all the bug I've contributed to without having to do an advanced search.

The resolved one could be displayed last by default, or there should be a way to customize the request made to show the bugs related to me.

as I mention on bug 207808, users should see all bugs even dups when clicking on reportedbugs/commented

Harvey Muller (hlmuller) wrote :

I created bug #213669 which was later marked a duplicate of #124406. Having created bug #213669, I have an interest in watching the bug it is made a duplicate of, #124406.

When I review my bugs page, neither are shown on the personal bugs page. I attempt to use the advanced search to identify all bugs I am the reporter of, and it does not find the bug I created and missing a few more. I then search for the title and do not find it.

Guessing that I must be missing something, I click on advanced search (again) this time scrolling ALL the way down the page seeing the innocuously checked box "hide duplicates".

I recommend the feature "If an individual's bug is later made a duplicate of another, the other bug is listed on the person's bug page." Otherwise it becomes an unecessary burden to track bugs of interest.

Hope this helps,

Harvey

description: updated

Time and time again I've been looking for a bug I know I've commented on
or subscribed to and have gone to
https://bugs.launchpad.net/~ralph-inputplus/+commentedbugs only for it
not to be there. Puzzled, I've resorted to Google to find it for me.
Now I discover that these Actions on
https://bugs.launchpad.net/~ralph-inputplus/ don't perform as
advertised.

    Link Text Link Title
    List assigned bugs Lists bugs assigned to Ralph Corderoy.
    List commented bugs Lists bug reports on which Ralph Corderoy
                            has commented.
    List reported bugs Lists bugs reported by Ralph Corderoy.
    List subscribed bugs Lists bug reports Ralph Corderoy is
                            subscribed to.
    List all related bugs Lists all bug reports which Ralph Corderoy
                            reported, is assigned to, or is subscribed to.

Neither the Text or the Title of the links suggests a subset of the bugs
is displayed. That last Title says "Lists *all* bug reports". Nor does
the results page indicate that it's a subset.

These two things would seem trivial to fix and should be done ASAP to
avoid others to be as confused. The adding of a "Show all such bugs"
link on the results page would be useful but waiting to implementing
that shouldn't hold up clarifying the existing funtionality.

The workaround of doing an Advanced Search is a right PITA. You have to
tick all ten Status tick boxes and then scroll past the milestone list
to get to the Search button.

John Ward (automail) wrote :

I'm having same problems and have reported it in # 260019.

Otto Kekäläinen (otto) wrote :

The bug page should also list bugs that have been selected with the "This bug affects me too" -link.

dave b. (d+b) wrote :

This still affects me and i would like it fixed.

Martin Pool (mbp) wrote :

This could be fixed in the way suggested in bug 277352, which would also cover other bug lists.

Petr Šplíchal (psss) wrote :

Agreed with Martin. The solution suggested in bug 277352 seems to me nice and elegant. Does not flood you with unnecessary long bug lists by default, yet provides an easy way how to access less common bugs.

Perhaps, the text could include invalid / duplicates bug counts / links as well:
"Furthermore %d closed, %d invalid bugs and %d duplicates matched".

I subscribed myself to Bug #328484 and added a comment there. This bug was later marked as a duplicate of Bug #378617 and I was automatically subscribed to it. Now *none* of them is shown in https://bugs.launchpad.net/~morgwai/+subscribedbugs list.
Moreover when I go to the advanced search, uncheck 'Hide duplicate bugs' and put 'morgwai' into 'Bug subscriber' box *only* Bug #328484 appears.
So it seems there's no possibility of finding Bug #378617 to which I'm subscribed.

Cheers

  Morg

description: updated

Oh my goodness. This is broken since 2005?
What a shame!
I can't see my reported bug 222561 when I click on "List all related bugs".
This is bad. Please help!

Peter Antoniac (pan1nx) wrote :

Well, I guess that are more pressing problems...

Martin Pool (mbp) on 2010-01-25
summary: - Person Bugs pages seem to be incomplete
+ want to see closed bugs in person's reported/subscribed/commented bugs
+ lists

Summary:also dublicate
Dublicate bug removed from my bug page and "reporting bug search"
i reported bug https://bugs.launchpad.net/launchpad/+bug/556768 "Searching ubuntu packages should show them"
and i wanted to add solution so im looking in my personal page to get that bug link. and its not there. im looking by newest and its not there.
so ok maybe it was not saved. im tryng to find it by reporting new bug with same name so it appears. i wrote exact the same Summary and it doesnt show up. i looked in email and there i got link to it. So now im seeing its marked as dublicate so i assume dublicate bugs are removed from users bug page and also not showing up when bug report is made.
That makes a big problem and here my arguments for and against solutions
If bug a and b is made as dublicate to c and each has its own name but all is the same then dublicates will be made more couse somedy will write Summary similar to bug a and b and sometimes similar to bug c but when they write as a and b then since a and b not showing becouse of dublicates are not shown then new bug witch will be marked as dublicate will be made.
BUT if bug c Summary will be changed similar to a,b,c then that bug will show up.
BUT since not allways that is beeing done dublicates are being made couse dublicates doesnt show up

Stephen Brandwood (sbrandwoo) wrote :

It is sad to see that this bug is still left open!

Note I am only writing this post so that I will hopefully be emailed about further updates to this issue. I will resort to using email to manage my issues until this usability issue can be finally fixed.

summary: - want to see closed bugs in person's reported/subscribed/commented bugs
- lists
+ Person's Bugs pages unexpectedly exclude closed bug reports
summary: - Person's Bugs pages unexpectedly exclude closed bug reports
+ Person's Bugs pages should show closed bug reports by default

Good heavens, this was reported in 2005 and still no change? Well, the thing is that this is not only confusing, but many times u need to get to a bug that has been marked invalid and u don't think it's invalid, because u know new facts, or u just need to check some comment. So u go there and it has vanished... So confusing!

Nevertheless, this is not the behaviour one would expect...

summary: - Person's Bugs pages should show closed bug reports by default
+ Person's Bugs pages do not show closed bug reports
Changed in launchpad:
importance: Medium → Low
summary: - Person's Bugs pages do not show closed bug reports
+ Person's related bugs pages do not show closed bug reports
description: updated
Changed in launchpad:
status: Triaged → In Progress

@Benny if you're planning to work on this and you want any help,
please don't hesitate to ask, here or on irc. I would love to see it
fixed.

Doesn't look like this is in progress. Setting status back to Triaged

Changed in launchpad:
status: In Progress → Triaged

Oh man, launchpad is a piece of ...

Martin Pool (mbp) on 2011-10-11
tags: added: affectsmetoo
Karma Dorje (taaroa) wrote :

it's just plain wrong.

summary: - Person's related bugs pages do not show closed bug reports
+ Person's related bugs pages do not show closed / duplicate bug reports
tags: added: confusing-ui
Enkouyami (furyhamster) wrote :

Will a fix for this bug come 10 years or more since it was reported? It sure looks that way...

One more reminder that this is really annoying. I wished that ubuntu would use bugzilla or something else more "feature complete" ;-)

The problem is that I'm also unable to browse the closed bugs of an package. So I created a broader bug report and merge this.
Maybe has a new bug report more chances to be fixed as an 10 year old bug ;-)

Deryck Hodge (deryck) wrote :

While I appreciate that you want attention on the issue, this is not the way to do it. We prefer to have the older bug with all of its history be the main bug for a given issue. I will un-dupe this from the newer bug and make the newer bug this bug's duplicate.

As to the comment above, you can indeed find the closed bugs of a package. Use the advanced search link. You can also find them for a person's bug page. This bug is about changing the default behavior or the user experience around this issue.

LAZA (laza74) wrote :

Maybe THIS issue will bring a faster response to those old bugs:

https://bugs.launchpad.net/launchpad/+bug/1089983

Curtis Hovey (sinzui) wrote :

@LAZA
The community is welcome to contribute a fix. Launchpad has 3 developers who work exclusively on critical and high bugs. Launchpad may not even have developers in 6 months, so issues that are important to users require someone from the greater Launchpad community to provide the solution.

LAZA (laza74) wrote :

@Curtis Hovey:
Thanks for your open-hearted answer!
I'm neither a hacker nor a programmer... - so the only i can do ist to report bugs, that occur on my machines.

But it IS a great problem, that some bugs - especially in LTS releases - will never be fixed and the users have to live and fight *five* years with it!
A bit offtopic, but jm2c.

@Frank Breitling:
This post was just... total nonessential

William Grant (wgrant) on 2015-09-11
tags: added: bug-search
To post a comment you must log in.