Inkscape: A Vector Drawing Tool

on output, the option 'convert text to paths' does not work for .ps, .eps, .pdf, .emf

Reported by Alvin Penner on 2008-10-16
50
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
theAdib

Bug Description

- running Win32 Inkscape19989-081013.7z
- attached is the .svg source document
- when I save this into .ps, .eps, .pdf, .emf format and uncheck the option 'convert text to paths', then I get text in what usually looks like a bitmap, no problem.

Alvin Penner (apenner) wrote :
Alvin Penner (apenner) wrote :

when I save into .ps, .eps, .pdf and check this option, then I get nothing, sample attached

Alvin Penner (apenner) wrote :

when I save into .emf and check this option, then I get occasional text, sometimes, sample attached

ZeToken (sourceforge-zetoken) wrote :

I confirm, exactly the same problem with 20222 revision, fresh compiled.

Alvin Penner (apenner) on 2008-11-19
Changed in inkscape:
status: New → Confirmed
ZeToken (sourceforge-zetoken) wrote :

Back again,
As I'm interested in a solution for this problem, I've done some tests to reduce the field of investigation for the inkscape team.
It appears that some letters disappear in emf format when the letter is "an easy one". What I mean is a letter that is formed of one unique path and each point is an angular one.
What happens in the emf file is that the path of the letter is present, but not filled with a color, so not shown at the end.

Don't ask me why, but if a letter is conform to this definition it will never be shown, and if it is not shown then it is conform to this definition. I've tested that on a lot of fonts (svg file attached here, the emf corresponding in next comment).

If I knew how is made inkscape (and had time), I would have searched for a patch, but... I hope it will help you.

ZeToken (sourceforge-zetoken) wrote :
Alvin Penner (apenner) wrote :

thanks for the feedback, this bug should probably be split into 2 bugs because the behaviour of the .emf output is different from the .ps .eps and .pdf output.

Alvin Penner (apenner) wrote :

the emf portion of this bug has been reported separately under Bug 307783

jazzynico (jazzynico) wrote :

At least two duplicates and very annoying. Set importance to medium.

Changed in inkscape:
importance: Undecided → Medium
tags: added: exporting text

I've marked bug #375389 as a duplicate of this, although it's not exactly a duplicate.
It seems to be related anyway, since the conversion to curves isn't working both from UI and from command line.
I'd raise the importance of this bug to high, since PDF and EPS formats are the the most frequently supported vector formats and this bug breaks the interoperation between inkscape and other applications.

theAdib (theadib) wrote :

Dear friends, I committed a patch (svn rev 21337) that should solve the issue. please test. Adib.

Changed in inkscape:
assignee: nobody → theAdib (theadib)
status: Confirmed → Fix Committed

On 2009-May-12 , at 16:51 , theAdib wrote:

> Dear friends, I committed a patch (svn rev 21337) that should solve
> the
> issue. please test. Adib.

works for me (Inkscape 21339, OS X)

Alvin Penner (apenner) wrote :

running rev 21345, this works great, thanks Adib !

Changed in inkscape:
status: Fix Committed → Fix Released
~suv (suv-lp) wrote :

I want to reopen this bug because export to pdf, ps and eps with 'texts converted to paths' still is broken in current SVN builds and in 0.47pre0.

Please see bug #388257 for details and steps to reproduce/test files.

I just compared the pdf output of the development builds r21262 and r21339 on OS X 10.5.7, and it looks like SVN commit rev 21337 solved one bug (texts as paths not exported) and created a related one (text as path export quality varies within document).

(I don't know the rules ;-) - is bug #388257 to be considered as a duplicate of this one?)

Changed in inkscape:
status: Fix Released → Confirmed
~suv (suv-lp) wrote :

Let me rephrase my previous comment and add a summary of the findings in bug report #388257:

The fix committed in rev 21337 solved the issue with omitted text objects when exporting to PS/EPS/PDF using the (cairo) 'text to path' option. At the same time it revealed another bug within this routine:

Text objects are converted and added to the document several times, stacked in place (on top of each other), thus increasing the overall size of the exported drawing and decreasing the rendered quality of text objects converted to paths (not anti-aliased 'pixelated' appearance). The effect only gets visible when exporting documents with several lines of text. Small drawings like logos or buttons with single words don't expose this bug, maybe that's why it was not noticed when testing rev 21337.

examples illustrating this effect:

<http://launchpadlibrarian.net/28012678/test.47.svg>
<http://launchpadlibrarian.net/28012660/test.47.pdf>
<http://launchpadlibrarian.net/28815267/388257-test.47-reimported-and-ungrouped.svg>

<http://launchpadlibrarian.net/28831387/O_clone.svg>
<http://launchpadlibrarian.net/28831394/O_clone.ps>
<http://launchpadlibrarian.net/28833163/388257-O_clone-ps-reimported.svg>

In comment 26 of bug #388257, I tried to describe it like this:
'attaching another example trying to illustrate what happens. Somewhere
while parsing the svg-tree for text objects or in a loop (calling the
cairo_glyph_path() function in 'cairo-render-context.cpp'?) a counter
seems not getting reset or updated properly, thus the current text/path
object is appended instead of replacing with every loop.'
<http://launchpadlibrarian.net/28833164/2009-07-08--2-ps-reimported.svg>

My apologies to 'theAdib' for badly wording my observations and using the unfounded phrase 'and created a related [bug]'!

theAdib (theadib) wrote :

suv, thank you for you report. I will follow 388257 to solve this issue. Adib.

Changed in inkscape:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers