Inkscape: A Vector Drawing Tool

inkscape 46-2 won't load in OSX Leopard 10.5.2, Xquartz 2.2.1

Reported by groomedmonkey on 2008-05-04
16
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Michael Wybrow

Bug Description

I had a look at the other related bugs and tried downloading Inkscape from the homepage and from sourceforge, with and without starting X11 first and the error is the same:

Inkscape pops a dialogue up saying that it might take a while the first time to cache fonts but after clicking ok nothing ever happens. Sorry I'm not sure how to do the log dumps that others have done but I have noted others with similar issues on Version Tracker Inkscape page and Inkscape's forums.

inkscape 46-2, OSX Leopard 10.5.2, Xquartz 2.2.1

Tags: osx Edit Tag help
Rygle (rygle) wrote :

Not a Mac man myself, but try googling the following [site:nabble.com inkscape mac] or substitute mac for osx or x11. There are lots of posts there about these sort of issues.

If you come up with some good answers, please consider sharing them here, but more importantly there is a wiki page for installation problems where I've put a whole lot of stuff about X11, but it doesn't deal with errors like this, so it could use your input. Not hard to make a login for the wiki, and it doesn't have to be super polished, just have a go and others will improve it over time.

Here's the page;
http://wiki.inkscape.org/wiki/index.php/InstallHelp

Looking forward to your input (or anyone in the Mac community) when you figure out something.

Rygle.

groomedmonkey (groomedmonkey) wrote :

This looks relevant:
http://www.nabble.com/0.46,-0.45-startup-problems-on-Leopard-td16141194.html

I must admit that X11 technical stuff is a bit out of my league. If I do come across a solution (Illustrator driving me nuts as my motivation) I'll post here and the wiki but so far no donut.

I have reinstalled the QuartzX thing as the first time it froze when I got logged out at end of install. This time works fine but Inkscape still doesn't load.

I tried rolling back to Inkscape 45-1-2 but that crashes on start so it's not looking too good for Inkscape on Leopard. I'm surprised there isn't more on it - are there people with working installs on Leopard?

tGM.

kananga (kananga) wrote :

I too have this same issue. I've got a clean install of 10.5.2, Inkscape 0.46-2 and Xquartz 2.2.1. If I try to launch Inkscape, it shows me a message about running the first time, then I click OK and it quits. Is anyone having any luck running Inkscape on 10.5.2?

Dementid (csdement) wrote :

same trouble on brand new iMac clean install. Tried the scripts that other posts mention and still nothing. If I double click the inkscape icon while it bounces the cursor goes color pinwheel as if it might open but then times out

groomedmonkey (groomedmonkey) wrote :

Ok I think I have found a fix in another bug post:
https://answers.launchpad.net/inkscape/+question/28776

Although this is a solution I hope that the next release of Inkscape can rectify this out of the box. Haven't tested stability or anything - just happy that it loads now!

Here's direct instructions from the above post:

open the Terminal application (its in Applications/Utilities)
1. "nano /Applications/Inkscape.app/Contents/Resources/script" (paste this into a terminal window without quotes and press ENTER)
2. then press CTRL+V (scrolls down a page)

3. change the code (use the arrows keys to get to the right part) from:

"""
else
        # Leopard onwards...

        # Warn the user about time-consuming generation of fontconfig caches.
        test -d ${HOME}/.fontconfig || exit 12
"""

to:

"""
else
        # Leopard onwards...

        # Warn the user about time-consuming generation of fontconfig caches.
        test -d ${HOME}/.fontconfig
"""
4. save changes - press CTRL+O and then ENTER to confirm
5. open Inkscape, go eat some snacks (it takes a few minutes for the first time - just like the popup window said)
6. Happiness

tGM

Dementid (csdement) wrote :

sounds like that helped you. I had tried that one but no luck, still on the hunt.

Dementid (csdement) wrote :

when I try that both terminal and xterm say no file found. (yet inkscape is clearly in my applications) No other script ever comes up for me to edit

groomedmonkey (groomedmonkey) wrote :

So you are unable to open that script file at all? Weird.

Is this after you try and run Inkscape the first time? Maybe it "installs" itself and creates that file...

Also (maybe a dumb one) but you haven't renamed "Inkscape" to "Inkscape 46" or something? I do that sometimes with programs that don't have any automatic update so I can quickly see what version I have.

Let us know what happens.

Dementid (csdement) wrote :

Yes strange. Never renamed it, just downloaded then followed the graphic screen that had the arrow showing me to drag it to the applications folder. I may try to erase the x11 and inkscape and start over, I just came from pc to mac, any advice on uninstalling something that never really installed?

Dementid (csdement) wrote :

got it !!!!!!!!!!!!!!!!!!! I control click inkscape. Click show contents. Went to resources and just happened to click on a gray folder labeled "opendoc" them some script started. Less than a minute inkscape opened to a drawing page. After that was able to open by clicking inkscape icon.

Rygle (rygle) on 2008-05-08
Changed in inkscape:
importance: Undecided → Medium
milestone: none → 0.46.1
status: New → Confirmed
groomedmonkey (groomedmonkey) wrote :

woah that sounds odd. But glad you got it working, and hopefully the answer here will help others out. Thanks for following up with your solutions as thats what makes these forums work. Now, onwards to a better world! lol

Rygle (rygle) wrote :

Michael Whybrow has indicated that XQuartz 2.2.1 changes the way that it handles fontconfig. I have updated the wiki to include his suggestions, as well as tidying up the suggested fixes that were in there already.

http://wiki.inkscape.org/wiki/index.php/InstallHelp

groomedmonkey (groomedmonkey) wrote :

Looks good. Glad that the problem seems to be pinpointed.

Rygle (rygle) on 2008-05-12
Changed in inkscape:
status: Confirmed → In Progress
Rygle (rygle) wrote :

Michael, can you please follow up on this and close when fixed in the build? I have updated the wiki pages as indicated.

Changed in inkscape:
assignee: nobody → mjwybrow
rwst (ralf-ark) wrote :

Hello, this applies to pre-0.47-1 too. Sometime in the last six weeks, Inkscape on Leopard
stopped starting up correctly. NONE of the mentioned fixes work for me. Clearing .fontconfig/
does not, and neither deleting the || exit part from that script. Fonts are cached in .fontconfig:
four files are created BUT after that CPU goes up to 100 percent on both cores and never goes down.

Please fix that BEFORE the 0.47 release.

~suv (suv-lp) wrote :

@rwst - do you have MacPorts installed on your system? See possibly related bug #400165 ('The problem is Inkscape trying to read incompatible fontcaches from Macports') which has a fix released (latest 0.47-pre1-2 on sf.net).

Sorry, I haven't tried to get inkscape up and running for at least a
year.

-John

On Jul 21, 2009, at 7:24 AM, ~suv wrote:

> @rwst - do you have MacPorts installed on your system? See possibly
> related bug #400165 ('The problem is Inkscape trying to read
> incompatible fontcaches from Macports') which has a fix released
> (latest
> 0.47-pre1-2 on sf.net).
>
> --
> inkscape 46-2 won't load in OSX Leopard 10.5.2, Xquartz 2.2.1
> https://bugs.launchpad.net/bugs/226355
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Inkscape: A Vector Drawing Tool: In Progress
>
> Bug description:
> I had a look at the other related bugs and tried downloading
> Inkscape from the homepage and from sourceforge, with and without
> starting X11 first and the error is the same:
>
> Inkscape pops a dialogue up saying that it might take a while the
> first time to cache fonts but after clicking ok nothing ever
> happens. Sorry I'm not sure how to do the log dumps that others have
> done but I have noted others with similar issues on Version Tracker
> Inkscape page and Inkscape's forums.
>
> inkscape 46-2, OSX Leopard 10.5.2, Xquartz 2.2.1
>
> !DSPAM:735,4a65d11c5851021468!
>

~suv (suv-lp) wrote :

@John (aka strangefish) - sorry for creating confusion, my comment was in response to 'rwst' who wrote two days ago:
"this applies to pre-0.47-1 too. Sometime in the last six weeks, Inkscape on Leopard stopped starting up correctly. […]"

Michael Wybrow (mjwybrow) wrote :

This is fixed in SVN and in the Inkscape-0.47pre2-1.LEOPARD.dmg, up now on sourceforge.

Changed in inkscape:
status: In Progress → Fix Released
ti-beo (jean-luc-ti-beo) wrote :

back to problems with snow leopard
none of above fixes seem to work ...

Last login: Fri Sep 25 23:44:35 on console
/Applications/Inkscape.app/Contents/MacOS/Inkscape ; exit;
MacBook-Pro-XXXXXXXXXX /Applications/Inkscape.app/Contents/MacOS/Inkscape ; exit;
dyld: Library not loaded: /usr/lib/libxml2.2.dylib
  Referenced from: /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/DictionaryServices.framework/Versions/A/DictionaryServices
  Reason: Incompatible library version: DictionaryServices requires version 10.0.0 or later, but libxml2.2.dylib provides version 9.0.0
logout

[Opération terminée]

so , where can I download dictionaryservices version 10.0.0 ???

thanks from Brittany

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions