.eps files fail to import into signmaking programs

Bug #168411 reported by Baicam on 2007-02-27
6
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned

Bug Description

Signmaking programs need a 'flat' .eps file to be able to import. Currently
I have tested .eps exports of basic shapes to import into Artcut, WinPCsign
and others but none import. The export feature does not allow more than
cursory .eps feature selection and does not state if compression, pdf
output and others are included in the output file. I have to assume that
they are because no .eps export from Inkscape can be imported into these
programs. Does anybody have any information on this?

Bug Importer (bug-importer) wrote :

> I have tested .eps exports of basic shapes

Please attach such a simple (single object) .svg together with the
exported .eps generated by Inkscape *and* a similar simple .eps generated
by any other application that you are able to import by your "signmaking
programs".

Baicam (baicam) wrote :

Originator: YES

Hi,

The file pincut.svg is a .gif file.

The file was traced using path trace and saved as pincut.svg, it was then
saved as pincut.eps. pincut.eps will not import into the programs
mentioned.

pincut.svg was then imported into Corel Draw X3 and exported as (all
options deselected, postscript2 option) pincut2.eps. pincut2.eps opens with
no problems at all in all programs.

Thanks

Colin.
File Added: pincut.svg

Baicam (baicam) wrote :

Originator: YES

Hi,

The file pincut.svg is a .gif file.

The file was traced using path trace and saved as pincut.svg, it was then
saved as pincut.eps. pincut.eps will not import into the programs
mentioned.

pincut.svg was then imported into Corel Draw X3 and exported as (all
options deselected, postscript2 option) pincut2.eps. pincut2.eps opens with
no problems at all in all programs.

Thanks

Colin.
File Added: pincut2.svg

Baicam (baicam) wrote :

Originator: YES

Hi,

The file pincut.svg is a .gif file.

The file was traced using path trace and saved as pincut.svg, it was then
saved as pincut.eps. pincut.eps will not import into the programs
mentioned.

pincut.svg was then imported into Corel Draw X3 and exported as (all
options deselected, postscript2 option) pincut2.eps. pincut2.eps opens with
no problems at all in all programs.

Thanks

Colin.
File Added: pincut.eps

Baicam (baicam) wrote :

Originator: YES

Hi,

The file pincut.svg is a .gif file.

The file was traced using path trace and saved as pincut.svg, it was then
saved as pincut.eps. pincut.eps will not import into the programs
mentioned.

pincut.svg was then imported into Corel Draw X3 and exported as (all
options deselected, postscript2 option) pincut2.eps. pincut2.eps opens with
no problems at all in all programs.

Thanks

Colin.
File Added: pincut2.svg

Baicam (baicam) wrote :

Originator: YES

File Added: pincut2.eps

Bryce Harrington (bryce) wrote :

Since EPS support has changed in recent Inkscape versions, could someone please test this against Inkscape 0.46 alpha?

Changed in inkscape:
status: New → Incomplete

I just started using inkscape together with Summa Inc.'s Winplot for cutting/plotting. I am using version Inkscape 0.46. When I try to read in a .eps file exported by Inkscape, I don't get any of it displayed in WinPlot. I believe this problem is the same as described above and that it still exists, even in the newer versions of Inkscape.

I just tried to import the pincut.eps and pincut2.eps files from above into WinPlot. pincut.eps showed a blank picture (import failure) and pincut2.eps (created from exporting to CorelDraw from Inkscape) worked just fine. This problem still exists in Inkscape 0.46.

Alvin Penner (apenner) wrote :

this is a cross-reference to Bug 192923 and also to Question 35004
I have downloaded the file pincut2.svg and converted it to .dxf using the desktop cutting plotter output, running the win32 build from May 9. The resulting dxf file is viewable in Voloview Express 2.01 and also QCad.
    Could you tell me whether this .dxf file is usable by Winplot?
    I am trying to understand why a .eps file would work while a .dxf file does not work.

Thanks,
Alvin Penner

I loaded it in WinPlot as you requested, and I found the same problems as I've seen before. I have attached a word Document containing a screen shot of what the .dxf file looks like after it has been imported into Winplot. I don't know much about computers and file formats, but if there is something else you would like me to do, I know enough to get around with instruction. I know some very specific things in many broad topic when it comes to computers. I hope this helps you. You will notice upon inspection, that the joints between splines (I'm pretty sure their b-splines, but I could be mistaken) are not continuous, the curves are transposed to other coordinates, and random circles appear. I hope this give you a better idea of what the problem is.

Like was mentioned up above, the .eps files, as formated by inkscape, show up blank in WinPlot. The one that did not was formated by CorelDraw and it showed to be just fine.

Alvin Penner (apenner) wrote :

thanks for the screen shot, that clarifies it a lot. there is clearly something very unusual happening at some of the sharper pointy endpoints. I'll take a look at it this weekend and see if anything interesting shows up

Changed in inkscape:
status: Incomplete → New
  • unnamed Edit (1.4 KiB, text/html; charset=ISO-8859-1)

By the way, this may help you. WinPlot is a freeware product to all. The
only catch is that it will only output cutting to a Summa brand cutter, but
you could still use it to test graphics and the effect of changes on the
graphic in WinPlot. You can download it free of charge on the summa website:
www.summausa.com.

I hope that helps,
Thank You again,
Andrew Sampson

On Fri, Jun 6, 2008 at 9:48 AM, Alvin Penner <email address hidden> wrote:

> thanks for the screen shot, that clarifies it a lot. there is clearly
> something very unusual happening at some of the sharper pointy
> endpoints. I'll take a look at it this weekend and see if anything
> interesting shows up
>
> ** Changed in: inkscape
> Status: Incomplete => New
>
> --
> .eps files fail to import into signmaking programs
> https://bugs.launchpad.net/bugs/168411
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Alvin Penner (apenner) wrote :

with respect to .dxf rendering see the comment at https://bugs.launchpad.net/inkscape/+bug/192923/comments/35

I will try to contact Summa Winplot to see if they would be willing to investigate their rendering procedure

Alvin Penner (apenner) wrote :

the response from Winplot was negative concerning the .dxf rendering problem.
https://bugs.launchpad.net/inkscape/+bug/192923/comments/36
Personally, I would recommend Uniconvertor 1.1.2 to do the conversion from .svg to .ai. The resulting .ai file appears to load well into Winplot.
uniconv is available from :
http://sk1project.org/modules.php?name=Products&product=uniconvertor

hth
Alvin Penner

  • unnamed Edit (1.5 KiB, text/html; charset=ISO-8859-1)

Alvin, I thank you. I been trying to get support from them for a while now.
They never answered by questions before. This time they actually gave me a
step by step procedure to get export something from Inkscape that is
portable into WinPlot. It worked great!

Thank You Again,
Andrew

On Mon, Jun 9, 2008 at 6:17 PM, Alvin Penner <email address hidden> wrote:

> the response from Winplot was negative concerning the .dxf rendering
> problem.
> https://bugs.launchpad.net/inkscape/+bug/192923/comments/36
> Personally, I would recommend Uniconvertor 1.1.2 to do the conversion from
> .svg to .ai. The resulting .ai file appears to load well into Winplot.
> uniconv is available from :
> http://sk1project.org/modules.php?name=Products&product=uniconvertor
>
> hth
> Alvin Penner
>
> --
> .eps files fail to import into signmaking programs
> https://bugs.launchpad.net/bugs/168411
> You received this bug notification because you are a direct subscriber
> of the bug.
>

For those who are trying to export .eps files from Inkscape to import into sign-making software, refer to the link above given here again: ( https://bugs.launchpad.net/inkscape/+bug/192923/comments/36 ). The response come from Summa who makes their own cutting software WinPlot. Following the procedure outlined, the .eps file imported with no problems into the WinPlot. I've had the same issues trying to import a regular .eps file from Inkscape into WinPlot, but this worked just file. This might be the same fix for other sign-making software. Give it a try.

Alvin Penner (apenner) wrote :

good to hear,
Alvin Penner

please retest with latest svn, new cairo based eps exporter is enabled

Alvin Penner (apenner) wrote :

I believe the original intent was to produce an .eps file that could be read by Winplot.
- running Win32 Inkscape19792-080902.7z
- downloaded the file pincut2.svg
- used Inkscape to produce the file pincut2_080902.eps using the standard .eps output, not Cairo, which no longer exists.
- the attached file is readable by Inkscape, and by GSView32, and by Summa Winplot v6.80.

I think this issue is resolved satisfactorily

Changed in inkscape:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers