Blocking when double clicking on the spinner widget

Bug #1164150 reported by randruc on 2013-04-03
152
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned

Bug Description

When creating an object we can edit some of its properties by clicking on the "up" or "down" button of the spinner widget (under the menu bar).

For example, create a spiral and edit its divergence by clicking on the buttons of the spin widget.

If we double-click on one of these buttons, the spin widget stays blocked on the "clicked" state, so the value increases/decreases until the min/max admissible value is reached. And after that, it stays blocked and it's impossible to fix the desired value by clicking the other button nor by entering a value using the keyboard.

This is very annoying because the only solution is to delete the created object.

My configuration :

- Inkscape 0.48.4 r9939
- Fedora 18
- XFCE 4.10

Tags: ui Edit Tag help
Alvin Penner (apenner) wrote :

- not reproduced on Windows 7, Inkscape 0.48.4 r9939 (Dec 17 2012)
- not reproduced on Windows XP, Inkscape rev 12260

jazzynico (jazzynico) wrote :

Not reproduced on Debian testing, Inkscape 0.48.3.1 and trunk revision 12265.

tags: added: ui
removed: double-click spin
randruc (remi1802) wrote :

Maybe I can post some kind of trace/log to help you (?).

Does Inkscape have a debug mode or a way to trace calls using GDB or Xtrace ?

jazzynico (jazzynico) wrote :

> Does Inkscape have a debug mode or a way to trace calls using GDB

Of course you can use GDB. I'm not a GDB expert, but there are some details in the Inkscape wiki (http://wiki.inkscape.org/wiki/index.php/Debugging_Inkscape).

su_v (suv-lp) wrote :

Not reproduced with Inkscape 0.48.3.1, 0.48.x r9947, 0.48+devel r12272 on OS X 10.7.5:
- GTK+/X11 2.24.11, gtkmm 2.24.2, glib 2.32.4, glibmm 2.32.0
  (XQuartz 2.7.4 (xorg-server 1.13.0))
- GTK+/Quartz 2.24.17, gtkmm 2.24.2, glib 2.34.3, glibmm 2.34.1
  (OS X native window management)

Tested with default prefs, using external mouse and built-in trackpad (MBP 13").

Ryan Lerch (ryanlerch) wrote :

Yeah, I'm hitting this one on a trunk build of inkscape (bzr revision 12322).

I am running Fedora 18 / GNOME 3.6

any ideas on how to get more info on this issue.

To work around it at the moment, i just choose a different tool, then go back to the tool that was having the issue, and it has stopped counting up.

Ryan Lerch (ryanlerch) wrote :

Hmmm, this may be the same bug that was talked about here back in 2007:

http://wiki.inkscape.org/wiki/index.php/LivePathEffects

Ryan Lerch (ryanlerch) wrote :

I can still reproduce this one (with the 0.48 stable release, and recent trunk builds) on Fedora 19 with GNOME/GTK 3.8

Ryan Lerch (ryanlerch) wrote :

Also, tried trunk with the experimental GTK3 build on fedora, and could not reproduce the issue.

Gingerling (gingerling) wrote :

Had a lot of trouble with this in Fedora. Bunching my keyboard over and over sometimes makes it stop.... its an intermittent and annoying bug with no consistent fix for me unfortunately. It seems to be okay today. Its been worse on the text attributes on the main tool bar at the top of my window

Ryan Lerch (ryanlerch) wrote :

Here is the text from the wiki page (http://wiki.inkscape.org/wiki/index.php/LivePathEffects) that might be the same issue:

"""
Spinbutton of effect parameters can get stuck: it keeps on increasing and increasing and is impossible to stop!

* I had the same thing with opacity. It's a GTK bug. The workaround is to disable display interruptibility while you are updating document from the spinbutton's change. See how I did it here: http://inkscape.svn.sourceforge.net/viewvc/inkscape/inkscape/trunk/src/ui/widget/selected-style.cpp?r1=13149&r2=13257&sortby=date --bbyak

* I added the dis-interrupt functions. Now, it only gets stuck when the dialog is not selected before pressing the spinbutton. If the item is selected, then right after the spinbutton is pressed, it gets stuck again. However now, it can be stopped by clicking the spinbutton again... --johan

"""

Ryan Lerch (ryanlerch) wrote :

It only appears to happen in toolbars at the moment, not on dialog spinbuttons.

Ryan Lerch (ryanlerch) wrote :

Not sure if this is the same issue, but there is a note in the source for the opacity spinner in the statusbar that seems to describes a similar issue, and implements a workaround:

http://bazaar.launchpad.net/~inkscape.dev/inkscape/trunk/view/13394/src/ui/widget/selected-style.cpp#L1210

jazzynico (jazzynico) wrote :

Marked confirmed (duplicate reports).

Changed in inkscape:
status: New → Confirmed
Harald H. (haarektrans) wrote :

Affects me too. I can reproduce this on Ubuntu Gnome 16.04.1 LTS (GNOME Shell 3.18.5), Inkscape Inkscape 0.91 r13725

jazzynico (jazzynico) on 2016-09-20
Changed in inkscape:
importance: Undecided → Medium
Luke picciau (luke-b-picciau) wrote :

I have this issue on xubuntu 16.04 and I can reproduce it every time but if I make a new user on the same system I can't reproduce it. I can only conclude that its a bug related to one of my user settings however I can't reproduce it on the same type of input box on gimp.

Inkscape version: Inkscape 0.91 r13725

Hachmann (marenhachmann) wrote :

Also happens on LM 18 Xfce for me.

Michael Soluyanov (crantisz) wrote :

It affects me too (Ubuntu Gnome 16.04.1 LTS (GNOME Shell 3.18.5), Inkscape Inkscape 0.91 r13725) Does it have any workaround?

Michael Soluyanov (crantisz) wrote :

Bug doesn't appear in new Inkscape 0.92+devel (Oct 24 2016)

Michael Soluyanov (crantisz) wrote :

Same bug in Inkscape 0.92.1

Michael Soluyanov (crantisz) wrote :
Patrick Storz (ede123) wrote :

Video link from duplicate bug #1694429
https://youtu.be/a_YMde1rdUc

(also affects Inkscape 0.92 under Linux Mint 18.1 with KDE5 desktop environment)

oleh (skifua) wrote :

Some problem on Linux Ubuntu with KDE. Issue on inkscape's versions 0.91 and 0.92. I have different computerrs (laptops and desctops) with same problem.
This "blocking" stops after pushing key ESC on keyboard.

yotama9 (yotama9) wrote :

yes, I have the same issue with 0.91 on Linux mint 18.2. Yesterday I worked on Linux mint 17.3 and this problem didn't occur

Maris Nartiss (maris-nartiss) wrote :

This is a Gtk bug (feature?) as I just observed the same issue (on same machine where Inkscape has this problem) in another Gtk application (LAG by arsf).
I see the same issue in Inkscape 0.91 running Ubuntu 16.04 (XFCE), but 0.92 on my Gentoo ~AMD64 (KDE) seems to not be affected.

Hachmann (marenhachmann) wrote :

It's going to be fixed in 0.93 (but probably not in 0.92.3, as far as I understand - that branch still has the issue).

Patrick Storz (ede123) wrote :

@Maren: Can you point toward the fix?

If you're referring to [1] that's unfortunately unsuitable for back-porting...

[1] https://gitlab.com/inkscape/inkscape/commit/9ceb238f8a4f5527c3621740e75713ea79eceebc

Hachmann (marenhachmann) wrote :

The buttons are entirely different in master. I've now got a + and a - icon next to each other - a huge waste of space on my screen - I dislike that change a lot, because I can no longer access the kerning and letter rotation settings (aside from a couple of preset values), and the keyboard shortcuts for those don't work, either, with a German keyboard, AND they cannot be set in the keyboard shortcuts list, so even the workaround for the workaround doesn't work.
Maybe those fold-in-fold-out animated toolbar content changes Jabier uses could be a solution here, too. Or a more useful dropdown, that allows to enter numbers. Or wrapping the toolbar, if needed.

I think V has been working on a 'small' gtk theme?...

Anyway, double-clicking on any of them just makes the number change twice, so *this* issue is fixed in master.

I think [1] is probably the correct commit.

> I think V has been working on a 'small' gtk theme?...
Yes she do a good work with it. Is on his gitlab repo:

https://gitlab.com/su-v/inkscape-gtk3-theme-small

Regards.

Sage Tyrtle (sagetyrtle) wrote :

version: 0.92.3
operating system: Linux Mint 18.3 Sylvia

Hachmann - You're right, it does stop if you switch the tool. I realized after playing with it that I could hit the up button once on the "corners" number for the Polygon before it went nuts, so with some trial and error I was able to set it to a number that will generally work for me until the bug is finished. Thanks.

Zabir (zabir91) wrote :

This bug is back again in 9.2. Now it is 0.92.4, also had this bug in 0.93.3 too. installed in ubuntu 18.04 through ppa:inkscape.dev/stable

Hachmann (marenhachmann) wrote :

Zabir, the bug isn't 'back', it's still there. It is going to be gone with 1.0 (formerly called 0.93).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments