Broken message indicator with Evolution

Bug #657837 reported by Kevin Soviero on 2010-10-10
92
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Messaging Menu
Invalid
High
Unassigned
evolution-data-server (Ubuntu)
High
Unassigned
Maverick
High
Unassigned

Bug Description

Uploaded to maverick-proposed:

evolution-data-server (2.30.3-2ubuntu2) maverick-proposed; urgency=low

  * debian/patches/107-git-consider-local-inbox-as-inbox.patch:
    - adapted from upstream git: local inbox wasn't recognized as an inbox,
      debugged with upstream shown that the consequence was POP account not
      getting notification neither indicator support in the messaging menu.
      (LP: #657837)
  * debian/patches/108-git-fix-eproxy-and-https.patch:
    - fix the authentication of https webcal through a proxy (LP: #659167)

Test case:
1. install the version from -proposed
2. restart evolution
3. see that you are notified when your local INBOX (for instance, with a pop account) is receiving an email, evolution being unfocused and that the messaging menu is turning green with an incremented number.

You should have the default selection in evolution, which means getting notified on new emails from the Inbox folder only.

-------------

I just did a fresh install of Ubuntu 10.10, and I noticed that neither Evolution nor Liferea will cause the indicator applet to light up upon activity.

In other words, when I get an email, or a new feed, the indicator applet stays black and does not turn green...

However, if you click on it, it will show that an email has arrived, it just won't change color.

Omer Akram (om26er) wrote :

thanks for the bug report. please report each bug against each application that is causing the problem in this case liferea and evolution please report bugs using 'ubuntu-bug <appname>' so that the report have a little information about your system.

Changed in indicator-applet:
status: New → Invalid
Kevin Soviero (ksoviero) wrote :

Well, from what I can tell, its not an app specific bug, it is the indicator applet, not any particular application.

I have Evolution, Pidgin, and Liferea installed, and none of them are triggering the indicator app. Is there a way to test if the indicator app is accepting input?

evolution and empathy are working fine for me. if there is a bug its in the
app itself.

On Mon, Oct 11, 2010 at 12:49 AM, Ksoviero <email address hidden> wrote:

> Well, from what I can tell, its not an app specific bug, it is the
> indicator applet, not any particular application.
>
> I have Evolution, Pidgin, and Liferea installed, and none of them are
> triggering the indicator app. Is there a way to test if the indicator
> app is accepting input?
>
> --
> Broken message indicator with Evolution and Liferea
> https://bugs.launchpad.net/bugs/657837
> You received this bug notification because you are subscribed to
> Indicator Applet.
>
> Status in Indicator Applet: Invalid
>
> Bug description:
> I just did a fresh install of Ubuntu 10.10, and I noticed that neither
> Evolution nor Liferea will cause the indicator applet to light up upon
> activity.
>
> In other words, when I get an email, or a new feed, the indicator applet
> stays black and does not turn green...
>
> However, if you click on it, it will show that an email has arrived, it
> just won't change color.
>
>
>

Default install with default Evolution on Ubuntu 10.10, and its not working, so...

Didier Roche (didrocks) wrote :

It's working for me in evolution, fresh install, the icon turn green. Are you using a i386 or amd64 image?

Guillaume Desmottes (cassidy) wrote :

I'm using a amd64 install and experience lot of issues with this indicator.
I received a message in Empathy, the icon turned green but I wasn't able to accept the chat in the applet (the entry was empty and clicking on it didn't do anything). See http://people.collabora.co.uk/~cassidy/indicator.jpg

Then I played a bit with the applet (clicking on some evolution and liferea entries) and it changed to:
http://people.collabora.co.uk/~cassidy/indicator2.jpg

I was now able to accept the chat but the liferea items were broken.

Didier Roche (didrocks) on 2010-10-11
Changed in indicator-applet:
status: Invalid → Triaged
importance: Undecided → High
Omer Akram (om26er) on 2010-10-11
affects: indicator-applet → indicator-messages
Kevin Soviero (ksoviero) wrote :

I just thought I would mention that I am using 32 bit...

Didier Roche (didrocks) wrote :

ok, there is something weird then. I'm using happily the evolution indicator for 4 months in maverick and I can assure you it's working the way it worked in lucid (with the limitations explain in the duplicate) :/

Do me a favor please, install maverick in a VM, and see if the problem
appears... It may be that because you were running the dev version,
that whatever setting got broken, you were not affected.

--
Kevin Soviero <email address hidden>

On Mon, 2010-10-11 at 15:06 +0000, Didier Roche wrote:

> ok, there is something weird then. I'm using happily the evolution
> indicator for 4 months in maverick and I can assure you it's working the
> way it worked in lucid (with the limitations explain in the duplicate)
> :/
>

I reinstalled final on my netbook to check and didn't get any issue as well.

Maia Everett (lucidfox) wrote :

In Liferea, this is intended behavior. It never lights up the indicator because newsfeeds are not urgent messages demanding the user's immediate attention.

the original description of the bug seems more of evolution-indicator issue
then messaging menu

On Tue, Oct 12, 2010 at 1:22 PM, Maia Kozheva <email address hidden>wrote:

> In Liferea, this is intended behavior. It never lights up the indicator
> because newsfeeds are not urgent messages demanding the user's immediate
> attention.
>
> --
> Broken message indicator with Evolution and Liferea
> https://bugs.launchpad.net/bugs/657837
> You received this bug notification because you are subscribed to
> Messaging Menu.
>
> Status in The Messaging Menu: Triaged
>
> Bug description:
> I just did a fresh install of Ubuntu 10.10, and I noticed that neither
> Evolution nor Liferea will cause the indicator applet to light up upon
> activity.
>
> In other words, when I get an email, or a new feed, the indicator applet
> stays black and does not turn green...
>
> However, if you click on it, it will show that an email has arrived, it
> just won't change color.
>
>
>

right, but I got puzzled by Liferea before knowing it was the intended behavior :)
to people encountering the issue: is it the same with empathy?

Didier Roche (didrocks) on 2010-10-13
summary: - Broken message indicator with Evolution and Liferea
+ Broken message indicator with Evolution

Same problem for me. After upgrading to maverick.

No notification if I receive a new email.

But empathy notification works well.

I'm on 64bits.

Sebastien Bacher (seb128) wrote :

could you give details on what account type you use? imap, pop, etc? do you get those emails in the inbox? did you activate the evolution preferences to use the indicator?

The test I made is with my gmail account, so POP protocole.
I get the messages in the inbox yes.
And the option is activated in the preferences yes.

I have an important information :

In the preferences, I changed the "when messages arrive in :"
from "any inbox" to "any folder".
And it worked.
But I was receiving a notification each time I received a RSS feed (I use the RSS plugin), so it's not very useful for me

If I turn the option back to "any inbox", it doesn't work anymore.

Didier Roche (didrocks) wrote :

ok, the issue was in evolution-data-server, fix and SRU coming.

Changed in indicator-messages:
status: Triaged → Invalid
Changed in evolution-data-server (Ubuntu):
status: New → Triaged
importance: Undecided → High
Regulus (fbmail74) wrote :

I confirm the information reported by Loic Alejandro on Maverick amd64.

Didier Roche (didrocks) on 2010-10-14
description: updated
Changed in evolution-data-server (Ubuntu Maverick):
status: New → Triaged
importance: Undecided → High
Didier Roche (didrocks) wrote :
description: updated
Martin Pitt (pitti) wrote :

Is that patch limited to showing POP mailboxes, or will it really also show notifications for local Maildir changes? I don't remember the indicator ever showing me notifications about my local Maildir, neither in lucid nor anytime in maverick. This would introduce quite a behaviour change which isn't quite what an SRU is for?

Didier Roche (didrocks) wrote :

It should work for the local Maildir as well as it's not POP related.

The thing is that people are waiting for it quite a while and all notifications are broken currently for local maildir. and looking at the number of duplicates, people are just thinking that message indicator is broken, which isn't the case. This has been fixed and debugged with upstream who backported it to evolution 2.32.1 as a well as a stable release update.

Didier Roche (didrocks) wrote :

@Martin: it's for maildir used for mailbox pushed in evolution, of course.

Accepted evolution-data-server into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in evolution-data-server (Ubuntu Maverick):
status: Triaged → Fix Committed
tags: added: verification-needed
BehzadSh (behzadsh) wrote :

not worked for me :-/

christh (chris-theaker) wrote :

Can confirm that the maverick-proposed version of evolution-data-server resolves the issue.

Prior to patch, indicator was not announcing new messages when set to INBOX.

With patch messages are announced with sound and colour change when set to INBOX. Message count increments as it should.

Tested on Maverick 32bit using POP account.

Cheers

tags: added: verification-done
removed: verification-needed
Martin Pitt (pitti) wrote :

Copied to natty, too.

Changed in evolution-data-server (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package evolution-data-server - 2.30.3-2ubuntu2

---------------
evolution-data-server (2.30.3-2ubuntu2) maverick-proposed; urgency=low

  * debian/patches/107-git-consider-local-inbox-as-inbox.patch:
    - adapted from upstream git: local inbox wasn't recognized as an inbox,
      debugged with upstream shown that the consequence was POP account not
      getting notification neither indicator support in the messaging menu.
      (LP: #657837)
  * debian/patches/108-git-fix-eproxy-and-https.patch:
    - fix the authentication of https webcal through a proxy (LP: #659167)
 -- Didier Roche <email address hidden> Thu, 14 Oct 2010 14:08:13 +0200

Changed in evolution-data-server (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments