"System->About Ubuntu" should more directly display version information

Bug #395905 reported by Craig Hansen on 2009-07-05
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
ubuntu-docs (Ubuntu)
Undecided
Matthew East

Bug Description

"Thank you for your interest in Ubuntu 9.04" is very polite language, but it doesn't quite say "The version of Ubuntu you are running right now is ...."

pranith (bobby-prani) wrote :

Seems to be a valid and doable request. Also meaningful for new users.

Changed in hundredpapercuts:
status: New → Confirmed
Lightbreeze (nedhoy-gmail) wrote :

Currently, or at least for Jaunty, it says "Thank you for your interest in Ubuntu 9.04 - the Jaunty Jackalope - released in April 2009."

Maybe we could add the version number to the logo?

Changed in hundredpapercuts:
milestone: none → round-3

I imagine that most users searching for the version number are (1) novice or average users who don't know the version of their desktop operating system; (2) are in the process of getting help or support, so they may be in a hurry to find this information and therefore more likely to skim body text rather than read it carefully; and (3) frustrated by the problem they are seeking help with, given 2. Displaying the version number so that it is immediately seen when "About Ubuntu" is opened is a great idea.

Lightbreeze, I agree that placing the version number in the logo (or somewhere where it can be displayed more prominently) would help users quickly identify which version of Ubuntu they are running.

PeterShinners (pete-shinners) wrote :

What makes this a challenging ticket is the ubuntu-docs package. I can find no way to test and see the results of anything I do in the source xml.

I've tried to create a patch for this, but I have a fear this is not valid docbook xml any longer. For what it's worth, here this was my idea. This should apply against the 9.10.2 tarball for ubuntu docs.

PeterShinners (pete-shinners) wrote :

What makes this a challenging ticket is the ubuntu-docs package. I can find no way to test and see the results of anything I do in the source xml.

I've tried to create a patch for this, but I have a fear this is not valid docbook xml any longer. For what it's worth, here this was my idea. This should apply against the 9.10.2 tarball for ubuntu docs.

On Wed, Jul 22, 2009 at 07:52, PeterShinners<email address hidden> wrote:
> What makes this a challenging ticket is the ubuntu-docs package. I can
> find no way to test and see the results of anything I do in the source
> xml.

yelp /path/to/your.xml (there was a bug which meant the full path was
needed, not sure if it's been fixed or not)

> This should apply against the 9.10.2 tarball for ubuntu docs.

You're better off getting the ubuntu-docs bzr branch and working from
that. bzr branch lp:ubuntu-docs

There's more info on contributing to the docs at
https://wiki.ubuntu.com/DocumentationTeam/SystemDocumentation

Matthew East (mdke) wrote :

Perhaps all that is needed to fix this bug is to say:

"You are using Ubuntu 9.04 - the Jaunty Jackalope - released in April 2009."

Instead of:

"Thank you for your interest in Ubuntu 9.04 - the Jaunty Jackalope - released in April 2009."

I personally don't think the existing phrase is unclear at all, but perhaps the person who reported this bug could comment.

I agree with the poster of this bug. Thanking someone for their "interest" after they have installed the OS on their machine is a little condescending. Displaying that screen under a Live CD environment is fine as people are mostly still at the evaluation stage and have yet to commit.

The only reason I ever clicked on "About Ubuntu" was to check which version I was running after an upgrade.

My recommendation is to change to "Thank you for using Ubuntu X.XX - {version name} - {release date}

But also add in a line stating whether or not the installed version is the latest version, and stating when the support period expires for the installed version.

"This is the most up to date version of Ubuntu available"
or
"There is a newer version of Ubuntu available, click here to learn how to update"

And
"Your currently installed version of Ubuntu will be supported until xxxx, click here to learn about Ubuntu's release cycles and support periods"

Alex Lourie (alourie) wrote :

I really like Hercules' concept, but here's one caveat: it may be possible to update Ubuntu, but not necessarily to the "next" or "other" version.

So, it may include phrases like:
"This is the most up to date version of Ubuntu available - <version>"/"You are using the most updated version of Ubuntu - <version>",

and

"You're using Ubuntu <version>. There are updates available for your system, click here to learn how to update",

and finally,

And
"Your currently installed version of Ubuntu - <version> - will be supported until xxxx, click here to learn about Ubuntu's release cycles and support periods"

Matthew East (mdke) wrote :

We can't easily implement either the suggestion to include whether updates are available or whether the version is the most recent version of Ubuntu or not, because those are both things that change during the lifetime of an Ubuntu system and the help system that Ubuntu uses doesn't allow us to plug it into external systems and dynamically update its content.

However, I've committed a fix to our branch with amended wording and information about the support period.

Changed in ubuntu-docs (Ubuntu):
status: New → Fix Committed
PeterShinners (pete-shinners) wrote :

The documentation package could be updated after each release to include information about newer releases. This should allow the documentation to "dynamically" update a couple times each year.

Matt, can we please re-open this and include a change to the Ubuntu logo graphic shown in the help viewer?

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Matthew East (mdke)
status: Fix Committed → Confirmed

Ken, can you please take a look at the mockup I've attached and supply Matthew with an updated graphic to use?

Changed in hundredpapercuts:
assignee: nobody → Kenneth Wimer (kwwii)
Kenneth Wimer (kwwii) wrote :

I think that adding an extra number to the graphic is not necessary. I agree that thanking someone for their "interest" in Ubuntu is somewhat unnecessary after they have already installed the system (sounds like this came from the liveCD or such). In any case a simple and clear text with the version number, etc. seems to be all we need. Perhaps adding the version number in Bold or such would make things clearer.

In any case, the System->About Ubuntu menu entry has nothing to do with updating the system or suggesting anything like that.

Kenneth Wimer (kwwii) wrote :

In addition, it is probably not a good idea to tack a version number on the end of the logo, branding and all.

Matthew East (mdke) wrote :

I agree with Kenneth that adding a version number to the graphic is undesirable. Most importantly, it's contrary to the usual branding philosophy used in relation to the logo (i.e. that it should remain unchanged except where there is a good reason to change it) - this is to ensure consistency with the Ubuntu logo. For me, this is a prime place for the logo to retain its consistency.

Furthermore, it would actually be quite a pain to update the image for every release. It's very easy for us to update the version number in the text because it is changed globally throughout ubuntu-docs in an entity, but that wouldn't be true of the graphic.

Lastly, I think that moving the new text with the version number to the top of the file means that this is now pretty clear.

Re-marking the bug as fixed on that basis. Please feel free to post back here if you disagree, but I'd rather keep the bug status as it is pending any different consensus.

Changed in ubuntu-docs (Ubuntu):
status: Confirmed → Fix Released
Kenneth Wimer (kwwii) wrote :

In addition, adding it to the graphic makes it impossible to translate into other languages/char-sets

Ken, agreed. Paper cut is considered fixed, as the sentence containing the version number was improved to make it clear which version of Ubuntu you are running.

Changed in hundredpapercuts:
status: Confirmed → Fix Committed
vhellmet (vhellmet) wrote :

An easier way to do is would be to have something similar to what you get when you do "About Firefox" with the window showing links to ubuntu docs, to update current running ubuntu etc.

Matthew East (mdke) wrote :

vhellmet - it's a good idea, and something like this was planned (https://wiki.ubuntu.com/DesktopTeam/Specs/AboutThisComputer) but the specification appears to have been abandoned:

"ted-gould, 2008-06-02: Made obsolete after discussions at UDS. Doesn't currently match our desktop goals and QA is no longer interested (they've got more advanced tools)"

David Terei (dave-terei) wrote :

This is a problem thats always annoyed me greatly. I don't know for how many versions its said the phrase 'Thank you for your interest in Ubuntu 9.04 - the Jaunty Jackalope - released in April 2009.' But I only noticed it after coming to this bug report as I was planning on reporting it myself.

One important usage case I'd like to make though is that whenever I've gone to the 'About Ubuntu' menu item I've always been searching for what code name my Ubuntu version is. I'm always aware of which version number I'm using, such as 9.04 right now but I never have any idea of what the code name is. So highlighting by putting the version number and version codename in bold or something would be great.

This to me is a ubuntu wide branding problem though, having both the version names such as 'Jaunty Jackalope' (which I just had to look up since I didnt know it) and 9.04. Pretty confusing to new users when the same product keeps getting referred to in two different ways. This is obviously outside the scope of 100 paper cuts though.

Vish (vish) on 2009-08-10
Changed in hundredpapercuts:
status: Fix Committed → Fix Released
assignee: Kenneth Wimer (kwwii) → nobody
Matthew East (mdke) wrote :

@David - I entirely agree with your comment as follows:

"This to me is a ubuntu wide branding problem though, having both the version names such as 'Jaunty Jackalope' (which I just had to look up since I didnt know it) and 9.04. Pretty confusing to new users when the same product keeps getting referred to in two different ways."

Ubuntu already has a clear policy on this (https://wiki.ubuntu.com/CodeNamesToVersionNumbers) and I think we should remove reference to the codename in about-ubuntu, pursuant to that specification. I will make that change subject to comments here from other docteam members.

Vish (vish) wrote :

@Matthew East , i disagree.
The code names are commonly used , irc / ubuntuforums / other online help resources , to identify the version.
Removing the codes names from the About-Ubuntu ,would only make it difficult for users to identify their OS and cause more confusion.

Vish (vish) wrote :

Also, any repo will only have code names , in the sources line.
Users might not know both the names "Jaunty Jackalope" , but surely would know "Jaunty" , its hard *not* to notice that when you are adding repos.

Alex Lourie (alourie) wrote :

The name of the version IS part of the branding. It is interchangeably used in various sources, and as such, there's no good reason to remove it from the "about-ubuntu" dialog.

Matthew East (mdke) wrote :

@mac_v and Alex: have you read the wiki page I linked in comment 23? That is part of defined Ubuntu branding policy from as long ago as 2006 to eliminate the use of the development code name from any user visible space.

Vish (vish) wrote :

@Mathew, my comments are only after i'v read the wiki...
Since its a wiki , and atleast 1yr old page , it is not clear who has made the page...
AFAIC , it doesnt seem to be an official page , or an official decision Ubuntu wants to take...

If it was the official decision , why was it not done for 3 yrs?
why does Mark Shuttlework still refer to the versions using codenames, in his interviews ?
I dont recall any mailing list discussions which have concluded to accept the removal of code names.

And, the arguments i have raised above are valid.

Matthew East (mdke) wrote :

On Tue, Aug 11, 2009 at 8:29 AM, mac_v<email address hidden> wrote:
> @Mathew, my comments are only after i'v read the wiki...
> Since its a wiki , and atleast 1yr old page , it is not clear who has made the page...
> AFAIC , it doesnt seem to be an official page , or an official decision Ubuntu wants to take...

Ok, please take my word for it that it is an official Ubuntu policy.
You'll see from the page history that two current members of the
Ubuntu Technical Board have made changes to it.

> If it was the official decision , why was it not done for 3 yrs?

It has been done in all places mentioned on the wiki page except
about-ubuntu.xml. That's due to an oversight on the part of the
docteam, I believe.

> why does Mark Shuttlework still refer to the versions using codenames, in his interviews ?

I don't know, you'll have to ask him.

> I dont recall any mailing list discussions which have concluded to accept the removal of code names.

Well, Ubuntu specifications are not always discussed on mailing lists.
But this one was implemented (e.g.
https://lists.ubuntu.com/archives/dapper-changes/2006-May/011479.html)

Anyway, instead of relying on recollection, the best plan is to search
the mailing lists. There is quite a long and interesting discussion
about it on sounder from 2006. This email from the Canonical CEO sums
it up:

https://lists.ubuntu.com/archives/sounder/2006-February/004305.html

But as far as I am aware, Ubuntu policy has always been that the
codenames are for development use, and the version numbers are for
public visibility.

--
Matthew East
http://www.mdke.org
gnupg pub 1024D/0E6B06FF

Vish (vish) wrote :

Ok... i think you are right > https://wiki.ubuntu.com/DevelopmentCodeNames , says the the "Official" name is the number...

But again, to re-enforce the problems> comments #24 and #25 are valid causes of concern.
All external repos, lp repos refer to codenames!Even the ubuntuforums.org only list the code names...

To properly fix this , it *needs* to be fixed in *all* other locations listed in > https://wiki.ubuntu.com/CodeNamesToVersionNumbers
most importantly , it has not been fixed in Synaptic [several locations only refer to the codename jaunty/karmic]
Only then, removing it from the About page makes sense.
This might mean a small change in the docs , but I truly believe removing the code names , /as of now/ , is going to hurt users more.

Phil Bull (philbull) wrote :

Wow, I can't believe that such a minor bug has generated so many comments. I'm going to add one more:

I know that the policy states that we should refer to Ubuntu releases by their release number, but a sufficient number of people use the codenames that we should provide some way of users finding out what their codename is. That is, we should at least mention what the codename is somewhere obvious. The use cases for needing to know the codename are the same as those for needing to know the release number.

Like https://wiki.ubuntu.com/DevelopmentCodeNames ? It's also the first Google hit on "Ubuntu code names".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers