Bluetooth 'Send files' returns permission denied error

Bug #872044 reported by CaptainMark on 2011-10-10
740
This bug affects 251 people
Affects Status Importance Assigned to Milestone
GNOME Bluetooth
New
Undecided
Unassigned
Linaro Linux
Won't Fix
Undecided
Unassigned
Linaro Ubuntu
Medium
Unassigned
OEM Priority Project
Medium
Ursula Junque
Precise
Undecided
Unassigned
bluez (Fedora)
Unknown
Unknown
bluez (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned
linux (Ubuntu)
Medium
Ming Lei
Oneiric
Undecided
Unassigned
Precise
Medium
Ming Lei
obex-data-server (Ubuntu)
Oneiric
Undecided
Unassigned
Precise
Medium
Unassigned
obexd (Ubuntu)
Oneiric
Undecided
Unassigned
Precise
Medium
Unassigned

Bug Description

Gnome 3 bluetooth manager cannot send files to my HTC Desire phone, (or any phone that I could try) Gnome2 bluetooth manager would send some form of authorisation request when first sending a file to my phone, which i would accept on the phone and then all future files could be sent with a simple 'accept?' message on the phone, on any gnome3 setup i have tried there is not authorisation request and i believe this is what leads to a permission denied error on screen (video attached)

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-bluetooth 3.2.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Mon Oct 10 23:23:33 2011
ExecutablePath: /usr/bin/bluetooth-applet
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111010.1)
SourcePackage: gnome-bluetooth
UpgradeStatus: No upgrade log present (probably fresh install)

CaptainMark (imark-skinner) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-bluetooth (Ubuntu):
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

Thanks for the report, could you please attach your /var/log/messages after reproduced the issue? thanks in advance.

Changed in gnome-bluetooth (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Oscar Tiderman (oscar-tiderman) wrote :

I am suffering from the same problem but on my Samsung Galaxy S, used to work in Natty.
My /var/log/messages is empty but these are the only lines regarding this in /var/log/syslog:

Oct 25 18:33:42 oscar-laptop kernel: [ 549.861814] ACPI: EC: GPE storm detected, transactions will use polling mode
Oct 25 18:37:03 oscar-laptop bluetoothd[1306]: Mode session 0x7f1d90aa0530 with :1.63 activated
Oct 25 18:37:07 oscar-laptop obex-client[2467]: Permission denied (13)
Oct 25 18:37:12 oscar-laptop bluetoothd[1306]: Mode session 0x7f1d90aa0530 with :1.63 activated
Oct 25 18:37:15 oscar-laptop obex-client[2467]: Permission denied (13)

It's pretty quiet, this is after two unsuccessful attempts to send a file to my phone (18:37).

CaptainMark (imark-skinner) wrote :

Same as post #4 /var/log/messages is empty or does not exist, i can reproduce the error anytime so i can run any commands needed

aka (vangop) wrote :

Same thing. Also I cannot pair Phone->PC if the pairing is initiated from the phone.
The phone asks if the pin is correct, I confirm, it then says pin incorrect. Samsung galaxy, Android.

petogal (petogal) wrote :

Same thing, Samsung Galaxy s2 and HP laptop

Florent Mertens (givre) wrote :

Same problem with my Samsung i5800.

Changed in gnome-bluetooth (Ubuntu):
status: Incomplete → Confirmed
Amneet Bedi (amneetbedi) wrote :

Facing the same issue with my Samsung Corby Plus

Same problem with samsung galaxy s2 - also it seems as though bluetooth audio will be broken.

Jonathan Bispo (jfb0101) wrote :

I have problemas with bluetooth in Ubuntu 11.10 too. I can send files but when it ends my system brakes and I need to restart that. I'm using the default manager of Gnome 3.

Nelo (nelo) wrote :

Same problem, Samsung Galaxy S2 and DELL Studio xps 1647

David Young (dove-young) wrote :

Seems there is not a workaround so far. I confirm the same problem between Thinkpad T400 and HTC Incredible S. Ubuntu 11.10 i386 desktop

David Young (dove-young) wrote :

Workaround:

Seems I checked “Share public files over Bluetooth" in Personal File Sharing Preference panel, then I could send files in ~/Public folder to my smart phone.

Files not in ~/Public folder can also be sent over Bluetooth.

mano-மனோ (manoj-neyveli) wrote :

 The same problem between my lg510 and ideapad z460.

fgy (1stmrfgy) wrote :

Same problem, Lenovo X201-Samsung S5230.
part of syslog:
.....
Nov 1 19:32:57 x201 bluetoothd[1071]: Discovery session 0x7f7331e11550 with :1.93 activated
Nov 1 19:33:06 x201 bluetoothd[1071]: Mode session 0x7f7331e0f500 with :1.86 activated
Nov 1 19:33:08 x201 obex-client[6181]: Permission denied (13)
......

fjkum (fongjeng-kum) wrote :

Please has someone assigned to look at this bug as it's really makes me feel handicapped when this bluetooth stops working.

Niklas Fischer (niklasfi) wrote :

I can confirm the bug as well as as the error message Permission denied (13) when I initialize sending a file.

Same problem here with Galaxy S. And why importance set to low ? It's pretty annoying...

CaptainMark (imark-skinner) wrote :

This is not restricted to ubuntu 11.10, running the early cut of 12.04 and this bug is also present

aka (vangop) wrote :

There's a workaround - to mount the phone with obexfs. see http://ubuntu-answers.blogspot.com/2011/11/bluetooth-on-ubuntu-1110.html

David Young (dove-young) wrote :

Send files in your ~/Public folders are OK. In case you have checked “Share public files over Bluetooth" in Personal File Sharing Preference

Send files from other folders will encounter 'Permission deny' problem

Steffen Krumbholz (skrumbholz) wrote :

Sending files from ~/Public folder [1] to my Android phone doesn't work for me. I have configured sharing over bluetooth in gnome-file-share-properties and paired the devices successfully. But I still get the permission denied (13) error.

Sending files the other way around works like a charm.

Linux eeepc 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 i686 i386 GNU/Linux
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
gnome-user-share: 3.0.0-2ubuntu3
gnome-bluetooth: 3.2.0-0ubuntu2

[1] I have configured the folder ~/Temp as the public folder in file $HOME/.config/user-dirs.dirs (XDG_PUBLICSHARE_DIR="$HOME/Temp")
drwxrwxr-x 2 skrumbholz skrumbholz 4096 2011-11-15 14:01 /home/skrumbholz/Temp

ಸతీशः (bdsatish) wrote :

Same problem, Galaxy S. Even sending from ~/Public doesn't work anymore. There is a segmentation fault with the error messages:

Nov 16 01:58:17 sarvamula kernel: [ 2936.499111] gnome-control-c[3211]: segfault at 8 ip a6d1e230 sp bfc3df20 error 4 in libgnome-bluetooth.so.8.0.0[a6d17000+1a000]
Nov 16 01:58:27 sarvamula bluetoothd[2033]: input-headset driver probe failed for device CC:05:1B:97:08:E7
Nov 16 01:59:09 sarvamula bluetoothd[2033]: Discovery session 0xb7f2d0d8 with :1.82 activated
Nov 16 01:59:17 sarvamula obex-client[3764]: obex-client daemon 0.42
Nov 16 01:59:17 sarvamula bluetoothd[2033]: Mode session 0xb7f2d0d8 with :1.85 activated
Nov 16 01:59:20 sarvamula obex-client[3764]: Permission denied (13)
Nov 16 01:59:22 sarvamula bluetoothd[2033]: Mode session 0xb7f2d0d8 with :1.85 activated
Nov 16 01:59:24 sarvamula obex-client[3764]: Permission denied (13)

From /var/log/syslog

phcoder (phcoder) wrote :

I've discovered where the problem comes from: some devices are unable to respond to open request in rapid succession after the SDP scanning. You need to close SDP session and wait 2 seconds before connecting to rfcomm, like the attached patch.

The attachment "sdp.diff" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Teguh Wibowo (kangtguh) wrote :

The same problem between my samsung phone and fujitsu MH-330, service list just dial-up,no file transfer no object push.
I've installed blueman (bluetooth-manager) package.
I just found that my netbook CAN receive files SUCCESSFULLY from my phone while the bluetooth-manager (blueman) active,but CANNOT send back from my netbook to my phone. [Sending files - failed with the a 'permission denied error(13)'].

Felix (apoapo) wrote :

On 07.12.2011 16:07, Felix wrote:
> Are we talking about the same bug?
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-bluetooth/+bug/879923
>
I think we do. There is the same bug in both obexd-client and
obex-data-server. I've posted a patch only to one of the packages. Here
attached is the patch for obexd.

--
Regards
Vladimir 'φ-coder/phcoder' Serbinenko

I confim. Samsung Galaxy 5 in Ubuntu 11.10 (gnome-shell). IMHO this bug is critical. Bluetooth is the stardard way to comm with mobile. All Ubuntu look&fell is affected by this bug. How will change to Ubuntu if it cannot comm with his mobile?

phcoder (phcoder) wrote :

On 07.12.2011 18:54, Andre Cavalcante wrote:
> I confim. Samsung Galaxy 5 in Ubuntu 11.10 (gnome-shell). IMHO this bug
> is critical. Bluetooth is the stardard way to comm with mobile. All
> Ubuntu look&fell is affected by this bug. How will change to Ubuntu if
> it cannot comm with his mobile?
>
It's not Ubuntu fault. Just your and my phones are piece of crap. It
would be nice if my or similar workaround would be accepted though.

--
Regards
Vladimir 'φ-coder/phcoder' Serbinenko

carlosv (cvedovatti) wrote :

The bug stills present on the alpha version of Ubuntu 12.04, hope to see to solve soon.

icewater (a-ubuntu) wrote :

Connection to the headset I use to listen to music (LG HDS 700) also fails with the bluetooth applet, but works with blueman, as mentioned earlier in this bug.

It worked with the applet exactly one time, then not again.

I'm on 11.10

sreenivasa reddy (cnureddy-b) wrote :

Both the solutions in comment #21 worked for me

1). I could mount folders via obexfs

2). apt repo upgrade as below
  $ sudo add-apt-repository ppa:blueman/ppa
  $ sudo apt-get update
  $ sudo apt-get upgrade

I feel this bug can be closed

Kent Lin (kent-jclin) on 2011-12-20
Changed in oem-priority:
importance: Undecided → Critical
Changed in oem-priority:
status: New → Confirmed

I am affected by the same bug (fresh install of Ubuntu 11.10 with Unity). Actually I cannot do any file transfer with my phone : sending files from the phone, from the PC, browsing files, nothing works (permission denied everywhere). Also, the bluetooth-applet crashes. Only the initial pairing with the phone went fine. Typical errors in syslog are :

Dec 21 11:26:27 guilleri obex-data-server: sdp_extract_seqtype: Unexpected end of packet
Dec 21 11:27:08 guilleri bluetoothd[4523]: Bluetooth daemon 4.96
Dec 21 11:27:08 guilleri bluetoothd[4523]: Unable to get on D-Bus
[...]
Dec 21 11:29:34 guilleri obex-client[4567]: obex-client daemon 0.42
Dec 21 11:29:34 guilleri bluetoothd[1136]: Mode session 0x7fa6debc6630 with :1.82 activated
Dec 21 11:29:36 guilleri obex-client[4567]: Permission denied (13)

Comment #14 suggested to look into the "Personal file sharing" settings but I cannot find them in Unity's system settings (though the package gnome-user-share is installed).

Update : I finally found the Personal file sharing settings, it was well-hidden in the Dash (see Bug #883769). I can now receive files sent from the phone on my PC. No luck yet for sending files from the PC, and browsing files on the phone...

Mathias Dietrich (theghost) wrote :

There is also an upstream bug-report: https://bugzilla.gnome.org/show_bug.cgi?id=663044

I might help with this bug.

dAnjou (danjou) wrote :

This bug has probably nothing to do with GNOME. I tried to use the Bluetooth Chat sample from Android ( http://developer.android.com/resources/samples/BluetoothChat/index.html ) with the little code snippet in the attachment and I get this (MAC disguised by me):

max@XV88:~/Projekte/python$ python bt_spam_server.py
Searching ...
connecting to "BluetoothChat" on 3C:5A:37:XX:XX:XX
Traceback (most recent call last):
  File "bt_spam_server.py", line 39, in <module>
    sock.connect((host, port))
  File "<string>", line 5, in connect
bluetooth.btcommon.BluetoothError: (13, 'Permission denied')
max@XV88:~/Projekte/python$

I tested it on a Natty machine too and it worked perfectly.

(Credits for the snippet go to http://www.humbug.in/2010/sample-bluetooth-rfcomm-client-app-in-python/ )

Indeed not an issue with gnome-bluetooth really, this has more to do with obexd or obex-data-server than GNOME (and probably not bluez either).

I'm reassigning this to obexd for now, since there really does seem to be something wrong with it at least in precise (and updating to the latest source seems to let it work better).

The two patches provided might help, but I'm just generally not fond of adding timeouts for the fun of it; it always seems like there ought to be a better way to achieve this. However, since the "ugliest" one is for obexd, which has heavily changed in 0.43, it still seems like the lesser evil than trying to look through and backport the changes.

affects: gnome-bluetooth (Ubuntu) → obexd (Ubuntu)
Changed in obexd (Ubuntu):
importance: Low → Medium
Changed in obex-data-server (Ubuntu):
importance: Undecided → Medium

The issue probably also affects o-d-s, so let's keep a task open for it too.

Changed in obex-data-server (Ubuntu):
status: New → Confirmed
Changed in oem-priority:
assignee: nobody → Ursula Junque (ursinha)
tags: added: rls-mgr-p-tracking
Ursula Junque (ursinha) on 2012-01-30
Changed in obexd (Ubuntu):
status: Confirmed → Incomplete
Changed in oem-priority:
status: Confirmed → Incomplete
Changed in obex-data-server (Ubuntu):
status: Confirmed → Incomplete
Ursula Junque (ursinha) on 2012-01-30
Changed in oem-priority:
status: Incomplete → Confirmed
Changed in obexd (Ubuntu):
status: Incomplete → Confirmed
Changed in obex-data-server (Ubuntu):
status: Incomplete → Confirmed
Changed in oem-priority:
importance: Critical → Medium
tags: added: linaro-ubuntu lt-origen
tags: added: patch-needswork
removed: patch
Changed in bluez (Ubuntu):
status: New → Confirmed
Changed in obex-data-server (Ubuntu):
status: Confirmed → Incomplete
Changed in linaro-ubuntu:
status: New → Confirmed
importance: Undecided → Medium
Changed in obex-data-server (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
tags: added: bluetooth
Changed in linux (Ubuntu):
assignee: nobody → Ming Lei (tom-leiming)
Changed in linux (Ubuntu Precise):
status: Confirmed → Fix Committed
Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
37 comments hidden view all 117 comments
jeremy-list (quick-dudley) wrote :

It would be great if someone could backport the patch to oneric too.

Ming Lei (tom-leiming) wrote :

OK, I will send out the patch for Oneric to ubuntu kernel mail list later.

Anomaly (bertrand3000) wrote :

I can confirm that updating Precise to the latest kernel fix the Send file issue. Unfortunately, the "Browse File on Device" menu option is still broken. It's better than before, because when you choose that option, the device will react and ask for confirmation. But even if you say "yes", nothing will happen on the computer side.

Anomaly (bertrand3000) wrote :

To add on my previous reply, the following will be added /var/log/syslog while trying to "Browse File on Device" :

obex-data-server: sdp_extract_seqtype: Unexpected end of packet

Ego (egogratis) wrote :

I tested new kernel too and i can confirm this works now. Thanks for fixing this.

"But even if you say "yes", nothing will happen on the computer side."

Actually "something" does happen.

If u open Nautilus you will notice the device is mounted but this does not work and the BUG is reported here:

https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/899858

But i do do agree Nautilus should open when pressing on the button. Average Ubuntu user just does not know he/she has to open Nautilus after pressing the button and just assumes it does not work!

tags: added: rls-p-tracking
Tim Gardner (timg-tpi) on 2012-03-19
Changed in linux (Ubuntu Oneiric):
status: New → Fix Committed
tags: removed: rls-p-tracking

Closing the obex tasks, since this was fixed in the kernel.

no longer affects: obexd (Ubuntu)
no longer affects: obex-data-server (Ubuntu)
Changed in obex-data-server (Ubuntu Oneiric):
status: New → Invalid
Changed in obex-data-server (Ubuntu Precise):
status: Confirmed → Invalid
Changed in obexd (Ubuntu Precise):
status: Confirmed → Invalid
Changed in obexd (Ubuntu Oneiric):
status: New → Invalid

Also not an issue in bluez, see above.

Changed in bluez (Ubuntu Oneiric):
status: New → Invalid
Changed in bluez (Ubuntu Precise):
status: Confirmed → Invalid
no longer affects: oem-priority/q-series
Changed in oem-priority:
status: Confirmed → Fix Released
Fahd Harb (eg-fofo) wrote :

I have the same problem with ubuntu 11.10 64bit and samsung galaxy s2 with gingerbread 2.3.5
please fix the bug for this release, thanks

Anthony Wong (anthonywong) wrote :

Fahd, if possible could you test with 12.04 beta 2? This bug has already been fixed there and my testing is positive.

Ming Lei (tom-leiming) wrote :

On Sat, Mar 31, 2012 at 6:39 AM, Fahd Harb <email address hidden> wrote:
> I have the same problem with ubuntu 11.10 64bit and samsung galaxy s2 with gingerbread 2.3.5
> please fix the bug for this release, thanks

Ubuntu-3.0.0-18.31(Oneiric) has applied the fix patch already, so please
update linux-image to fix your problem.

Thanks,

Anthony Wong (anthonywong) wrote :

Fahd, for 11.10, this fix has already been queued up for the next SRU (stable release update).

garypeg (pegngary) wrote :

On Fri, Mar 30, 2012 at 11:49 PM, Anthony Wong
<email address hidden> wrote:
> Fahd, for 11.10, this fix has already been queued up for the next SRU
> (stable release update).
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (887734).
> https://bugs.launchpad.net/bugs/872044
>
> Title:
>  Bluetooth 'Send files' returns permission denied error
>
> Status in GNOME Bluetooth:
>  New
> Status in Linaro Ubuntu Evaluation Builds:
>  Confirmed
> Status in Linaro Linux:
>  New
> Status in OEM Priority Project:
>  Fix Released
> Status in OEM Priority Project precise series:
>  New
> Status in “bluez” package in Ubuntu:
>  Invalid
> Status in “linux” package in Ubuntu:
>  Fix Released
> Status in “bluez” source package in Oneiric:
>  Invalid
> Status in “linux” source package in Oneiric:
>  Fix Committed
> Status in “obex-data-server” source package in Oneiric:
>  Invalid
> Status in “obexd” source package in Oneiric:
>  Invalid
> Status in “bluez” source package in Precise:
>  Invalid
> Status in “linux” source package in Precise:
>  Fix Released
> Status in “obex-data-server” source package in Precise:
>  Invalid
> Status in “obexd” source package in Precise:
>  Invalid
> Status in “bluez” package in Fedora:
>  Unknown
>
> Bug description:
>  Gnome 3 bluetooth manager cannot send files to my HTC Desire phone,
>  (or any phone that I could try) Gnome2 bluetooth manager would send
>  some form of authorisation request when first sending a file to my
>  phone, which i would accept on the phone and then all future files
>  could be sent with a simple 'accept?' message on the phone, on any
>  gnome3 setup i have tried there is not authorisation request and i
>  believe this is what leads to a permission denied error on screen
>  (video attached)
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.10
>  Package: gnome-bluetooth 3.2.0-0ubuntu1
>  ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
>  Uname: Linux 3.0.0-12-generic x86_64
>  ApportVersion: 1.23-0ubuntu3
>  Architecture: amd64
>  Date: Mon Oct 10 23:23:33 2011
>  ExecutablePath: /usr/bin/bluetooth-applet
>  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111010.1)
>  SourcePackage: gnome-bluetooth
>  UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-bluetooth/+bug/872044/+subscriptions

is there a fix for 11.04? 11.10 runs poorly on my machine.

garyk

florin (florin-arjocu) wrote :

Just some thoughts:
At least in my opinion, the OS should be something stable that you use for a long period of time. At least people coming from Windows or MacOS/iOS/etc. are not expecting to change the OS every 3-5 months because of some nagging bug (in this case, the bluetooth connection) . An OS is not just a program, you have to re-make all configurations and install everything that one needs for the computer to be a useful and pleasant tool.
And some programs are not always updated to the latest version with all dependencies, so some of us have trouble installing them (for instance, I could not install GIMP 2.7.5 on Oneiric; yes, I'm a noob, but I am willing to learn and I have learned a lot in the last year since I switched to Ubuntu (from Windows)).

I am sure I am not the only one thinking this, so maybe at some point in the future, the launching philosophy gets closer to major groups of users' needs. There are some bugs dragged for many versions (for instance Gnome desktop icons overlapping) that once fixed will bring lots of smiles and happiness for most of the users, more than some fancy transparency. Together, letting Gnome developers that we care about it might work. Interaction really matters.

//reply to #86:
//Fahd, if possible could you test with 12.04 beta 2? This bug has already been fixed there and my testing is positive.

Anthony Wong (anthonywong) wrote :

@garypeg, it is new to me that this issue also happens in 11.04, because in various comments in this bug report, it is stated that in 11.04 bluetooth transfer works. If it is not working for you, please describe your symptoms and steps to reproduce, by possibly opening a new bug. Thanks.

Saurav (sauravzone1) wrote :

@florin (comment #90): I am a free and open source software proponent and I fully sympathise with your sentiments. Indeed, I have myself felt this often. The problem is that, of late, both the GNOME project and Canonical have been increasingly focussing on adapting their user interfaces for mobile and touch-oriented devices, which require different approaches than traditional desktops and laptops. As a result, many other bugs in the existing software are either getting neglected or are even being created as regressions, when in previous versions they did not exist. For example, Ubuntu 10.04 is infinitely more stable than Ubuntu 11.10. More importantly, 10.04 does not have all the features of 11.10, but what it does have works absolutely correctly and as expected, which is what matters. Similarly, the Debian distribution also provides a stable and reliable system which is not updated with every fad and fancy. The same goes for the KDE SC project. The only way to have a stable OS today (open source) that I can think of is either using Ubuntu's LTS release, which is Ubuntu 10.04 at present and will be 12.04 in April, although the number of new features in 12.04 is again huge, or using something other than Ubuntu which does not rush with updates, such as Debian or OpenSUSE. I have personally also found Fedora to be much better than Ubuntu at fixing bugs, although it provides updates even more frequently. But most of the time, when there is some annoying bug in Fedora, they fix it much more quickly than Ubuntu. The Unity interface in 11.10, for example, had bugs related to both the window management system for maximised LibreOffice windows as well as the launcher quick-lists, which were fixed just a few days ago when the next version of Ubuntu is almost due. By contrast, Fedora fixed most of its problems in version 16 very rapidly after they were reported. I only hope that Canonical in particular will take stock of the situation and put its quality control back in place for which it was known so well for so long.

CaptainMark (imark-skinner) wrote :

Please remember this is a bug report not a chat forum, please only comment in relation to this bug and try to refrain from posting opinions and views that don't relate to this bug and don't help developers fix it

garypeg (pegngary) wrote :

Well I tried connecting again after seeing your comment about 11.04,
and everything worked fine this time. Sorry.

garyk

On 3/31/12, CaptainMark <email address hidden> wrote:
> Please remember this is a bug report not a chat forum, please only
> comment in relation to this bug and try to refrain from posting opinions
> and views that don't relate to this bug and don't help developers fix it
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (887734).
> https://bugs.launchpad.net/bugs/872044
>
> Title:
> Bluetooth 'Send files' returns permission denied error
>
> Status in GNOME Bluetooth:
> New
> Status in Linaro Ubuntu Evaluation Builds:
> Confirmed
> Status in Linaro Linux:
> New
> Status in OEM Priority Project:
> Fix Released
> Status in OEM Priority Project precise series:
> New
> Status in “bluez” package in Ubuntu:
> Invalid
> Status in “linux” package in Ubuntu:
> Fix Released
> Status in “bluez” source package in Oneiric:
> Invalid
> Status in “linux” source package in Oneiric:
> Fix Committed
> Status in “obex-data-server” source package in Oneiric:
> Invalid
> Status in “obexd” source package in Oneiric:
> Invalid
> Status in “bluez” source package in Precise:
> Invalid
> Status in “linux” source package in Precise:
> Fix Released
> Status in “obex-data-server” source package in Precise:
> Invalid
> Status in “obexd” source package in Precise:
> Invalid
> Status in “bluez” package in Fedora:
> Unknown
>
> Bug description:
> Gnome 3 bluetooth manager cannot send files to my HTC Desire phone,
> (or any phone that I could try) Gnome2 bluetooth manager would send
> some form of authorisation request when first sending a file to my
> phone, which i would accept on the phone and then all future files
> could be sent with a simple 'accept?' message on the phone, on any
> gnome3 setup i have tried there is not authorisation request and i
> believe this is what leads to a permission denied error on screen
> (video attached)
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: gnome-bluetooth 3.2.0-0ubuntu1
> ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
> Uname: Linux 3.0.0-12-generic x86_64
> ApportVersion: 1.23-0ubuntu3
> Architecture: amd64
> Date: Mon Oct 10 23:23:33 2011
> ExecutablePath: /usr/bin/bluetooth-applet
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64
> (20111010.1)
> SourcePackage: gnome-bluetooth
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-bluetooth/+bug/872044/+subscriptions
>

Saurav (sauravzone1) wrote :

@CaptainMark (comment #93): I know that this is a bug report and all bug reports do have only bug-related comments. We are not going to flood this thread with opinionated comments. However, comment #90 is still valid. This type of discussion also occurs elsewhere on forums but that has never helped either, regarding bug fixing on Ubuntu.

That said, I have a query here too. Are you pushing this fix upstream as well or has it already been fixed upstream?

Anthony Wong (anthonywong) wrote :

@Saurav, this is a regression upstream and the fix has already been accepted there, please see #62.

Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Oneiric in -proposed solves the problem (3.0.0-18.31). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-oneiric' to 'verification-done-oneiric'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-oneiric

Right now I tested sending files with 3.0.0-18.31 on oneiric and am happy to report that it works now. yay :)

Just to be sure I did also a test with the previous kernel (3.0.0-17.30) where it failed as expected.

tags: added: verification-done-oneiric
removed: verification-needed-oneiric
Rafael P. (rafael-p) wrote :

Just tested kernel 3.0.0-19.32 in proposed repo and...wooohoo...I'm confirming that sending files works! (Galaxy S i9000) Nevertheless, browsing files still doesn't, but that is another issue...

3.0.0-19-generic #32-Ubuntu SMP Thu Apr 5 18:22:38 UTC 2012 x86_64
and Galaxy S i9000 (ICS)
Sending files works

Thank You

Ethan Chang (ethan.chang) wrote :

I've two Asus lattop, both upgraded to 3.0.0-19-generic #32 kernel, but send file to each other still failed.
But if I install blueman and use blueman to send file, then it works.

CaptainMark (imark-skinner) wrote :

I can send a file to my phone but still cannot recieve a picture from phone to pc, the phone gives a connection refused error message

Oliver Joos (oliver-joos) wrote :

I am not affected by this bug but the reporter of a similar bug 839157. Those who still have problems with browsing a bluetooth device could have a look at bug 839157. Please leave a comment if its workaround works for you.

Karel Kozlik (karel.kozlik) wrote :

The fix worked for me in Oneiric, sending files was fine. But then I upgraded to Precise and I can sent files from PC to phone only. Sending from phone to PC gives me connection refused error. Probably same situation as for CaptainMark.

$ cat /proc/version
Linux version 3.2.0-23-generic (buildd@crested) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu4) ) #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012

Launchpad Janitor (janitor) wrote :
Download full text (24.1 KiB)

This bug was fixed in the package linux - 3.0.0-19.33

---------------
linux (3.0.0-19.33) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #985736

  [ Luis Henriques ]

  * SAUCE: ite-cir: postpone ISR registration
    - LP: #984387

linux (3.0.0-19.32) oneiric-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #974368

  [ Brad Figg ]

  * SAUCE (no-up) Provide a param for allowing the BIOS to handle changing
    the brightness on AC/battery status changes.
    - LP: #949311
  * SAUCE (no-up) Quirk for enabling backlight hotkeys on Samsung N150P
    - LP: #875893

  [ Daniel Vetter ]

  * SAUCE: (drop after 3.5) drm/i915: reinstate GM45 TV detection fix
    - LP: #638939

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: (no-up) Reinstate missing hunk from nx emulation
    - LP: #972821

  [ Tim Gardner ]

  * SAUCE: ubuntu drivers: use UMH_WAIT_PROC consistently
    - LP: #963685
  * SAUCE: disable_nx should not be in __cpuinitdata section for X86_32
    - LP: #968233
  * SAUCE: (no-up) remove __initdata from vesafb_fix
    - LP: #969309

  [ Upstream Kernel Changes ]

  * usermodehelper: use UMH_WAIT_PROC consistently
    - LP: #963685
  * usermodehelper: introduce umh_complete(sub_info)
    - LP: #963685
  * usermodehelper: implement UMH_KILLABLE
    - LP: #963685
  * usermodehelper: kill umh_wait, renumber UMH_* constants
    - LP: #963685
  * usermodehelper: ____call_usermodehelper() doesn't need do_exit()
    - LP: #963685
  * kmod: introduce call_modprobe() helper
    - LP: #963685
  * kmod: make __request_module() killable
    - LP: #963685
  * x86, tsc: Fix SMI induced variation in quick_pit_calibrate()
    - LP: #965586
  * ata_piix: Add Toshiba Satellite Pro A120 to the quirks list due to
    broken suspend functionality.
    - LP: #886850
  * ACPICA: Fix regression in FADT revision checks
    - LP: #883441
  * ASPM: Fix pcie devices with non-pcie children
    - LP: #961482
  * USB: option: Add MediaTek MT6276M modem&app interfaces
    - LP: #971808
  * USB: option driver: adding support for Telit CC864-SINGLE, CC864-DUAL
    and DE910-DUAL modems
    - LP: #971808
  * USB: option: make interface blacklist work again
    - LP: #971808
  * USB: option: add ZTE MF820D
    - LP: #971808
  * USB: ftdi_sio: fix problem when the manufacture is a NULL string
    - LP: #971808
  * USB: ftdi_sio: add support for BeagleBone rev A5+
    - LP: #971808
  * USB: Microchip VID mislabeled as Hornby VID in ftdi_sio.
    - LP: #971808
  * USB: ftdi_sio: new PID: Distortec JTAG-lock-pick
    - LP: #971808
  * USB: ftdi_sio: add support for FT-X series devices
    - LP: #971808
  * USB: ftdi_sio: new PID: LUMEL PD12
    - LP: #971808
  * powerpc/usb: fix bug of kernel hang when initializing usb
    - LP: #971808
  * usb: musb: Reselect index reg in interrupt context
    - LP: #971808
  * usb: gadgetfs: return number of bytes on ep0 read request
    - LP: #971808
  * USB: gadget: Make g_hid device class conform to spec.
    - LP: #971808
  * futex: Cover all PI opcodes with cmpxchg enabled check
    - LP: #971808
  * sysfs: Fix memory leak in sysfs_sd_setsecdata().
    - LP: #971808
  * tty: ...

Changed in linux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Peter Sewell (peter-sewell) wrote :

I can't understand how this bug as been reported as fixed when it's still not working in ubuntu 12.04 for me.

What am I doing wrong which is stopping me using the bluetooth transfer between a Nokida E65 and HTC Desire (with Bluetooth Transfer App installed)?

When I open Personal File Sharing it says at the top of the app that "This feature can not be enabled because the required packages are not installed on your system". What packages are these and how do I install them?

It allows me to tick the Share Files over Bluetooth boxes and the receive files over Bluetooth.

Any help would be appreciated.

Anthony Wong (anthonywong) wrote :

Hi Peter, we need more specifics what is not working. Does it fail when sending files from the phone to Ubuntu 12.04, or from Ubuntu to the phone?

In Personal File Sharing, the "This feature cannot be enabled..." message is not related to bluetooth file transfer, you can ignore it. The "Receive files in Downloads folder over Bluetooth" must be checked for other devices to send files to Ubuntu over bluetooth.

For me, sending files over bluetooth (both directions) also failed despite the fix. I had to remove the saved pairing from my phone and then re-pair my PC and phone. Peter, you might want to try that, maybe it helps.

Steve 91 (devetjedan) wrote :

And I am suffering from the same problem but on my Samsung B2170, I can send files from the laptop to the phone without issue.
But I can not send files to the PC from phone, the phone have a message "access denied"? 10.04 does not have all the features of 12.04, but what it does have works absolutely correctly and as expected.
part of syslog:
.....
May 8 07:13:14 Devet1-PC obex-client[4799]: obex-client daemon 0.44
May 8 07:13:14 Devet1-PC bluetoothd[704]: Mode session 0x7fbc4e624040 with :1.91 activated
May 8 07:13:24 Devet1-PC bluetoothd[704]: Mode session 0x7fbc4e624040 with :1.91 activated
May 8 07:14:24 Devet1-PC modem-manager[698]: <info> (rfcomm0) opening serial port...
May 8 07:14:24 Devet1-PC kernel: [ 3988.023462] Bluetooth: TIOCGSERIAL is not supported!
......

Stephen Zimmerman (szimmer3) wrote :

Having this happen on Xubuntu 12.04 as well -- can transfer files from phone to computer file (drag and drop, you name it), but computer to phone is not happening. 11.04 (what I was on previously) worked.

> touch file.txt
> touch: cannot touch `file.txt': Operation not supported

...culminating in a gvfsd-obexftp SIGSEGV when I try to do a bulk copy (again, computer to phone) from thunar.

Ming Lei (tom-leiming) wrote :

On Thu, May 10, 2012 at 5:14 AM, Stephen Zimmerman
<email address hidden> wrote:
> Having this happen on Xubuntu 12.04 as well -- can transfer files from
> phone to computer file (drag and drop, you name it), but computer to
> phone is not happening. 11.04 (what I was on previously) worked.
>
>> touch file.txt
>> touch: cannot touch `file.txt': Operation not supported
>
> ...culminating in a gvfsd-obexftp SIGSEGV when I try to do a bulk copy
> (again, computer to phone) from thunar.

If so, please submit a new bug report. It is surely that your bug is
not consistent
with this bug title: "Bluetooth 'Send files' returns permission denied error"

>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/872044
>
> Title:
>  Bluetooth 'Send files' returns permission denied error
>
> Status in GNOME Bluetooth:
>  New
> Status in Linaro Ubuntu Evaluation Builds:
>  Confirmed
> Status in Linaro Linux:
>  New
> Status in OEM Priority Project:
>  Fix Released
> Status in OEM Priority Project precise series:
>  New
> Status in “bluez” package in Ubuntu:
>  Invalid
> Status in “linux” package in Ubuntu:
>  Fix Released
> Status in “bluez” source package in Oneiric:
>  Invalid
> Status in “linux” source package in Oneiric:
>  Fix Released
> Status in “obex-data-server” source package in Oneiric:
>  Invalid
> Status in “obexd” source package in Oneiric:
>  Invalid
> Status in “bluez” source package in Precise:
>  Invalid
> Status in “linux” source package in Precise:
>  Fix Released
> Status in “obex-data-server” source package in Precise:
>  Invalid
> Status in “obexd” source package in Precise:
>  Invalid
> Status in “bluez” package in Fedora:
>  Unknown
>
> Bug description:
>  Gnome 3 bluetooth manager cannot send files to my HTC Desire phone,
>  (or any phone that I could try) Gnome2 bluetooth manager would send
>  some form of authorisation request when first sending a file to my
>  phone, which i would accept on the phone and then all future files
>  could be sent with a simple 'accept?' message on the phone, on any
>  gnome3 setup i have tried there is not authorisation request and i
>  believe this is what leads to a permission denied error on screen
>  (video attached)
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.10
>  Package: gnome-bluetooth 3.2.0-0ubuntu1
>  ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
>  Uname: Linux 3.0.0-12-generic x86_64
>  ApportVersion: 1.23-0ubuntu3
>  Architecture: amd64
>  Date: Mon Oct 10 23:23:33 2011
>  ExecutablePath: /usr/bin/bluetooth-applet
>  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111010.1)
>  SourcePackage: gnome-bluetooth
>  UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-bluetooth/+bug/872044/+subscriptions

Download full text (5.1 KiB)

----- Reply message -----
Od: "Ming Lei" <email address hidden>
Datum: so, 5. 12, 2012 08:22
Předmět: [Bug 872044] Re: Bluetooth 'Send files' returns permission denied error
Komu: <email address hidden>

On Thu, May 10, 2012 at 5:14 AM, Stephen Zimmerman
<email address hidden> wrote:
> Having this happen on Xubuntu 12.04 as well -- can transfer files from
> phone to computer file (drag and drop, you name it), but computer to
> phone is not happening. 11.04 (what I was on previously) worked.
>
>> touch file.txt
>> touch: cannot touch `file.txt': Operation not supported
>
> ...culminating in a gvfsd-obexftp SIGSEGV when I try to do a bulk copy
> (again, computer to phone) from thunar.

If so, please submit a new bug report. It is surely that your bug is
not consistent
with this bug title: "Bluetooth 'Send files' returns permission denied error"

>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/872044
>
> Title:
>  Bluetooth 'Send files' returns permission denied error
>
> Status in GNOME Bluetooth:
>  New
> Status in Linaro Ubuntu Evaluation Builds:
>  Confirmed
> Status in Linaro Linux:
>  New
> Status in OEM Priority Project:
>  Fix Released
> Status in OEM Priority Project precise series:
>  New
> Status in “bluez” package in Ubuntu:
>  Invalid
> Status in “linux” package in Ubuntu:
>  Fix Released
> Status in “bluez” source package in Oneiric:
>  Invalid
> Status in “linux” source package in Oneiric:
>  Fix Released
> Status in “obex-data-server” source package in Oneiric:
>  Invalid
> Status in “obexd” source package in Oneiric:
>  Invalid
> Status in “bluez” source package in Precise:
>  Invalid
> Status in “linux” source package in Precise:
>  Fix Released
> Status in “obex-data-server” source package in Precise:
>  Invalid
> Status in “obexd” source package in Precise:
>  Invalid
> Status in “bluez” package in Fedora:
>  Unknown
>
> Bug description:
>  Gnome 3 bluetooth manager cannot send files to my HTC Desire phone,
>  (or any phone that I could try) Gnome2 bluetooth manager would send
>  some form of authorisation request when first sending a file to my
>  phone, which i would accept on the phone and then all future files
>  could be sent with a simple 'accept?' message on the phone, on any
>  gnome3 setup i have tried there is not authorisation request and i
>  believe this is what leads to a permission denied error on screen
>  (video attached)
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.10
>  Package: gnome-bluetooth 3.2.0-0ubuntu1
>  ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
>  Uname: Linux 3.0.0-12-generic x86_64
>  ApportVersion: 1.23-0ubuntu3
>  Architecture: amd64
>  Date: Mon Oct 10 23:23:33 2011
>  ExecutablePath: /usr/bin/bluetooth-applet
>  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111010.1)
>  SourcePackage: gnome-bluetooth
>  UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-bluetooth/+bug/872044/+subscriptions

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.lau...

Read more...

Steve White (stevan-white) wrote :

Here is a work-around:

Again, the Linux bug has something to do with waiting for an acknowlegement prompt on the receiving device.
This still needs to be fixed.

There is a free (as in beer if you watch our ad) Android app called Bluetooth File Transfer (very well done in fact).
With it you can disable the Receiving "security prompt".
That done, files can be transferred from Linux.

(Using this app, one can also turn file browsing on.
Once that is done, in Linux, just re-pair the devices, and voilà, file browsing with Android!)

Stefan Zeyen (stefan-zeyen) wrote :

the bug is back in Ubuntu 12.10
I can send files to my mobile, but i cant't receive files from my mobile

Avinash R (nashpapa) wrote :

Hi,
I just upgraded to 12.04 (Xubuntu) from 11.10, like janitor claim in response #105 (that it is fixed in 3.0.0-19.33), it is apparent that bug is yet to be fixed (or is it a new bug?).

cat /proc/version gives me this output

    Linux version 3.2.0-33-generic (buildd@lamiak) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #52-Ubuntu SMP Thu Oct 18 16:19:45 UTC 2012

I'm not being able to send files ftom computer to mobile. I tried to send through 'blueman-sendto' interface, which failed, so i tried to browse and copy the file to some directory. this crashes the filemanager (thunar).
Previously while using 11.10, there was no problem with bluetooth.I was able to send files vice-versa.
I tried re-pairaing the connection and th output was same.

i hope someone would reply on this matter.

Thanks.

Fathi Boudra (fboudra) on 2013-03-29
Changed in linaro-ubuntu:
status: Confirmed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Linus Walleij (triad) wrote :

Distro issue.

Changed in linux-linaro:
status: New → Won't Fix
Displaying first 40 and last 40 comments. View all 117 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.