MASTER - Font hinting does not honour gnome-settings in Firefox

Bug #379761 reported by mbana
696
This bug affects 151 people
Affects Status Importance Assigned to Milestone
Chromium
Invalid
Undecided
Unassigned
Chromium Browser
Invalid
Undecided
Unassigned
Mozilla Firefox
Fix Released
Medium
firefox (Ubuntu)
High
Chris Coulson
Nominated for Karmic by akashiii
Nominated for Lucid by akashiii

Bug Description

Binary package hint: firefox-3.5

asac, ask that I create a new account and observe if the FF 3.5 uses the gnome appearance settings, it seems that it doesn't.

I set my gnome settings to *hint full*. http://img206.imageshack.us/img206/9426/74100265.png, FF 3.1 (on the right) is hinting correctly. F 3.5 isn't, it seems to be using *hint slight*. Have a look at the gnome taskbar and the FF 3.5 menu bar the renderings clearly aren't the same.

Is the hinting hardcoded somewhere?

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: firefox-3.5 3.5~b4~hg20090330r24021+nobinonly-0ubuntu1
ProcEnviron:
 SHELL=/usr/bin/zsh
 PATH=(custom, user)
 LANG=en_GB.UTF-8
SourcePackage: firefox-3.5
Uname: Linux 2.6.28-11-generic x86_64

Revision history for this message
In , Jeffrey Baker (jwbaker) wrote :

Created attachment 289559
Screenshot

Firefox 3.0 does something differently with on-screen type. This leads to excessive color fringing in some cases. Please see the attached screenshot (which may not make any sense if you don't use an LCD screen). The upper text is from Firefox 2.0 and the lower is from 3.0b1

Revision history for this message
In , Roc-ocallahan (roc-ocallahan) wrote :

Is it different from other GTK/Pango apps on your system?

Revision history for this message
In , Jeffrey Baker (jwbaker) wrote :

Created attachment 289572
Screenshot of native text

Screenshot is the same sentence typed into gedit with the same font, Droid Sans 12.

Revision history for this message
In , Roc-ocallahan (roc-ocallahan) wrote :

Ok, I'm not really sure what's going on here. Michael might be able to help out next week.

Revision history for this message
In , Sylvain Pasche (sylvain-pasche) wrote :

This may be related to the cairo version. I could see differences in rendering between cairo 1.4 (native GTK apps) and the more recent Firefox cairo. See bug 375591 comment 6

Revision history for this message
In , Dylan Grose (dkbg) wrote :

Yes, I can confirm this behaviour as well on Ubuntu Gutsy and Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008022304 Minefield/3.0b4pre. The problem is exactly as described by the bug creator.

Revision history for this message
In , 12345667890gregfdbdfsdbd (12345667890gregfdbdfsdbd-deactivatedaccount-deactivatedaccount) wrote :

I can confirm the same problem on Fedora 9 and Manfield 3.0 beta 4.

Revision history for this message
In , Sylvain Pasche (sylvain-pasche) wrote :

*** Bug 375591 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Sylvain Pasche (sylvain-pasche) wrote :

This is clearly a cairo issue. See:

https://bugs.freedesktop.org/show_bug.cgi?id=10301

Things are actually stalled upstream unfortunately. Ubuntu/Debian users are lucky because their cairo is patched against this bug.

Revision history for this message
In , Sylvain Pasche (sylvain-pasche) wrote :

*** Bug 436760 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Karlt (karlt) wrote :

Changing summary to reflect the current manifestation of this bug.

129 comments hidden view all 149 comments
Revision history for this message
mbana (m.bana) wrote :
130 comments hidden view all 149 comments
Revision history for this message
In , Jürgen 'jiha' Harter (jiha-bugzilla) wrote :

Trying to build SeaMonkey on a ubuntu 9.04 machine. It builds fine when --enable-system-cairo is not set. When setted it does not build.

What cairo libs are needed?

Revision history for this message
In , Sylvain Pasche (sylvain-pasche) wrote :

Look for the CAIRO_VERSION variable in the configure.in file at the top of the source tree. For mozilla-central, that's Cairo 1.6 (http://mxr.mozilla.org/mozilla-central/source/configure.in#122).

If you have building issues, I suggest you comment in the mozilla.dev.builds newsgroup (http://groups.google.com/group/mozilla.dev.builds/topics for the Web interface). You should also provide the complete error message there.

130 comments hidden view all 149 comments
Revision history for this message
tankdriver (stoneraider-deactivatedaccount) wrote :
Revision history for this message
mbana (m.bana) wrote : Re: [Bug 379761] Re: FF 3.5 font hinting

no, that doesn't work i'm afraid.

2009/6/21 tankdriver <email address hidden>

> I can confirm that. (v3.5pre
> https://launchpad.net/~ubuntu-mozilla-daily/+archive/ppa<https://launchpad.net/%7Eubuntu-mozilla-daily/+archive/ppa>
> )
> Here is a workaround: http://ubuntuforums.org/showthread.php?p=7094387
>
> --
> FF 3.5 font hinting
> https://bugs.launchpad.net/bugs/379761
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “firefox-3.5” source package in Ubuntu: New
>
> Bug description:
> Binary package hint: firefox-3.5
>
> asac, ask that I create a new account and observe if the FF 3.5 uses the
> gnome appearance settings, it seems that it doesn't.
>
> I set my gnome settings to *hint full*.
> http://img206.imageshack.us/img206/9426/74100265.png, FF 3.1 (on the
> right) is hinting correctly. F 3.5 isn't, it seems to be using *hint
> slight*. Have a look at the gnome taskbar and the FF 3.5 menu bar the
> renderings clearly aren't the same.
>
> Is the hinting hardcoded somewhere?
>
> ProblemType: Bug
> Architecture: amd64
> DistroRelease: Ubuntu 9.04
> NonfreeKernelModules: nvidia
> Package: firefox-3.5 3.5~b4~hg20090330r24021+nobinonly-0ubuntu1
> ProcEnviron:
> SHELL=/usr/bin/zsh
> PATH=(custom, user)
> LANG=en_GB.UTF-8
> SourcePackage: firefox-3.5
> Uname: Linux 2.6.28-11-generic x86_64
>

Revision history for this message
nanotube (nanotube) wrote : Re: FF 3.5 font hinting

I can confirm that as well.

Revision history for this message
Alexander Sack (asac) wrote :

i think for firefox the gtk way of applying the gnome settings fonts seems to have no effect. e.g. ffox only uses fontconfig.

Changed in firefox-3.5 (Ubuntu):
importance: Undecided → High
status: New → Triaged
Revision history for this message
Vadim Peretokin (vperetokin) wrote :

Confirming the problem and the workaround mentioned solved it.

Revision history for this message
Atlas (earth) wrote :

The workaround did not work for me

Revision history for this message
nanotube (nanotube) wrote :

another workaround has been posted in this thread on ubuntu forums (post #3):
http://ubuntuforums.org/showthread.php?t=1200992
that appears to have positive feedback.

Revision history for this message
Bhaskar Kandiyal (bkandiyal) wrote :

I can confirm the bug and the workarounds mentioned didn't work...

Revision history for this message
Pedro Varela Saraiva (varelasaraiva) wrote :

I installed firefox 3.5 through ubuntuzilla. I can confirm the bug and all the workarounds mentioned either here or at ubuntuforums.org don't work as well. I've been playing with the ~/.fonts.conf hinting setting and I see no difference.

Revision history for this message
Alexander Sack (asac) wrote :

Pedro, dont use ubuntuzilla. They use their own cairo which causes theproblem. the archive packages should at least be much better.

Revision history for this message
Alexander Sack (asac) wrote :

I played a bit around and i cannot reproduce the problem for the builds we provide for karmic. It happens with upstream builds only, which probably happens because of a version mismatch of what mozilla builds-in and what we have on the system. Can you confirm that you dont see any difference comparing ffox menu with other gnome app menus?

Revision history for this message
nanotube (nanotube) wrote :

Alexander: to clarify, ubuntuzilla installs the official mozilla build, so whatever cairo the mozilla guys build with is what gets used. Have you any suggestions how to get proper font hinting when using the mozilla build? Or should this be filed upstream?

Revision history for this message
Bhaskar Kandiyal (bkandiyal) wrote :

Actually, I get this bug even when I compile firefox from source...so, I guess it's not a mozilla build specific bug.

Revision history for this message
Alexander Sack (asac) wrote :

@nanotube: thats only partially correct. upstream build uses system pango and gtk ... both directly use cairo, so you end up having two cairos being used - which from my debugging leads to the moz cairo not seeing the proper XDefaults set by gtk.

@Bhaskar: if you dont explicitly add --enable-system-cairo, then you see the problem the upstream build is experiencing. please check with the packages in archive or daily ppa and let me know if you see it.

summary: - FF 3.5 font hinting
+ FF 3.5 font hinting wrong in content area
Revision history for this message
mbana (m.bana) wrote : Re: [Bug 379761] Re: FF 3.5 font hinting

2009/7/3 Alexander Sack <email address hidden>

> I played a bit around and i cannot reproduce the problem for the builds
> we provide for karmic. It happens with upstream builds only, which
> probably happens because of a version mismatch of what mozilla builds-in
> and what we have on the system. Can you confirm that you dont see any
> difference comparing ffox menu with other gnome app menus?

the menu in ff 3.5 has the same rendering as the desktop apps, it's only the
content of the page that seems to use a different rendering. can others
confirm?

>
>
> --
> FF 3.5 font hinting
> https://bugs.launchpad.net/bugs/379761
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “firefox-3.5” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: firefox-3.5
>
> asac, ask that I create a new account and observe if the FF 3.5 uses the
> gnome appearance settings, it seems that it doesn't.
>
> I set my gnome settings to *hint full*.
> http://img206.imageshack.us/img206/9426/74100265.png, FF 3.1 (on the
> right) is hinting correctly. F 3.5 isn't, it seems to be using *hint
> slight*. Have a look at the gnome taskbar and the FF 3.5 menu bar the
> renderings clearly aren't the same.
>
> Is the hinting hardcoded somewhere?
>
> ProblemType: Bug
> Architecture: amd64
> DistroRelease: Ubuntu 9.04
> NonfreeKernelModules: nvidia
> Package: firefox-3.5 3.5~b4~hg20090330r24021+nobinonly-0ubuntu1
> ProcEnviron:
> SHELL=/usr/bin/zsh
> PATH=(custom, user)
> LANG=en_GB.UTF-8
> SourcePackage: firefox-3.5
> Uname: Linux 2.6.28-11-generic x86_64
>

Revision history for this message
Alexander Sack (asac) wrote : Re: FF 3.5 font hinting

@nanotube: ... and yes, file a bug upstream (from what i understand its not the bug mbana has filed this bug for - I adjusted the title accordingly). If you want, file a new bug here too, where we can link the bugzilla bug to and track the progress.

Revision history for this message
mbana (m.bana) wrote : Re: [Bug 379761] Re: FF 3.5 font hinting

seems to work in FF 3.0.

2009/7/3 Alexander Sack <email address hidden>

> @nanotube: ... and yes, file a bug upstream (from what i understand its
> not the bug mbana has filed this bug for - I adjusted the title
> accordingly). If you want, file a new bug here too, where we can link
> the bugzilla bug to and track the progress.
>
> --
> FF 3.5 font hinting wrong in content area
> https://bugs.launchpad.net/bugs/379761
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “firefox-3.5” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: firefox-3.5
>
> asac, ask that I create a new account and observe if the FF 3.5 uses the
> gnome appearance settings, it seems that it doesn't.
>
> I set my gnome settings to *hint full*.
> http://img206.imageshack.us/img206/9426/74100265.png, FF 3.1 (on the
> right) is hinting correctly. F 3.5 isn't, it seems to be using *hint
> slight*. Have a look at the gnome taskbar and the FF 3.5 menu bar the
> renderings clearly aren't the same.
>
> Is the hinting hardcoded somewhere?
>
> ProblemType: Bug
> Architecture: amd64
> DistroRelease: Ubuntu 9.04
> NonfreeKernelModules: nvidia
> Package: firefox-3.5 3.5~b4~hg20090330r24021+nobinonly-0ubuntu1
> ProcEnviron:
> SHELL=/usr/bin/zsh
> PATH=(custom, user)
> LANG=en_GB.UTF-8
> SourcePackage: firefox-3.5
> Uname: Linux 2.6.28-11-generic x86_64
>

Revision history for this message
mbana (m.bana) wrote :

screenshot attached.

url: http://en.wikipedia.org/wiki/Memoization

pango-view -t "avoid repeated calculations - 3.5" --backend=xft
--font="Tahoma 11"

pango-view -t "avoid repeating calculations - 3.0" --backend=cairo
--font="Tahoma 11"

Revision history for this message
mbana (m.bana) wrote : Re: [Bug 379761] Re: FF 3.5 font hinting

screenshot attached.

url: http://en.wikipedia.org/wiki/Memoization

pango-view -t "avoid repeated calculations - 3.5" --backend=xft
--font="Tahoma 11"

pango-view -t "avoid repeating calculations - 3.0" --backend=cairo
--font="Tahoma 11"

2009/7/3 Mohamed Bana <email address hidden>

> seems to work in FF 3.0.
>
> 2009/7/3 Alexander Sack <email address hidden>
>
>> @nanotube: ... and yes, file a bug upstream (from what i understand its
>>
>> not the bug mbana has filed this bug for - I adjusted the title
>> accordingly). If you want, file a new bug here too, where we can link
>> the bugzilla bug to and track the progress.
>>
>> --
>> FF 3.5 font hinting wrong in content area
>> https://bugs.launchpad.net/bugs/379761
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>> Status in “firefox-3.5” package in Ubuntu: Triaged
>>
>> Bug description:
>> Binary package hint: firefox-3.5
>>
>> asac, ask that I create a new account and observe if the FF 3.5 uses the
>> gnome appearance settings, it seems that it doesn't.
>>
>> I set my gnome settings to *hint full*.
>> http://img206.imageshack.us/img206/9426/74100265.png, FF 3.1 (on the
>> right) is hinting correctly. F 3.5 isn't, it seems to be using *hint
>> slight*. Have a look at the gnome taskbar and the FF 3.5 menu bar the
>> renderings clearly aren't the same.
>>
>> Is the hinting hardcoded somewhere?
>>
>> ProblemType: Bug
>> Architecture: amd64
>> DistroRelease: Ubuntu 9.04
>> NonfreeKernelModules: nvidia
>> Package: firefox-3.5 3.5~b4~hg20090330r24021+nobinonly-0ubuntu1
>> ProcEnviron:
>> SHELL=/usr/bin/zsh
>> PATH=(custom, user)
>> LANG=en_GB.UTF-8
>> SourcePackage: firefox-3.5
>> Uname: Linux 2.6.28-11-generic x86_64
>>
>
>

Revision history for this message
Bhaskar Kandiyal (bkandiyal) wrote : Re: FF 3.5 font hinting wrong in content area

@Alexander: Yes, I've added the --enable-system-cairo option, and I've also checked with the archives and daily ppa, as you suggested, but the problem is still there.

And also, the menu is also different than other gnome apps. I've added a screenshot.

Revision history for this message
bgcommon (bgcommon) wrote :

I am using jaunty 32 bit. The workaround posted on this thread on ubuntu forums (post #3):
http://ubuntuforums.org/showthread.php?t=1200992 worked for me.

Revision history for this message
Jiří Zárevúcky (zarevucky-jiri) wrote :

Jaunty x64 here. Same problem. The .font.conf workaround worked.

Revision history for this message
Alan Trick (trick) wrote :

The .font.conf made everything consistent for me, but it was all consistently bad :-/

Alexander Sack (asac)
summary: - FF 3.5 font hinting wrong in content area
+ MASTER - FF 3.5 font hinting does not honour gnome-settings
Revision history for this message
Jamie Strandboge (jdstrand) wrote : Re: MASTER - FF 3.5 font hinting does not honour gnome-settings

I'm seeing this with 3.5.2+nobinonly-0ubuntu2 on karmic as well.

Revision history for this message
StarShock (sshock3) wrote :

I'm seeing this with 3.5.2+nobinonly-0ubuntu0.9.04.1 as well. Workarounds helped but bold fonts are still too dark and ugly. Menu is fine and matches other desktop apps; it's just the content area that is messed up.

See the screenshots in my post here: http://ubuntuforums.org/showthread.php?p=7805114#post7805114

Revision history for this message
StarShock (sshock3) wrote :

Oops, my problem may be something different. As explained in my next post in that thread, the difference I am seeing actually has to do with a text-shadow being applied (which FF 3.0 doesn't support). So the text actually IS supposed to be darker (but I still don't think that should make it jaggedy).

Revision history for this message
Matthew Woerly (nattgew) wrote :

Using Karmic same problem, the following workaround fixed it for me:

sudo rm /etc/fonts/conf.d/10*
sudo dpkg-reconfigure fontconfig

(from http://ubuntuforums.org/showpost.php?p=7634222&postcount=12)
The next post claimed that it messed up their Opera fonts... but I think I used the same workaround in Jaunty without any issues.

Revision history for this message
ktalinu (ktalinu) wrote :

I just create a symlink for 10-hinting-full.conf and removed 10-hinting-slight.conf on my laptop. Of course, full hinting is my selected option in Appearance Preferences -> Font Rendering Details.

Revision history for this message
Laryllan (laryllan) wrote :

i think the gnome font settings should change all fonts in the system, not only the ones used by gnome.

Revision history for this message
Nick Rhodes (ngrhodes) wrote :

I also have the same problem in Karmic, see screenshot.

Revision history for this message
Ian Hutchinson (ianhutchinson) wrote :

Getting this problem on the Karmic beta, but using the two commands suggested by Nattgew, sorted the problem out and Firefox 3.5 is using the same hinting as the rest of Ubuntu

Revision history for this message
Krzysztof Kosinski (tweenk) wrote :

The apparent culprit is /etc/fonts/conf.d/10-hinting-slight.conf from the binary package fontconfig-config (source package fontconfig); Firefox uses the settings from this file instead of using the desktop's settings. Removing that file brings back the correct behavior (hinting matches desktop). I'm not sure whether this is a bug in Firefox or Fontconfig because other programs do not show this behavior.

Revision history for this message
capricorn (ubuntuuser82) wrote :

Very annoying ideed. Well, that means I still have to tell a newbie to go to the commandline to configure their system, i.e. have their fonts displayed correctly in FF. Same thing happens when installing kde applications in gnome.

So, maybe gnome font settings should -- because they cannot set font hinting for all users in /etc/fonts/conf.d/ -- still write a .fonts.conf in the user directory for those applications that need it?

Revision history for this message
nexus (bugie) wrote :

You could tell them that they have a stable system at the cost of not having latest software versions. ;-)

Or you could tell them that they could download the font.conf from this site: http://blog.bugie.de/?p=312 (german blog) and save that file to their home directory.

Revision history for this message
Ignacio Huerta (iox8) wrote :

Removing /etc/fonts/conf.d/10-hinting-slight.conf (I renamed it) solved the problem in Karmic beta.

Revision history for this message
Artur Rona (ari-tczew) wrote :

@iox, comment 36,
Solving problem for me, thanks!

Revision history for this message
dhenry (tfc-duke) wrote :

Will it be fixed for Karmic release? It's a problem many people will suffer, and many of them may not want to look around the web for a hack fixing the issue.

Revision history for this message
Gannin (spacesword) wrote :

This is another one of those usability issues that smacks users right in the face, and yet it's persisted across multiple versions of Ubuntu. I'm surprised this hasn't been polished by now.

Revision history for this message
Krzysztof Kosinski (tweenk) wrote :

Gannin, please don't troll - this issue is present only in Karmic.

93 comments hidden view all 149 comments
Revision history for this message
In , Serenity-katz (serenity-katz) wrote :

I was going to submit for a new bug, but this is exactly the same thing here. Xft and Cairo color fringing has been a long standing problem, and David Turner (you know, Mr. Freetype) wrote a patch addressing it loooong time ago. Somehow the Freedesktop.org people just wouldn't accept it, then again they don't always make the best decisions when it comes to font rendering. However, since Mozilla by default uses embedded libcairo, I really don't see any reason the patch can't be applied when building. Turner patches can be found on his site at freetype:

http://david.freetype.org/lcd/

which will not work for current versions of Cairo now, but there's the ubuntu patch derived from it:

http://archive.ubuntu.com/ubuntu/pool/main/c/cairo/cairo_1.8.6-1ubuntu2.diff.gz

I also have my own version adapted from Turner's original patch that applies cleanly against cairo 1.8.* -- which is the sole reason I build Firefox from source on my laptop. It would be great if Mozilla can just apply this patch when building release binaries, as it would save a lot of eyesore for users.

Revision history for this message
In , Mozilla-behdad (mozilla-behdad) wrote :

Ubuntu patches cairo and fontconfig to use the newer FreeType subpixel filters, whereas upstream cairo doesn't (yet). The whole thing is very controversial since those filters are suspected to infringe patents in the US...

So, that's where the discrepancy comes from...

Revision history for this message
In , Ken-adcstudio (ken-adcstudio) wrote :

Please see Bug 512136 (https://bugzilla.mozilla.org/show_bug.cgi?id=512136)
for windows possible related bug, with a test for windows vista/7 with cleartype https://bug363861.bugzilla.mozilla.org/attachment.cgi?id=321706

Revision history for this message
In , Sylvain Pasche (sylvain-pasche) wrote :

(In reply to comment #15)
> Please see Bug 512136 (https://bugzilla.mozilla.org/show_bug.cgi?id=512136)
> for windows possible related bug, with a test for windows vista/7 with
> cleartype https://bug363861.bugzilla.mozilla.org/attachment.cgi?id=321706

That's bug 363861, which isn't related to this one.

Revision history for this message
In , Serenity-katz (serenity-katz) wrote :

> ... The whole thing is very controversial
> since those filters are suspected to infringe patents in the US...

But the specific patch mentioned doesn't directly do anything about glyphs. It only enables lcdfilter options if it's _already compiled_ into the system's FreeType libs; that is, any patent issue would lie not in cairo, but in the freetype binaries because the distribution or the user chose to enable patented features, so it shouldn't be a problem for Mozilla source to include that patch. Am I misunderstanding the situation here?

Revision history for this message
In , Mozilla-behdad (mozilla-behdad) wrote :

Can you require a freetype new enough to have that API? (I think they were introduced in 2.3.0). Or doing dlopen tricks again?

Revision history for this message
In , Serenity-katz (serenity-katz) wrote :

> Can you require a freetype new enough to have that API? (I think they were
> introduced in 2.3.0). Or doing dlopen tricks again?

Turner's first lcd patch was for cairo-1.0.4, which was what, 3 years ago? The patch I use was originally for cairo-1.2.4, also ancient. I'd think the lib version is a non-issue here.

Revision history for this message
In , Mozilla-behdad (mozilla-behdad) wrote :

However, I think it is, if the base system is still RHEL5.

Revision history for this message
In , Serenity-katz (serenity-katz) wrote :

RHEL5 itself has Cairo > 1.2.4 already, why would it be a problem?

Revision history for this message
In , Mozilla-behdad (mozilla-behdad) wrote :

I'm talking about FreeType version. Cairo doesn't matter since Mozilla ships its own cairo.

Revision history for this message
In , Serenity-katz (serenity-katz) wrote :

I meant to say, if the cairo version is recent enough, freetype is probably ok--which was not true. I compiled freetype-2.2.1 (that's what RHEL5 has I think), and patched cairo fails when linking against it. Bummer.

Revision history for this message
In , Mozilla-bugs-micahscomputing (mozilla-bugs-micahscomputing) wrote :

*** Bug 541319 has been marked as a duplicate of this bug. ***

Micah Gersten (micahg)
Changed in firefox (Ubuntu):
importance: Undecided → High
status: New → Triaged
Micah Gersten (micahg)
Changed in firefox (Ubuntu):
milestone: none → ubuntu-10.04-beta-1
Changed in firefox-3.5 (Ubuntu):
status: Triaged → Won't Fix
Micah Gersten (micahg)
Changed in firefox (Ubuntu):
milestone: ubuntu-10.04-beta-1 → none
Benjamin Drung (bdrung)
Changed in firefox (Ubuntu):
status: Triaged → Fix Released
Changed in firefox:
status: Unknown → Confirmed
summary: - MASTER - FF 3.5 font hinting does not honour gnome-settings
+ MASTER - Font hinting does not honour gnome-settings in Firefox
34 comments hidden view all 149 comments
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

This is still an issue, so it shouldn't really be closed. I've been investigating this for the last few days, and can see why Firefox is doing this now

Changed in firefox (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
status: Fix Released → Triaged
Revision history for this message
Chris Coulson (chrisccoulson) wrote :

Can we please not mix multiple products on the same bug. This bug is about font configuration in firefox rather than chromium (without investigating in depth, it might be a completely unrelated issue in chromium)

Changed in chromium:
importance: Unknown → Undecided
status: Unknown → New
Changed in chromium-browser:
importance: Unknown → Undecided
status: Unknown → New
Changed in chromium:
status: New → Invalid
Changed in chromium-browser:
status: New → Invalid
Revision history for this message
Louis Simard (louis-simard-deactivatedaccount) wrote :

In Firefox 3.6.6 Lucid 32-bit, the workaround from this thread worked: http://ubuntuforums.org/showthread.php?t=1128929&page=5

> In a previous page of this thread, amn108 wrote:
>
> Funny i just removed all /etc/files/conf.d/10-* and after that
> "dpkg-reconfigure fontconfig" and Firefox 3.5 started to obey
> my Gnome text rendering ways. That is all it took.

I have my GNOME font options set to No hinting + Grayscale antialiasing, and the defaults in /etc/fonts/conf.d say hinting-slight.

Just my 2 cents.

33 comments hidden view all 149 comments
Revision history for this message
In , Karlt (karlt) wrote :

*** Bug 581715 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Karlt (karlt) wrote :

*** Bug 590864 has been marked as a duplicate of this bug. ***

Changed in firefox:
importance: Unknown → Medium
33 comments hidden view all 149 comments
Revision history for this message
Suraj N. Kurapati (sunaku) wrote :

I am using Firefox 3.6.10 in Ubuntu Maverick 10.10 Beta. I was able to solve[1] this problem by adjusting the files in /etc/fonts/conf.d/ to reflect my GNOME font settings (in my case, I use full hinting):

cd /etc/fonts/conf.d/
sudo rm 10-hinting-slight.conf
sudo ln -s ../conf.avail/10-hinting-full.conf
sudo dpkg-reconfigure fontconfig

[1] http://www.ubuntu-inside.me/2009/07/howto-fix-firefox-35s-font-hinting.html

Revision history for this message
Patrick Gillespie (vermontpoet) wrote :

I seem to be having the same issues. Not sure. None of the solutions (offered above or at the Ubuntu Forum) have worked for me. I'm using 10.10 (RC AMD64) with Firefox 3.6.10. The problem also affects Thunderbird, predictably enough. The new Ubuntu font renders correctly in everything *but* Mozilla's software (so far). It appears "spindly" (as if it needed to be bolded). Other Fonts exhibit the same behaviour. One exceptions so far - Britannica Unicode Sans Roman renders correctly in the Desktop *and* Firefox.

Revision history for this message
Leo (llenchikk) wrote :

Solution in comment #28 help for me.
I setup fonts in appearance settings and then make

sudo rm /etc/fonts/conf.d/10*
sudo dpkg-reconfigure fontconfig

Fonts in qt-based packages looks like in other gtk packages.
Ubuntu 10.10 amd64.

Revision history for this message
Avery (docaltmed) wrote :

Confirm continued existence of this problem in Lucid.

None of the fixes suggested above worked.

Revision history for this message
sprt (sprt) wrote :

I'm using no hinting and it's impossible to exactly match Chrome's fonts.
Will this be ever fixed?

Revision history for this message
Bachsau (bachsau) wrote :

I can confirm #28 still works. Maybe these files should be removed from ubuntu. Please fix, it's getting on my nerves.

Revision history for this message
In , Bas-schouten (bas-schouten) wrote :

Karl, what's the status of this bug?

Revision history for this message
In , Karlt (karlt) wrote :

*** This bug has been marked as a duplicate of bug 404637 ***

27 comments hidden view all 149 comments
Revision history for this message
In , Karlt (karlt) wrote :

*** Bug 541319 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Karlt (karlt) wrote :

I think this should be fixed now, as of Bug 660448 landing, though most of the fix was in Bug 562746.

Changed in firefox:
status: Confirmed → Invalid
Changed in firefox:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in firefox:
importance: Unknown → Medium
status: Unknown → Fix Released
Adolfo Jayme (fitojb)
no longer affects: firefox-3.5 (Ubuntu)
Adolfo Jayme (fitojb)
no longer affects: fontconfig (Ubuntu)
Changed in firefox (Ubuntu):
status: Triaged → Fix Released
Displaying first 40 and last 40 comments. View all 149 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.