Problems with the icon of the "computer" implemented in the dock

Reported by Samuel on 2009-11-23
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Docky
Low
Jason Smith
docky (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Today 23 November update my Docky to Review 596 and noticed that the icon "Computer" (Nautilus) was always red and I mean, as the icon to indicate that the Nautilus had opened, but in this case is not.

Samuel (samuel-ss) wrote :
Samuel (samuel-ss) wrote :

When I run another window on the desktop this error disappears.

Robert Dyer (psybers) wrote :

How did you add that icon to your dock?

Changed in docky:
importance: Undecided → Low
assignee: nobody → Jason Smith (jassmith)
status: New → Incomplete
Robert Dyer (psybers) wrote :

Nevermind, I managed to reproduce this. Also note that its marking that item as active only when the Desktop has focus. :-)

Changed in docky:
status: Incomplete → Confirmed
Robert Dyer (psybers) wrote :

This is the exec line from the nautilus-computer.desktop file:

Exec=nautilus --no-desktop computer:

We are parsing this to match any 'nautilus' window. If *any* nautilus widow has focus (including the desktop) this item is currently marked as active.

I thing this is some Nautilus related issue, same i had in GNOME-Do on Jaunty. Also affects default Nautils File Browser launcher which is not working.

When i drag to Docky from applicaton menu launcher for "File Browser" - this launcher is not working. It should simply open Nautilus window like it works through that menu. After that, when i open manually Nautilus and close it, that non-working launcher in Docky stays highlighted, like it's open..

Tyler R (trowe) wrote :

Sorry, created a duplicate bug (https://bugs.launchpad.net/docky/+bug/570767), didn't see this.

@Robert: I assume when no other app is running that means the desktop has the focus. Interesting that the icon doesn't show an indicator dot if the desktop is considered Nautilus (a la Finder in OS X)

Robert Dyer (psybers) wrote :

This problem seems to be fixed.

Changed in docky:
status: Confirmed → Fix Committed
Tyler R (trowe) wrote :

Which version will this be fixed in? It still occurs in the latest I have.

Robert Dyer (psybers) wrote :

I tested it with bzr trunk and it is fixed. I used to be able to reproduce it, now I can't.

Tyler R (trowe) wrote :

I can still reproduce in bzr r1397

Robert Dyer (psybers) wrote :

You're right. I was testing with the wrong settings (which don't show this bug). It is now fixed in rev 1401.

Tyler R (trowe) wrote :

Confirmed fixed in 1406. Thanks!

BTW, wouldn't be the first time, but did I miss something? python-docky no longer needed? I had to uninstall it to get docky to upgrade.

Robert Dyer (psybers) on 2010-06-02
Changed in docky:
milestone: none → 2.0.5
Changed in docky:
status: Fix Committed → Fix Released
summary: - Problems with the icon of the "computer" implemented in the dock
+ debdiff which fixes this is attached to bug #579049
summary: - debdiff which fixes this is attached to bug #579049
+ Problems with the icon of the "computer" implemented in the dock
Rico Tzschichholz (ricotz) wrote :

debdiff which fixes this is attached to bug #579049

Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package docky - 2.0.5-1

---------------
docky (2.0.5-1) unstable; urgency=low

  * New upstream release 2.0.5 "Be proud of your dock",
    changes include:
    + remove --debug flag from launcher for lower memory usage
    + update the about dialog credits to list documenters and make translation
      tab easier to read
    + change url in about dialog to the launchpad project page
    + Window-Matching
      - fix for applications commandline
      - properly match qt creator (LP: #594814)
      - prefer local over global launchers (LP: #588073) (LP: #592841)
      - match prefix for gksudo (LP: #516433)
      - fix nautilus items showing active indicator when desktop
        is focused (LP: #487113)
      - fix matching wine apps that use a prefixed launcher (LP: #596092)
    + Memory Leaks
      - dispose of calendar painter when the clock item is disposed
      - fix leak in AutoHideManager
      - several fixes using Cairo.Context.Target and Pango.Layout
      - fix leak in PagingPainters
      - fix leak in recursive file-deletion
      - fix leaking SeparatorItems, WnckDockItems
      - fix leaks with FileEmblems
      - fix Pixbuf related leaks
      - fix some leaks regarding FileMonitors
      - fix leaks regarding Tiles and AbtractTileObjects
      - fix leaking Glib.FileAdapter caused by unreferenced Action in
        FileDockItem
    + Handle invalid desktopfile entry and UriFormatException in
      FileApplicationProvider (LP: #595921)
    + fix potential crash for invalid HelperMetadata
    + handle drops correctly
    + fix handling of Helpers in HelperService
    + make the sliders in preferences behave better
    + fix drawing of rotated items
    + fix HoveredItem click-position
    + avoids fatal errors on console when loading embedded icons when no
      height or width is specified and when dock items have a null Icon
    + fix icon theme change not refreshing the dock icons (LP: #590205)
    + fix SVG rendering bug
    + fix iconsize temporarily getting large when adding to full dock
      (LP: #579576)
    + fix the 'crash in PinToDock' (LP: #588073)
    + make 3d background height more consistent and a tad larger (LP: #503038)
    + fix dragging multiple files to a folder on the dock, which caused
      a crash and data corruption (LP: #579049)
    + don't request animations if urgent state is removed from a window and
      fix glow location (LP: #596422)
    + fix window previews being offset (LP: #495065)
    + fix broken zoom after shrinking icon size (LP: #598924)
    + fix problem with hovers still visible when painters show
    + fix displaying default icon in place of missing file emblem (LP: #534651)
    + fix crash when gconf key for menus_have_icons is not set (LP: #573751)
    + make sure painters fit on screen (LP: #589978)
    + fix icon minimize animations not working immediately for some newly
      opened windows
    + don't dispose our static DockyItem
    + fix CurrentDesktopOnly not working when dragging a window across desktops
      (LP: #600290)
    + GMail:
      - fix thread-guards and remove deprecated code
      - fix problem with feeds that don't have a...

Read more...

Changed in docky (Ubuntu):
status: New → Fix Released

Accepted docky into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in docky (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (3.9 KiB)

This bug was fixed in the package docky - 2.0.5-0ubuntu1

---------------
docky (2.0.5-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release 2.0.5 "Be proud of your dock",
    changes include:
    + remove --debug flag from launcher for lower memory usage
    + update the about dialog credits to list documenters and make translation
      tab easier to read
    + change url in about dialog to the launchpad project page
    + Window-Matching
      - fix for applications commandline
      - properly match qt creator (LP: #594814)
      - prefer local over global launchers (LP: #588073) (LP: #592841)
      - match prefix for gksudo (LP: #516433)
      - fix nautilus items showing active indicator when desktop
        is focused (LP: #487113)
      - fix matching wine apps that use a prefixed launcher (LP: #596092)
    + Memory Leaks
      - dispose of calendar painter when the clock item is disposed
      - fix leak in AutoHideManager
      - several fixes using Cairo.Context.Target and Pango.Layout
      - fix leak in PagingPainters
      - fix leak in recursive file-deletion
      - fix leaking SeparatorItems, WnckDockItems
      - fix leaks with FileEmblems
      - fix Pixbuf related leaks
      - fix some leaks regarding FileMonitors
      - fix leaks regarding Tiles and AbtractTileObjects
      - fix leaking Glib.FileAdapter caused by unreferenced Action in
        FileDockItem
    + Handle invalid desktopfile entry and UriFormatException in
      FileApplicationProvider (LP: #595921)
    + fix potential crash for invalid HelperMetadata
    + handle drops correctly
    + fix handling of Helpers in HelperService
    + make the sliders in preferences behave better
    + fix drawing of rotated items
    + fix HoveredItem click-position
    + avoids fatal errors on console when loading embedded icons when no
      height or width is specified and when dock items have a null Icon
    + fix icon theme change not refreshing the dock icons (LP: #590205)
    + fix SVG rendering bug
    + fix iconsize temporarily getting large when adding to full dock
      (LP: #579576)
    + fix the 'crash in PinToDock' (LP: #588073)
    + make 3d background height more consistent and a tad larger (LP: #503038)
    + fix dragging multiple files to a folder on the dock, which caused
      a crash and data corruption (LP: #579049)
    + don't request animations if urgent state is removed from a window and
      fix glow location (LP: #596422)
    + fix window previews being offset (LP: #495065)
    + fix broken zoom after shrinking icon size (LP: #598924)
    + fix problem with hovers still visible when painters show
    + fix displaying default icon in place of missing file emblem (LP: #534651)
    + fix crash when gconf key for menus_have_icons is not set (LP: #573751)
    + make sure painters fit on screen (LP: #589978)
    + fix icon minimize animations not working immediately for some newly
      opened windows
    + don't dispose our static DockyItem
    + fix CurrentDesktopOnly not working when dragging a window across desktops
      (LP: #600290)
    + GMail:
      - fix thread-guards and remove deprecated code
      - fix problem with feeds that do...

Read more...

Changed in docky (Ubuntu Lucid):
status: Fix Committed → Fix Released
splashis (splashote) wrote :

In my case Nautilus is displayed as the CD-DVD-Creator. Is it supposed to be a duplicate of this but?

If it is, it is not fixed as I'm using 2.1.0~bzr1659-0ubuntu1~10.04~dockycore.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers