Ships malformed interactive upgrade hook which causes translations to be shown in the dialog

Bug #993672 reported by Jonathan Thomas on 2012-05-03
198
This bug affects 47 people
Affects Status Importance Assigned to Milestone
intltool (Debian)
New
Unknown
intltool (Ubuntu)
Medium
Unassigned
Precise
Undecided
Unassigned
Quantal
Medium
Unassigned
Raring
Undecided
Unassigned
intltool-debian (Debian)
New
Unknown
intltool-debian (Ubuntu)
Medium
Unassigned
Precise
Undecided
Unassigned
Quantal
Medium
Unassigned
Raring
Undecided
Unassigned
update-notifier (Ubuntu)
High
Canonical Foundations Team
Precise
High
Canonical Foundations Team
Quantal
High
Canonical Foundations Team
Raring
Undecided
Unassigned

Bug Description

[Impact]
The package-data-downloads-failed and package-data-downloads-failed-permanently interactive upgrade hooks shipped with update-notifier-common are malformed. In each file, the internationalized Name fields of every supported language are scrunched up in to one line. This breaks the Kubuntu upgrade hook notifier, making the window extremely large.(So large that the window refuses to paint and becomes a black rectangle.)

[Test case]
1. Run sudo cp /usr/share/update-notifier/package-data-downloads-failed /var/lib/update-notifier/user.d/
2. Verify that the notification which appears is malformed
3. Upgrade to the update-notifier-common package from precise-proposed
4. Run the command from step 1 again
5. Verify that the notification which appears is correctly formed, and in your configured language

Changed in update-notifier (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in update-notifier (Ubuntu):
milestone: none → precise-updates
zub (zub-linux) wrote :

I assume this is the cause of the horrible display of an error message I see in Ubuntu. - See the attached screenshot.
(The actual source of the error displayed is #977178, but thats not important here.)

Jonathan Thomas (echidnaman) wrote :

That would be correct.

Changed in update-notifier (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Steve Langasek (vorlon) on 2012-05-14
summary: - Ships malformed interactive upgrade hook
+ Ships malformed interactive upgrade hook which causes translations to be
+ shown in the dialog
Steve Langasek (vorlon) on 2012-05-14
Changed in update-notifier (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Canonical Foundations Team (canonical-foundations)
milestone: none → precise-updates
milestone: precise-updates → ubuntu-12.04.1
Changed in update-notifier (Ubuntu Quantal):
milestone: precise-updates → none
Steve Langasek (vorlon) wrote :

Sorry, I had noticed this issue originally when preparing the package-data-downloader support, but couldn't work out why the file was being generated wrong. Since there were no translations available at the time, I postponed dealing with it until after the upload... but apparently a bunch of translations showed up in the meantime.

We definitely should get this fixed for .1.

Steve Langasek (vorlon) wrote :

It turns out this is a bug in intltool-merge, which doesn't behave correctly when using rfc822deb merging for a file whose very first field requires translation handling.

Easy enough to work around in update-notifier by reordering the fields, so I've committed a fix to do that; but the root bug ought to be fixed as well.

Changed in intltool (Ubuntu Precise):
status: New → Won't Fix
Changed in intltool (Ubuntu Quantal):
status: New → Triaged
importance: Undecided → Medium
Steve Langasek (vorlon) wrote :

intltool-debian includes a copy of the intltool-merge script with the same bug.

Changed in intltool-debian (Ubuntu Quantal):
status: New → Triaged
Changed in intltool-debian (Ubuntu Precise):
status: New → Won't Fix
Changed in intltool-debian (Ubuntu Quantal):
importance: Undecided → Medium
Steve Langasek (vorlon) on 2012-05-14
Changed in update-notifier (Ubuntu Quantal):
status: Triaged → Fix Committed

BTW: Bug description suxx!!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-notifier - 0.119ubuntu9

---------------
update-notifier (0.119ubuntu9) quantal; urgency=low

  * fix data/Makefile.am to clean up all generated files.
  * fix wrong intltool-merge invocation.
  * data/package-data-downloads-failed{,-permanently}.in: work around a bug in
    intltool-merge rfc822deb handling that causes wrong syntax when the first
    line in the file is a translated field. LP: #993672.
  * use po2debconf instead of the upstream intltool-merge, since the latter
    doesn't actually handle multi-paragraph description fields correctly.
  * Fix package-data-downloader to do a correct timestamp comparison. Thanks
    to Loïc Minier for catching this. LP: #986183.
  * data/package-data-downloads-failed.in: use pkexec instead of gksudo, for
    compatibility with Kubuntu. Thanks to Jonathan Thomas for pointing out
    the correct fix. LP: #982032.
 -- Steve Langasek <email address hidden> Tue, 15 May 2012 16:16:08 -0700

Changed in update-notifier (Ubuntu Quantal):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) on 2012-05-15
description: updated
Changed in update-notifier (Ubuntu Precise):
status: Triaged → In Progress
Changed in intltool-debian (Debian):
status: Unknown → New
Changed in intltool (Debian):
status: Unknown → New

Hello Jonathan, or anyone else affected,

Accepted update-notifier into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in update-notifier (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Jonathan Thomas (echidnaman) wrote :

I can confirm that the testcase provides the predicted results with the updated update-notifier-common package with an en_US configuration.

tags: added: verification-done
removed: verification-needed
Steve Langasek (vorlon) wrote :

verification failed due to bug #1003100.

tags: added: verification-failed
removed: verification-done
Steve Langasek (vorlon) wrote :

Bug #1003100 shows that the test case for this bug was flawed; it tested that the file was a valid translated desktop file, but did not test that the file could be post-parsed by the python code.

A more complete test case would require installing a hook in /usr/share/package-data-downloads/ that fails. But in this case, I think it's sufficient to get confirmation that the package fixes bug #1003100 for the submitter.

Steve Langasek (vorlon) wrote :

marking verification-done now that the new SRU is uploaded.

tags: added: verification-done
removed: verification-failed
axel (axel334) wrote :

I reported bug 1001396 concerning System Notification Helper in Kubuntu 12.04, which was marked as a duplicate of this one. I see that for Precise fix was committed. I updated to KDE 4.8.3 but the bug 1001396 - this yellow bulb crash - is still valid on my system. Is the fix going to be released to regular Kubuntu updates or I need to add / enable additional repository?

Badcam (kiwicameron+launchpad) wrote :

(Sorry. this has also been posted in Bug #1005934 - I didn't know how to remove it )

I can confirm this. Attached is a screenshot.

http://i.imgur.com/vXOJJ.png

You can actually see what this box says if you drag the black window (I had to resize it first) to another desktop.

This is what it is:

http://i.imgur.com/9Vpzf.png

Not ethe "Run this action" icon below. Which isn't in the prior posters screenshot.

Clicking "Run this action" brings up a terminal box with an error, and then I get a strange cursor and can't use the mouse anymore. I had to Ctrl-Alt-Backspace.

http://i.imgur.com/eLyTo.png

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-notifier - 0.119ubuntu8.4

---------------
update-notifier (0.119ubuntu8.4) precise-proposed; urgency=low

  * Rebuild the source package with complete autotools support.

update-notifier (0.119ubuntu8.3) precise-proposed; urgency=low

  * po/*.po: the string '$packages' must not be translated, but we currently
    have no way to mark the string as such in the input files. LP: #1003100.

update-notifier (0.119ubuntu8.2) precise-proposed; urgency=low

  * fix data/Makefile.am to clean up all generated files.
  * fix wrong intltool-merge invocation.
  * data/package-data-downloads-failed{,-permanently}.in: work around a bug in
    intltool-merge rfc822deb handling that causes wrong syntax when the first
    line in the file is a translated field. LP: #993672.
  * use po2debconf instead of the upstream intltool-merge, since the latter
    doesn't actually handle multi-paragraph description fields correctly.
  * Fix package-data-downloader to do a correct timestamp comparison. Thanks
    to Loïc Minier for catching this. LP: #986183.
  * data/package-data-downloads-failed.in: use pkexec instead of gksudo, for
    compatibility with Kubuntu. Thanks to Jonathan Thomas for pointing out
    the correct fix. LP: #982032.
 -- Steve Langasek <email address hidden> Wed, 23 May 2012 00:27:10 +0000

Changed in update-notifier (Ubuntu Precise):
status: Fix Committed → Fix Released
Torsten Casselt (blu2lz) wrote :

Still not in the updates for Kubuntu. Window appears on every boot after every update of flashplugin-nonfree.

WORKAROUND (to be repeated after every update):

sudo rm /var/lib/update-notifier/user.d/data-downloads-failed
sudo rm /var/lib/update-notifier/user.d/data-downloads-failed-permanently

Torsten Casselt (blu2lz) wrote :

Oh, my bad. It's marked for 12.04.1. So it will be updated August 23rd!?

Steve Langasek (vorlon) wrote :

Torsten, this bug report is about the notification incorrectly showing the translations for all languages. That issue has already been fixed in precise-updates. It sounds like you're experiencing a different problem, and should file a separate bug report.

ill (illumilore) wrote :

"this bug report is about the notification incorrectly showing the translations for all languages."

Then why is bug 1007553 marked as a duplicate when it is clearly a different problem?

Jonathan Thomas (echidnaman) wrote :

It's the same bug, all the translations were showing on one line, making the window extremely wide. So wide, in fact, that the window would not render, leaving a black rectangle.

> Still not in the updates for Kubuntu. Window appears on every boot after every update of flashplugin-nonfree.
>
> WORKAROUND (to be repeated after every update):
>
> sudo rm /var/lib/update-notifier/user.d/data-downloads-failed
> sudo rm /var/lib/update-notifier/user.d/data-downloads-failed-permanently
>

Torsten, that error belongs to muon-updater, just try 'apt-get install --reinstall flashplugin-installer' (or 'apt-get upgrade' when upgrades are availiable). And I recall I've seen the bugreport for this issue, you should do some search.

description: updated
Changed in intltool (Ubuntu Quantal):
status: Triaged → Won't Fix
Changed in intltool-debian (Ubuntu Quantal):
status: Triaged → Won't Fix
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in intltool (Ubuntu Raring):
status: New → Confirmed
Changed in intltool-debian (Ubuntu Raring):
status: New → Confirmed
Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in intltool (Ubuntu Raring):
status: Confirmed → Won't Fix
Changed in intltool-debian (Ubuntu Raring):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.