[quantal] [regression] [i915] Corrupted display, desktop and menus don't repaint correctly using Mesa 9.0 (8.0.4 works)

Bug #1042211 reported by Jean-Baptiste Lallement on 2012-08-27
238
This bug affects 47 people
Affects Status Importance Assigned to Milestone
Compiz
Critical
Unassigned
Mesa
Invalid
Medium
compiz (Ubuntu)
Critical
Unassigned
mesa (Ubuntu)
High
Unassigned

Bug Description

WORKAROUND:
Download and install the old Mesa 8.0.4 packages for quantal from:
https://launchpad.net/ubuntu/+source/mesa/8.0.4-1ubuntu1

or add the Unity staging PPA:

sudo add-apt-repository ppa:unity-team/staging

ORIGINAL DESCRIPTION:
After installing the latest updates on Quantal, desktop fails to repaint correctly:
- moving a window leave trails
- plain color is displayed instead of custom background
- menus are flickering

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: compiz 1:0.9.8+bzr3319-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-12.12-generic 3.5.2
Uname: Linux 3.5.0-12-generic i686
ApportVersion: 2.5.1-0ubuntu2
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Mon Aug 27 10:38:41 2012
DistUpgraded: Fresh install
DistroCodename: quantal
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller [8086:a011] (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:83ac]
   Subsystem: ASUSTeK Computer Inc. Device [1043:83ac]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110209)
MachineType: ASUSTeK Computer INC. 1015PE
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-12-generic root=UUID=014cdf46-1d84-4e78-a68e-5d6de3419ad9 ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/31/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0402
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1015PE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0402:bd05/31/2010:svnASUSTeKComputerINC.:pn1015PE:pvrx.x:rvnASUSTeKComputerINC.:rn1015PE:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1015PE
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.
version.compiz: compiz 1:0.9.8+bzr3319-0ubuntu2
version.libdrm2: libdrm2 2.4.38-0ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0~git20120821.c1114c61-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0~git20120821.c1114c61-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.12.99.905-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.99.99~git20120713.6ef1ad6a-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.3-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.1-4~ubuntu1

Created attachment 60981
Xorg log file

I am running Kubuntu 12.04, and after upgrading to the packages in the xorg-edgers PPA, some OpenGL elements are no longer rendered correctly. Among the package upgrades were:
 . xserver: 1.11.4 -> 1.12.1+git20120502+server-1.12-branch.ed33772a
 . xserver-xorg-video-intel: 2.19.0 (x-updates PPA) -> 2.19.0+git20120501.7e09babb

The rendering bug can be seen with GLX-dock. I have attached a comparison screenshot where you can see the dock reflections are incorrect. and the icon below the one with focus disappears.

** My System **
OS: Kubuntu 12.04 i386 w/ KDE SC 4.8.2
PC: HP Pavilion dv1550se laptop
CPU: Intel(R) Pentium(R) M processor 1.60GHz
RAM: 1.5GB DDR400
Video: Mobile 915GM/GMS/910GML Express Graphics Controller
Sound: 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller
Linux Kernel: 3.2.0-24-generic
Screen Resolution: 1280 x 768

Created attachment 60982
screenshot showing bug

Can we identify which package is the culprit? i.e. purge the ppa then just install xserver-xorg-video-intel, then install libgl1-mesa-dri, testing after each step to see when the bug is introduced.

The problem appeared when I upgraded libgl1-mesa-dri from 8.0.2 to 8.1~git20120501.2d75a1e2 from the xorg-edgers PPA. I have reassigned this bug to Mesa:Server/Ext/DRI. Please reassign if this isn't correct.

Jean-Baptiste Lallement (jibel) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
tags: added: compiz-0.9
Daniel van Vugt (vanvugt) wrote :

jibel,

Please post the output from this command:
    /usr/lib/nux/unity_support_test -p

Also, are you using any PPAs?

Jean-Baptiste Lallement (jibel) wrote :

$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) IGD x86/MMX/SSE2
OpenGL version string: 1.4 Mesa 8.1-devel

Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: yes

I only use packages from the official Ubuntu archive, so no PPA

I attached a screenshot to illustrate the issue. The launcher hid, leaving a plain blue background, while the rest of the desktop shows the desktop bqckground.

My screen gets garbled then crashes when minimizing and maximizing windows to the point of having to manually power down the system and power back up the system...

Adam Szalkowski (adamsz) wrote :

I have the same problem with desktop, windows and menus not redrawing correctly i.e. replaced by background color (black in my case). This is also on an Atom processor with integrated Intel graphics.
This does not happen when I turn off the unity plugin in compiz, but then of course the launcher etc is not displayed.

Changed in compiz:
status: New → Confirmed
milestone: none → 0.9.8.2
Daniel van Vugt (vanvugt) wrote :

Confirmed on an Atom N270 :(

Changed in compiz:
importance: Undecided → Critical
Changed in compiz (Ubuntu):
importance: Undecided → Critical
summary: - corrupted display / desktop doesn't repaint correctly
+ [quantal] [regression] corrupted display / desktop doesn't repaint
+ correctly
tags: added: regression-update
Changed in compiz:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz:
status: Confirmed → In Progress

Tried Gnome Classic too. It's missing all the plugins (bug 1036752), but once I loaded a couple it was usable. This bug was almost nowhere to be found until I resized a window. If you resize a window then the same damage/corruption is left on the desktop.

Daniel van Vugt (vanvugt) wrote :

Tried reverting XDamageReport changes. No improvement.

Daniel van Vugt (vanvugt) wrote :

Forcing fullscreen redraws on makes the problem worse, but more consistent, in Unity: Wallpaper is always a solid colour and menus are never visible.

Fullscreen redraws does not make the problem any worse or better in Gnome Classic.

Sam Spilsbury (smspillaz) wrote :

I think this only happens when you switch from gnome-shell to compiz.

killall -9 nautilus will fix it.

There's no desktop window.

Daniel van Vugt (vanvugt) wrote :

Tried that already. Killing nautilus does not help.

Also, it would never solve the problem of the blank grey menus that I see.

Daniel van Vugt (vanvugt) wrote :

And the problem occurred long before I had installed gnome-shell or gnome-panel.

Daniel van Vugt (vanvugt) wrote :

Restarting compiz under LLVMpipe fixes the problem:
    env LIBGL_ALWAYS_SOFTWARE=1 unity --replace

Also, my other laptop (Intel i5 / HD 3000) running all the same packages is unaffected. It only seems to be the Atom graphics driver affected (i915)

Sam Spilsbury (smspillaz) wrote :

Hmm, great.

Oddly enough I'm running on an atom now and everything is fine.

summary: - [quantal] [regression] corrupted display / desktop doesn't repaint
- correctly
+ [quantal] [regression] [i915] [Atom] corrupted display / desktop doesn't
+ repaint correctly

Problem solved. I downgraded to Mesa 8.0.4-1ubuntu1 packages from:
https://launchpad.net/ubuntu/+source/mesa/8.0.4-1ubuntu1

Bug fixed.

Changed in mesa (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
Changed in compiz:
status: In Progress → Invalid
milestone: 0.9.8.2 → none
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
summary: [quantal] [regression] [i915] [Atom] corrupted display / desktop doesn't
- repaint correctly
+ repaint correctly using Mesa 9.0 (8.04 works)
description: updated
summary: [quantal] [regression] [i915] [Atom] corrupted display / desktop doesn't
- repaint correctly using Mesa 9.0 (8.04 works)
+ repaint correctly using Mesa 9.0 (8.0.4 works)
summary: - [quantal] [regression] [i915] [Atom] corrupted display / desktop doesn't
- repaint correctly using Mesa 9.0 (8.0.4 works)
+ [quantal] [regression] [i915] [Atom] Corrupted display, desktop and
+ menus don't repaint correctly using Mesa 9.0 (8.0.4 works)
tags: added: rls-q-incoming
Changed in compiz:
assignee: Daniel van Vugt (vanvugt) → nobody

This bug affects Intel x86 architecture as well (i915 graphics). Mesa downgrade is fix

Daniel van Vugt (vanvugt) wrote :

Yes, it's a bug in Mesa 9.0 affecting all older/low-end intel graphics chipsets that use i915_dri. Newer intel graphics using i965_dri are unaffected.

summary: - [quantal] [regression] [i915] [Atom] Corrupted display, desktop and
- menus don't repaint correctly using Mesa 9.0 (8.0.4 works)
+ [quantal] [regression] [i915] Corrupted display, desktop and menus don't
+ repaint correctly using Mesa 9.0 (8.0.4 works)
Andy Whitcroft (apw) wrote :

Confirming on an n455 netbook. Background solid colour much of the time, menus flashing contents then blank. Downgrading libgl1-mesa-glx libgl1-mesa-dri and libglapi-mesa to 8.0.4 fixes the issue for me.

Andy Whitcroft (apw) wrote :

The n455 was running 32 bit.

Further confirming on an N470 netbook running 64bit. Symptoms are identical.

Colin Ian King (colin-king) wrote :

Confirming on a HP Mini 210 netbook, i915 graphics, same artifacts and mess as apw is seeing. Again, Downgrading libgl1-mesa-glx libgl1-mesa-dri and libglapi-mesa to 8.0.4 fixes the issue for me.

Omer Akram (om26er) wrote :

I was having the same issue on my netbook. I updated from the unity's staging ppa and the issue is gone.

description: updated

Installing updates from ppa:unity-team/staging solved my issue in bug #1043171 as well.

Marking bug #1043171 as a duplicate of the present one.

Testing the PPA here, will report back...

Yeah much better now. I suggest pushing the versions to the main repos :)

snimmins (snimmins) wrote :

latest update seems to have fixed the problem. thanks!

Daniel van Vugt (vanvugt) wrote :

I have no idea how the staging PPA fixes this, but can confirm the latest unity+compiz updates have fixed it too.

Changed in mesa (Ubuntu):
status: Triaged → Incomplete

As original poster, I confirm the latest updates fixed it on the Asus 1015pe.

Daniel van Vugt (vanvugt) wrote :

Although, between this bug being a problem and it apparently being resolved, compiz 0.9.8.0 was released to quantal. That includes the GLES work which is a very large change. Maybe that did the trick and is working around the original problem in Mesa.

Kiwinote (kiwinote) wrote :

I was experiencing this same issue on the dell mini 9. It seemed that it was working again with the compiz/unity updates (minus that every now and then the image on the screen would freeze indefinitely whilst the cursor would still move - required a reboot to work again). Having installed the latest mesa update however (9.0~git20120903.e1673d20-0ubuntu1), after entering my password in the login screen I am left with a black screen with a cursor that can move as normal. Top shows that compiz and the usual desktop processes are running normally. This may be a different bug, but downgrading the three mesa packages mentioned above at least allows unity to load. I still have sporadic issues with the image freezing indefinitely. Are others seeing similar things, or am I best opening a new bug?

Timo Aaltonen (tjaalton) wrote :

kiwinote: that's possibly bug 966744, maybe open a new bug now and we'll worry about duping it later

This is most probably not the right place for reporting this, bug I can hardly create a new bug report outside of any working GUI...

Today's (2012/09/07) latest updates on Quantal Beta completely broke graphics on 2 different Intel Atom netbooks :

- Asus EeePC 1005PE running Quantal Beta 1 AMD64

- Acer eMachines eM355

On both machines, LightDM login screen is OK, but as soon as logged in, I get a flickering, completely unusable display. Unity doesn't start (or starts and fails at the same time). No way to launch anything from there. I'm stuck.

Omer Akram (om26er) wrote :

@Swami, can you try to enable unity staging ppa (ppa:unity-team/staging) and update after that and see if the issue is fixed or not. If its still an issue please do report it using 'ubuntu-bug unity'. Your issue sounds quite important to me.

@Omer I could finally report above issue as separate bug #1047306 .

Unity staging PPA does NOT fix it. (I tried...)

Didier Roche (didrocks) wrote :

Putting it on the "notfixing" list for now as it seems that this particular bug was workarounded by the new compiz.

tags: added: rls-q-notfixing
removed: rls-q-incoming

This has been verified on ubuntu too, see

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1042211

bottom line: mesa 8.0.4 works, 9.0~ doesn't

Changed in mesa (Ubuntu):
status: Incomplete → Triaged
assignee: nobody → Timo Aaltonen (tjaalton)
Changed in mesa:
importance: Unknown → Medium
status: Unknown → Confirmed
Daniel van Vugt (vanvugt) wrote :

I'm not totally sure Mesa #49442 is the same as this bug. But maybe.

Stefan Freyr (stefan-freyr) wrote :

I'm not sure if this helps or not but I think I have the same problem in Kubuntu 12.10. I'm attaching a screenshot of how it manifests for me.

I have a Lenovo Thinkpad T430 and I'm using the i915 video driver. Output of lshw -c display below:

stefan@atlas-stfs:~/Documents$ sudo lshw -c display
  *-display
       description: VGA compatible controller
       product: 3rd Gen Core processor Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:43 memory:f0000000-f03fffff memory:e0000000-efffffff ioport:5000(size=64)

Stefan Freyr (stefan-freyr) wrote :

A bit more information which I again don't know if is helpful.

The desktop effects seem to be generally "slow". For example, maximizing and minimizing windows is very jerky.

However, if I switch from using OpenGL as the "compositing type" in "System Settings" -> "Desktop Effects" -> "Advanced" tab and use XRender instead the effects become much smoother (although a few effects are disabled because they require OpenGL).

Switching to XRender also _seems_ to have gotten rid of the artifacts although I don't have a good way of reliably reproducing them so I can't say for sure.

Stefan Freyr (stefan-freyr) wrote :

So what's the plan here? It seems that this is serious enough to do something about it before the release of 12.10.

I'm mostly curious but of course I'd also like to see a fix for this sooner than later but what are the options? I imagine that waiting for an upstream fix is out of the question (if mesa bug 49442 is the culprit it's marked as "medium normal" importance and besides I'm not sure if 12.10 is open for such patches this late?). The other option is to downgrade mesa in the repository but if that is done I'd imagine it would be best to do that sooner than later to get some testing done on it in the beta phase?

Can anybody quench my curiosity and tell me who makes these decisions and what the process is then?

Daniel van Vugt (vanvugt) wrote :

Stefan,

Your screenshot shows quite different corruption to what this bug is about. So you're commenting on the wrong bug. Please log a new bug about your problem.

avlas (avlas) wrote :

using kwin instead of kwin_gles in kubuntu quantal fixes the issues

Reinis Danne (readan2) wrote :

Originally I reported Bug #1051486 and it was marked as duplicate for this one. As of todays updates I have none of those issues anymore. Note, I'm using xorg edgers ppa.

keestux (kees-bakker-xs4all) wrote :

The i915 is giving me lots of problems. After upgrading to 12.10 I had a blank screen after logging in (using Unity).

There was a kernel BUG at drivers/gpu/drm/i915/i915_gem.c:3084! in my syslog, so I first upgraded to 3.6.3 as suggested in https://bugs.launchpad.net/bugs/1058546 and that got rid of the BUG message, but still a blank screen.

Then I upgraded unity (using ppa:unity-team/staging), and know I have a working screen.

Nevertheless it keeps bugging me with a popup about a hangcheck timer GPU. I forgot which bug#.

FYI, using XFCE avoids the problem too.

c.h. (wryfi) wrote :

I hate to be "that guy" but somebody has to say what I'm sure others are thinking.

It's a horrible decision to ship a broken Mesa in a desktop-oriented distro, when both major desktop environments (Unity and KDE) use or rely on it, and it affects nearly-ubiquitous commodity video hardware.

It was known for two months that this was broken, and still it went into the release. Someone should have stopped it.

Just once I would like to successfully upgrade ubuntu without suffering from nasty regressions or serious breakage. It hasn't happened yet (since Breezy, for me).

Daniel van Vugt (vanvugt) wrote :

Mesa 9.0 was released in Ubuntu 12.10 because this bug is not known to be a problem any more with the latest Compiz/Unity packages released with 12.10. So the original bug in Mesa is largely irrelevant right now.

As usual, most people will comment on the wrong bug and think they're experiencing the same issue. If you think you are experiencing this bug still then please attach a video so we can confirm.

Timo Aaltonen (tjaalton) on 2013-01-31
Changed in mesa (Ubuntu):
assignee: Timo Aaltonen (tjaalton) → nobody
importance: Critical → High
Tommy_CZ (t-kijas) wrote :

Well I think mesa is still buggy, because 9 and 10 version produces some screen corruptions in all KDE versions (in 12.04.4 and 14.04) and the only resolution is to downgrade to Mesa 8. It occurs on Ivy bridge and Sandy bridge intels.

Changed in mesa:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.