AttributeError: 'Inter1and2Helper' object has no attribute 'source_repo'

Bug #513432 reported by Monty Taylor on 2010-01-27
106
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Bazaar
Critical
Martin Pool
2.0
Critical
Unassigned
2.1
Critical
Martin Pool
Launchpad itself
Critical
Michael Hudson-Doyle
bzr (Ubuntu)
Undecided
Unassigned

Bug Description

When I try to grab the libsndfile-dev branch:

bzr branch http://www.mega-nerd.com/Bzr/libsndfile-dev

I get:

bzr: ERROR: exceptions.AttributeError: 'Inter1and2Helper' object has no attribute 'source_repo'

This happens very consistently.

The tail of the log file:

   File "/usr/lib/python2.6/dist-packages/bzrlib/repository.py", line 4482, in _generate_root_texts
     self.from_repository).generate_root_texts(revs)
   File "/usr/lib/python2.6/dist-packages/bzrlib/fetch.py", line 257, in generate_root_texts
     graph = _get_rich_root_heads_graph(self.source_repo, revs)
 AttributeError: 'Inter1and2Helper' object has no attribute 'source_repo'

This bug was present in trunk and 2.1 rc releases. It is fixed now in both branches.

Launchpad currently has this bug in its deployed server code, with the result that branching from LP can fail.

Related branches

Martin Pool (mbp) on 2010-01-28
Changed in bzr:
status: New → Confirmed
importance: Undecided → High
tags: added: fetch
Martin Pool (mbp) on 2010-01-28
Changed in bzr:
importance: High → Critical
Martin Pool (mbp) wrote :

http://www.mega-nerd.com/Bzr/libsndfile-dev is a pack-0.92 branch.

I think as a workaround you should run 'bzr info' to check what format of repository you're trying to bring it into. Perhaps create or upgrade a specific libsndfile repository in --0.92 format.

Martin Pool (mbp) wrote :

I can reproduce it going from an old format to 2a

Martin Pool (mbp) on 2010-01-29
Changed in bzr:
assignee: nobody → Martin Pool (mbp)
status: Confirmed → In Progress
Martin Pool (mbp) wrote :

This is now fixed in trunk. 2.1 has already branched off so this also needs to be landed there. The bug is not present in the 2.0 branch.

Changed in bzr:
milestone: none → 2.1.0
status: In Progress → Fix Released
Martin Pool (mbp) wrote :

This probably also needs to be rolled out on Launchpad, because by branching from a remote old branch into a 2a repo you can get

bzr: ERROR: bzrlib.errors.ErrorFromSmartServer: Error received from smart server: ('error', "'Inter1and2Helper' object has no attribute 'source_repo'")

Changed in launchpad-code:
importance: Undecided → High
Robert Collins (lifeless) wrote :

Jorge Castro appeared to encounter this error using bzr 2.0.3. but in actual fact it was coming from launchpad. Seeing about escalating/doing a fix there.

description: updated
Changed in launchpad-code:
status: New → Confirmed
Changed in launchpad-code:
importance: High → Critical
assignee: nobody → Michael Hudson (mwhudson)
Michael Hudson-Doyle (mwhudson) wrote :

Fix rolled out to launchpad production.

Changed in launchpad-code:
status: Confirmed → Fix Released
Tim Penhey (thumper) on 2010-02-10
Changed in launchpad-code:
milestone: none → 10.02
Martin Pool (mbp) wrote :

Actually Lucid now has 2.1.0-1 so this is fixreleased there.

Changed in bzr (Ubuntu):
status: New → Fix Released
Alan Bell (alanbell) wrote :

getting the error above on bzr branch lp:ubiquity on a Maverick box.
Doing on-the-fly conversion from RemoteRepositoryFormat(_network_name='Bazaar pack repository format 1 (needs bzr 0.92)\n') to RepositoryFormat2a().

Andrew Bennetts (spiv) wrote :

Alan: Which version of bzr? This bug has been fixed since 2.1.0. Maverick has 2.2.0, and using that version I can branch from lp:ubiquity into a local 2a repository just fine. So the most likely explanation seems to be that for some reason you are still using an old version of bzr.

Andrew Bennetts (spiv) wrote :

Oh, I spoke too soon: this bug does occur in 2.2.0. Sorry for the noise!

It is fixed in 2.2.1, though. So it is a problem in the current Maverick package; we should probably get an SRU going for 2.2.1 in Maverick.

Changed in bzr (Ubuntu):
milestone: none → maverick-updates
status: Fix Released → Confirmed
Martin Pool (mbp) wrote :

An sru has alread been requested for bug 636930, which is quite similar (but I guess not a dupe?)

tags: added: sru
Andrew Bennetts (spiv) wrote :

It's essentially the same bug. The faulty line of code was different in lp:bzr/2.2 vs. lp:bzr/2.1 due to a refactoring (and so apparently caused the fix in 2.1 to be lost when 2.1 was merged into 2.2), but the actual fault was the same, and the nature of the fix was the same. So probably we could/should mark this bug as a dupe of 636930, although ideally we wouldn't want to lose the bug metadata on this bug about when it was fixed in e.g. 2.1... :/

Vincent Ladeuil (vila) on 2011-01-20
Changed in bzr (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers