[Ubuntu] [hardy] Office Open XML (OOXML) is not associated with OpenOffice.org, opens with File roller

Bug #138252 reported by Jonathan Ernst on 2007-09-08
100
This bug affects 2 people
Affects Status Importance Assigned to Milestone
shared-mime-info
Fix Released
Medium
openoffice.org (Baltix)
Undecided
Unassigned
openoffice.org (Ubuntu)
High
Unassigned
Declined for Gutsy by Henrik Nilsen Omma
Hardy
High
Unassigned
shared-mime-info (Ubuntu)
Low
Unassigned
Declined for Gutsy by Henrik Nilsen Omma
Hardy
Low
Unassigned

Bug Description

OpenOffice.org 2.3 in gutsy is able to open OOXML files but they are not associated with this application and thus cannot be double clicked to be opened in OpenOffice.org.

Hi,

Thanks for the bug report.

I am not aware of such a possibility. As listed in the new features [1], openOffice.org doesn't offer to open OOXML files. Could you post a link describing this features please?

Thanks

[1] http://development.openoffice.org/releases/2.3.0rc2.html

Changed in openoffice.org:
assignee: nobody → ndeschildre
status: New → Incomplete
Jonathan Ernst (jonathan.ernst) wrote :

You can see here : http://www.openoffice.org/issues/show_bug.cgi?id=79123 and http://en.wikipedia.org/wiki/Ooxml (search "openoffice") that this release contains a filter able to open .docx documents (it seems that .xlsx are not supported yet). Also you can open OpenOffice.org 2.3 and go in File->Open and you'll see "Microsoft Word 2007" format in the drop down list.

I'm uploading here a .docx file here so you can check it out yourself.

Since i cannot test it, i set the bug back to new.

Changed in openoffice.org:
assignee: ndeschildre → nobody
status: Incomplete → New
Maduser (maduser) wrote :

I can confirm this.
To get a sample docx file you search in google for filetype:docx http://www.google.com/search?&q=filetype%3Adocx
So you can find for testing a docx under http://www.richkiddventures.com/Services.docx

Dave Walker (davewalker) wrote :

I can further confirm that a docx can be successfully opened within OpenOffice 2.3 but is not associated as a writer document under Gnome; the default behaviour is to open as an archive. This bug should really be fixed prior to Gutsy release IMO.

Changed in openoffice.org:
status: New → Confirmed
Henrik Nilsen Omma (henrik) wrote :

Confirmed, but it's not critical enough for a 7.10 SRU. See: https://wiki.ubuntu.com/StableReleaseUpdates

Changed in openoffice.org:
importance: Undecided → Low
Changed in openoffice.org:
assignee: nobody → ccheney

It seems bugs #173093 and #191752 (about pptx files) are duplicates of this bug

Chris Cheney (ccheney) on 2008-03-10
Changed in openoffice.org:
assignee: ccheney → nobody
status: Confirmed → In Progress

Remember to make it open in Kubuntu also.
My bugreport quickly got stamped duplicate, so just want make sure that it is.

Colin Watson (cjwatson) wrote :

With an updated Hardy system at the time of writing, double-clicking a .docx file opens it in OpenOffice.org for me.

Perhaps this is still open for Kubuntu, though?

Colin Watson (cjwatson) wrote :

21:42 <cjwatson> ah, I see! you have them in the .desktop files but not the .mime files
21:42 <cjwatson> should be trivial to fix

Sebastien Bacher (seb128) wrote :

The issue is fixed in the hardy shared-mime-info version

Changed in openoffice.org:
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

the openoffice.org old mime definition still need to be updated

Chris Cheney (ccheney) on 2008-03-19
Changed in openoffice.org:
importance: Undecided → High
status: New → In Progress

If someone wanna have simple use of Office Open XML (OOXML, docx, xlsx, pptx) files in Ubuntu 7.10 (Gutsy) they can install shared-mime-info package from this software repository:

deb http://ppa.launchpad.net/baltix-members/ubuntu gutsy main universe

Chris Cheney (ccheney) on 2008-03-30
Changed in openoffice.org:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.7 KiB)

This bug was fixed in the package openoffice.org - 1:2.4.0-3ubuntu1

---------------
openoffice.org (1:2.4.0-3ubuntu1) hardy; urgency=low

  [ Chris Cheney ]
  * Resynchronise with Debian (r1044). Remaining changes:
    - debian/broffice.org.postrm.in:
      . Change diversions to ubuntu bitmap filenames.
    - debian/broffice.org.preinst.in:
      . Change diversions to ubuntu bitmap filenames.
    - debian/control.in:
      . Change maintainer line.
      . Use imagemagick instead of graphicsmagick.
      . Change bzr repo location.
      . Add package openoffice.org-style-human.
      . Add replaces openoffice.org-gtk (<< 2.0.3-1) for openoffice.org-gnome
        dapper upgrade.
    - debian/control.l10n.in:
      . Add file for Ubuntu.
    - debian/control.lang.in:
      . Add L10N_COMMON to Depends.
    - debian/control.mozilla.in:
      . Add Xb-Npp-xxx tags according to "firefox distro add-on suport" spec.
    - debian/control.ubuntu-feisty.in:
      . Add file for Ubuntu.
    - debian/deppackage.postinst.in:
      . Add file for Ubuntu.
    - debian/module-po.map:
      . Add file for Ubuntu.
    - debian/ooo-build-ubuntu.diff:
      . Various Ubuntu specific changes to ooo-build.
    - debian/openoffice.org-base.mime:
      . Update and sort mime-types.
    - debian/openoffice.org-calc.mime:
      . Update and sort mime-types.
    - debian/openoffice.org-draw.mime:
      . Update and sort mime-types.
    - debian/openoffice.org-filter-binfilter.mime:
      . Update and sort mime-types.
    - debian/openoffice.org-impress.mime:
      . Update and sort mime-types.
    - debian/openoffice.org-math.mime:
      . Update and sort mime-types.
    - debian/openoffice.org-writer.mime:
      . Update and sort mime-types.
    - debian/rules:
      . Add BUILD_SPARC option.
      . Add USE_COMMON_DOCDIR option.
      . Add USE_LZMA_COMPRESS option.
      . Add support to build on lpia.
      . Add support to build l10n as a separate source.
      . Add support to chmod +x programs in debian dir.
      . Add support to uuencode binary files in ubuntu dir.
      . Add support for Ubuntu specific bitmaps.
      . Add support for openoffice.org-style-human package.
      . Add support for launchpad translations.
      . Update location of aotcompile.py file.
      . Use imagemagick instead of graphicsmagick.
      . Use openjdk-6-jre instead of icedtea-java7-jre. Closes LP: #203636
      . Various Ubuntu specific changes.
    - debian/scripts/convert2po:
      . Add file for Ubuntu.
    - debian/scripts/fix_image_rgb:
      . Use imagemagick instead of graphicsmagick.
    - debian/scripts/gsifilter.py:
      . Add file for Ubuntu.
    - debian/scripts/splitgsi:
      . Add file for Ubuntu.
    - debian/template.desktop.in:
      . Add NoDisplay=true.
  * Resynchronise with ooo-build (r12081).
    - Closes LP: #54776, #62256, #105906, #113358, #131272, #137469, #138252
      Closes LP: #148552, #154940, #160988, #175983, #194759, #197451, #197622
  * ubuntu/*:
    - Update splash screen for OOo 2.4. Closes LP: #199193
    - Various Ubuntu specific changes.

  [ Matthias Klose ]
  * ubuntu/lpi2gsi: Add templates and conversion scripts to generate
    ...

Read more...

Changed in openoffice.org:
status: Fix Committed → Fix Released
Changed in shared-mime-info:
status: Unknown → Fix Released
DaveQB (david-dward) wrote :

This is still a bug in Kubuntu Hardy.

I fixed it by making a new file type [.docx] in File Types settings in KDE System Settings and then associating it with OpenOffice [2.4]

Can this association not be added to the base Kubuntu system for Ibex ? Seems a simple fix.

Chris Cheney (ccheney) wrote :

DaveQB,

Does KDE still not use the freedesktop shared-mime-info standard yet?

Chris

Chris,

I have no idea mate.

--------------
Regards
David Ward

On Mon, 20 Oct 2008 05:55:33 am Chris Cheney wrote:
> DaveQB,
>
> Does KDE still not use the freedesktop shared-mime-info standard yet?
>
> Chris

Changed in shared-mime-info:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.