window close/minimize buttons disappear from global menu for maximized windows with an open popup window

Reported by Rocko on 2011-04-15
188
This bug affects 36 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Unity
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Undecided
Marco Trevisan (Treviño)

Bug Description

Binary package hint: unity

If I open (for example) Synaptic non-maximized and tell it to reload or apply updates, an update window appears for potentially a considerable length of time. With Synaptic non-maximized, it is possible to minimize both windows by clicking on the minimize icon in the main Synaptic window.

However, with Synaptic maximized, the minimize/close window buttons disappear from the global menu when the child window is opened. Because it is a modal popup window, you cannot switch the focus back to Synaptic. This means you can no longer minimize Synaptic, which is a regression.

A workaround would be to allow the application to be minimized from the unity launcher, eg by making it (like every other launcher/dockbar) minimize a focused application when you click on its icon (eg as requested in bug #733349), or by adding a right-click menu option to minimize the application.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.8-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Sat Apr 16 06:17:30 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100602.2)
ProcEnviron:
 LANGUAGE=en_AU:en
 PATH=(custom, no user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-04-13 (2 days ago)

Related branches

Rocko (rockorequin) wrote :
summary: - window close/minimize buttons disappear from gobal menu for maximized
+ window close/minimize buttons disappear from global menu for maximized
windows with an open popup window
Bilal Akhtar (bilalakhtar) wrote :

Needs design discussion.

Changed in unity (Ubuntu):
status: New → Opinion
status: Opinion → Incomplete
tags: added: needs-design
Changed in unity:
status: New → Incomplete

There are various other issues with having the file menu for a floating window being located in the panel. The most obvious of which is that it's completely unintuitive because one would logically expect that the panel should control the window that it appears to be visibly connected to (the top-most maximised window).

I would like to suggest that the file menu for floating windows be re-located into a "windicator", thereby allowing the maximised window to always have it's file menu located in the panel. This would also allow it to always have it's window controls visible as there would no longer be any confusion about which window's file menu is in the panel.

Perhaps the maximised window can also have a windicator as it's file menu, for the sake of consistency, but located on the left side, next to the window controls, as opposed to the right side.

Bart (bart-geluykens) wrote :

In addition a screenshot of this issue. Windows decoration is completely missing, I am not able 2 move my window or closing it using the mouse.

tekstr1der (tekstr1der) wrote :

This is easily the 2nd most annoying usability (or lack thereof) bug in unity! Please fix or at least allow the option:

 [ ] Global Menu on
 [ ] Global Menu off
 [x] Global Menu only for maximized windows

Matthew Paul Thomas (mpt) wrote :

(tekstr1der, your comment is unrelated to this bug report. Please report a separate bug.)

tekstr1der (tekstr1der) wrote :

My apologies if I confused two separate issues.

Looking at it further though, it seems that if un-maximized windows had their own menu/controls as suggested by disabling Global Menu for un-maximized windows, that the issue reported here in this bug would also be resolved as a result.

There is indeed a separate (popular) bug # 682788 for providing an option to enable Global Menu for maximized windows only.

TomasHnyk (sup) wrote :

Marked 5 bugs as duplicates, it seems this is bothering a lot of people.

MrSnowflake (mrsnowflake) wrote :

That's because this basically is a usability fail. Instead of making things easier, this adds another step! Same goes for the hidden menu.

zetah (otrov) wrote :

As discussed on AskUbuntu: http://askubuntu.com/questions/81175/how-can-i-always-show-the-close-minimise-and-maximise-buttons-on-their-windows I proposed kind of idea which I link also here.

Screenshot: http://i.imgur.com/eZ3zh.png

Design is only informative so it does not look good, but here is how it's supposed to virtually work: If user hovers near top left region (not including global menu or launcher panel) then this floating control to pop-up allowing user action on background maximised window. Similarly how overlay scrollbar work.

I guess it's far from perfect but anyway...
I also like proposed idea from bug report, of embedding window controls in Unity launcher quicklist (for running applications) which will also allow controlling windows that aren't even visible

Omer Akram (om26er) wrote :

The Unity dialog implementation planned for 12.04 might fix the issue to an extent.

TomasHnyk (sup) wrote :

Omer: would you care to ellaborate on that or provide some links?

Omer Akram (om26er) wrote :

the code is in lp:unity soruce in the unitydialog folder, don't have any reference on it though. I actually think I might have mis understood this bug report though :-/

Matthew Paul Thomas (mpt) wrote :

No, it has nothing to do with changing the behavior of dialogs. The same bug occurs if you open the Calculator in front of a maximized window, for example.

Igor Bozovic (igorbozovic81) wrote :

Almost the same problem with me. In Unity (Ubuntu 12.04) any of the "not maximized" windows doesnt have borders and is missing of Close, Minimize and/or Maximize buttons.

The issue doesn't show at maximized windows.

This is now fixed when using unity in LIM mode.

Changed in unity:
status: Incomplete → Fix Committed
Changed in unity (Ubuntu):
status: Incomplete → Fix Released
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
milestone: none → 7.2.0
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → Medium
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.2.0.

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers