Graphics unstable on Ubuntu 14.04 and 14.10 using Intel HD Graphics 5500

Bug #1432194 reported by seth goldstein on 2015-03-14
486
This bug affects 89 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Undecided
Unassigned
xf86-video-intel
Unknown
Unknown
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Utopic
Medium
Timo Aaltonen
xserver-xorg-video-intel-lts-utopic (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

Trying to achieve: Get a more stable graphics environment up and running

Steps to take: basic ubtuntu 14.04 install. Boot up and run for a few minutes and then ...

What happens: After running for a few minutes the graphics gets flacky.

What should happen: Graphics should not get flaky.

I have just installed ubuntu 14.04 on my new thinkpad t450s. Everything basically works, but something is very flaky about my keyboard or display or both. After running for awhile some apps (E.g., thunderbird and sometimes emacs for example) will display garbage. If I refresh by moving the screen around or changing buffers/tabs/etc. they can often recover.

I see that there is an [Intel(R) Graphics Installer for Linux* 1.0.7](https://01.org/linuxgraphics/downloads/2014/intelr-graphics-installer-linux-1.0.7). I am leery about just loading this and running it. Any suggestions about how I should proceed?

    $ sudo lshw -c video
      *-display
           description: VGA compatible controller
           product: Broadwell-U Integrated Graphics
           vendor: Intel Corporation
           physical id: 2
           bus info: pci@0000:00:02.0
           version: 09
           width: 64 bits
           clock: 33MHz
           capabilities: msi pm vga_controller bus_master cap_list rom
           configuration: driver=i915 latency=0
           resources: irq:63 memory:e0000000-e0ffffff memory:d0000000-dfffffff ioport:3000(size=64)
    $ modinfo i915 | head
    filename: /lib/modules/3.16.0-31-generic/kernel/drivers/gpu/drm/i915/i915.ko
    license: GPL and additional rights
    description: Intel Graphics
    author: Tungsten Graphics, Inc.
    srcversion: 9929027A8A6F05972AD6986
    alias: pci:v00008086d000022B3sv*sd*bc03sc*i*
    alias: pci:v00008086d000022B2sv*sd*bc03sc*i*
    alias: pci:v00008086d000022B1sv*sd*bc03sc*i*
    alias: pci:v00008086d000022B0sv*sd*bc03sc*i*
    alias: pci:v00008086d0000162Dsv*sd*bc03sc*i*
    $ uname -a
    Linux mypad 3.16.0-31-generic #43~14.04.1-Ubuntu SMP Tue Mar 10 20:13:38 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Po-Hsu Lin (cypressyew) on 2015-03-16
affects: ubuntu-certification → linux
Po-Hsu Lin (cypressyew) wrote :

Hello, can you attach the screenshot when this happens?

seth goldstein (seth-o) wrote :

Here are a few screen shots of portions of the screen that show the kinds of corruption that are happening.

remerson (ubuntu-remerson) wrote :

I have a NUC5i3RYH with a very similar issue. Same kernel/driver.

I get the "missing (corrupt) letters" only, but no "black blobs". Particularly, this is an issue after resume from suspend. Regular usage is stable fresh from boot, so I do not get it as bad as Po-Hsu Lin.

Seems certain font sets get corrupted but once corrupted, are stuck. E.g. switching font size in terminal shows this. 11 pt broken, 12 point fine (until next suspend). Maybe if I do enough stuff (moving/resizing windows) the corruption moves.

See attached - note the "V" of "VGA compatible controller" near the bottom is mangled. This is typical. Corruption can occur within any app/title bar etc.

Is this any better on 15.04? Happy to help out testing fixes.

uname -a
Linux remerson-desktop 3.16.0-31-generic #43~14.04.1-Ubuntu SMP Tue Mar 10 20:13:38 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

sudo lshw -c video
  *-display
       description: VGA compatible controller
       product: Broadwell-U Integrated Graphics
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:61 memory:f6000000-f6ffffff memory:e0000000-efffffff ioport:f000(size=64)

lspci
00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection (3) I218-V (rev 03)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3)
00:1c.3 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #4 (rev e3)
00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03)
00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
02:00.0 Network controller: Intel Corporation Wireless 7265 (rev 59)

seth goldstein (seth-u) wrote :

Often this is accompanied by Xorg consuming more than 50% of the cpu cycles. Once it gets into that state the only thing I can do is log out and log back in. Help!

seth goldstein (seth-u) wrote :

One more thing. Enclosed is another screen shot. I have also tried 14.10 and similar issues happen there.

klinge (rosgnilk) wrote :

The same problem here. Unfortunately i didn't find out how to make a screen shot to share the disaster ;-)

Ubuntu 14.04
Kernel 3.16.0-33

seth goldstein (seth-u) wrote :

This is not a solution, but under kubuntu things work pretty well. Maybe this has something to do with the different window managers. I would really like to go back to unity and ubuntu. I hope someone looks into this.

GH (chili-g) wrote :

I am also seeing this on a fresh 14.04 install on a T450s.
So far I'm only seeing the missing letters.
So far have only seen it on the external 2550x1400 monitor, and not the native laptop screen.... but I don't have a lot of hours in yet, and it happened fairly quickly on the external monitor.

John doe (r9-launchpad-fq) wrote :

Hello same problem here on Dell Latitude E7450 with kernel 3.16.0-33 and with xserver-xorg-video-intel-lts-utopic stack on Ubuntu 14.04.2 LTS.

Mostly black rectangles and missing letters, for example in folder's name on the Desktop. This occurs after some time after having boot and probably when resuming from sleep.

I Will try to provide screenshot next time it happens. To resume to a normal situation, I have to logout & logon, but it doesn't work each time.

John doe (r9-launchpad-fq) wrote :

Please find screenshots as attachement

John doe (r9-launchpad-fq) wrote :

an an other screenshot

John doe (r9-launchpad-fq) wrote :

I forgot to say the bug occurs this time just after having boot (not from resume).

Michael Holler (mikejholler) wrote :

I am affected by this bug as well. T450s running Ubuntu 14.10 on kernel 3.16.0-33-generic #44-Ubuntu SMP Thu Mar 12 12:19:35 UTC 2015. Attached are is a screenshot of the error (one taken with an actual camera because Ubuntu won't let you snap a screenshot while you have a right-click context menu open). The system has been like this since boot, and the missing letters manifest themselves in different ways whenever I restart. However, they only seem to show up around system utilities like the WiFi drop downs, right-click context menus, and yes, even my terminal.

seth goldstein (seth-u) on 2015-04-02
summary: - Graphcis is unstable on ubuntu 14.04 on thinkpad 450s using Intel HD
+ Graphics is unstable on ubuntu 14.04 on thinkpad 450s using Intel HD
Graphics 5500
summary: - Graphics is unstable on ubuntu 14.04 on thinkpad 450s using Intel HD
+ Graphics unstable on ubuntu 14.04 on thinkpad 450s using Intel HD
Graphics 5500

I was just playing around with it some more, and discovered that a x session logout followed by a login seemed to fix the issue, at least temporarily. I am no longer seeing any missing text anywhere. I'll keep trying to see if I can reproduce it reliably.

girisha (girishad) wrote :

logging out and logging in again fixes the issue.. But it keeps coming up sometimes..

I am running Ubuntu 14.04 LTS on a Thinkpad X1 Carbon 3rd Gen

seth goldstein (seth-u) wrote :

Logging out and logging in will sometimes fix the issue for me, but only temporarily. More info, changing fonts in a particular application will generally cause the letters to be rendered correctly. Changing back (in the same session) will show the missing letters again. This happens on all of Ubuntu 14.04, Ubuntu 14.10, Kubuntu 14.10 on a Thinkpad T450s. (It is least problematic on Kubuntu 14.10). Hope this extra bit of info helps.

John doe (r9-launchpad-fq) wrote :

Sounds like bug 1311488

summary: - Graphics unstable on ubuntu 14.04 on thinkpad 450s using Intel HD
- Graphics 5500
+ Graphics unstable on ubuntu 14.04 using Intel HD Graphics 5500
summary: - Graphics unstable on ubuntu 14.04 using Intel HD Graphics 5500
+ Graphics unstable on Ubuntu 14.04 and 14.10 using Intel HD Graphics 5500
Michael Holler (mikejholler) wrote :

Has anyone tried the Intel graphics installer that seth mentioned in his original post?

* Intel(R) Graphics Installer for Linux* 1.0.7 -- https://01.org/linuxgraphics/downloads/2014/intelr-graphics-installer-linux-1.0.7

There seems to be a new version, too. Maybe this is fixed in that:

* Intel(R) Graphics Installer for Linux* 1.0.8 -- https://01.org/linuxgraphics/downloads/2015/intelr-graphics-installer-linux-1.0.8

seth goldstein (seth-u) wrote :

1.0.8 will not work on 14.04. I tried it on 14.10 and it complained and woudn't load.

John doe (r9-launchpad-fq) wrote :

I had 1.0.8 installed on Ubuntu 14.04 before it was made impossible (because of potential problem with backported graphic stack on 14.04.2). Anyway it was well installed and the missing letter bug was also present. Note that Intel driver is not annonced as compatible for HD graphic 5500.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
girisha (girishad) wrote :

has anyone experienced this bug on Gnome or Xfce?

Michael Holler (mikejholler) wrote :

Judging by the bug attachments, it looks like Unity and LXDE are confirmed so far.

Luke Darnell (q-luke) wrote :

I see similar to this on a Dell E7450.

Symptoms include:
- title bar corruption (title_bar_corruption.png)
- incorrectly rendered fonts
- incorrectly spaced fonts (similar to screenshot here - http://askubuntu.com/questions/594451/14-04-thinkpad-t450-text-getting-messed-up-on-large-screens)

sandy:~ $ lspci -nnk | grep '\[03' -A2
00:02.0 VGA compatible controller [0300]: Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09)
 Subsystem: Dell Device [1028:062e]
 Kernel driver in use: i915

seth goldstein (seth-u) wrote :

I can confirm that it is also happening on KDE (version 4.14.1) running ubuntu 14.10 and kernel 3.16.0-33-generic

John doe (r9-launchpad-fq) wrote :

Sad but seems to work solution: disabling SNA for old XUA method (as described here: https://wiki.archlinux.org/index.php/Intel_graphics#SNA_issues).

It seems it works better (for now) with UXA method, but it's a sad story as performance drops a little (and it is worthy...)

seth goldstein (seth-u) wrote :

I was going to try out John's suggestion, but it seems that I don't have xf86-video-intel installed on my system. So, should I try and install it (and if I do, can I remove it easily?) and if I install it, should i take the suggestion above?

Luke Darnell (q-luke) wrote :

As per the comment from "John doe", switching the intel X11 driver AccelMethod to uxa fixed the problem for me.

Michael Holler (mikejholler) wrote :

Is the workaround much of a performance drop? In any case, it's good there is at least a workaround.

Luke Darnell (q-luke) wrote :

Noticeably slower than sna when alt-tab'ing between applications.
But better than corrupted text and/or graphics.

seth goldstein (seth-u) wrote :

Since I don't have xf86-video-intel installed, is there a way to disable sna on what I am using? Should I switch? I am attaching my xorg.log.

Robert Erdin (robert-erdin) wrote :

I can confirm that the fix from comment #28 works for me. Don't notice any difference in performance but don't do anything that would require any noticeable graphics performance.

girisha (girishad) wrote :

as mentioned in #33, I also don't have xf86-video-intel installed. tired installing it and its not possible to install as there are unmet dependencies

John doe (r9-launchpad-fq) wrote :

Switching from SNA to UXA downgrade 2D day-to-day performances as SNA is the not-so-new default acceleration method for recent Intel graphics card (as in my case Broadwell HD 5500). More info about performances here :
http://www.phoronix.com/scan.php?page=article&item=intel_2dxorg30_ubuntu1404&num=1

For example, at startup, the only icon folder on my desktop is now displayed slowly with UXA rather than SNA. However as Luke #32 said before this is better to have this workaround than missing letters problem, but it's only a workaround, not a real solution.

@girisha #35: forget about xf86-video-intel, your xorg.log show you have Intel driver :
 3.831] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20080730
[ 3.831] (II) intel(0): SNA compiled: xserver-xorg-video-intel 2:2.99.914-1~exp1ubuntu4.2 (Maarten Lankhorst <email address hidden>)

In any case, try to create the following folder:
sudo mkdir /etc/X11/xorg.conf.d/

Then create inside the new folder a file named for example "20-intel.conf" with the following content:
Section "Device"
 Identifier "Card0"
 Driver "Intel"
 Option "AccelMethod" "uxa"
EndSection

Then reboot and voila. If something goes wrong (if X server failed for example), you just have to delete the 20-intel.conf to revert back.

girisha (girishad) wrote :

@John doe #36: thank you very much for the reply. I will try it out :)

Fluepke (fluepke) wrote :

I am running Ubuntu GNOME with kernel 4.0.0-040000rc7 on a T450s. I could solve the issue of missing letters by changing font hinting to medium or slight in the gnome-tweak-tool. But I am still experiencing rendering issues sometimes. Will try out the fix.

John doe (r9-launchpad-fq) wrote :

Do you mean that by modify font size the missing letter prb is permanently solve or were you modify the font when the prb occurs to temporary resolve it?

As the problem seems to be a mixtape between kernel, Intel Driver, glib2, etc. I was hoping it may be solve using kernel 4.0 so thanks to have reported that it's not the case.

seth goldstein (seth-u) wrote :

I can confirm that the temporary fix john proposed is working well under kubuntu 14.10 on my T450s. Particulars:
KDE: Platform Version 4.14.1, Ubuntu: 14.10, Kernel: 3.16.0-33-generic

Changed in xserver-xorg-video-intel:
assignee: nobody → Chris Wilson (ickle)
status: New → Confirmed
Changed in xserver-xorg-video-intel:
assignee: Chris Wilson (ickle) → nobody
phitastic (robbel) on 2015-05-02
information type: Public → Public Security
information type: Public Security → Public
Timo Aaltonen (tjaalton) on 2015-05-05
no longer affects: xserver-xorg-video-intel
affects: ubuntu → xserver-xorg-video-intel (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
Timo Aaltonen (tjaalton) on 2015-05-05
Changed in xserver-xorg-video-intel (Ubuntu Utopic):
assignee: nobody → Timo Aaltonen (tjaalton)
status: New → Incomplete
Timo Aaltonen (tjaalton) on 2015-05-11
Changed in xserver-xorg-video-intel (Ubuntu Utopic):
importance: Undecided → Medium
tags: added: amd64 trusty
affects: linux → xserver-xorg-video-intel
Changed in xserver-xorg-video-intel:
importance: Undecided → Unknown
status: New → Unknown
Timo Aaltonen (tjaalton) on 2015-05-15
Changed in xserver-xorg-video-intel (Ubuntu Utopic):
status: Incomplete → In Progress
86 comments hidden view all 166 comments
Luke Darnell (q-luke) wrote :

I'm still seeing issues on 14.04.
I have the latest kernel - 3.16.0-38-generic

Symptoms are the same as before:
Use sna in the X11 conf.
Attach an external monitor.
Run for a while and you'll see characters start disappearing and title bars corrupted.
Opening google earth seems to make things go bad pretty quick.

uxa is still a work around.
But sna is markedly faster, so I'd still love to be able to use that.

Tom Carnell (tcarnell) wrote :

I am also getting this problem on a Dell Latitude E7250 - also with i7 5600 + Intel 5500 video, using Ubuntu 14.04.2 - the corrupt text is making software development very hit and miss... a fix would be GREAT!

Can I help?

Simao (simaomm) wrote :

Hello,

I had the same problem with my hardware (Asus Ux303LA, Intel 5500, i7)

It appears to have been fixed upstream in drm-intel-next,

You can try it using a kernel with the latest drm-intel-next, which you can get from here: http://kernel.ubuntu.com/~kernel-ppa/mainline/drm-intel-next/current/

I also use i915.enable_execlists=0 as a kernel parameter and it appears to be stable now.

Elin (toijer) wrote :

Hey,

I tried to follow the instructions given in post 100 and got he error: breaks existing package n 'intel-gpu-tools' that conflict: 'xserver-xorg-video-intel'.

My computer is a dell latitude E7450 and i have Ubuntu 14.04. Any idea how to solve this problem? I would very much appreciate your help!

Carlos (carlos-alos-ferrer) wrote :

I am running Ubuntu 14.04 on a Thinkpad X250. I still have this issue (corrupted fonts, flacky graphics interface) running the latest kernel. Besides, I have the exact same problem reported in post 130 when trying to apply the fix in post 100.

The problem is exacerbated when using an external monitor, which in my case is 90% of the time. I also confirm that running google maps essentially corrupts everything (I have to reboot), although the LITE version works.

Help would be very much appreciated.

Timo Aaltonen (tjaalton) wrote :

I've finally uploaded a new intel driver to utopic and lts-utopic backport to trusty that fix the font corruption issue on GT3... they'll get built and pushed to -proposed once accepted

Hello seth, or anyone else affected,

Accepted into utopic-proposed. The package will build now and be available in a few hours in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xserver-xorg-video-intel (Ubuntu Utopic):
status: In Progress → Fix Committed
tags: added: verification-needed
no longer affects: xserver-xorg-video-intel-lts-utopic (Ubuntu Utopic)
no longer affects: xserver-xorg-video-intel (Ubuntu Trusty)
Changed in xserver-xorg-video-intel-lts-utopic (Ubuntu):
status: New → Invalid
Changed in xserver-xorg-video-intel-lts-utopic (Ubuntu Trusty):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Hello seth, or anyone else affected,

Accepted xserver-xorg-video-intel-lts-utopic into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/xserver-xorg-video-intel-lts-utopic/2:2.99.914-1~exp1ubuntu4.5~trusty1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Débora (setton-debora) wrote :

Hi, I am also affected by this issue and would like to test the fixed package,
but I'm running Ubuntu 15.04 (vivid).

Will this fix be available in vivid repositories too?

Thanks!

Pablo Gambetta (gambeita) wrote :

Same problem here,

Ubuntu 14.04
Inspiron 15 3000 Series (Intel(R)) - 3543
Intel® Core™ i5-5200U CPU @ 2.20GHz × 4
Intel® HD Graphics 5500 (Broadwell GT2)

Erik-Jan Blanksma (erikjan-6) wrote :

I've upgraded from the proposed repository and it does ideed seem to fix the issue for me. package version: 2:2.99.914-1~exp1ubuntu4.5~trusty1

Using XPS 13 9343.
Thx a lot!

Carlos (carlos-alos-ferrer) wrote :

I have upgraded from the trusty-proposed repository on a Thinkpad X250 and after testing it for a day, it seems to fix the problem for me. No font corruption anymore, even google maps seems to work.

Comment: Might be related or not, but yesterday after the upgrade the minimize/maximize/switch off buttons were gone in the non-maximized windows in the external monitor, today they are back. Go figure.

Many thanks!

stephen (ste-moorhouse) wrote :

setting update software updater to install pre-released updates fixed the graphics issues

although it killed my trackpad

this was fixed using
sudo apt-get install xserver-xorg-input-synaptics

Mark A. Hershberger (hexmode) wrote :

I think I fixed my vivid system by downgrading 2:2.99.917~exp1ubuntu2.2 to 2:2.99.917~exp1ubuntu2build1. I also tried exp1ubuntu3 and it didn't work.

Timo Aaltonen (tjaalton) wrote :

too much noise here, if you have issues with vivid file a new bug

marking verified since the utopic upload seems to work

tags: added: verification-done
removed: verification-needed
Luke Darnell (q-luke) wrote :

I can confirm that this bug is fixed with 2:2.99.914-1~exp1ubuntu4.5~trusty1 of xserver-xorg-video-intel-lts-utopic

Michel-Ekimia (michel.ekimia) wrote :

Works great with proposed package.

We cannot sell those broadwell laptops and desktops because of this bug right now.

We can we expect the fix to be in main ?

David (abbasi-david) wrote :

I was affected by this bug as well, but it was not too annoying to me as it rarely happened, so I did not pay much attention if it were solver or not. In the other hand the resume after suspend used to work well until a software update:

Start-Date: 2015-07-01 01:24:16
Commandline: aptdaemon role='role-commit-packages' sender=':1.83'
Upgrade: xserver-xorg-video-intel-lts-utopic:amd64
(2.99.914-1~exp1ubuntu4.2~trusty1, 2.99.914-1~exp1ubuntu4.3~trusty1),
unattended-upgrades:amd64 (0.82.1ubuntu2.2, 0.82.1ubuntu2.3)
End-Date: 2015-07-01 01:24:19

Since then, resume after suspend does not work well and the windows are not drawn properly (the same as bug #1452318 https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1452318 ). I post here because the bugs seems to be related.

I tried the proposed 2:2.99.914-1~exp1ubuntu4.5~trusty1 , but the resume after suspend problem persists. The only workaround for the moment is to switch the SNA to UXA as commented in #28, but a lack of performance is noticable as happen to #111.

I attach screenshots of the problem with versions 2:2.99.914-1~exp1ubuntu4.3~trusty1 and 2:2.99.914-1~exp1ubuntu4.5~trusty1

David (abbasi-david) wrote :

By the way, I can confirm that the missing letters problem is solved with the proposed 2:2.99.914-1~exp1ubuntu4.5~trusty1 .

Laptop ThinkPad T550
i5-5200U
Intel HD Graphics 5500 (Broadwell GT2)
Ubuntu 14.04

Thank you very much!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel - 2:2.99.914-1~exp1ubuntu4.5

---------------
xserver-xorg-video-intel (2:2.99.914-1~exp1ubuntu4.5) utopic; urgency=medium

  [ Timo Aaltonen ]
  * sna-gen8-clear-instancing-enabled-bit-between-batches.diff: Fix
    corruptions and missing letters on 2nd head. (LP: #1432194)

  [ Robert Hooker ]
  * sna-clear-cursor-image-after-rotation.patch: Fix a double cursor problem after
    rotating the screen (LP: #1376760) (LP: #1443345) backport from
    a88795c641 upstream.

 -- Timo Aaltonen <email address hidden> Fri, 26 Jun 2015 14:22:42 +0300

Changed in xserver-xorg-video-intel (Ubuntu Utopic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for xserver-xorg-video-intel has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-intel-lts-utopic - 2:2.99.914-1~exp1ubuntu4.5~trusty1

---------------
xserver-xorg-video-intel-lts-utopic (2:2.99.914-1~exp1ubuntu4.5~trusty1) trusty; urgency=medium

  * Backport utopic package for lts-utopic stack.

 -- Timo Aaltonen <email address hidden> Mon, 11 May 2015 14:35:11 +0300

Changed in xserver-xorg-video-intel-lts-utopic (Ubuntu Trusty):
status: Fix Committed → Fix Released
julien (jrmlhermitte) wrote :

The issue is not fixed for vivid (15.04). What is the status on this? Here is what I see. I use FVWM and the results are even worse. This occurs every time I suspend and resume into fvwm. If I log out of FVWM and log back in, the glitches go away.

David (abbasi-david) wrote :

@Julien, this bug is about the missing letters. The resume after suspend bug seems to be related as well with the xorg-video-intel, and is filed as the bug #1452318 . So please, go there and include yourself in the list of affected users.

zlatko (zlatko23) wrote :

I can report issue is NOT fixed with 2:2.99.914-1~exp1ubuntu4.5~trusty1 Using Lenovo X1 Carbon 3rd Gen - just got corrupted UI menus after suspend-resume. Should be reopened.

zlatko (zlatko23) wrote :

Adding to my above report - after the update to 2:2.99.914-1~exp1ubuntu4.5~trusty1 screen started to go blank(black) constantly. In intervals from seconds to minutes. System is till running OK, I am able to start the screen by Ctrl-Alt-F1 and then Ctrl-Alt-F7. I do not know if this is really connected to driver.

julien (jrmlhermitte) wrote :

thank you for the information, i will go there :-)

David (abbasi-david) wrote :

Zlatko, as said before, the resume after suspend bug seems to be related with the xorg-video-intel, and is filed as the bug #1452318 . So please, go there and include yourself in the list of affected users. Report there your bug.

Ara Pulido (ara) on 2015-08-10
Changed in oem-priority:
status: New → Fix Released
julien (jrmlhermitte) wrote :

I tried:
$ sudo apt-get update
$ sudo apt-get upgrade xserver-xorg-video-intel

It did upgrade the driver.

However, I still see the issue with my graphics in FVWM.

Any recommendations on what to do for the layman if I'm not doing something right? Thanks :-)

I have ubuntu 15.04

I've got exactly this issue (missing characters, sometimes funny colored artifacts replacing characters in fonts) on the Lenovo T410s (Ubuntu 15.04, xserver-xorg-video-intel 2:2.99.917-1~exp1ubuntu2.2). Will this fix be ported to Vivid?

Timo Aaltonen (tjaalton) wrote :

vivid issues after resume from suspend is a different bug, should be fixed by
https://bugs.launchpad.net/ubuntu/vivid/+source/linux/+bug/1483320

(the "migrate bdw to i915_bpo" part)

tracked also on bug 1452318

Neil Myrick (neil-myrick) wrote :

I don't really see a fix in all of the notes. I see a 'workaround', but it isn't a very good option, as it affects performance.

Same problem for me
Modifying anti-aliasing improves with Ubuntu Tweak, but only disappears leaving the session. Reappears random.
Lenovo g50-30
GPU Intel 4000
kernel 3.16.0-60-generic

This bug also affects me:

Kernel: 4.4.0-16-generic x86_64 (64 bit) Desktop: KDE Plasma 5.5.4
           Distro: Ubuntu 16.04 xenial

It also affects all of the HP Streams my family uses. They are currently running Ubuntu 15.10.

vik (askvictor) wrote :

I've experienced this sort of bug twice today on 16.04. I've submitted a new bug with logs at https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1578043

chrisber (christcan) wrote :

Affects:
- Thinkpad T550:
- Linux lpt 4.4.0-22-generic #39-Ubuntu SMP Thu May 5 16:53:32 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
- Ubuntu 16.04

kris van der Merwe (krisvdm) wrote :

Serious bug

Lost my second screen via HDMI on kernel update to vmlinuz-4.4.0-37-generic

Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)

Timo Aaltonen (tjaalton) wrote :

kris: don't hijack old bugs, file a new one

Displaying first 40 and last 40 comments. View all 166 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.