console-setup/layoutcode settings are ignored

Bug #188492 reported by Agostino Russo on 2008-02-03
28
Affects Status Importance Assigned to Milestone
Wubi
Medium
Agostino Russo
console-setup (Ubuntu)
Medium
Colin Watson
oem-config (Ubuntu)
Undecided
Unassigned
ubiquity (Ubuntu)
Medium
Colin Watson

Bug Description

Console-setup/layoutcode is set both in menu.lst and in preseed.cfg but it does not seem to have any effect.

#menu.lst
kernel /ubuntu/install/boot/vmlinuz boot=casper find_iso=/ubuntu/install/hardy-desktop-i386.iso debian-installer/custom-installation=/ubuntu/install/custom-installation quiet splash ro automatic-ubiquity locale=en_GB console-setup/layoutcode=gb console-setup/variantcode=

#preseed.cfg
d-i debian-installer/locale string en_GB
d-i console-setup/layoutcode string gb

Agostino Russo (ago) on 2008-02-03
Changed in wubi:
importance: Undecided → Medium
status: New → Confirmed
Colin Watson (cjwatson) wrote :

Ubiquity tries to move /etc/default/console-setup out of the way, but fails because it doesn't have privileges. Regaining privileges for this chunk of ubiquity.components.console_setup.prepare should fix this.

Changed in ubiquity:
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → evand
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.7.12

---------------
ubiquity (1.7.12) hardy; urgency=low

  [ Colin Watson ]
  * Slight shell efficiency improvement in
    partman/check.d/03partition_too_small.
  * Use 'autoreconf -fi' so that Autotools files reliably get upgraded.
  * Upgrade to gettext 0.17.

  [ Evan Dandrea ]
  * Update partman_popup with respect to other recent changes
    (LP: #194688). Thanks Colin Watson.
  * Regain root when moving /etc/default/console-setup out of the way
    (LP: #188492). Thanks Colin Watson.
  * Minor changes to ubiquity-dm from suggestions by Colin Watson.
  * Remove suffix from icon path in .desktop file (LP: #188221).

  [ Jonathan Riddell ]
  * Fix QApplication args in ubiquity/frontend/kde_ui.py

 -- Jonathan Riddell <email address hidden> Mon, 25 Feb 2008 10:13:27 -0500

Changed in ubiquity:
status: Confirmed → Fix Released
Agostino Russo (ago) on 2008-02-27
Changed in wubi:
status: Confirmed → Fix Released
Agostino Russo (ago) wrote :

As of 8.04 beta preseeding of layoutcode still has no effect. I only used preseeding this time, no boot args.

#preseed.cfg
d-i debian-installer/locale string en_GB
d-i console-setup/layoutcode string gb

Changed in wubi:
status: Fix Released → In Progress
Agostino Russo (ago) wrote :

Installation logs attached, the installer was preseeded as indicated above

Changed in ubiquity:
status: Fix Released → In Progress
Colin Watson (cjwatson) on 2008-04-14
Changed in console-setup:
assignee: nobody → kamion
importance: Undecided → Medium
status: New → Fix Committed
Changed in ubiquity:
assignee: evand → kamion
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package console-setup - 1.21ubuntu7

---------------
console-setup (1.21ubuntu7) hardy; urgency=low

  * Honour OVERRIDE_ALLOW_PRESEEDING environment variable when deciding
    whether to allow preseeding, which is ordinarily only allowed in d-i
    (LP: #188492).

 -- Colin Watson <email address hidden> Mon, 14 Apr 2008 11:49:55 +0100

Changed in console-setup:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.8.5

---------------
ubiquity (1.8.5) hardy; urgency=low

  [ Evan Dandrea ]
  * Move the map when the cursor is near an edge instead of whenever the
    cursor moves (LP: #214989, #195159).
  * Various fixes to the new tzmap. Thanks Colin Watson.
    - Wait half a second before zooming in.
    - Zoom in from the position of the mouse, rather than the top left
      corner.
    - Widen the hover-to-move areas.
    - Find the closest hotspot if there are several nearby.
    - Zoom to 4.5x.
  * Removed 12system_partitions_formatted. It now lives in partman-target.
  * Automatic update of included source packages: console-setup
    1.21ubuntu7, partman-target 54ubuntu6.

  [ Mario Limonciello ]
  * Default the MythTV theme to the newly changed Mythbuntu-8.04 theme
    to prevent upgrade crashes. (LP: #215036)

  [ Colin Watson ]
  * Allow diagonal scrolling in timezone map.
  * Update translations from Launchpad.
  * Fix typo in German welcome message (LP: #195075). This needs to be fixed
    in Launchpad or it *will* regress, but this will at least paper over it
    for 8.04.
  * Set OVERRIDE_ALLOW_PRESEEDING=1 while calling console-setup to force it
    to allow preseeding (LP: #188492).

 -- Evan Dandrea <email address hidden> Mon, 14 Apr 2008 20:47:52 -0400

Changed in ubiquity:
status: Fix Committed → Fix Released
Agostino Russo (ago) on 2008-04-15
Changed in wubi:
status: In Progress → Fix Released
Michael Kofler (michael-kofler) wrote :

> [Bug 217716] Re: wubi.exe does not setup X keyboard layout
> *** This bug is a duplicate of bug 188492 ***
> Please retry using today's daily ISO, if it still does not work please
> report it here: https://bugs.launchpad.net/wubi/+bug/188492

I tested again with hardy-desktop-amd64.iso from April 15th, the bug is still here (no surprise for me); to summarize:

I did a WUBI installation with language='German'; ubiquity installed german language packs etc., but failed to set the keyboard to german layout (both for the text console and for X)

this problem *is* WUBI related (even if the bug itself might be in ubiquity -- I don't know);

this problem it *does not* appear on a standard desktop installation

Agostino Russo (ago) wrote :

Let's do a last try with today ISO,
Use a dummy password (since it will be in following logs)
Before rebooting back up c:\ubuntu\install\custom-installation\preseed.cfg
After selecting Ubuntu at reboot, press esc and select verbose installer mode.

If it does not work please zip and attach /var/log/installer (within Ubuntu) as well as the preseed.cfg above

Agostino Russo (ago) wrote :

Remove the old ISO (including ubuntu-backup) to make sure it is not used

Changed in ubiquity:
status: Fix Released → In Progress
Changed in wubi:
status: Fix Released → In Progress
Agostino Russo (ago) wrote :

Can you please also provide the Wubi log, it is in your user temp folder (%temp%) in Windows.

Agostino Russo (ago) on 2008-04-16
Changed in wubi:
assignee: nobody → ago
Colin Watson (cjwatson) wrote :

Fixed harder; the previous fix wasn't sufficient to deal with automatic mode.

Changed in ubiquity:
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

Agostino is also going to change wubi to pass locale and keyboard information on the kernel command line rather than in the preseed file, which is needed for this to work properly for various tedious reasons in casper.

Agostino Russo (ago) wrote :

Wubi changes done in rev 489 (but need testing)

Changed in wubi:
status: In Progress → Fix Committed

should I wait for daily of April 17th before I test again?

Agostino Russo (ago) wrote :

My understanding is that the changes will go in after release candidate, Michael it would be great if you could test once they are in!

I tested again with the release candidate, the problem is still unsolved

attachement preseed.cfg

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.8.6

---------------
ubiquity (1.8.6) hardy; urgency=low

  [ Luke Yelavich ]
  * bin/ubiquity-dm:
    - Move code relating to at-spi-registryd to ensure that a11y is loaded
      before the background and window manager. (LP: #197887)
    - Ensure that orca/onboard are only run if the a11y gconf key is set.
    - Don't show any background image if the v1 profile is selected, similar to
      what happens in the GNOME desktop with this profile enabled.
    - Do not drop privileges when running the window manager,
      gnome-settings-daemon, or any of the a11y tools. Privileges are still
      dropped when accessibility is not enabled.
    - Wait for 15 seconds before loading orca, to let the a11y framework settle,
      and prevent orca from zombifying. This is a workaround until a cleaner
      solution is found.

  [ Colin Watson ]
  * Fix console-setup seen flag handling; console-setup/layout and
    console-setup/variant need to be marked unseen even in automatic mode so
    that they get their defaults set correctly, so use a different method to
    avoid displaying the question in preseeded installations (LP: #188492).
  * Fix partition_too_small check only to warn about partitions that are not
    free space, are not marked as "do not use", and are marked for use with
    a filesystem.

  [ Evan Dandrea ]
  * Automatic update of included source packages: grub-installer
    1.27ubuntu7, partman-base 114ubuntu5.

 -- Evan Dandrea <email address hidden> Sat, 19 Apr 2008 12:13:35 -0400

Changed in ubiquity:
status: Fix Committed → Fix Released
Agostino Russo (ago) wrote :

Michael,

Please test with Wubi rev 492 (from wubi-installer.org)

There should not be any uncommetned line on locales/layoutcode in preseed.cfg
But you should see locale/layoutcode info in cat /proc/cmdline

Changed in wubi:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oem-config - 1.36

---------------
oem-config (1.36) hardy; urgency=low

  * Set OVERRIDE_ALLOW_PRESEEDING=1 while calling console-setup to force it
    to allow preseeding (LP: #188492).
  * Update translations from Launchpad.
  * Automatic update of included source packages: console-setup 1.21ubuntu8.

 -- Colin Watson <email address hidden> Tue, 22 Apr 2008 01:15:50 +0100

Changed in oem-config:
status: New → Fix Released

does still not work :-(

I tested again with wubi 495 from wubi-installer.org and daily iso from 21th of April

Agostino Russo (ago) wrote :

Can you please post c:\ubuntu\install\boot\grub\menu.lst and c:\ubuntu\install\custom-installation\preseed.cfg
Also install in verbose mode and post the tgz of /var/log/installer.

Changed in wubi:
status: Fix Released → In Progress
Agostino Russo (ago) wrote :

I have run a few tests and it works well for me, using wubi rev 495 with daily ISO of 23-04-2008.

Agostino Russo (ago) wrote :

Marked again as fixed until I have evidence of the contrary (as mentioned my own tests were successful).

Changed in wubi:
status: In Progress → Fix Released

I tested again with daily of April 23rd, worked!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers