Date and time disappeared from top panel [$50]

Bug #1356698 reported by assem on 2014-08-14
542
This bug affects 112 people
Affects Status Importance Assigned to Milestone
Wingpanel
Fix Released
High
Unassigned
Freya
Won't Fix
Undecided
Unassigned

Bug Description

Date and time disappeared from the center of top panel

ProblemType: Bug
DistroRelease: elementary OS 0.3
Package: elementary-desktop 1.349+393~ubuntu0.3.1 [origin: LP-PPA-elementary-os-daily]
ProcVersionSignature: Ubuntu 3.13.0-33.58-generic 3.13.11.4
Uname: Linux 3.13.0-33-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.3
Architecture: amd64
CrashDB: elementary_meta
CurrentDesktop: Pantheon
Date: Thu Aug 14 07:07:24 2014
InstallationDate: Installed on 2014-08-13 (0 days ago)
InstallationMedia: It
SourcePackage: elementary-meta
SuspiciousXErrors:

ThirdParty: True
UpgradeStatus: No upgrade log present (probably fresh install)

assem (assemdido-gmail) wrote :
Cody Garver (codygarver) on 2014-08-14
Changed in elementaryos:
milestone: none → freya-beta2
importance: Undecided → High
Luís Roberto Weck (luisrweck) wrote :

When I had a "unoficial" beta installed, I managed to fix it by messing with the locale option in dconf editor. Though I can't seem to reproduce the fix again, I'm pretty sure it has something to do with the locale, where LC_ALL appears as 'unset'.

Joel Almeida (joelalmeidaptg) wrote :

This just happened to me with no apparent reason. I turned my computer on, watched some Youtube videos and now I noticed it is gone

Shaun Ward (shaun-alethia-inc) wrote :

Have this as well

Artem Anufrij (artem-anufrij) wrote :

I confirm this bug.

I had the same issue : sudo apt-get install --reinstall indicator-datetime solved the problem for me

Luís Roberto Weck (luisrweck) wrote :

It didn't work out for me...

Current fix:
Edit the /etc/environment file and put this line at the end of it:
LC_ALL="en_US.UTF-8"
**Log out and in again and it's fixed!

Luís Roberto Weck (luisrweck) wrote :

Well, I'm sorry @hassan-zombie but I don't know how to save the changes... Scratch asks if I want to save somewhere else...

Arvis Lācis (arvis-lacis) wrote :

Luís Roberto Weck (luisrweck): To save edited file in /etc/ directory you need sudo rights that's way normal Scratch instance can't save changes there.

Anyway, I also find easier solution:
1. With Scratch editor (or any other text editor) open .pam_environment file in your HOME directory.
2. Add LC_ALL=en_US.UTF-8 at the beginning of the file.
3. Log out and log in back. Now time indicator worked for me.

If you prefer to save your regional settings, for example, week starts with Monday, local weekday names etc., then in .pam_environment add this, for example (for Latvian language):

LC_ALL=lv_LV.UTF-8
LC_MESSAGES=en_US.UTF-8

This has happened to me on two installations.

Philippe (philippe-morere) wrote :

Same bug for me.
It happened after I played with the Region & Language setting plug. I changed the "Number and dates" language/format. After a log out/log in, it had dissapeared.

Exactly what I did... Except I'm kind of a noob when it comes to using
terminal and I am too dumb to know how to fix it, even though I know what I
must do...

2014-08-22 10:28 GMT-03:00 Philippe <email address hidden>:

> Same bug for me.
> It happened after I played with the Region & Language setting plug. I
> changed the "Number and dates" language/format. After a log out/log in, it
> had dissapeared.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1356698
>
> Title:
> Date and time disappeared from top panel
>
> Status in elementary OS:
> New
> Status in WingPanel:
> New
>
> Bug description:
> Date and time disappeared from the center of top panel
>
> ProblemType: Bug
> DistroRelease: elementary OS 0.3
> Package: elementary-desktop 1.349+393~ubuntu0.3.1 [origin:
> LP-PPA-elementary-os-daily]
> ProcVersionSignature: Ubuntu 3.13.0-33.58-generic 3.13.11.4
> Uname: Linux 3.13.0-33-generic x86_64
> ApportVersion: 2.14.1-0ubuntu3.3
> Architecture: amd64
> CrashDB: elementary_meta
> CurrentDesktop: Pantheon
> Date: Thu Aug 14 07:07:24 2014
> InstallationDate: Installed on 2014-08-13 (0 days ago)
> InstallationMedia: It
> SourcePackage: elementary-meta
> SuspiciousXErrors:
>
> ThirdParty: True
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/elementaryos/+bug/1356698/+subscriptions
>

--

*Luís Roberto Weck*
*Bacharelado em Sistemas de Informação - UDESC/CEAVI*
*Turma 2013-1*

Belenos (belenos) wrote :

Thanks @hassan-zombie! The date/time is back again.

Damn, Could you people describe exactly how to save the document? I'm kind
of a n00b here..

2014-08-25 12:12 GMT-03:00 Belenos Govannnon <email address hidden>:

> Thanks @hassan-zombie! The date/time is back again.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1356698
>
> Title:
> Date and time disappeared from top panel
>
> Status in elementary OS:
> New
> Status in WingPanel:
> New
>
> Bug description:
> Date and time disappeared from the center of top panel
>
> ProblemType: Bug
> DistroRelease: elementary OS 0.3
> Package: elementary-desktop 1.349+393~ubuntu0.3.1 [origin:
> LP-PPA-elementary-os-daily]
> ProcVersionSignature: Ubuntu 3.13.0-33.58-generic 3.13.11.4
> Uname: Linux 3.13.0-33-generic x86_64
> ApportVersion: 2.14.1-0ubuntu3.3
> Architecture: amd64
> CrashDB: elementary_meta
> CurrentDesktop: Pantheon
> Date: Thu Aug 14 07:07:24 2014
> InstallationDate: Installed on 2014-08-13 (0 days ago)
> InstallationMedia: It
> SourcePackage: elementary-meta
> SuspiciousXErrors:
>
> ThirdParty: True
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/elementaryos/+bug/1356698/+subscriptions
>

--

*Luís Roberto Weck*
*Bacharelado em Sistemas de Informação - UDESC/CEAVI*
*Turma 2013-1*

For those of you struggling to save this file correctly and get it moved back into the etc folder here ya go.

Open the /etc/environment file with Scratch. It will telll you the file cannot be saved in its current location, save it to your home directory with the same file name. Now you can add the following to the beginning of the file.

LC_ALL="en_US.UTF-8"

Save the changes.

Open terminal and type.

sudo mv environment /etc/environement

Hit enter, it will ask for your password, enter it in and hit enter again.

Log out and log back in.

This solved the issue for me.

Dawid Deręgowski (venomen) wrote :

It doesn't have to be 'en_US' , you can use your own for example "pl_PL.UTF-8"

vik1234 (vik1234) wrote :

Thanks Hasan. That fixed my clock. But my other icons on the panel are also missing. I had a wifi icon, copy.com icon and a chrome notifications icon. How to get them back?

vik1234 (vik1234) wrote :

Latest update fixed it.

JoaoH (joao-machado-family) wrote :

For me, everytime I add a Google calendar to the Calendar app, the Date and time disappear. Restarting the laptop the date will initially load at login but then disappear. If I remove the Google calendar from the Calendar app and reboot then the Date and time in the panel will not crash and disappear.

As of August 29th, problem is still there and I ran all of the updates this morning and tested it out...

Umeneri (umeneri) wrote :

As of today, September 18th this still happens (and I used the "fix" described above). Right now this minute date/time just disappeard and I have no idea what I did to trigger it.

Daniel Fore (danrabbit) on 2014-10-04
Changed in elementaryos:
status: New → Confirmed
harris (harrismrubin) wrote :

Mine came back???? It was gone for a day and i randomly popped up.

Paweł Banach (pawlobanano) wrote :

Mine came back too.
I was figting with it and now don't know if that's the case it appears back in panel.

I don't even have my '/etc/environement' file changed.

'locale' function gives me this output:
LANG=en_US.UTF-8
LANGUAGE=en
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=pl_PL.UTF-8
LC_TIME=pl_PL.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=pl_PL.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=pl_PL.UTF-8
LC_NAME=pl_PL.UTF-8
LC_ADDRESS=pl_PL.UTF-8
LC_TELEPHONE=pl_PL.UTF-8
LC_MEASUREMENT=pl_PL.UTF-8
LC_IDENTIFICATION=pl_PL.UTF-8
LC_ALL=

So, is it actually fixed?

meese (meese) wrote :

If anyone still has this happening could you try disabling "Network Time" in Date & Time in System Settings and then log off/reboot? Also this bug happens in Ubuntu too.

Daniel Fore (danrabbit) on 2014-10-21
Changed in elementaryos:
milestone: freya-beta2 → freya-rc1
Daniel Fore (danrabbit) wrote :
summary: - Date and time disappeared from top panel
+ Date and time disappeared from top panel [$50]
Yeni Setiawan (sandalian) wrote :

Tried @hassan-zombie's tip, works like charm!

JaccoH (jacco) wrote :

In my case I noticed the indicator was simply not installed anymore! Apt-get fixed it. Although its not in the hour-format I configured. Its in 12h instead of 24h.

I am suffering more than you all. I have no network indicator, time & date display, keyboard indicator.

Giulio Sant (giulio-sant) wrote :

Personally, this issue has disappeared for quite some time now.

Paulo Molina (polochamps2004) wrote :

I can confirm this.

itschigs (chirag-visavadia) wrote :

This issue still exist for me, please find below details.
OS:
0.3 "Freya" BETA 2"

Let me know if you require more details.

Sapa Holliday (saparonia) wrote :

I have this bug. I have installed various things to customise and the latest was Alarm Clock. It hadn't disappeared at that time. I added Ubuntu repositories and updated but this brought in too many things I don't use such as Bluetooth and Email. (I access email online). I got rid of some of these and the Date, Time and Calendar disappeared. Have tried various fixes but none have worked.
I don't want to change opsys as I like Elementary. I could reinstall from disk but this would be a hassle due to my customisations.
I'm in UK, does anyone know the code?
Another thing that may be related is that I seem to have always been in Spain according to Google and Libre Office and I have to change the language for spellcheck every time. This I could live with but the date, time and calendar loss is a pain.

Sapa Holliday (saparonia) wrote :

Solved by synaptic install of indicator-datetime

Sapa Holliday (saparonia) wrote :

Occam's razor :)

davidak (davidak) wrote :

same problem; installed as beta1, indicator-datetime "is already the newest version"

i purged it and installed it again; still no time :(

Victor Martinez (victored) wrote :

This is actually an integration bug. It'd be interesting to see the debug output of the panel to determine if the indicator is being loaded or not. To print debug output:

1. Remove wingpanel from cerbere's list of monitored processes, or simply use 'killall wingpanel' more than 5 times in a row.
2. Run it from a terminal with $ wingpanel -d
3. Paste terminal output here.

Changed in wingpanel:
status: New → Incomplete

@Victor:

This is what I get:
[_LOG_LEVEL_INFO 07:55:06.050288] Application.vala:155: Wingpanel version: 0.2.4
[_LOG_LEVEL_INFO 07:55:06.050341] Application.vala:157: Kernel version: 3.13.0-46-generic
[_LOG_LEVEL_WARN 07:55:06.050533] [Gtk] Locale not supported by C library. Using the fallback 'C' locale.

Using Freya.
Had used English (Australia) with Ireland as locale.

8bit lucifer (8bit-lucifer) wrote :

To reproduce this bug you need a fresh install of Freya beta, go to region & language plug in switchboard.
There will be a white infobar telling you that the language packages are not fully installed, press on fully install language packages . Log out and in again, voila your time and date in wingpanel is gone.

BTW comment #10 wil fix it.

As said in #40 and others the language plug of switchboard also screwed my fresh installation of Freya beta.
I fixed it like adviced here:
https://github.com/dnschneid/crouton/wiki/Languages

I guess, that's the cleanest method. Wondering if it works for others, too?

Jason Yeomans (jyeo098) wrote :

Battery icon on my laptop also dissapeared when this bug started happening.

Daniel Fore (danrabbit) on 2015-04-11
Changed in elementaryos:
milestone: freya-rc1 → none
Alex Viscreanu (alexviscreanu) wrote :

The issue still happens on Freya Stable release. Happens when the popup at locale switchboard tells the language support is not complete.

I have just seen this on Terminal when trying to run the first batch of updates for Freya stable (by the way, the Date/Time indicator has disappeared in this session, but I haven't noticed whether it happened before or after running the update):

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
 LANGUAGE = "en",
 LC_ALL = (unset),
 LC_TIME = "en_US.UTF-8",
 LC_MONETARY = "en_US.UTF-8",
 LC_ADDRESS = "en_US.UTF-8",
 LC_TELEPHONE = "en_US.UTF-8",
 LC_NAME = "en_US.UTF-8",
 LC_MEASUREMENT = "en_US.UTF-8",
 LC_IDENTIFICATION = "en_US.UTF-8",
 LC_NUMERIC = "en_US.UTF-8",
 LC_PAPER = "en_US.UTF-8",
 LANG = "en"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
(Reading database ... 122677 files and directories currently installed.)

Running "locale -a", there appears "en_US.utf8" in the list of valid and available locations. Perhaps "en" being set as the value of the LANG and LANGUAGE variables is causing issues, since it probably doesn't resolve to "en_US.utf8"? Also, when I ran

update-locale LANG=en_US.UTF-8 LANGUAGE=en_US.UTF-8 LC_NUMERIC=en_US.UTF-8 LC_TIME=en_US.UTF-8 LC_MONETARY=en_US.UTF-8 LC_PAPER=en_US.UTF-8 LC_IDENTIFICATION=en_US.UTF-8 LC_NAME=en_US.UTF-8 LC_ADDRESS=en_US.UTF-8 LC_TELEPHONE=en_US.UTF-8 LC_MEASUREMENT=en_US.UTF-8 LC_CTYPE=en_US.UTF-8

in my previous Freya Beta 2 installation, the Date/Time indicator stopped disappearing.

An interesting observation: I tried running "update-locale" in my Freya stable installation as mentioned in my previous comment, and at first it seemed to fail, because I received the same Perl error messages from the "apt-get upgrade" command. However, by looking at the /etc/default/locale file, I noticed that the LANG and LANGUAGE variables had indeed been changed. Then, I rebooted, and now the "update-locale" command doesn't output errors anymore, thereby giving the impression that everything has finally been made alright by setting the LANG and LANGUAGE variables to "en_US.UTF-8". I will post here again in case anything significant happens.

Also, setting "LC_ALL" might have helped as well. The complete list of variables that have been changed to "en_US.UTF-8" (please notice that this name does resolve to the file "en_US. utf8") in my installation are

LANG
LANGUAGE
LC_ALL
LC_CTYPE

amingilani (amingilani) wrote :

Happened to me on a fresh Freya install after I changed the language settings.
Adding "LC_ALL=en_US.UTF-8" to the beginning of the file fixed it.

Sanjay Karki (snykri) wrote :

Same thing happened to me after I changed the language setting on Freya stable.

benjamin (jesuisbenjamin) wrote :

This happened also after changing language settings and rebooting.

Saputro Andi (sptandi) wrote :

still facing it in freya stable.. and comment #10 will fix it

benjamin (jesuisbenjamin) wrote :

@Saputro Andi, thanks indeed comment #10 fixed it. Thanks @Arvis Lācis.

Terrence Edwards (tedwards86) wrote :

I have this problem too... not sure when it occurred.

Daniel Fore (danrabbit) on 2015-06-21
Changed in wingpanel:
milestone: none → loki-beta1
Changed in elementaryos:
milestone: none → loki-beta1
marco dahms (dahmsdahmsdahms) wrote :

I did a test install and it somehow did not happen again with fully upgraded system... Maybe it sorted out itself with some updates?

amingilani (amingilani) wrote :

No, this is still a valid issue. It happens a while after you've installed Freya. Just redid it and and can still confirm.

Cody Garver (codygarver) on 2015-09-16
Changed in wingpanel:
importance: Undecided → High
Daniel Fore (danrabbit) on 2015-09-21
no longer affects: elementaryos
TC (smalltimer) wrote :

This bug has come up again after the updates last night. Really weird.

Daniel Fore (danrabbit) wrote :

I'm marking this as "fix committed" for Loki, but "Won't fix" for Freya. There's some kind of interaction with certain locales that is breaking this for the ayatana datetime indicator. In Loki, we've replaced this indicator with a new libwingpanel indicator that so far doesn't seem to exhibit this problem.

Changed in wingpanel:
status: Incomplete → Confirmed
milestone: loki-beta1 → none
milestone: none → loki-alpha1
status: Confirmed → Fix Committed
opensas (opensas) wrote :

I had uninstalled evolution* packages (I thought I didn't need them) and the time indicator dissapeared

I reinstalled it with: sudo apt-get install --reinstall indicator-datetime

logged out and everything went fine

I got my wingpanel time back by doing 2 things:

1) ensure LC_ALL is not set by any of my login scripts (.profile, .bashrc, etc.). In particular, I had a script setting it to "C", because I prefer legacy sorting from "ls" in the shell. I simply changed that setting so it only ran in *interactive* shells.

2) I renamed $HOME/.local/ to $HOME/.local.old/ , followed by a logout/login. I had to manually restore some settings (swaps caps lock & esc) but not others (keyboard layout). The time in wingpanel came back - hurray! Any attempts to change from AM/PM to 24hour get ignored, but I can live with that.

I had tried all of the above suggestions (/etc/environment, +++), and I'm sure some of those other attempts are still in play, but not $HOME/.pam_environment . Since things are now working for me, I'm inclined not to mess with it.

Karl Morrison (karl-morrison) wrote :

This bug just hit my laptop!

Karl Morrison (karl-morrison) wrote :

Can confirm that opensas' workaround fixed the issue.

sudo apt-get install --reinstall indicator-datetime

Then logout and login.

Daniel Fore (danrabbit) on 2016-06-13
Changed in wingpanel:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers