Better controls for specifying preference of strong and weak soldiers

Bug #1202228 reported by Hans Joachim Desserud on 2013-07-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

(See bug 1202040 for the graphics used, this bug concerns the usability)

We recently got controls for setting a preference in military buildings whether we want strong or weak soldiers in it. It can be found as a button in the lower right corner in any millitary building window. It displays the icon for either strong or weak soldiers as well as a corresponding tooltip text if you hover. However, this button is ambigious.

The problem is that it is not clear whether the option displayed is the currently selected one, or one you can change to. It might display the current state, allowing you to click on it to change it. Or it might display the state you can change to, though not displaying the current state. This isn't really clear to a user unless he/she toggles it a bit to find out how it works. Compare this with the upgrade or dismantle buttons which clearly indicate that clicking on it would change the building to the state depicted.

The simple solution would be to always display both buttons, and then place a colored border around the selected one. However, with military buildings which can be upgraded (like Fortress), we are already low on space, so I'm not sure if this is the _best_ solution.

Related branches

Nasenbaer (nasenbaer) wrote :

I complete agree and was already up to write my own bug report - you beat me to it :-D.

My suggestion would be to improve the hover text to e.g. "Heroes - click button to switch to Beginners" - but well it seems to me all good and understandable texts would be quite long... ;) Any idea on a plain, good Text that makes the current and the state after click understandable?

Further I think it is a unlucky approach to close the window as soon as the button was clicked. I know this problem comes out of the graphic change of the clicked button, which lead to reinitialization of the window. But as I had the same problem with the port and the ship windows in the seafaring branch, I added a function to reinitialize the window after such a change - that could be used here as well :)

Changed in widelands:
status: New → Confirmed
SirVer (sirver) on 2013-07-18
Changed in widelands:
assignee: nobody → cghislai (charlyghislain)
assignee: cghislai (charlyghislain) → Teppo Mäenpää (kxq)
SirVer (sirver) wrote :

Teppo, I took the freedom to assign you to this. Maybe you have some time to work on it, otherwise someone else will work on this before feature freeze I guess.

I personally think that this should be solved using a radiobutton that mimicks the ware priority red-light approach. Only that this one only has two states. It could be part of or displayed next to the soldier display and the buttons can be full size.

The toggling of the one button would depress the other one and therefore convey very clearly which option is enabled.

Hans Joachim Desserud (hjd) wrote :

>I personally think that this should be solved using a radiobutton that mimicks the ware priority red-light approach.

That's a really good idea. :)

I wonder, how do we want to place these for military buildings with two rows of soldiers? Do we want place a button after each row or show them both at the end of the last row? I think stacking them at the bottom might look odd, but I'm slightly worried about the potential space we would get between them for each row, would it still be clear they are connected?

Teppo Mäenpää (kxq) wrote :

Originally, I thought of using radio buttons like suggested above. I could not place them neatly anywhere, and went for the current solution.

The current logic has been copied from "stop work" / "resume working" buttons in productionsite windows, and personally, I do not see problems. I have also tried putting two buttons where we now have one, and cannot recall any problems with that. In other words, the simple solution suggested in the original bug report would work.

I would also consider changing MilitarySite::get_statistics_string() to return "now preferring rookies/heroes" for a short period of time, like 5 seconds, after the preference button has been clicked. This would be my preferred solution, unless keep-as-is is also considered.

If radio buttons are preferred, then would somebody volunteer actually doing just that?

What should we do?

SirVer (sirver) wrote :

> The current logic has been copied from "stop work" / "resume working" buttons in productionsite windows, and personally, I do not see problems. I have also tried putting two buttons where we now have one, and cannot recall any problems with that. In other words, the simple solution suggested in the original bug report would work.

The reason here is that we already have the wares priority - it is a concept the players already know and needs no further explanation. The radiobutton can live below the list of soldiers, centered and can have full size I think (20px). I am not concerned about looks - if people dislike it they will come up with a cleaner look and provide concept graphics for us.

Stop/start is quite a different concept than prefer strong/prefer weak IMHO. Also the statistics string is a new concept - we never show replies to user actions in the statistics string. I do not see the need to introduce this concept into the game.

> If radio buttons are preferred, then would somebody volunteer actually doing just that?
Well, this has been targeted for b18. In the past, when the feature freeze came near, we all crunched and fixed those "unliked bugs" one by one. So far we made the deadline every time - I do not doubt we will again this time.
Do not feel obliged or pressured to work on this if you do not want to. You already implemented the feature which is great and more than we could have asked for! You do not have to do all followup work that falls out of this - especially if you do not feel that it improves the feature by much. But if you would do it, it would be very, very cool of course 8).

Changed in widelands:
assignee: Teppo Mäenpää (kxq) → nobody
Teppo Mäenpää (kxq) wrote :

>Stop/start is quite a different concept than prefer strong/prefer weak IMHO.

If there were no IMHO parts in this discussion, things would be so easy..

I have been planning to add at least one more preference: Prefer evade-only trained soldiers. I would not like to promise to finish it by the coming feature freeze. This would of course work equally well with the traffic light option. However, if there would be a fourth option, traffic lights would no longer work. Radio buttons would, of course, still be an option.

> Do not feel obliged or pressured to work on this if you do not want to.

I tried the traffic lights, and the outcome hurt my eyes. Therefore I would like somebody else to do that particular change.

> we never show replies to user actions in the statistics string. I do not see the need to introduce this concept into the game.

You are right. I have taken a look at some ancient version for the sake of curiosity, and believe you: Such thing has never been done. I do not see any problems in doing that now, but if you do not like it, I will not push.

I am reading between lines that traffic lights are your preferred option. If so, then could this bug report be reassigned?

SirVer (sirver) wrote :

> If there were no IMHO parts in this discussion, things would be so easy..
This is pretty much the definition of discussion :).

> Radio buttons would, of course, still be an option.
I think this is the way to go. I didn't actually mean to use red lights, but only meant to suggest using radiobuttons.

> Therefore I would like somebody else to do that particular change.
I already unassigned you. I didn't mean to force you to work on this by assigning you in the first place, I am sorry if this was the impression. I just thought that you would be interested in this bug report (as it is user feedback for your change) and might not see it otherwise.

> I do not see any problems in doing that now, but if you do not like it, I will not push.
There is no real problem to that, except for that it introduces a new thing into Widelands that we did not have before and we have other ways of conveying changing informations to the user, so it seems unnecessary and adds complexity. I think it does not make a lot of sense - and there are other things to think about: e.g. users can disable the statistics strings and will not see informations in them.

> I am reading between lines that traffic lights are your preferred option. If so, then could this bug report be reassigned?
I would love to see Radiobuttons. Bjorn agreed to make graphics for buttons, so they should work out nicely then.

SirVer (sirver) wrote :

Bjorn made a bunch of graphics for a radiobutton:
derkex.eu/wl/msite_prefer_heroes.png
derkex.eu/wl/msite_prefer_rookies.png

Changed in widelands:
assignee: nobody → SirVer (sirver)
SirVer (sirver) on 2013-07-24
Changed in widelands:
status: Confirmed → In Progress
Nasenbaer (nasenbaer) wrote :

I guess this is fix committed as well as both the code and the new pictures are in trunk

Changed in widelands:
status: In Progress → Fix Committed
SirVer (sirver) on 2013-09-23
Changed in widelands:
assignee: SirVer (sirver) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers