Panel opacity toggle doesn't quite work

Reported by George Karavasilev on 2012-02-24
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Unity
Low
Marco Trevisan (Treviño)
unity (Ubuntu)
Low
Marco Trevisan (Treviño)

Bug Description

Ok, just noticed a really annoying but about the "Panel Opacity Toggles".
Steps to reproduce:
1) Enable "panel opacity toggles" and set the panel opacity to some random value (for example I've used 0.6800)
B) Open a non maximized window on some workspace
C) Open a maximized one on another workspace
D) Go back to the workspace with the non maximized one and make sure the panel gets transparent
E) Now go the workspace with the maximized window:
1) What happens - the panel is still transparent
2) What should happen - the panels should go opaque
F) That can be fixed for this window in specific my unmaximizing it and maximizing it again or just by activating and deactivating the Dash, but it's a bug and it should not happen :)
P.S. I can record a video if needed :)

Sorry, I can't reproduce that on precise.

Bilal Akhtar (bilalakhtar) wrote :

Neither can I reproduce this.

OK, just get and watch the video:
http://ubuntuone.com/5sYOfmemI4YnDRuQRQnj8Q
(And don't laugh and my adorable accent ... at least not a lot :D)

OK, ffmpeg sucks, so I just have to explain it.
I use Expo for switching from one workspace to another, but ffpmeg didn't recorded that.
Also, when I say "by doing that" I mean "unmaximizing and maximizing the window" and "activating and deactivating the Dash" :)

Ah, using the switcher button. I was using the shortcuts, sorry.
/me fixing it.

Changed in unity:
status: New → In Progress
milestone: none → 5.6.0
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → Low

I was not using the workspace switcher icon, I was using expo edge binding (bottom right).
Also, I can also reproduce it using the keyboard shortcuts (Super+S, Ctrl+Alt+Arrow).

Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Hanine HAMZIOUI (hanynowsky) wrote :

I confirm the bug on 12.04 amd64 . I have just noticed it today when
Activating/deactivating the dash might work around it.

Can reproduce it this way:

Reduce all windows, Go to compiz Settings (Or a dedicated tool like MyUnity), set Panel Opacity to a value close to full transparency, set Toggle Max Windows to ON : The Panel transparency is reset to 0. Maximize a window and reduce and maximize it, nothing changes.
Go to compiz again to set Panel transparency value: it has no effect.
Activate then deactivate the dashboard: the panel transparency is back.

Hanine HAMZIOUI (hanynowsky) wrote :

Symptom Addition:

While Maximize Windows Toggle is on,
In a dual monitor desktop, the opacity toggle is supported in only one monitor, despite the fact that the displayed windows are maximized in both screens.

See screenshot.

Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
Omer Akram (om26er) on 2012-04-01
Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
darkmatch (alexanderr-otto) wrote :

Isn't fixed on me ...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers