Launcher - Properly colorize icons

Bug #938620 reported by Andrea Cimitan on 2012-02-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Andrea Cimitan
Unity
Fix Released
Medium
Andrea Cimitan
unity (Ubuntu)
Medium
Andrea Cimitan

Bug Description

In the current implementation launcher icons get desaturated and become more transparent. They should be colorized instead (for example, desaturating the icon and blend it with OVERLAY blending operator) and not lose in transparency.

The animation from state A (fully normal colored) to be (wallpaper-colorization for icons) could be applied by calculating the wallpaper-colorized version of the icon and paint with alpha from 0.0 to 1.0 above the state A icon.

Screenshot of the bug: http://i.imgur.com/qYNSZ.png

Related branches

Andrea Cimitan (cimi) on 2012-02-22
Changed in ayatana-design:
assignee: nobody → Andrea Cimitan (cimi)
status: New → Fix Committed
Changed in unity:
milestone: none → 5.6.0
description: updated
Changed in unity:
importance: High → Medium
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2012-02-23
Changed in unity:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Andrea Cimitan (cimi) on 2012-03-08
Changed in unity:
milestone: 5.6.0 → 5.8.0
Andrea Cimitan (cimi) wrote :

http://i.imgur.com/qYNSZ.png screenshot of the bug

description: updated
Andrea Cimitan (cimi) on 2012-03-22
Changed in unity:
assignee: nobody → Andrea Cimitan (cimi)
milestone: 5.8.0 → 5.10.0
Changed in unity (Ubuntu):
assignee: nobody → Andrea Cimitan (cimi)
Andrea Cimitan (cimi) on 2012-03-22
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Nick Tait (jnick-tait) on 2012-04-26
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers