Launcher - Inserting items into launcher makes unnecessary animations on other monitors

Bug #925021 reported by Joshua R. Poulson on 2012-02-01
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
Fix Released
High
Andrea Azzarone
Unity Distro Priority
High
Unassigned
unity (Ubuntu)
High
Andrea Azzarone

Bug Description

Setup: two monitors side by side with nvidia-current/nvidia-settings "twinview" mode.

Unlock firefox from launcher
Search for firefox, grab the icon and insert it into the launcher
The launcher on both monitors will spread to indicate possible placement of the icon for firefox, but it really should only spread on the current monitor.
When complete, the firefox icon is added to both monitors, but the animation is a streak of the icon across the left monitor into the launcher, which seems disturbing.

Related branches

Joshua R. Poulson (jrp) on 2012-02-01
tags: added: 5.2-rc1
tags: added: multimonitor
Omer Akram (om26er) wrote :

Added ayatana-design as affects to get design feedback

Changed in unity:
status: New → Incomplete
status: Incomplete → Confirmed
Omer Akram (om26er) on 2012-02-02
Changed in unity:
importance: Undecided → Low
Omer Akram (om26er) wrote :

video to show the problem

Didier Roche (didrocks) wrote :

John says critical, seeing the other issues we have, I'll put it as "High"

Changed in ayatana-design:
status: New → Fix Committed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in ayatana-design:
importance: Undecided → High
Changed in unity:
importance: Low → High
Changed in unity-distro-priority:
importance: Undecided → High
status: New → Fix Committed
Changed in unity (Ubuntu):
importance: Undecided → High
John Lea (johnlea) on 2012-02-07
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
tags: added: udp
Changed in unity:
milestone: none → backlog
Omer Akram (om26er) wrote :

this http://bazaar.launchpad.net/~unity-team/unity/trunk/revision/1947 might have fixed the issue, atm can't test multimonitor though.

Didier Roche (didrocks) wrote :

no, it's not fixed.

Changed in unity:
milestone: backlog → 5.6.0
John Lea (johnlea) on 2012-02-16
summary: - Inserting items into launcher makes unnecessary animations on other
- monitors
+ Launcher - Inserting items into launcher makes unnecessary animations on
+ other monitors
Andrea Cimitan (cimi) on 2012-02-17
tags: added: top5p
Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: High → Critical
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Didier Roche (didrocks) on 2012-03-14
Changed in unity:
milestone: 5.8.0 → none
Angelo Compagnucci (angeloc) wrote :

Which should be the desired behaviour?

I'm testing with unity trunk (rev 2112) and a multimonitor setup, I think there is no problem.

When I drag an icon from dash to launcher, an empty space it's created on both launchers, signalling that the icon will be inserted on that place on both launchers. The animations works great, both sliding and inserting one.

I think that this bug could be closed.

Andrea Azzarone (azzar1) on 2012-03-26
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
milestone: none → 5.10.0
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Andrea Azzarone (azzar1) on 2012-03-30
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Tim Penhey (thumper) on 2012-04-16
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-04-16
Changed in ayatana-design:
status: Fix Released → Fix Committed
Nick Tait (jnick-tait) on 2012-04-26
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignq
removed: udp
John Lea (johnlea) on 2012-09-05
tags: added: reviewedbydesignp
removed: reviewedbydesignq
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments