Compiz add transparency to titlebar along with the panel

Bug #912682 reported by Owais Lone
98
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Sam Spilsbury
4.0
Fix Released
High
Sam Spilsbury
unity (Ubuntu)
Medium
Unassigned
Oneiric
High
Unassigned

Bug Description

When using a translucent panel using CCSM, compiz also adds the transparency value to the titlebar of unmaximized apps.

I noticed this in unity trunk, ppa:unity-team/staging to be more precise.

Version: 5.0.0~+bzr1815ubuntu0+611

Update:
-------

Just noticed that overlay scrollbars thumb also turns transparent

Testcase:
---------

Change the panel opacity in CCSM
Move a window
The decorations should not be transparent

Related branches

Revision history for this message
Owais Lone (loneowais) wrote :
description: updated
Revision history for this message
Bilal Akhtar (bilalakhtar) wrote :

This is intended, isn't it? Or am I missing something?

Revision history for this message
Owais Lone (loneowais) wrote :

No. Only the top panel should turn transparent nothing else.

Revision history for this message
Owais Lone (loneowais) wrote :

BTW, the screenshot is an unmaximized window.

Omer Akram (om26er)
tags: added: pre5
Revision history for this message
Bilal Akhtar (bilalakhtar) wrote :

Can you double-check in the list of running processes if you're using unity-window-decorator or gtk-window-decorator?

Revision history for this message
Bilal Akhtar (bilalakhtar) wrote :

Might be an issue with gtk-window-decorator because I can't reproduce it with unity-window-decorator here.

If it doesn't help, try if unity --reset fixes the issue.

Changed in compiz (Ubuntu):
status: New → Incomplete
Changed in unity:
status: New → Incomplete
Revision history for this message
Owais Lone (loneowais) wrote :

No, this is not a bug in gtk-window-decorator. It's not running on my machine. I don't this even is a bug in unity-window-decorator because ayatana-scrollbars become transparent too. The problem is somewhere in compiz.

Revision history for this message
Owais Lone (loneowais) wrote :

What fixes the issue is making the panel 100% opaque.

Revision history for this message
Owais Lone (loneowais) wrote :

Ok, now this is being touted as 5.0's new feature https://twitter.com/#!/Chris_Wilkinson/status/157903375470563328/photo/1

Revision history for this message
George Karavasilev (kokoto-java) wrote :

The funny thing is this bug can become a nice little feature, however if it's to become one it needs blur, just like the Dash and the Panel :)

Revision history for this message
Owais Lone (loneowais) wrote :

Seriously, is this a feature or a bug?

Revision history for this message
George Karavasilev (kokoto-java) wrote :

Well, there is not an option for titlebar opacity in CCSM, which kinda indicates that this is more of a bug, but even if that's a fact, I still consider it more of a feature.
Anyway I am in favour of adding blur and making option in CCSM for "titlebar opacity"

Revision history for this message
George Karavasilev (kokoto-java) wrote :

And one. more thing: If this "thing" is to become a feature the windows controls (e.g. close, minimize and maximize buttons) should *not* become transparent.

Revision history for this message
Chris Wilkinson (chrisw-firedroplet) wrote :

I vote for feature.

Obviously people might want to have different transparency levels for the panel and titlebar. However the matching transparency levels look good. Having the blur would improve readability of the titles etc.

Revision history for this message
Cassidy James Blaede (cassidyjames) wrote :

 I'm gonna chime in and say it's a bug. Doing this breaks the coherency provided by the new titlebar and toolbar themes that blend together really well.

Revision history for this message
Marco Biscaro (marcobiscaro2112) wrote :

If it's a feature, it's broken because of buttons (comment #13) and because it looks really ugly with light themes (see the attached screenshot; it looks bad when using, for example, Radiance).

Revision history for this message
Marco Biscaro (marcobiscaro2112) wrote :

@smspillaz, can you help us? :)

Revision history for this message
George Karavasilev (kokoto-java) wrote :

Thinking of what @CassidyJames said and from pure design point of view I don't consider transparent titlebars to be a good idea, because they break the consistency with the window bellow them *BIG* time (Win 7, anyone). That means even if this ... well whatever it is becomes a feature (gets fixed to look nice with all themes, buttons should stay opaque etc...) it should not come enabled out of the box.
Also, if "panel transparency" also affects the thumbs of the overlay scrollbars, that's gotta be a bug.

Revision history for this message
Andrea Azzarone (azzar1) wrote :

I think it's a bug.

Revision history for this message
syscon-hh (syscon-kono) wrote :

Additionally the background of the "root-terminal" (/usr/bin/x-terminal-emulator) is involved in the same manner.

Depending the theme, it could happen, no character could be read anymore.

For me it's a bug, too!!

Revision history for this message
Joseph Chereshnovsky (joseph.chereshnovsky) wrote :

Have the same issue on panel opacity < 1

Revision history for this message
Omer Akram (om26er) wrote :

Nothing much have changed in compiz in Precise, just the SRU from oneiric was take in so is mostly a unity BUG.

tags: removed: pre5
Changed in unity:
importance: Undecided → Low
Changed in compiz (Ubuntu):
importance: Undecided → Low
Changed in unity:
status: Incomplete → New
Changed in compiz (Ubuntu):
status: Incomplete → New
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Omer Akram (om26er)
tags: added: regression-proposed
Changed in unity:
importance: Low → High
Changed in compiz (Ubuntu):
importance: Low → High
affects: compiz (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
importance: High → Low
importance: Low → High
Changed in unity:
status: New → Confirmed
Revision history for this message
Omer Akram (om26er) wrote :

I am still not able to reproduce this bug on my system, I have the transparent panel but dont see the issue o_O

Revision history for this message
Omer Akram (om26er) wrote :

aha, so the issue Does not happen on my nvidia machine with the nvidia-current but on my netbook it happens which have intel graphics.

Revision history for this message
Omer Akram (om26er) wrote :

sorry, its all confusing; I see it on both intel and NVIDIA.

since the issue is also happening in unity 4.28.0 (the -proposed oneiric update) where there are not much changes, it might be easier to hunt the responsible commit. (BigFBO ?)

Revision history for this message
George Karavasilev (kokoto-java) wrote :

I *can* confirm that it happens for Intel and ATi videos (the 2nd with both fglrx and the open source driver), however I'm unable to replicate it with nVidia card (with both - the proprietary and the open source driver). It's weird.
My Intel and ATi machines both run Unity 5.0 and the nVidia 4.28.0 and according to @om26er it *should* be happening to all of the machines ... weird.

Omer Akram (om26er)
Changed in unity (Ubuntu Oneiric):
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu Oneiric):
status: New → Confirmed
Revision history for this message
Markus Birth (mbirth) wrote :

It is definately a bug, because the transparency is also applied to terminal windows (tried with Terminal and Terminator). And if you have already set a transparency value, they are added up.

If this should be a feature, then please make panel and titlebars configurable separately.

Revision history for this message
Omer Akram (om26er) wrote :

I have reduced the importance for Unity(upstream) and unity in precise since its a non-standard option but kept the priority high for the stable series since its a regression there

Changed in unity:
importance: High → Medium
Changed in unity (Ubuntu):
importance: High → Medium
Didier Roche (didrocks)
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Omer Akram (om26er)
Changed in unity:
status: Confirmed → In Progress
milestone: none → 5.2.0
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
description: updated
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello Owais, or anyone else affected,

Accepted unity into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Revision history for this message
Owais Lone (loneowais) wrote :

Hey Martin,

I'm sorry but I can't test the packages in proposed as I've only Precise installed on my laptop. I can confirm it works fine on precise.

Revision history for this message
George Karavasilev (kokoto-java) wrote :

Hi Martin, I can cconfirm it's fixed in Unity 5.x in Precise and Oneiric (via the staging PPA).
However I can't test for Unity 4.x for Oneiric, at least not now.
I guess it should be tagged as "Fix Rleased" for milestone Unity 5.2.0 "Greased Weasel"

Revision history for this message
George Karavasilev (kokoto-java) wrote :

I can confirm it's fixed in Ubuntu 11.10 Unity 4.30 from the proposed repo :)
Evidence: see the screenie :)
It think it's pretty safe to say that it can be tagged as "Fix Released :P

Omer Akram (om26er)
tags: added: verification-done
removed: verification-needed
Revision history for this message
Martin Pitt (pitti) wrote :

This only affected oneiric-proposed, so closing oneiric task now.

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Revision history for this message
Jan Schürmann (visionfactory.net) wrote :

wasn't fixed with latest updates from the staging ppa in Oneiric

Didier Roche (didrocks)
Changed in unity:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.2.0-0ubuntu1

---------------
unity (5.2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Unity needs a way to switch (tab) between windows on current workspace
      (LP: #863399)
    - compiz crashed with SIGSEGV in BamfLauncherIcon::NameForWindow()
      (LP: #865840)
    - Gradual degradation in desktop performance. (LP: #888039)
    - compiz (unity) crashes with SIGSEGV when a window is minimized.
      (LP: #918329)
    - FavoriteStore external change support (LP: #681503)
    - Launcher - Make Launcher left of screen reveal more responsive and less
      prone to false positives (LP: #765819)
    - Window auto-maximise functionality should be disabled on monitors with a
      resolution above 1024 x 600 (LP: #797808)
    - Dash: very high latency responding to input (LP: #828582)
    - Dash - Behaviour of the 'All' button in the Dash filters broken in
      several ways (LP: #841864)
    - alt-tab - The app title in the top left of the top bar should change as
      the alt-tab focus changes (LP: #855516)
    - Keyboard shortcut - Add keyboard shortcut hint overlay that is displayed
      when a user presses and holds the Super key (LP: #855532)
    - Unity crashes when started in an environment without utouch support
      (LP: #860707)
    - Dash - Remove Dash Home shortcut icons (LP: #885738)
    - Dash - Most Frequently Used apps change to Recently Used, without
      Launcher favorites (LP: #893214)
    - Should have a launcher on every monitor (LP: #915944)
    - Launcher autohide behaviour on multi-monitor (LP: #915946)
    - the unity wrapper should kill compiz before restarting it (LP: #919132)
    - Launcher - Implement workspace/launcher cross interactions (LP: #690143)
    - Application icons should only display windows from the current workspace
      in the window spread (LP: #689733)
    - Notification area ("system tray") missing when using dual monitors of
      different sizes, with their bottoms aligned (LP: #778256)
    - Clicking Nautilus launcher icon fails to open a Nautilus file explorer
      window when copying a file and all other Nautilus windows are closed /
      bamf should skip the taskbar (LP: #784804)
    - Dash - the search box is not aligned correctly relative to the Launcher
      BFB button (LP: #838904)
    - Dash - A expand/collapse arrow is missing from all the filter category
      headers (LP: #841870)
    - Dash - the filter buttons should not have a mouse over state
      (LP: #838901)
    - Dash - the "Filter results" text is the wrong size, wrong font weight,
      and aligned incorrectly in both the vertical and horizontal axis
      (LP: #863240)
    - Add SUPER+TAB switching mode that enables the user to switch
      applications via the Launcher (LP: #891620)
    - Software Centre - automatically add app icon to launcher (LP: #761851)
    - Compiz add transparency to titlebar along with the panel (LP: #912682)
    - The search box is too opaque and dark (LP: #913717)
    - Dash - Make statefulness of Dash Home and Dash Lenses consistent
      (LP: #914759)
    - Unity 5.0: "All" button for filters render as "..." (LP: #91...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers