Background colorization should use a different heuristic

Reported by John Lea on 2011-10-03
72
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
High
Robert Carr
unity (Ubuntu)
High
Unassigned

Bug Description

NEW ITERATION:
What is currently defective by design is the way unity is put on top of the background windows. It's a simple colored layer placed above stuff, with some nice blur to makes things more readable but it carries all the issues of washing out the resultant color of the dash, making it less crisp and vibrant.

A nice trick is to play with the underlying background windows (the damage area/pixmap taken from Compiz), blend them with colors, and place the resultant below the dash.

The steps are these:
1) Take the underlying pixmap
2) Blend this pixmap with a tweaked average color using OVERLAY operator
3) Blur the pixmap (as we currently do)
4) Put this new obtained pixmap below the dash
5) At this point, the dash could be just a solid dark layer even with a lower opacity

We might tweak the steps further, but the essential bits will remain the same because what will make the big difference is the blending described in step 2, that we are not doing now.

~~~

ORIGINAL BUG (FIXED Cimi):
The background of the BFB, Workspace Switcher, Lens, and Trash launcher icons tiles need to use a higher saturation of the average background colour of the wallpaper.

Currently the colour is not as prominent as shown in the design, compare the attached image "unity_desktop_24_06_11_02.png" to the current implementation (when using the default wallpaper). In the exact visual effect we are trying to achieve the colour takes on much more prominence.

Desired resolution:
- Increase the colour saturation in the BFB, Workspace Switcher, Lens, and Trash launcher icons

Related branches

lp:~cimi/unity/saturated-dash-bg-color
Merged into lp:unity at revision 1813
Gord Allott (community): Approve on 2012-01-04
lp:~unity-team/unity/new-dash-blending
Merged into lp:unity at revision 2130
Robert Carr: Approve on 2012-03-18
Tim Penhey (community): Approve on 2012-03-18
Jay Taoko (community): Approve on 2012-03-13
John Lea (johnlea) wrote :
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Fix Committed
tags: added: onew udo
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2011-10-08
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
importance: Undecided → Medium
status: New → Confirmed
John Lea (johnlea) on 2011-10-18
Changed in unity:
milestone: none → backlog
tags: added: udp
Changed in ayatana-design:
status: Fix Committed → Triaged
John Lea (johnlea) on 2011-11-03
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
status: Confirmed → Fix Committed
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity:
status: Fix Committed → Confirmed
importance: Medium → High
Daniel van Vugt (vanvugt) wrote :

I actually thought that the launcher/dash using the wallpaper colour was a bug. It looks awful in my opinion, with all wallpapers I've tried, and can't be controlled.

IMHO, the launcher should not inherit ANY of the colour from the wallpaper because the end result is unpredictably dependent on the user's choice of wallpaper. And it's not configurable. But that's covered by bug 821810...

Daniel van Vugt (vanvugt) wrote :

Put another way... the launcher's colour should not be affected by colours not present under the launcher. It looks wrong.

The launcher colour should only be affected by the local wallpaper colours near it. This would easily be achieved by ensuring the launcher's colour is a shade of grey.

Andrea Cimitan (cimi) on 2011-12-13
tags: added: unity3p
Andrea Cimitan (cimi) wrote :

Patch is attached here: https://bugs.launchpad.net/ayatana-design/+bug/903645
But I'm not satisfied: I'd increase the opacity and reduce the darkness applied by 5%.

Daniel van Vugt (vanvugt) wrote :

Andrea, you patch seems dangerously arbitrary:

- hsv_color.saturation = std::min(base_hsv.saturation, hsv_color.saturation);
+ hsv_color.saturation = std::min(base_hsv.saturation, hsv_color.saturation) * 1.36;

I suggest making this a compiz config option instead, and you can make 1.36 the default value. Anything to do with choosing colours or opacities should be configurable. People won't log bugs if they have the option of changing colours themselves.

Andrea Cimitan (cimi) wrote :

@Daniel: indeed 36% more saturation is a value we decided with designers. It's the same if we make it configurable or so, all we need is to set it as default :-) (it seems to work well on different wallpapers too... was tested)

Daniel van Vugt (vanvugt) wrote :

Comment #6 still applies. Just because something was agreed on with designers doesn't change this (or even make it a good design decision IMHO).

I know there will be many people including myself who will hate the fact that colours from the right hand side of their wallpaper are bleeding into the launcher on the left. It really should be configurable for the user. Even if the configuration is buried in ccsm and subject to change in later releases...

Changed in unity:
assignee: Jason Smith (jassmith) → Andrea Cimitan (cimi)
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) wrote :

@Andrea Azzarone: Do not forget to set the target to the next milestone the bug so that we have an easy list of knowing what is closed. Thanks! :)

Changed in unity:
milestone: backlog → 5.0.0
Andrea Cimitan (cimi) wrote :

we might want to increase the opacity and reduce the darkness

Changed in unity:
status: Fix Committed → In Progress
Changed in unity (Ubuntu):
status: Fix Committed → In Progress
Gord Allott (gordallott) on 2012-01-12
Changed in unity:
milestone: 5.0.0 → 5.2.0
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
milestone: 5.2.0 → 5.0.0
Didier Roche (didrocks) on 2012-01-12
Changed in unity:
milestone: 5.0.0 → 5.2.0
Omer Akram (om26er) on 2012-01-30
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Andrea Cimitan (cimi) wrote :

I don't know if gord touched this, I doubt.

Changed in unity:
status: Fix Committed → In Progress
Changed in unity (Ubuntu):
status: Fix Committed → In Progress
Changed in unity:
assignee: Andrea Cimitan (cimi) → Gord Allott (gordallott)
Didier Roche (didrocks) on 2012-02-03
Changed in unity:
milestone: 5.2.0 → 5.4.0
Hernando Torque (htorque) wrote :

What about the device items, that pop up between workspace switcher and trash? They look out of place right now (see screenshot)

Omer Akram (om26er) on 2012-02-13
Changed in unity (Ubuntu):
importance: Medium → High
Gord Allott (gordallott) on 2012-02-13
Changed in unity:
milestone: 5.4.0 → 5.6.0
Andrea Cimitan (cimi) on 2012-02-14
summary: - Launcher - The background of the BFB, Workspace Switcher, Lens, and
- Trash launcher icons tiles need to use a higher saturation of the
- average background colour of the wallpaper
+ Background colorization should use a different heuristic
description: updated
description: updated
Changed in ayatana-design:
status: Fix Committed → In Progress
Andrea Cimitan (cimi) on 2012-02-14
description: updated
Andrea Cimitan (cimi) on 2012-02-14
description: updated
Andrea Cimitan (cimi) on 2012-02-14
description: updated
Andrea Cimitan (cimi) on 2012-02-14
description: updated
Andrea Cimitan (cimi) on 2012-02-14
description: updated
Andrea Cimitan (cimi) on 2012-02-17
tags: added: top5p
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: High → Critical
Andrea Cimitan (cimi) on 2012-02-23
Changed in unity:
assignee: Gord Allott (gordallott) → Robert Carr (robertcarr)
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.8.0-0ubuntu1

---------------
unity (5.8.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - New "push mouse offscreen" feature really difficult to get (LP: #923749)
    - unity-2d-panel crashed with SIGSEGV in
      unity::indicator::DBusIndicators::Impl::RequestSyncAll() (LP: #864737)
    - Pressing "Alt+Enter" causes compiz to crash in CompOption::value() from
      unity::UnityScreen::showLauncherKeyTerminate (LP: #960957)
    - SEGSIGV after unplugging external monitor (LP: #962693)
    - Background colorization should use a different heuristic (LP: #865239)
    - compiz+unity3d generates > 50 wakeups a second on idle system
      (LP: #917210)
    - [FFe, UIFe] HUD - The HUD does not respect launcher autohide or icon
      size settings (LP: #921506)
    - clicking on folders in the file lens does not open nautilus
      (LP: #921665)
    - No text inside multirange filters (LP: #927710)
    - can't alt-tab restore minimized uis which have an instance on another
      workspace (LP: #933397)
    - Ubuntu Software Center Unity launcher integration is not working
      (LP: #932280)
    - The line separator between the launcher and the dash is cleared when
      selecting a category (LP: #941082)
    - unity-panel-service crashed with SIGSEGV in g_hash_table_foreach()
      (LP: #937119)
    - Alt-F10 locks up Unity (LP: #948522)
    - multimonitor, launcher: Provide an option to display either a single
      launcher or a launcher on each display in a multi-monitor environment
      (LP: #950136)
    - multimonitor: Please give me a way to turn off sticky monitor edges
      (LP: #946104)
    - Unity 5.6: key bindings (such as Super) don't work on empty workspace or
      on slow/loaded systems (LP: #953089)
    - Alt+arrows keyboard shortcuts don't invoke Back and Forward navigation
      (LP: #953783)
    - HUD is sending 2 menu signals instead of 1 (LP: #956878)
    - 6th item of HUD not fully visible (LP: #957229)
    - HUD: seems to trigger operations more than once (LP: #960503)
    - Launcher gets always desaturated when using HUD on secondary monitor
      (LP: #961169)
    - [5.8 pre staging] launcher is displayed on the left screen, not the
      primary one (LP: #961281)
    - launcher icons do not re-saturate after dash is closed (LP: #961844)
    - Launcher shows arrows for applications on all workspaces (LP: #961977)
    - Dash - Implement overlay scrollbars in Dash (LP: #608124)
    - [UIFe] Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - Dash - Missing category separator line in dash (LP: #850984)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - When multiple results have equal string match relevancy ranking,
      those with equal ranking should be then sorted by frequency of use.
      (LP: #871900)
    - Keyboard shortcut - F10 shortcut is used to show m...

Read more...

Changed in unity (Ubuntu):
status: In Progress → Fix Released
John Lea (johnlea) on 2012-04-20
Changed in ayatana-design:
status: In Progress → Fix Released
status: Fix Released → Fix Committed
Nick Tait (jnick-tait) on 2012-04-26
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udo udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers