Dash doesn't get the focus on pressing the super key first time after login

Bug #860805 reported by Guruprasad on 2011-09-27
272
This bug affects 53 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Brandon Schaefer
Unity Distro Priority
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Login.
Press Super key.
Dash shows up.
Type to search in the dash.
No text is typed because the focus is not in the dash.
Click on the dash text box to get focus. The issue doesn't appear again.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.18.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu1
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,vpswitch,place,grid,resize,imgpng,mousepoll,snap,gnomecompat,regex,move,wall,unitymtgrabhandles,animation,session,workarounds,fade,expo,scale,ezoom,unityshell]
Date: Wed Sep 28 00:16:40 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110901)
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Guruprasad (lgp171188) wrote :
Neil J. Patel (njpatel) on 2011-09-28
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → High
milestone: none → 4.20.0
status: New → Confirmed
Alejandro Piñeiro (apinheiro) wrote :

For additional information take a look to bug 852506 comment 2.

Didier Roche (didrocks) on 2011-09-29
Changed in unity:
importance: High → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
tags: added: a11y
Didier Roche (didrocks) on 2011-09-29
Changed in unity:
milestone: 4.20.0 → 4.22.0
Alejandro Piñeiro (apinheiro) wrote :

Note: I have found a user workaround for the problem of the dash not being closed pressing Esc.

The workaround is the next one:

   * Press Alt+F2: Dash is opened, without no focus
   * Press Alt+F1: Launcher receives the focus
   * Press Esc: no focus in any window
   * Press Alt+F2: Dash is opened, with focus

It is a nasty workaround, but at least the users could use the dash until this bug is solved.

Didier Roche (didrocks) on 2011-10-04
Changed in unity:
milestone: 4.22.0 → 4.24.0
Joschi Poschi (joschiposchi) wrote :

Is this inconsistency worked on? It really lowers the workflow (even if it is only once after booting up) and the overall impression I got of the very nice Unity design.

Didier Roche (didrocks) on 2011-10-17
Changed in unity:
milestone: 4.24.0 → 4.26.0
Changed in unity (Ubuntu Oneiric):
importance: Undecided → Medium
status: New → Confirmed
Alison Rowland (alisonrowland) wrote :

I am getting behavior like this, but not only the first time after login. Right now, it is all the time. If I have any window(s) open and I press the Super key, the dash opens only in the background, and makes my other windows completely unresponsive and unmoveable. I am not yet sure what triggered this, as it seemed to be working OK yesterday after I upgraded to Oneiric.

Alison Rowland (alisonrowland) wrote :

Apologies. I thought my system was up to date, but it was not. The problem appears to be resolved after a round of updates.

Bilal Shahid (s9iper1) wrote :

i have seen this issue many times and also easily reproduce able.also find a duplicate one of this bug
bug# 861738

Didier Roche (didrocks) on 2011-10-28
Changed in unity-distro-priority:
status: New → Fix Committed
Tim Penhey (thumper) on 2011-11-10
Changed in unity:
assignee: Neil J. Patel (njpatel) → Brandon Schaefer (brandontschaefer)
status: Confirmed → In Progress
Changed in nux:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Brandon Schaefer (brandontschaefer)
Tim Penhey (thumper) on 2011-11-14
tags: added: udp
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu Oneiric):
status: New → Confirmed
Changed in nux (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-11-22
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-11-22
Changed in nux (Ubuntu):
status: Confirmed → In Progress
Jesper de Jong (jespdj) wrote :

@alisonrowland This issue is not currently resolved. I have 4 different computers running Ubuntu 11.10 (32-bit and 64-bit), all up-to-date with the latest updates, and the issue is still there on all 4 of my computers.

Kostya Stat (statyan) wrote :

The common attitude I've found in Software update center (Ubuntu x64 11.10).
I've opened txt file from ntfs partition in gedit. There was some english text and some unreadable chars. I've tried to ctrl+c some text from gedit and paste it in other window. This didn't work. I've done this throu context menu in gedit - copypaste worked, but after that my keyboard doesn't type in Ubuntu Software update center. But it's still working in Dash, skype, firefox.
After system restart - all works fine, until I open a text file in gedit again...
Any suggessions ? Thanks!

Kostya Stat (statyan) wrote :

It also didnt work in terminal window after editing text in gedit

Omer Akram (om26er) on 2011-12-09
Changed in unity:
status: In Progress → Fix Committed
Changed in nux (Ubuntu):
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in nux:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2011-12-09
Changed in nux (Ubuntu Oneiric):
status: Confirmed → Triaged
no longer affects: unity (Ubuntu)
no longer affects: unity (Ubuntu Oneiric)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu Oneiric):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Luis Alvarado (luisalvarado) wrote :

Super confirmed. It even affects the first time you right click a launcher icons. When you hover the context menu of the launcher icon you can not select anything from it until you right click the icon again.

Joschi Poschi (joschiposchi) wrote :

@ Luis. The bug concerning the quicklists has a different report -> Bug #819721.

Rafael P. (rafael-p) wrote :

The bug does not happen in Unity 2D mode

Joschi Poschi (joschiposchi) wrote :

When is the fix going to be released? This is really frustrating and avoiding a smooth workflow.
And the killer phrase: what will people new to Ubuntu think when they try to use the Dash for searching the first time.

Hello Guruprasad, or anyone else affected,

Accepted unity into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Miklos Juhasz (mjuhasz) wrote :

This bug has been resolved. I have installed the proposed version on two laptops, logged in several times with different users, and the search bar always got the focus.

Martin Pitt (pitti) on 2012-01-13
tags: added: verification-done
removed: verification-needed
Omer Akram (om26er) on 2012-01-16
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-01-19
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Invalid

Didier: why was that marked invalid?

Omer Akram (om26er) on 2012-01-19
Changed in unity (Ubuntu Oneiric):
status: Invalid → Fix Committed
no longer affects: nux
no longer affects: nux (Ubuntu)
no longer affects: nux (Ubuntu Oneiric)
Omer Akram (om26er) wrote :

Didier meant to mark the nux task invalid it seems :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.28.0-0ubuntu2

---------------
unity (4.28.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick some additional fixes:
    - fix a regression where transparency is setup on the panel (LP: #830949)
    - the wrong commit causing a crash was revert. Revert the revert and
      revert the right guilty commit.

unity (4.28.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    - don't segfault in geis_configuration_get_value() (lp: #850623)
    - get focus on dash by pressing the super key first time after login
      (lp: #860805)
    - clicking on panel when dash is open no longer causes maximized window
      to raise (lp: #873100)
    - window management, alt-tab - After using 'show desktop' to minimise all
      windows, opening any new window also incorrectly restores all
      the minimised windows (lp: #871801)
    - compiz crashed with SIGSEGV in
      unity::switcher::SwitcherModel::DetailSelectionWindow() (lp: #834630)
    - compiz crashed with SIGSEGV in g_strcmp0() (lp: #832151)
    - compiz crashed with SIGSEGV in nux::BaseWindow::GetInputWindowId()
      (when onboard is used) (lp: #865890)
    - fix multi-monitor crashers (lp: #838128, #864037, #864784, #868120)
    - Fix SIGSEGV after SwitcherController desctruction (lp: #887465)
    - Fix for "right-clicking launcher when choosing a workspace causes
      quicklists to freeze" (lp: #791810)
  * debian/patches/add_postrelease_buildfix.patch:
    - add post-release fix to build in a clean env
  * backport some additional reverts or regression fixes
 -- Didier Roche <email address hidden> Thu, 19 Jan 2012 09:54:44 +0100

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers