Missing lens shortcuts (Super-A, Super-F)

Bug #834078 reported by David Barth on 2011-08-25
112
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Didier Roche
Unity Distro Priority
Undecided
Unassigned
unity-2d
Medium
Albert Astals Cid
unity (Ubuntu)
Medium
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

The new lenses are not accessible directly via the old places shortcuts: Super-A or Super-F.

Related branches

David Barth (dbarth) on 2011-08-25
Changed in unity:
status: New → Incomplete
importance: Undecided → Medium
milestone: none → 4.12.0
Neil J. Patel (njpatel) on 2011-09-01
Changed in ayatana-design:
assignee: nobody → Neil J. Patel (njpatel)
assignee: Neil J. Patel (njpatel) → nobody
status: New → Invalid
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
status: Incomplete → Confirmed
Didier Roche (didrocks) on 2011-09-01
Changed in unity:
milestone: 4.12.0 → 4.14.0
Omer Akram (om26er) on 2011-09-05
affects: ayatana-design → unity (Ubuntu)
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: Invalid → Confirmed
Didier Roche (didrocks) on 2011-09-07
Changed in unity:
assignee: Neil J. Patel (njpatel) → Didier Roche (didrocks)
Didier Roche (didrocks) on 2011-09-08
Changed in unity:
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-09-08
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.14.2-0ubuntu1

---------------
unity (4.14.2-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - unity crashed with AttributeError in reset_unity_compiz_profile(): 'str'
      object has no attribute 'get_string' (LP: #809378)
    - Trying to minimize Unity Dash to make it fit on a 1024x768 screen makes
      Unity freeze and then, after I log out by killing X, never start again
      (LP: #839200)
    - unity-panel-service crashed with SIGSEGV in main_arena() (LP: #817477)
    - UIFe: Panel - Indicators should be orderable regardless of their parent
      IndicatorObject (LP: #823061)
    - 'Show Desktop' fails to hand focus to desktop (LP: #836315)
    - Dash - Functionality of top left close, minimise and maximise/restore
      window decorations is confused (LP: #838875)
    - unity-panel-service Leaks Memory (LP: #779185)
    - Missing lens shortcuts (Super-A, Super-F) (LP: #834078)
    - Unity window switcher takes over <alt> key (LP: #835699)
    - update assets for window buttons (topleft) with dash opened
      (LP: #836655)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Applications don't have priority over other results (LP: #839518)
    - task tray icons are misaligned and badly sized (LP: #839354)
    - UIFe: Dash - Shape and positioning of most of the elements in the Dash
      need adjustment (LP: #841945)
    - Cannot drag applications from dash to desktop (LP: #756614)
    - systray icons still visible on each desktop in expo mode (LP: #759129)
    - transparency on unity panel broken (LP: #827012)
    - Window buttons and application menu don't autohide if left edge is
      touched (LP: #835637)
    - 'Filter results' should be right indented as in the mockups(and unity-
      2d) (LP: #838118)
    - window title should not appear until cursor leaves the menubar
      (LP: #838759)
    - Window title is not redrawn on leaving global-menu from buttons
      (LP: #839488)
    - In the dash, main text field can not be edited, except at the end
      (LP: #840862)
    - Quicklist can't be correctly hidden (LP: #843425)
    - After double clicking on the panel to restore a window, the menus won't
      be hidden on mouse-out (LP: #838021)
    - After restoring a window the application title doesn't fade-out and it
      goes below the menus (LP: #838479)
  * debian/control:
    - build-dep on latest libunity-dev for ABI/API break, nux
  * debian/rules:
    - bump shlibs, remove tweak for garantuing the version as the ABI
      is considered stable until finale now.
 -- Didier Roche <email address hidden> Thu, 08 Sep 2011 20:07:50 +0200

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Yann Dìnendal (yannbreliere) wrote :

<Super>A & <Super>F still don't work, for me.

$ unity --version
unity 4.14.2

Yann Dìnendal (yannbreliere) wrote :

Sorry, I had not restarted my session. I can confirm it works. Thanks.

Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Medium
Gerry Boland (gerboland) on 2011-09-14
Changed in unity-2d:
assignee: nobody → Gerry Boland (gerboland)
milestone: none → 4.8
Changed in unity-2d:
milestone: 4.8 → none
milestone: none → 4.8
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-09-15
Changed in unity-2d:
milestone: 4.8 → 4.10
Changed in unity:
assignee: Didier Roche (didrocks) → nobody
assignee: nobody → Didier Roche (didrocks)
Changed in unity-2d:
assignee: Gerry Boland (gerboland) → nobody
milestone: 4.10 → none
status: In Progress → Triaged
Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d (Ubuntu):
status: New → Triaged
Maarten Boekhold (boekhold) wrote :

Confused by the last status update. Does this bug still exist in unity-2d? I'm asking cos I can't for the world of me get Super-A/F/... working. I'm tied to unity-2d since I am inside a VMWare VM.

ii unity 4.24.0-0ubuntu2b1 Interface designed for efficiency of space and interaction.
ii unity-2d 4.12.0-0ubuntu1 Unity interface for non-accelerated graphics cards
ii unity-2d-launcher 4.12.0-0ubuntu1 Unity 2D Launcher
ii unity-2d-panel 4.12.0-0ubuntu1 Unity 2D Panel
ii unity-2d-places 4.12.0-0ubuntu1 Unity 2D Places
ii unity-2d-spread 4.12.0-0ubuntu1 Unity 2D Spread
ii unity-asset-pool 0.8.22-0ubuntu1 Unity Assets Pool
ii unity-common 4.24.0-0ubuntu2b1 Common files for the Unity interface.
ii unity-greeter 0.1.1-0ubuntu1 Unity Greeter
un unity-icon-theme <none> (no description available)
ii unity-lens-applications 0.4.12-0ubuntu2 Application lens for unity
ii unity-lens-files 0.6.12-0ubuntu1 File lens for unity
un unity-lens-gwibber <none> (no description available)
ii unity-lens-music 0.2.6-0ubuntu2 Music lens for unity
ii unity-place-applications 0.4.12-0ubuntu2 transitional package
ii unity-place-files 0.6.12-0ubuntu1 transitional package
ii unity-scope-musicstores 0.2.6-0ubuntu2 Store music lens for unity
ii unity-services 4.24.0-0ubuntu2b1 Services for the Unity interface

boekhold 1859 1694 0 12:11 ? 00:00:28 unity-2d-launcher
boekhold 1861 1694 1 12:11 ? 00:00:45 unity-2d-panel
boekhold 2217 1 0 12:16 ? 00:00:17 /usr/bin/unity-2d-places
boekhold 2236 1 0 12:16 ? 00:00:00 /usr/lib/unity-lens-music/unity-music-daemon
boekhold 2237 1 0 12:16 ? 00:00:01 /usr/lib/unity-lens-files/unity-files-daemon
boekhold 2238 1 0 12:16 ? 00:00:01 /usr/lib/unity-lens-applications/unity-applications-daemon
boekhold 2288 1 0 12:16 ? 00:00:00 /usr/lib/unity-lens-music/unity-musicstore-daemon
boekhold 6138 1 2 13:12 ? 00:00:14 /usr/lib/unity/unity-panel-service
boekhold 6436 2374 0 13:23 pts/0 00:00:00 grep --color=auto unity

Jim Holman (jdholman) wrote :

Hello:
I am on Unity 4.24.0 and it does not work for me:

jim@jim-Precision-M6400:~$ unity --version
unity 4.24.0

Pressing <Super>-A opens a small white box in the lower-right corner of my display. I can type a few characters in here, but nothing happens and the box disappears after a few seconds.

Not sure what this is and what happened to the Application lens.

Jim

Didier Roche (didrocks) on 2012-01-20
Changed in unity-distro-priority:
status: New → Fix Committed
Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
Changed in unity-2d:
assignee: nobody → Bartosz Kosiorek (gang65)
Changed in unity-2d:
status: Triaged → In Progress
Gerry Boland (gerboland) on 2012-03-30
Changed in unity-2d:
milestone: none → 5.10.0
JaSauders (jasauders) wrote :

Just a few moments ago, I did a:

sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade

I ran it twice, then rebooted. I am running 12.04 32 bit and I noticed in 3D, they work fine, in 2D, they do not work.

Changed in unity-2d:
assignee: Bartosz Kosiorek (gang65) → Albert Astals Cid (aacid)
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-04-12
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.10.0-0ubuntu1

---------------
unity-2d (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - unity-2d-shell crashed with SIGSEGV in
      QCoreApplication::notifyInternal() (LP: #918566)
    - Unity-2d-shell crashes on startup on 64bit machines with 20+ tiles in
      launcher (LP: #967012)
    - Unity 2-d launcher doesn't hide or display properly (LP: #940590)
    - [dash] search terms aren't applied on lens change / dash show
      (LP: #947985)
    - [5.8 pre staging] "sticky edge" option does nothing visible
      (LP: #961285)
    - [dash] Maximise, then restore - much of background not removed from
      screen (LP: #968215)
    - [hud] shows up when using ctrl+alt and pressing alt first (LP: #972318)
    - [UIFe] Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Missing lens shortcuts (Super-A, Super-F) (LP: #834078)
    - [dash] Unable to scroll Filter Results (LP: #920878)
    - [launcher] stays open if you mouseOut before reveal animation completes
      (LP: #943296)
    - HUD on wrong screen on mutli monitor system (LP: #947145)
    - [a11y] Orca reports "Shell" when opening HUD, Dash or Launcher
      (LP: #948033)
    - multimonitor: Please give me a way to turn off sticky monitor edges
      (LP: #946104)
    - [dash] Esc key behavior inconsistent with Unity (LP: #966121)
    - toggling the spread from the launcher does not work (LP: #968146)
    - unity-2d-shell crashed with SIGSEGV in KeyMonitor::registerEvents()
      (LP: #965464)
    - [Dash] Focus is lost when switching with the mouse (LP: #974235)
    - Multiple items selected in HUD list (LP: #948441)
    - Hud hides launcher even if set to always show (LP: #948960)
    - [launcher] Pointer reveal barrier should be 1 way only (LP: #960175)
    - [hud] connection to HUD being created on startup (LP: #965106)
    - [dash] On 1024x786 screen, dash not fullscreen so border truncated
      (LP: #967305)
  * debian/20_ubuntu-2d-gconf-default:
    - set a default key for HUD showing on Alt, in case unity-3d isn't
      installed or run before unity-2d.
  * debian/control:
    - bump libnux-2.0-dev to latest for ABI break
 -- Didier Roche <email address hidden> Thu, 12 Apr 2012 11:02:08 +0200

Changed in unity-2d (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2012-04-17
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions