Dash text input does not get focus

Bug #774447 reported by Raven on 2011-04-30
62
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Gord Allott
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: dash

Found in 11.04 Natty Narwhal

I have yet to find the exact source of this bug, but occasionally when hitting super to get the dash, the text entry field in dash is not made the active widgit. As a result, the text I type will be entered into a textfield/textbox in the application I was previously using. Additionally, while in this state, the dash can not be closed again by pressing super or escape. It can only be closed by clicking on the top bar.

I'm sorry that I can not pinpoint the source, but this has happened to me multiple times already, so I thought fit to report it. I will try to find the source and report back if I do find it.

Related branches

Raven (ravenskrag) on 2011-04-30
description: updated
description: updated
description: updated
Jilles Tjoelker (jilles) on 2011-05-16
Changed in dash (Ubuntu):
status: New → Invalid
Omer Akram (om26er) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Jorge Gustavo (jgr) wrote :

I have no idea how to reproduce or debug this issue. Should I run unity in debug mode?
It is quite annoying, since the keystrokes goes to somewhere else.

$ cat /etc/issue
Ubuntu 11.04

$ uname -a
Linux cagliari 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

$ dpkg -l | grep unity | awk '{print $2, $3}'
gir1.2-unity-3.0 3.8.4-0ubuntu1
gnome-themes-ubuntu 0.6.1
libmeanwhile1 1.0.2-3ubuntu1
libunity-misc0 0.2.1-0ubuntu2
libunity4 3.8.4-0ubuntu1
unity 3.8.14-0ubuntu1~natty1
unity-asset-pool 0.8.20-0ubuntu2
unity-common 3.8.14-0ubuntu1~natty1
unity-place-applications 0.2.46-0ubuntu3.1
unity-place-files 0.5.46-0ubuntu5.1

I have not faced this issue, I know the issue is there as I have seen
other bug reports as well but its important that we have the steps to
reproduce the issue so that its easy and less time consuming for
developers to work on the fix

On Tue, Jun 28, 2011 at 2:57 PM, Jorge Gustavo <email address hidden> wrote:
> I have no idea how to reproduce or debug this issue. Should I run unity in debug mode?
> It is quite annoying, since the keystrokes goes to somewhere else.
>
> $ cat /etc/issue
> Ubuntu 11.04
>
> $ uname -a
> Linux cagliari 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
>
> $ dpkg -l | grep unity | awk '{print $2, $3}'
> gir1.2-unity-3.0 3.8.4-0ubuntu1
> gnome-themes-ubuntu 0.6.1
> libmeanwhile1 1.0.2-3ubuntu1
> libunity-misc0 0.2.1-0ubuntu2
> libunity4 3.8.4-0ubuntu1
> unity 3.8.14-0ubuntu1~natty1
> unity-asset-pool 0.8.20-0ubuntu2
> unity-common 3.8.14-0ubuntu1~natty1
> unity-place-applications 0.2.46-0ubuntu3.1
> unity-place-files 0.5.46-0ubuntu5.1
>
> --
> You received this bug notification because you are subscribed to unity.
> https://bugs.launchpad.net/bugs/774447
>
> Title:
>  Dash text input does not get focus
>
> Status in Unity:
>  Incomplete
> Status in “dash” package in Ubuntu:
>  Invalid
> Status in “unity” package in Ubuntu:
>  Incomplete
>
> Bug description:
>  Binary package hint: dash
>
>  Found in 11.04 Natty Narwhal
>
>  I have yet to find the exact source of this bug, but occasionally when
>  hitting super to get the dash, the text entry field in dash is not
>  made the active widgit.  As a result, the text I type will be entered
>  into a textfield/textbox in the application I was previously using.
>  Additionally, while in this state, the dash can not be closed again by
>  pressing super or escape.  It can only be closed by clicking on the
>  top bar.
>
>  I'm sorry that I can not pinpoint the source, but this has happened to
>  me multiple times already, so I thought fit to report it.  I will try
>  to find the source and report back if I do find it.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/774447/+subscriptions
>

Jorge Gustavo (jgr) wrote :

i) Today I noticed that this happens on the first time I access dash with the Super key. After booting and after some hard work (ie reading the email) I pressed the Super key and the dash appears, but without focus. I also noticed that the dash didn't go way by clicking outside it. So, I had to hit Super again to hide dash. Afterwards, it is working as expected.

ii) I can reproduce the error. After a reboot, the dash does not get the focus after the first attempt (using the Super key), and can not be dismissed by clicking outside it.

Today I upgraded from unity 3.8.14-0ubuntu1~natty1 to unity 3.8.16-0ubuntu1~natty1 and the behavior is the same.

Can someone else reproduce the bug?

Jorge Gustavo (jgr) on 2011-06-29
Changed in unity:
status: Incomplete → Confirmed
Jorge Gustavo (jgr) wrote :

This bug can be reproduced (in my configuration) by:
compiz --replace
After compiz restarts, the dash can be activated with the Super key, but it does not get the focus.
I'm using:
nvidia 270.41.06-0ubuntu1
compiz 1:0.9.4+bzr20110606-0ubuntu1~natty1

Didier Roche (didrocks) on 2011-07-05
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Antti Boman (antti-boman) wrote :

I confirm the problem, too. When I access dash for the first time, whether with Super key or clicking the Ubuntu icon, the focus stays on the active application. Hiding the dash and reopening it solves the problem.

Sergio Zanchetta (primes2h) wrote :

I confirm this bug testing Oneiric Alpha 3 201100802.1.

How to reproduce.
Boot from a live usb, click on Super and try to type text.
You can't, even if you click on the dash search to get focus.

If you do something else (like opening an application), then next time you click on super the bug disappears.

tags: added: iso-testing
Jorge Gustavo (jgr) wrote :

I confirm the same behavior in Oneiric. First time I access dash with the Super key, the text entry field in dash does not gets focus.

no longer affects: dash (Ubuntu)
Gord Allott (gordallott) on 2012-04-12
Changed in unity:
milestone: none → 5.12.0
assignee: nobody → Gord Allott (gordallott)
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
milestone: 5.12.0 → 5.10.0
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers