Thunderbird won't stay in launcher and no quicklist

Bug #765736 reported by Giovanni Mellini on 2011-04-19
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
BAMF
Undecided
Unassigned
Unity
Fix Released
High
Jason Smith
unity-2d
Medium
Unassigned
bamf (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

After I installed the italian localization on my system, that included thunderbird files, I noticed that thunderbird won't stay in my launcher anymore.
If I flag "keep in launcher" and then I logoff/login, thunderbird disappear; notice that during the session thunderbird icon is always visible in launcher but the launcher quicklist is not available (before was here)

Thunderbird is the only program affected on my system.

description: updated
Omer Akram (om26er) wrote :

Which version of Unity are you using? I just added thunderbird to the launcher and logged out and on the login the thunderbird icon was there and It started just fine. Also are you using thunderbird from any ppa?

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Giovanni Mellini (merlos) wrote :

I'm using default Thunderbird for natty

giovanni@shrimp:~$ apt-cache policy thunderbird
thunderbird:
  Installato: 3.1.9+nobinonly-0ubuntu3
  Candidato: 3.1.9+nobinonly-0ubuntu3
  Tabella versione:
 *** 3.1.9+nobinonly-0ubuntu3 0
        500 http://it.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status
giovanni@shrimp:~$

As I said in description this bug happened to me after installing missing language packs for Italian language, via Language System application.
After this I cannot stick thunderbird icon to the launcher anymore, but I can see the icon in the launcher during the session.

Let me know I can help in debugging

Giovanni Mellini (merlos) wrote :

Ops I forgot my unity version

giovanni@shrimp:~$ apt-cache policy unity
unity:
  Installato: 3.8.8-0ubuntu2
  Candidato: 3.8.8-0ubuntu2
  Tabella versione:
 *** 3.8.8-0ubuntu2 0
        500 http://it.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status
giovanni@shrimp:~$

Giovanni Mellini (merlos) wrote :

Ok I solved the issue removing and reinstalling Thunderbird and italian localization.
Now it's ok, don't know what's happened before

Giovanni Mellini (merlos) wrote :

Sorry again, the bug is still here.
After installing localization I got this

Giovanni Mellini (merlos) wrote :
Download full text (5.1 KiB)

More on this bug. I found why this happens.

This is the system without italian localization

giovanni@shrimp:~$ dpkg-query -l 'thunderbird*'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Nome Versione Descrizione
+++-=======================================-=======================================-==============================================================================================
ii thunderbird 3.1.9+nobinonly-0ubuntu3 mail/news client with RSS and integrated spam filter support
ii thunderbird-globalmenu 3.1.9+nobinonly-0ubuntu3 Unity appmenu integration for Thunderbird
un thunderbird-gnome-support <none> (nessuna descrizione disponibile)
un thunderbird-locale-en-gb <none> (nessuna descrizione disponibile)
un thunderbird-locale-en-us <none> (nessuna descrizione disponibile)
un thunderbird-locale-it <none> (nessuna descrizione disponibile)
un thunderbird-thunderbird-locale-en-gb <none> (nessuna descrizione disponibile)
un thunderbird-thunderbird-locale-en-us <none> (nessuna descrizione disponibile)
un thunderbird-thunderbird-locale-it <none> (nessuna descrizione disponibile)
giovanni@shrimp:~$

And this is the setting of the launcher. You can see the /home/giovanni/.local/share/applications/thunderbird.desktop desktop file, that contains the quicklist.

giovanni@shrimp:~$ gsettings get com.canonical.Unity.Launcher favorites
['nautilus-home.desktop', 'google-chrome.desktop', '/home/giovanni/bin/unity/CustomSSH.desktop', '/home/giovanni/.local/share/applications/thunderbird.desktop', 'gedit.desktop', 'virtualbox-ose.desktop', 'filezilla.desktop', 'libreoffice-writer.desktop', 'libreoffice-calc.desktop', 'ubuntu-software-center.desktop']

I removed Thunderbird icon from launcher, then installed missing language packages

giovanni@shrimp:~$ dpkg-query -l 'thunderbird*'
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Nome Versione Descrizione
+++-=======================================-=======================================-==============================================================================================
ii thunderbird 3.1.9+nobinonly-0ubuntu3 mail/news client with RSS and integrated spam filter support
ii thunderbird-globalmenu 3.1.9+nobinonly-0ubuntu3 Unity appmenu integration for Thunderbird
un thunderbird-gnome-support <none> ...

Read more...

Giovanni Mellini (merlos) wrote :

Is a language pack bug.
Disabling Italian Language pack from Language tab (from Add-ons menu in Thunderbird) I can stick the icon in the launcher and get the quick-list back.

The gsettings key is updated when I click "stick on launcher"

giovanni@shrimp:~$ gsettings get com.canonical.Unity.Launcher favorites
['nautilus-home.desktop', 'google-chrome.desktop', '/home/giovanni/bin/unity/CustomSSH.desktop', 'gedit.desktop', 'virtualbox-ose.desktop', 'filezilla.desktop', 'libreoffice-writer.desktop', 'libreoffice-calc.desktop', 'ubuntu-software-center.desktop', '/home/giovanni/.local/share/applications/thunderbird.desktop']
giovanni@shrimp:~$

Omer Akram (om26er) on 2011-04-19
Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Changed in bamf:
status: New → Confirmed
Changed in bamf (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) wrote :

Giovanni, I think unity/bamf should deal with the situation so added bamf to affects

Giovanni Mellini (merlos) wrote :

Tks Omer, I can send all the info needed, tks again

Chris Coulson (chrisccoulson) wrote :

This seems to be because WM_CLASS is translated in Thunderbird, so doesn't match the StartupWMClass field in the desktop file for all locales.

This shouldn't really be translated at all

affects: bamf (Ubuntu) → thunderbird (Ubuntu)
Changed in thunderbird (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → High
status: Confirmed → Triaged
Giovanni Mellini (merlos) wrote :

Tks Chris for this.
If you need some test let me know.

Didier Roche (didrocks) on 2011-04-20
Changed in unity (Ubuntu):
status: Confirmed → Invalid
Changed in unity:
status: Confirmed → Fix Committed
importance: Undecided → High
assignee: nobody → Jason Smith (jassmith)
milestone: none → 3.8.12
Changed in bamf:
status: Confirmed → Fix Committed
affects: thunderbird (Ubuntu) → bamf (Ubuntu)
Changed in bamf (Ubuntu):
status: Triaged → Fix Committed
assignee: Chris Coulson (chrisccoulson) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.90-0ubuntu2

---------------
bamf (0.2.90-0ubuntu2) natty; urgency=low

  * Cherry-pick from upstream:
    - Thunderbird won't stay in launcher and no quicklist (LP: #765736)
 -- Didier Roche <email address hidden> Wed, 20 Apr 2011 18:07:49 +0200

Changed in bamf (Ubuntu):
status: Fix Committed → Fix Released
Giovanni Mellini (merlos) wrote :

The new package don't fix the issue for me, enabling Italian package on add-on menu avoid Thunderbird to be kept in launcher.
So pls reopen the bug

giovanni@shrimp:~$ apt-cache policy bamfdaemon
bamfdaemon:
  Installato: 0.2.90-0ubuntu2
  Candidato: 0.2.90-0ubuntu2
  Tabella versione:
 *** 0.2.90-0ubuntu2 0
        500 http://it.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status
giovanni@shrimp:~$

Giovanni Mellini (merlos) wrote :

My test-case is the following.

- Be sure the launcher is clean (no Thunderbird icon in) and get the output of " gsettings get com.canonical.Unity.Launcher favorites" command (be sure no thunderbird.desktop reference in)
- Launch Thunderbird and enable italian localization
- close Thunderbird
- launch Thunderbird again
- click the "keep in launcher" ("Mantieni nel launcher") and be sure is flagged
- again, get the output of " gsettings get com.canonical.Unity.Launcher favorites" and I notice that no thunderbird.desktop (or similar) is in
- close Thunderbird, verify that the icon is still in the launcher (with no reference in gsettings key)
- try to click on Thunderbird icon again to launche the program ==> the program, as expected, is no laucnhed
- logout/login
- verify that the Thunderbird icon is not kept in the launcher

I want to add more information.
If I move the Thunderbird icon from Dash to Launcher, the gsettings key is added.
From launcher I can launch and close Thunderbird only the first time.
The second time I can launch Thunderbird again, but I cannot close it anymore, because the program and launcher are not "linked".
The tird time I cannot launch Thunderbird from launcher anymore.
Notice that after these tests, the thunderbird.desktop value in gsettings key is still here

It's not fixed for me also but with "Miro", i have set the icon to "keep in laucnher" yesterday but today after rebooting its gone.
I have made a separate bug report ,but was marked as duplicate of this one.

Didier Roche (didrocks) on 2011-04-21
Changed in unity (Ubuntu):
status: Invalid → Fix Committed
Didier Roche (didrocks) on 2011-04-22
Changed in unity:
status: Fix Committed → Fix Released
Changed in bamf:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Giovanni Mellini (merlos) wrote :

Sorry Didier but the bug is not fixed for me

Didier Roche (didrocks) wrote :

Reverting the status as per Giovanni's comment. Miro (the dup) is fixed for me though

Changed in unity:
status: Fix Released → Triaged
Changed in bamf (Ubuntu):
status: Fix Released → Triaged
Changed in bamf:
status: Fix Released → Triaged
Changed in unity (Ubuntu):
status: Fix Released → Triaged
David Barth (dbarth) on 2011-04-22
Changed in unity:
milestone: 3.8.12 → 3.8.14
David Barth (dbarth) wrote :

I can't reproduce the issue here, with the equivalent french extension. I can confirm that the thunderbird desktop reference goes into gsettings as soon as I check the keep in launcher option.

David Barth (dbarth) wrote :

Keeping the issue on the radar, but I propose to lower the priority since it seems there are not a lot of duplicates.

Changed in unity:
importance: High → Medium
Changed in bamf (Ubuntu):
importance: High → Medium
David Barth (dbarth) wrote :

Just to check, could you try modifiying the italian strings in the desktop file, replacing that with english strings, to see if those are actually the cause for the bug somehow?

Giovanni Mellini (merlos) wrote :

@David after your suggestion I tried again and I found finally the problem.
The problem is related to the extension "Unity Launcher Integration" v0.1
After disabling the extension I can keep thunderbird on launcher, so I think I should report this to the extension developers.
I think you can close the bug

Tks, for your support
Giovanni

Didier Roche (didrocks) wrote :

Thanks for the feedback Giovannni! Reverting to fix released then :)

Changed in unity:
milestone: 3.8.14 → none
Changed in bamf:
status: Triaged → Fix Released
Changed in unity:
status: Triaged → Fix Released
Changed in bamf (Ubuntu):
status: Triaged → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Released

Still not fixed for me , tried to remove "Miro" and any files related form hiddin files in home folder and reinstall it again, but that didn't solve the issue, it even got worst today i was downloading a video minimized the application to the launcher tried to maximize it but it was gone, tried to add it again to the launcher and start it ,but wont start (the icon just blinks for a while) , finally killed it in the system monitor but i don't know if thats normal , there where two miro's:
1- Miro - ID 12280
2- Miro Real - ID 12281
I did another test's after loging out and in and found that when i check the "keep in launcher" close the app and start it by clicking on the "Miro" icon on the launcher , it will not start.
If i searched for it in unity search and start it it will start successfully .

Chris Coulson (chrisccoulson) wrote :

Ok, I *think* I understand what is going on here.

For the Thunderbird case (when I run with LC_ALL=it_IT.UTF-8 so that WM_CLASS != StartupWMClass), bamf_matcher_possible_applications_for_pid is returning a list of possible desktop files based on the applications executable name (which just contains a single entry pointing to the correct desktop file). However, bamf then iterates over this list in bamf_matcher_possible_applications_for_window and only adds each desktop file to the final list of possible desktop files if the windows WM_CLASS matches. In the Thunderbird case, WM_CLASS does not match what is in the desktop file, which is why we want to fall back to Exec matching in the first place

Giovanni Mellini (merlos) wrote :

Tks Chris
I noticed today that I'm experiencing tha bug again, without the "Unity Launcher Integration".
Now I have a stock thunderbird installation, without extension, with italian localization.

So is not fixed...

I confirm the issue with Thunderbird, no particular extension installed and using italian localization...

Changed in unity (Ubuntu):
status: Fix Released → Triaged
Changed in unity:
status: Fix Released → Triaged
Changed in bamf:
status: Fix Released → Triaged
Changed in bamf (Ubuntu):
status: Fix Released → Triaged
Changed in unity (Ubuntu):
importance: Undecided → Low
Didier Roche (didrocks) on 2011-05-02
Changed in unity:
milestone: none → 3.8.14
Stefano Mtangoo (mtangoo) wrote :

Hi there,
The same problem even worse for me. I add some programs to launcher and remove others (Like Ubuntu Software et al) I logout and when I login, the whole settings are gone! Everything resets to default!!!

If it helps:
1. I upgraded from 10.10 and then to 11.04
2. unity --version brings : unity 3.8.12

Thanks!

Stefano Mtangoo (mtangoo) wrote :

I meant I upgraded from 10.04--->10.10-->11.04

David Barth (dbarth) wrote :

Raising the priority since the bug seems more widespread than noticed initially.

Changed in unity:
milestone: 3.8.14 → 3.8.16
importance: Medium → High
Giovanni Mellini (merlos) wrote :

Tks David, I have the same behavior with stable Google Chrome with my italian localized system, I cannot keep it in the launcher.
I hope a fix will land soon

Giovanni

Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d:
status: New → Triaged
Vipul (vipul-bhandari) wrote :

I have stock 11.04 and unity 3.8.14. No icon stick in unity on reboot. Can you tell me where does unity store its default settings ?

Vipul (vipul-bhandari) wrote :

Another issue I noticed with my system which may be relevant is that even though I refresh and update my system constantly, the update manager still shows the package information was updated 42 days ago.

Sebastien Bacher (seb128) wrote :

Vipul, do you have libdconf0 installed?

Vipul (vipul-bhandari) wrote :

yes, I have libdconf installed.

Vipul (vipul-bhandari) wrote :

Also my update manager, even though it has updated packages, it says last updated 90 days ago

Not sure whats the problem in Natty but thunderbird stays very well in
the launcher in Oneiric

Florian Boucault (fboucault) wrote :

I cannot reproduce either in Natty or Oneiric.

Changed in unity-2d:
importance: Undecided → Medium
Tim Penhey (thumper) wrote :

Is there anyone that is still impacted by this bug? I'm wondering if it has been fully fixed now so we can close this bug.

papukaija (papukaija) wrote :

This bug is definitely fixed in Oneiric but I think it's better to wait for a confirmation from anyone who's using Ubuntu in Italian (the technical details are in comment 24).

Giovanni Mellini (merlos) wrote :

Hi, I'm using Oneiric in Italian and I can cofirm the bug is fixed. I can't reproduce the issue anymore

Tks, GIovanni

Tim Penhey (thumper) wrote :

thanks

Changed in unity:
milestone: 3.8.16 → none
status: Triaged → Fix Released
Changed in bamf:
status: Triaged → Fix Released
Changed in bamf (Ubuntu):
status: Triaged → Fix Released
Changed in unity-2d:
status: Triaged → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Released

I'm using Ubuntu in Italian and this issue doesn't affects me anymore.
Thank you.

Lonepsi (imho) wrote :

Well, at first sight, I would to say I have the same bug with U12.04 LTS
[uname gives
Linux A64 3.5.0-29-generic #49~precise1-Ubuntu SMP Wed May 8 00:08:45 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
apt-cache policy unity gives
unity:
  Installé : 5.18.0-0ubuntu2
  Candidat : 5.18.0-0ubuntu2
...]

1) TB doesn't appear in the dashboard when I type "thunderbird" while it is already installed.

2) I launch TB with a terminal. The icon in the Launcher is a grey question mark, not the nice blue bird. If I select "keep in the launcher" on the TB icon, then log out then log in again , TB is not kept in the Launcher.

3) I lauch TB, again with a terminal. The grey icon for TB appears in the launcher, ok. Then I use dconf-editor for a check.
When I set "keep in the launcher" on TB icon, dconf-editor shows immediatly the item 'thunderbird.desktop' in the favorites list (see desktop/unity/launcher in the left panel), but if I set "keep in the launcher" for another application that is not already in the list (for instance dconf-editor), then 'dconf-editor.desktop' appears and 'thunderbird.desktop' is deleted.

Too much entries ? No.
If I launch another application (gparted), I may keep it in the launcher, its item 'gparted.desktop' is added in the favorites list and the one of dconf-editor is always in the list.

Now, if I remove gparted, dconf-editor stays in the list of favorites and so on.

At second sight, I found a strange file ~/.local/share/applications/thunderbird.desktop which properties are:
Command: /opt/thunderbirdV14/thunderbird %u
This is a remaining of my previous install (U10.04 LTS). I needed to install TB V14 in /opt instead of the standard install for an obscur reason of french locating missing( hey, that's sound the very first post). It seems the upgrade to U12.04 is corrupted by this old file although it seems the right file is at the right place: ~/.gnome2/panel2.d/default/launchers/thunderbird.desktop.
Then I deleted the .desktop in .local and all is ok now: TB is visible in the Dashboard, the blue icon is used, TB stays in the Launcher.

All this to give perhaps a clue to other users having the same troubles.

Adolfo Jayme (fitojb) on 2014-01-11
no longer affects: bamf (Ubuntu Quantal)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers