unity places don't start up on login.

Bug #761225 reported by Travis Carter on 2011-04-14
92
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Didier Roche
unity-lens-applications
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned
unity-place-applications (Ubuntu)
Undecided
Unassigned

Bug Description

I just installed the update to Unity 3.8.8 and the search from the Dash no longer returns results. For example, previous versions I typed "ap" and, among others, Appearance would show up. Not anymore.

workaround: browse the "places" manually

Related branches

Bilal Akhtar (bilalakhtar) wrote :

Could you double-check that unity-applications-daemon and unity-files-daemon are running?

You can check that with this command:
ps aux | grep unity

It should return something like:
bilal 2354 0.0 0.8 34708 8608 ? Sl 07:30 0:02 /usr/bin/unity-window-decorator
bilal 2369 0.0 0.4 51696 4408 ? Sl 07:30 0:00 /usr/lib/unity-place-files/unity-files-daemon
bilal 2371 0.0 0.6 56740 6304 ? Sl 07:30 0:00 /usr/lib/unity-place-applications/unity-applications-daemon
bilal 4252 0.4 1.8 108780 18840 ? Sl 08:27 0:09 /usr/lib/unity/unity-panel-service
bilal 4813 0.0 0.0 4156 860 pts/1 S+ 09:03 0:00 grep --color=auto unity

In the above case on lines 2 and 3, both the daemon are running properly. Could you check whether this is the case with you? If not then a reboot would help. Thanks.

I checked with "ps aux | grep unity" and i got:

wgarcia 3401 0.0 0.1 249368 11600 ? Sl 08:18 0:00 /usr/bin/unity-window-decora
wgarcia 3409 0.1 0.1 365248 15496 ? Sl 08:18 0:00 /usr/lib/unity/unity-panel-s
wgarcia 3973 0.0 0.0 12908 1060 pts/1 S+ 08:20 0:00 grep unity

So indeed, they are not running. But I'm coming from a reboot, we'll try to reboot again.

I rebooted and unity-applications-daemon and unity-files-daemon are still not started. This happens to me in both my desktop and my laptop.

Bilal Akhtar (bilalakhtar) wrote :

You can run unity-applications-daemon by running this command:

/usr/lib/unity-place-applications/unity-applications-daemon

/usr/lib/unity-files-applications/unity-files-daemon

BTW, why aren't these daemons starting by themselves? Is it a regression in DBus which isn't starting these services?

Bilal Akhtar (bilalakhtar) wrote :

Try reinstalling unity-place-applications and unity-place-files again:

sudo apt-get install --reinstall unity-place-applications unity-place-files

dart (dart-v85) wrote :

I too confrim this bug. I have found a particular pattern for this. As soon as you login into a new unity session, searching from dash does not work. But once if you search from any of the files or places lens, search in main dash menu starts working again. Strange!

Bilal Akhtar (bilalakhtar) wrote :

Yeah, even I experienced this after a reboot.

Changed in unity:
status: New → Confirmed
Changed in unity-place-applications:
status: New → Confirmed
summary: - search in unity dash doesn't return results
+ unity-applications-daemon doesn't start up on login.
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity-place-applications (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-04-15
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) on 2011-04-15
Changed in unity-place-applications:
status: Confirmed → Invalid
Changed in unity-place-applications (Ubuntu):
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
milestone: none → 3.8.10
Didier Roche (didrocks) on 2011-04-15
summary: - unity-applications-daemon doesn't start up on login.
+ unity places don't start up on login.

Bilal, reinstalling as in #5 does not solve it.

Loïc Minier (lool) on 2011-04-15
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.8-0ubuntu2

---------------
unity (3.8.8-0ubuntu2) natty; urgency=low

  * Cherry pick a lazy activation case not starting the places on demand
    (LP: #761225)
 -- Didier Roche <email address hidden> Fri, 15 Apr 2011 12:15:40 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released

Running Natty Beta 2 since today. I'm clicking on the Ubuntu Logo, the window opens. That one with
  | Media Apps | Internet Apps | More Apps | Find Files|
  in it. Below the shortcuts for Firefox, E-Mail, etc. If i click them, they work.
  But if i click on one of the | Media Apps | Internet Apps | More Apps | Find Files| icons -there is (often) really nothing in it. The next screen opens - but it's empty. Sometimes after a few seconds to minutes it is all back again and i can run my apps. Sometimes i have to reboot to see and access the apps.
  The irritating thing is: If i click on one of thoose | Media Apps | Internet Apps | More Apps | Find Files|, the "Search" line changes to "Search Applications".

To my message: It has been marked as an duplicate of this bug - i don't agree with that. Cause it run's on login. But the Shortcuts, as described above are only sometimes shown. It works on login but during the session the shortcuts are gone. The login isn't the matter.

Travis Carter (princemanfred) wrote :

Forgive me, I haven't filed many bugs before, but is it customary to report that the fix does in fact work? It does.

Didier Roche (didrocks) wrote :

@Travis: it's always best when the reporter confirms the fixes work, thanks a lot for the report and for confirming as well! :)

Didier Roche (didrocks) on 2011-04-19
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-place-applications:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers