Dash - Search for a folder gives everything inside the folder, except the folder itself

Bug #749566 reported by François Tissandier on 2011-04-03
68
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
Fix Released
Medium
Michal Hruby
unity-2d
Medium
Unassigned
unity-lens-files
Medium
Michal Hruby
unity (Ubuntu)
Medium
Michal Hruby
unity-2d (Ubuntu)
Undecided
Unassigned
unity-lens-files (Ubuntu)
Undecided
Unassigned

Bug Description

If I look for a folder using the "Files & Folders" search, it will find by default all the files inside the folder, but not the folder itself, nor the included folders. If I filter on folders only, it will display the included folders, but still not the folder itself.

So I see two problems here:

-the "all files" default option doesn't display any folder. I know "all files" doesn't mean "all files and folders", but I would search on both, you don't always know how you call a file, so the more the better.

-the "folder" option doesn't show the right result: I would expect it to display the folder i'm looking for, not only the folders included in this folder. It seems that it shows only folders created after I upgraded to Natty. Would it just be an initialisation problem of the index?

-------------------------------

Desired resolution:

- If the search string contains all or part of the name of a folder, the folder should be displayed (underneath the 'folders' category header).
- The folders that contain the files in the search result should be displayed (underneath the 'folders' category header), after any folders whose name matches the search string.

Related branches

This is exacerbated by the fact that we changed the layout of file search results since the Maverick version where each tile in the result set had a link to open the parent folder of the file.

Otoh I think it is an indicator of our failure if search results need to contain folders to be useful. Users don't work with folders but with files. We're trying to shed our selves from our heritage of hierarchical file systems.

That said I still think there is room for improvement for users that do need to work with the file system. So let's keep this bug open as a place share ideas.

Changed in unity:
status: New → Confirmed
Changed in unity-place-files:
status: New → Confirmed
François Tissandier (baloo) wrote :

I see what you mean Mikkel. It's a bit hard to get rid of this kind of habit. And I think it's much easier to get rid of the hierarchical file systems for some kind of files, but not yet for all of them. For photos & music for instance, I think the applications are good enough now, we browse music by artist or album, photos by date.

But then in my case, I want to see which GPS tracks I have to upload to my Garmin profile. I put them in a "Sport" folder, then in folders by month. I imagine the right way to do that would be to tag the files properly. But I dont think Unity will search on the tags, from what I tested so far. So I don't think all the applications are ready for this, neither the users.

I agree the hierarchical file system should become invisible to the user. But then don't you think the tags should be easier & more efficient to use ? Including with Unity.

Changed in unity-2d:
status: New → Confirmed
Didier Roche (didrocks) on 2011-04-05
Changed in unity-place-files (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
importance: Undecided → Medium
vanadium (ftack) wrote :

Playing music and maintaining pictures may not need a hierarchical classification indeed. However, it is difficult to imagine a folder-less computer for professional work considering the way file open and file close dialogs currently work. A folder-less computer would require an entire overhaul of current file management tools, file save dialogs, etc., where instead of browsing for a folder users could comment/tag the files. As long as this is not the case, and users are obliged to classify theyr data based on a hierarchy, Unity must provide the proper tools to work with a hierarchical file system. This includes the simple ability to retrieve a folder a user knows is there.

Unity currently is extremely limited where it concerns the file lens. It assumes that the user knows bits of the name of every file he is working on and needs to retrieve. Instead, it will happen frequently that a user will look into the project folder and find the file he needs, browsing though it.

What is worse, Unity only seems to index files that have been recently used. Thus, older files, or files that have recently been copied onto the system (e.g. after a "fresh" OS install) cannot be retrieved using Unity!
As such, the Unity interface currently does not allow to search all folders/documents a user has. There is no other way than launching nautilus and use the old and slow search tools. Still far away from a desktop without hierarchical file systems.

Christoph Buchner (bilderbuchi) wrote :

I have to contradict the assertion in comment #1 that "Users don't work with folders but with files". If, e.g., I currently work with gimp on a collage of graphics, or some other task involving a number of files (think a poster for UDS :D), I have a folder full of source graphics from a number of different sources (i.e. random filenames), and probably one or more gimp files.
At least my workflow demands having quick access to that folder to start working on that project again. Add some more source files into the folder. Identify the current gimp file (not necessarily by filename, could be e.g. by preview), open it. Drag/drop the new source files from the folder into gimp.
So, I disagree with the notion that easy access to folders is unnecessary.

DavidBriscoe (idbrii) wrote :

Users do generally work with files, but they also group their files (with folders).

If someone's working on their thesis, then they probably have supporting data (e.g., images) in the same directory as their text. If they search for their text, they likely want to open the folder containing it so they can easily access all related material without having to search for each one individually.

Removing the need for deep file hierarchies is great, but users need some way to group their files and that group needs to be accessible from the search.

Eduardo Rivas (jerivasmelgar) wrote :

I'll add my case to prove the solution is needed. I work as a web developer, many times I bulk-download files with the most obscure names (CSS and HTML files, sprites, scripts, etc), and all I can remember is the folder where I put them, not the names. In other cases, I know I'll recognize a file when I see it, so browsing a folder is very much needed.

John Lea (johnlea) wrote :

I can't reproduce this issue, searching for the name of a folder in the 'Files Lens' returns the folder for me. This is without changing the filtering from the default 'All files'.

Didier Roche (didrocks) on 2011-09-30
Changed in unity-lens-files (Ubuntu):
status: New → Confirmed
Dimoune (dimoune) wrote :

I confirm that it's extremly embarrassing for people who work a lot with folders as me. When you search a folder by typing its name in the search entry, only recent files are displayed by default, so you need to apply a filter for folders. Why not display results for folders by default?
Working with folders is essential for me too.

John Lea (johnlea) on 2011-12-08
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Triaged
Changed in unity:
milestone: none → backlog
summary: - Search for a folder gives everything inside the folder, except the
- folder itself
+ Dash - Search for a folder gives everything inside the folder, except
+ the folder itself
tags: added: udp
Tim Penhey (thumper) wrote :

I feel that this bug is more about incomplete search than missing folders now.

If that is the case, we should close this bug, as folders are shown in the results, and link to the incomplete search bug.

John Lea (johnlea) wrote :

@kamstrup; is thumpers assertion (above) correct? Is it the case that folders will show up if they are indexed, and the issue is that we are not indexing everything?

Andrea Cimitan (cimi) on 2012-02-17
tags: added: top5p
Michal Hruby (mhr3) on 2012-02-20
Changed in unity:
assignee: nobody → Michal Hruby (mhr3)
importance: Undecided → Medium
status: Confirmed → Triaged
Michal Hruby (mhr3) on 2012-02-20
no longer affects: unity-place-files (Ubuntu)
Changed in unity:
milestone: backlog → 5.6.0
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: High → Critical
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
Michal Hruby (mhr3) on 2012-04-03
Changed in unity-lens-files:
assignee: nobody → Michal Hruby (mhr3)
milestone: none → 5.10.0
importance: Undecided → Medium
status: Confirmed → In Progress
Changed in unity:
status: Triaged → In Progress
Changed in unity-lens-files:
status: In Progress → Fix Committed
Michal Hruby (mhr3) on 2012-04-05
Changed in unity:
status: In Progress → Fix Committed
gianluca (antonelli) wrote :

thanks for taking care of it, for me it is crucial to open the folder and searching it by name. i basically would love to have

find ~ -name myname

best
g.

Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-lens-files:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-files - 5.10.0-0ubuntu1

---------------
unity-lens-files (5.10.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Dash - Search for a folder gives everything inside the folder, except
      the folder itself (LP: #749566)
    - Renaming / Moving a file results in duplicates in files lens
      (LP: #974417)
    - Dash - The "Desktop" folder is not accessible through the dash
      (LP: #837810)
  * debian/control:
    - build-dep on newer libzeitgeist-dev
    - update Standards-Version to latest
 -- Didier Roche <email address hidden> Thu, 12 Apr 2012 11:46:22 +0200

Changed in unity-lens-files (Ubuntu):
status: Confirmed → Fix Released
Tim Penhey (thumper) on 2012-04-20
Changed in ayatana-design:
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: New → Invalid
importance: Undecided → Low
status: Invalid → Fix Released
status: Fix Released → Invalid
John Lea (johnlea) on 2012-10-12
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udp
Changed in unity (Ubuntu):
status: Invalid → Fix Released
assignee: nobody → Michal Hruby (mhr3)
importance: Low → Medium
Changed in unity-2d:
status: Confirmed → Invalid
Changed in unity-2d (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers