Launcher reveals when dragging a window widget

Reported by David Callé on 2011-02-25
118
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Unity
Undecided
Andrea Azzarone
unity (Ubuntu)
Medium
Andrea Azzarone

Bug Description

When you go into "customize" mode in Firefox (righ click on the home button for example), dragging any element of the interface will reveal the launcher, preventing to reorganize the left side of the window.

Stefano Candori (cando) wrote :

If i'm not wrong this is strictly related (or duplicate) to bug #718185 because when you drag an element the active window became the *dragwindow* of the dragged element and the launcher shows up.
This should happen only when the launcher-autohide option is set to dodge active window.

Hernando Torque (htorque) wrote :

I'm getting something similar here with dragging operations in Chromium (open two tabs, start dragging one around) and Opera (click and drag an image or a link), but other than bug #718185 it's happening with "Autohide".

David Callé, please let us know to which hiding mode you set the launcher.

Alex Launi (alexlauni) on 2011-03-03
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
David Callé (davidc3) wrote :

"David Callé, please let us know to which hiding mode you set the launcher."
On default mode : "Dodge windows".

Adam Bruce (brucey-99) wrote :

This effects me to.

I have the bookmark toolbar on firefox. When I try to drag and re-arange a bookmark to the left hand, I can not drop it there as Unity pops out.

Dodge windows enabled

Stefan Löffler (st.loeffler) wrote :

This affects me, too.

This also happens when, e.g., dragging text around in gedit, or dragging mails around in thunderbird. So it might be a good idea to rename this bug to something more general and/or more descriptive of the underlying issue.

Michael Uvarov (freeakk) wrote :

Cannot drag files from nautilus to qmmp, because it has two windows.

summary: - Launcher reveals when customizing Firefox
+ Launcher reveals when dragging a window widget
Andrea Azzarone (andyrock) wrote :

I know that is weird, but this bug can be solved only if we solve this one (https://bugs.launchpad.net/unity/+bug/727901).

Omer Akram (om26er) on 2011-08-08
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
assignee: Jason Smith (jassmith) → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.8.2-0ubuntu3

---------------
unity (4.8.2-0ubuntu3) oneiric; urgency=low

  * Update to current trunk to get closer from an usable version, including
    - improvements to the alt-tab switcher, fixing the performances issues
      on intel cards, thanks Jason Smith
    - reworked dnd code fixing launcher showing when dragging text(lp: #773028)
      or widgets (lp: #724986), the expose slowness (lp: #821538) and other
      bugs as well, thanks Andrea Azzarone
    - the dash text is selected by default allow to type directly a new command
      (lp: #826904)
 -- Sebastien Bacher <email address hidden> Fri, 19 Aug 2011 18:04:19 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Omer Akram (om26er) wrote :

new version of Unity is not yet released only snapshot from trunk was taken to ubuntu.

Changed in unity:
status: Fix Released → Fix Committed
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers