Window management - Alt+Space window accessibility menu should not be accessible by right clicking on a window title bar

Reported by Olivier R-D on 2010-10-07
208
This bug affects 48 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Low
John Lea
Compiz
Low
Unassigned
Unity
Low
Unassigned
unity-2d
Low
Unassigned
compiz (Ubuntu)
Low
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

The benefit of being able to access the Alt+Space window accessibility menu via right clicking on a window title bar is outweighed by the cost of added complexity. This menu should remain accessible via Alt+Space for both restored and maximised windows, but should not be accessible via right click.

Desired change:
- remove the right click menu from window title bars

Didier Roche (didrocks) on 2010-10-09
Changed in unity (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
Changed in unity:
importance: Undecided → Wishlist
status: New → Triaged
Omer Akram (om26er) on 2011-04-04
summary: - right click window menu not available when in full screen
+ right click window menu not available for maximized windows
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Wishlist
John Lea (johnlea) on 2011-04-20
description: updated
summary: - right click window menu not available for maximized windows
+ Alt+Space window accessibility menu should not be accessible by right
+ clicking on a window title bar
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
tags: added: udo
Changed in ayatana-design:
importance: Undecided → Medium
status: New → Fix Committed
Olivier Tilloy (osomon) on 2011-04-26
Changed in unity-2d:
status: Confirmed → Fix Released
Jason Smith (jassmith) on 2011-05-05
Changed in unity:
milestone: none → alpha1
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
importance: Wishlist → Low
John Lea (johnlea) on 2011-05-06
Changed in ayatana-design:
importance: Medium → High

Can I Know why this menu should be remove ? I use it a lot to move windows between workspaces quickly ...

The "duplicates" (false duplicates I must say) of this bug show that they don't want this menu to be remove, just accessible when the windows are full screen.

If we remove this menu, we will lost some of the good points of having a linux Desktop instead of an over one. Like making a window "always on top" that I use very often to keep a gedit window on top of kdenlive. Moving a window between Workspaces easily, making a Window workspace omniscient (on every workspaces).

If the menu disappear, this features should be moved somewhere else to be accessible with a pointer ... (a fourth button on the title bar to bring the menu or something)

I agree... I think that the behavior should be consistent, but I didn't
notice that if the menu is removed, the "always on top" option is removed
also. Solutions?

2011/5/23 Fabien Lusseau <email address hidden>

> Can I Know why this menu should be remove ? I use it a lot to move
> windows between workspaces quickly ...
>
> The "duplicates" (false duplicates I must say) of this bug show that
> they don't want this menu to be remove, just accessible when the windows
> are full screen.
>
> If we remove this menu, we will lost some of the good points of having a
> linux Desktop instead of an over one. Like making a window "always on
> top" that I use very often to keep a gedit window on top of kdenlive.
> Moving a window between Workspaces easily, making a Window workspace
> omniscient (on every workspaces).
>
> If the menu disappear, this features should be moved somewhere else to
> be accessible with a pointer ... (a fourth button on the title bar to
> bring the menu or something)
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (766067).
> https://bugs.launchpad.net/bugs/656519
>
> Title:
> Alt+Space window accessibility menu should not be accessible by right
> clicking on a window title bar
>
> Status in Ayatana Design:
> Fix Committed
> Status in Unity:
> Triaged
> Status in Unity 2D:
> Fix Released
> Status in “unity” package in Ubuntu:
> Triaged
>
> Bug description:
> The benefit of being able to access the Alt+Space window accessibility
> menu via right clicking on a window title bar outweighs the cost of
> the added complexity. This menu should remain accessible via
> Alt+Space for both restored and maximised windows, but should not be
> accessible via right click.
>
> Desired change:
> - remove the right click menu from window title bars
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ayatana-design/+bug/656519/+subscribe
>

Changed in unity-2d:
status: Fix Released → Confirmed
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
John Lea (johnlea) on 2011-06-03
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-06-03
description: updated

Changing the status to "Fix Released" and marking a lot of bugs (about exactly the opposite desired behaviour) as duplicates without any comment is very bad practice... Where is the ayatana-design decision documented?
Coming from bug 668196 this decision seems to contradict the consensus there, see for example Mark Shuttleworth's comment[1]:
"Yes, the non-menu portion of the panel should be treated like the maximised window titlebar."

[1] https://bugs.launchpad.net/ubuntu/+source/unity/+bug/668196/comments/2

Didier Roche (didrocks) on 2011-06-22
Changed in unity:
milestone: 4.0.1 → 4.2.0

On Mon, Jun 20, 2011 at 7:54 PM, Marcel Stimberg
<email address hidden> wrote:
> Changing the status to "Fix Released" and marking a lot of bugs (about exactly the opposite desired behaviour) as duplicates without any comment is very bad practice... Where is the ayatana-design decision documented?
> Coming from bug 668196 this decision seems to contradict the consensus there, see for example Mark Shuttleworth's comment[1]:
> "Yes, the non-menu portion of the panel should be treated like the maximised window titlebar."

That comment is more referring to the intended behavior of the panel
as mirroring the titlebar when maximized, if the behavior of the
titlebar changes then the behavior of the panel does implicitly too.

>
> [1]
> https://bugs.launchpad.net/ubuntu/+source/unity/+bug/668196/comments/2
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/656519
>
> Title:
>  Alt+Space window accessibility menu should not be accessible by right
>  clicking on a window title bar
>
> Status in Ayatana Design:
>  Fix Released
> Status in Unity:
>  Triaged
> Status in Unity 2D:
>  Confirmed
> Status in “unity” package in Ubuntu:
>  Triaged
> Status in “unity-2d” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  The benefit of being able to access the Alt+Space window accessibility
>  menu via right clicking on a window title bar is outweighed by the
>  cost of added complexity.  This menu should remain accessible via
>  Alt+Space for both restored and maximised windows, but should not be
>  accessible via right click.
>
>  Desired change:
>  - remove the right click menu from window title bars
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-design/+bug/656519/+subscriptions
>

--
Sam Spilsbury

I use (and I think that I'm not alone) the "always on top" option when a window is unmaximized. For me, if you decide to remove the menu, it's not important to me, but without loosing of functionality. Also, there is a bug in Unity 2d: you can not move a window from one workspace to another without the window menu at the moment. That issue has to be fixed also.

And I agree with Marcel (comment #4). Why not to publish here the decisions of the ayatana-design list?

On Thu, Jun 23, 2011 at 7:48 AM, André Oliva <email address hidden> wrote:
> I use (and I think that I'm not alone) the "always on top" option when a
> window is unmaximized. For me, if you decide to remove the menu, it's
> not important to me, but without loosing of functionality.

There are keybindings for that as well in the extrawm plugin I think,
though they're disabled by default. In any case, you should be able to
hit alt-space and the menu will always come up

> Also, there
> is a bug in Unity 2d: you can not move a window from one workspace to
> another without the window menu at the moment. That issue has to be
> fixed also.

Please file a separate bug for that. I'm pretty sure you can use
shift-alt-arrowkeys to move windows around though

>
> And I agree with Marcel (comment #4). Why not to publish here the
> decisions of the ayatana-design list?
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/656519
>
> Title:
>  Alt+Space window accessibility menu should not be accessible by right
>  clicking on a window title bar
>
> Status in Ayatana Design:
>  Fix Released
> Status in Unity:
>  Triaged
> Status in Unity 2D:
>  Confirmed
> Status in “unity” package in Ubuntu:
>  Triaged
> Status in “unity-2d” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  The benefit of being able to access the Alt+Space window accessibility
>  menu via right clicking on a window title bar is outweighed by the
>  cost of added complexity.  This menu should remain accessible via
>  Alt+Space for both restored and maximised windows, but should not be
>  accessible via right click.
>
>  Desired change:
>  - remove the right click menu from window title bars
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ayatana-design/+bug/656519/+subscriptions
>

--
Sam Spilsbury

André Oliva (gandreoliva) wrote :
Download full text (3.3 KiB)

About the bug of Unity 2d, I have already filed a bug (bug #766036, but
nobody is working on it).

The point is that "always on top" is very used by lots of users, and I think
that the solution is not to access the same menu via the keyboard. There
must be an easy alternative for new users. Another button in the title bar,
perhaps? Or something similar.

2011/6/22 Sam Spilsbury <email address hidden>

> On Thu, Jun 23, 2011 at 7:48 AM, André Oliva <email address hidden>
> wrote:
> > I use (and I think that I'm not alone) the "always on top" option when a
> > window is unmaximized. For me, if you decide to remove the menu, it's
> > not important to me, but without loosing of functionality.
>
> There are keybindings for that as well in the extrawm plugin I think,
> though they're disabled by default. In any case, you should be able to
> hit alt-space and the menu will always come up
>
> > Also, there
> > is a bug in Unity 2d: you can not move a window from one workspace to
> > another without the window menu at the moment. That issue has to be
> > fixed also.
>
> Please file a separate bug for that. I'm pretty sure you can use
> shift-alt-arrowkeys to move windows around though
>
> >
> > And I agree with Marcel (comment #4). Why not to publish here the
> > decisions of the ayatana-design list?
> >
> > --
> > You received this bug notification because you are a bug assignee.
> > https://bugs.launchpad.net/bugs/656519
> >
> > Title:
> > Alt+Space window accessibility menu should not be accessible by right
> > clicking on a window title bar
> >
> > Status in Ayatana Design:
> > Fix Released
> > Status in Unity:
> > Triaged
> > Status in Unity 2D:
> > Confirmed
> > Status in “unity” package in Ubuntu:
> > Triaged
> > Status in “unity-2d” package in Ubuntu:
> > Confirmed
> >
> > Bug description:
> > The benefit of being able to access the Alt+Space window accessibility
> > menu via right clicking on a window title bar is outweighed by the
> > cost of added complexity. This menu should remain accessible via
> > Alt+Space for both restored and maximised windows, but should not be
> > accessible via right click.
> >
> > Desired change:
> > - remove the right click menu from window title bars
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/ayatana-design/+bug/656519/+subscriptions
> >
>
>
> --
> Sam Spilsbury
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (766067).
> https://bugs.launchpad.net/bugs/656519
>
> Title:
> Alt+Space window accessibility menu should not be accessible by right
> clicking on a window title bar
>
> Status in Ayatana Design:
> Fix Released
> Status in Unity:
> Triaged
> Status in Unity 2D:
> Confirmed
> Status in “unity” package in Ubuntu:
> Triaged
> Status in “unity-2d” package in Ubuntu:
> Confirmed
>
> Bug description:
> The benefit of being able to access the Alt+Space window accessibility
> menu via right clicking on a window title bar is outweighed by the
> cost of added complexity. This menu should remain accessible via
> Alt+Space for both restored and maximised windows, but should not be
> accessible ...

Read more...

If this menu is removed, how would the user move windows between different workspaces? This would be the main regression from moving the menu, in my opinion.

There is also an inconsistency in our user experience with that if you right click the panel when a window is maximized you don't see this menu.

Tom Bamford (tombamford) wrote :

Why should the Alt-Space menu be made inaccessible when using the mouse? I would also like to know where this design decision might be documented?

On Thu, Jun 23, 2011 at 10:51:53AM -0000, Jono Bacon wrote:
> If this menu is removed, how would the user move windows between
> different workspaces? This would be the main regression from moving the
> menu, in my opinion.

This can be done with the keyboard, but I don't see any reason to
eliminate the mouse as an alternative.

Not having this menu accessible via mouse in fullscreen is my number one
pet peeve with Unity at the moment. I'd be interested in seeing whatever
thread exists that explains why removing this menu/not implementing it
is a good idea.

> There is also an inconsistency in our user experience with that if you
> right click the panel when a window is maximized you don't see this
> menu.

Agreed.
--
Travis Poppe
IRC: tlp on irc.freenode.net

Jorge O. Castro (jorge) on 2011-07-01
tags: added: backlog
Changed in unity-2d:
importance: Wishlist → Low
Didier Roche (didrocks) on 2011-07-05
Changed in unity:
milestone: 4.2.0 → 4.4.0
Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Omer Akram (om26er) on 2011-07-22
Changed in unity (Ubuntu):
importance: Wishlist → Low
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0

I highly protest. The accessibility of the menu by mouse is essential to my workflow.

Magnes (magnesus2) wrote :

Keyboard shortcuts should always have an alternative:
- most people won't even know the shortcut exist (or maybe you want to make a 100 page manual with them?)
- keyboard shortcuts require movement of hands that distract from using the system with mouse,
- some disabled people could have problems with keyboard shortcuts (requiring holding two keys).

I was looking forward for new Unity in Ubuntu 11.10. But if this is changed I'm going to look for another distribution.

Changed in unity-2d:
status: Confirmed → Incomplete
Changed in unity:
status: Triaged → Incomplete
Changed in unity-2d (Ubuntu):
status: Confirmed → Incomplete
Changed in unity (Ubuntu):
status: Triaged → Incomplete
John Lea (johnlea) on 2011-08-09
Changed in unity-2d:
status: Incomplete → Confirmed
Changed in unity:
status: Incomplete → Triaged
Changed in unity-2d (Ubuntu):
status: Incomplete → Confirmed
Omer Akram (om26er) on 2011-08-09
Changed in unity-2d (Ubuntu):
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Incomplete → Triaged
Omer Akram (om26er) on 2011-09-24
Changed in unity-2d (Ubuntu):
importance: Undecided → Low
Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d:
status: Confirmed → Triaged
Changed in unity:
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: 4.8.0 → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
John Lea (johnlea) on 2011-10-19
Changed in ayatana-design:
importance: High → Low
Didier Roche (didrocks) on 2011-10-20
Changed in unity:
status: Fix Committed → Triaged
Changed in unity (Ubuntu):
status: Fix Committed → Triaged
John Lea (johnlea) on 2011-10-20
Changed in ayatana-design:
status: Fix Committed → Triaged
Alex Launi (alexlauni) on 2011-10-21
Changed in compiz (Ubuntu):
status: New → Triaged
Omer Akram (om26er) wrote :

Whats the status on this bug report? Are we going to remove the context menu from non-maximized windows this cycle?

Märt Põder (boamaod) wrote :

I second to Magnes. If I understand to decision right. It's absolutely needed to move windows between workspaces with only using the mouse.

>"The benefit of being able to access the Alt+Space window accessibility menu via right clicking on a window title bar is outweighed by the cost of added complexity"

What complexity? can some one clarify?

Removal of mouse based navigation just because there is a keyboard short cut is an antifeature.
This bug should be marked invalid/ won't fix.

I second magnes too.

John Lea (johnlea) on 2012-04-20
Changed in unity:
status: Triaged → Confirmed
Changed in unity-2d:
status: Triaged → Confirmed
Changed in unity (Ubuntu):
status: Triaged → Confirmed
Changed in unity-2d (Ubuntu):
status: Triaged → Confirmed
Changed in ayatana-design:
importance: Low → Medium
Changed in compiz (Ubuntu):
status: Triaged → Confirmed
John Lea (johnlea) on 2012-04-23
Changed in ayatana-design:
importance: Medium → Low
Tim Penhey (thumper) on 2012-04-23
Changed in unity:
assignee: Sam Spilsbury (smspillaz) → nobody
status: Confirmed → Triaged
Changed in ayatana-design:
status: Triaged → Fix Committed

The right click on maximized windows should be included again, i really miss this feature. Now when i put a window always on top, i have to
1- umaximize window
2- put it always on top
3- maximize it again

Really confusing. Please do not remove right click from umaximized windows and add it again for maximized windows.

The issue is that it'd be too difficult to implement right click for maximized windows.
Regardless, the menu is still available through the ALT + Space shortcut, so you do not have to unmaximize the window to put a window always on top.

Omer Akram (om26er) on 2012-07-24
tags: added: rclick
John Lea (johnlea) on 2012-10-15
summary: - Alt+Space window accessibility menu should not be accessible by right
- clicking on a window title bar
+ Window management - Alt+Space window accessibility menu should not be
+ accessible by right clicking on a window title bar
Changed in compiz:
status: New → Triaged
no longer affects: unity-2d (Ubuntu)
Changed in compiz:
importance: Undecided → Low
Changed in compiz (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed

Bug #1098419 proposes to implement right click on panel for maximised windows.
John Lea just marked it as a duplicate of this bug, action I reverted as those two bugs have two opposite objectives.

About this issue:
- I understand something might be difficult to implement. However, the discoverability of alt+space is extremely low (first time I hear about it in 5 years of Ubuntu), and most users do not use alt+xxx keybindings for everyday use of their system.
- I do not get why there such little input from the developpers/desing team in these comments to justify the unilateral decision that has been made here by linking some kind of discussion that happened elsewhere. Most comments here strongly oppose this.

asmoore82 (asmoore82) wrote :

I just stumbled on this bug. Bug #1292168 from me is related but not duplicate. I felt that I needed to pull over my related comments from there:

["lower" functionality] always *should* have been a part of the standard window menu so let's go ahead and have it in there. Secondly, if right click [the title bar] does not expose this menu because of LIM/Indicator consistency, then let's just go ahead and bring back the window menu as a standard part of every window decoration. I'm thinking it will replace/obsolete the always visible minimize/maximize buttons and will integrate seamlessly with LIM such that opening the window menu and then mousing right will move right on to "File, Edit, View, etc."

This would add a further layer of consistency for windows that do not support resizing or maximizing. As is, the dedicated maximize button on them can be taken away leading to slight inconsistency in window decoration, but with a window menu instead it will always be there and will simply have the options inside greyed if the window does not support them.

asmoore82 (asmoore82) wrote :

Pardon the double post but this is a separate thought:

The standard window actions menu or alt+space menu has "always" been available and "always" will in my perfect world by alt+rightclick _anywhere_ on a window. Anecdotally, this has been my preferred method for accessing Always on top/Move Workspace/etc. for quite a while now to eliminate the need to hit the smaller target of just the titlebar. I would note that this is not a pure mouse option though. But on top of that I support Gobal Menus and LIM moving on to accept any click. And on top of that I still would hope never to remove a pure mouse solution. So that brings me back to the good old window menu button again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers