Active windows loses focus after returning from Dash if another "Always on top" window is present

Bug #1446634 reported by Christopher Townsend on 2015-04-21
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Christopher Townsend
7.2
Fix Committed
Medium
Christopher Townsend
unity (Ubuntu)
Medium
Christopher Townsend
Trusty
Medium
Unassigned

Bug Description

Active window looses focus after returning from Dash if "Always on top" window like VLC is already running. The focus is given to VLC instead of the window on which HUD was invoke.

This is very similar to bug #1366583.

[Test Case]
1. Open a nautilus window
2. Make it "Always on top"
3. Open a gnome-terminal window
4. Focus it
5. Press super to open the dash
6. Close the dash using Esc
7. Make sure gnome-terminal is focused

[Regression Potential]
The dash fails to give focus to new windows:
1. Open a nautilus window
2. Press super to open the dash
3. Open a new app
4. Make sure the new app window is focused

Related branches

Changed in unity:
status: New → In Progress
Changed in unity (Ubuntu):
status: New → In Progress
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
assignee: nobody → Christopher Townsend (townsend)
Changed in unity (Ubuntu):
assignee: nobody → Christopher Townsend (townsend)
Changed in unity:
milestone: none → 7.3.3
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.2+15.10.20150512-0ubuntu1

---------------
unity (7.3.2+15.10.20150512-0ubuntu1) wily; urgency=medium

  [ Chris Townsend ]
  * Add new signal to tell the Launcher to terminate keynav mode and use
    that signal when a BFB quicklist item is chosen. (LP: #1052024,
    #1444643)
  * Add option to enable and disable Unity low graphics mode on the fly
    in ccsm or via gsettings. (LP: #1412937)
  * Remove code that is no longer needed and broke opening application
    spread while in Launcher keynav mode. (LP: #1445082)
  * Save the active window when showing the Dash so the correct window
    is focused when hiding the Dash. Fixes issue when "Always on Top"
    windows are present. (LP: #1446634)
  * Save the active window when showing the Hud so the correct window is
    focused when hiding the Hud. Fixes issue when "Always on Top"
    windows are present. (LP: #1366583)
  * Send signal to ensure the Dash will show when entering keynav mode
    since the first icon always highlighted is the BFB. (LP: #1444113)
  * When looking for the top-most valid window in a VP, also check if
    the window is focused if the window is set to Always on Top. This
    allows Launcher icon spread to work properly when a window is
    minimized an Always on Top exists in the group. (LP: #1131385)
  * When using the left arrow to exit a Quicklist, Launcher keynav is
    implied and should be active regardless of how the Quicklist was
    opened. (LP: #1444626)

  [ Eleni Maria Stea ]
  * The skydome rendering of the cube plugin was wrong with unity
    because transformation matrices set by the unityshell plugin were
    left in the opengl matrix stacks affecting other compiz plugins.
    Saving the compiz state at the beginning of the unityshell plugin
    rendering functions and restoring it at the end of them fixes the
    problem. (LP: #1446165)

 -- CI Train Bot <email address hidden> Tue, 12 May 2015 13:10:15 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2015-10-23
description: updated
description: updated
Changed in unity (Ubuntu Trusty):
status: New → In Progress
Changed in unity:
status: Fix Committed → Fix Released

Hello Christopher, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.2.6+14.04.20151021-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in unity (Ubuntu Trusty):
importance: Undecided → Low
importance: Low → Medium
Mathew Hodson (mathew-hodson) wrote :

This is fixed with the packages in trusty-proposed.

$ apt list libunity-core-6.0-9 unity unity-services
Listing... Done
libunity-core-6.0-9/trusty-proposed,now 7.2.6+14.04.20151021-0ubuntu1 amd64 [installed,automatic]
unity/trusty-proposed,now 7.2.6+14.04.20151021-0ubuntu1 amd64 [installed,automatic]
unity-services/trusty-proposed,now 7.2.6+14.04.20151021-0ubuntu1 amd64 [installed,automatic]

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.6+14.04.20151021-0ubuntu1

---------------
unity (7.2.6+14.04.20151021-0ubuntu1) trusty; urgency=medium

  * New upstream release

  [ Andrea Azzarone ]
  * Merge patch from https://launchpadlibrarian.net/216276242/low-gfx-
    override.patch (LP: #1491913)
  * Properly hide decorations when on "Show Desktop" mode. (LP: #1485073)
  * Do not handle events coming from viewports not actually containing the window.
    (LP: #1449654)
  * Make sure new icons are added to the model before calling SortAndUpdate
    (LP: #1458950)
  * GnomeSessionManager: Do not allow shutdown when screen is locked. (LP: #1460626)
  * GnomeSessionManager: Do not allow shutdown when screen is locked.

  [ Chris Townsend ]
  * When looking for the top-most valid window in a VP, also check if the window
    is focused if the window is set to Always on Top. This allows Launcher icon
    spread to work properly when a window is minimized an Always on Top exists in
    the group. (LP: #1131385)
  * Wait on Spread to be terminated before showing the Quicklist. (LP: #1441626)
  * If dragging an application:// uri type from the Dash to the desktop, change it
    to a file:// uri type so Nautilus can understand the type a make a copy of it
    on the desktop. (LP: #1241972)
  * Enable real page up/page down key navigation in the Dash. When using these
    keys the view scrolls the length of the visible view. (LP: #913612)
  * Save the active window when showing the Hud so the correct window is focused
    when hiding the Hud. Fixes issue when "Always on Top" windows are present.
    (LP: #1366583)
  * Save the active window when showing the Dash so the correct window is focused
    when hiding the Dash. Fixes issue when "Always on Top" windows are present.
    (LP: #1446634)
  * When using keyboard navigation in the Dash, skip category headers that are not
    expandable. Also, do not highlight the category header when the mouse cursor
    is over it. (LP: #1045933)
  * Also use the Compiz show() method when forcing an unmapped window to be
    visible when clicking on it's active Launcher icon. (LP: #989588)
  * Add option to enable and disable Unity low graphics mode on the fly in ccsm or
    via gsettings. (LP: #1412937)
  * UScreen, PanelService: get monitor at position, ignoring pre-
    multipled Gdk scale factor (LP: #1351591)

  [ Marco Trevisan (Treviño) ]
  * ResultViewGrid: wait for double-click event only if the relative result needs
    the Preview (LP: #1291950)
  * OverlayWindowButtons: trigger a queuedraw also when a child requires a redraw
    (LP: #1461618)
  * GnomeSessionManager: Request ScreenSaver (de)activation on VT changes (LP:
    #1405349)
  * UScreen, PanelService: get monitor at position, ignoring pre-multipled Gdk
    scale factor (LP: #1351591)
  * UScreen, PanelService: get monitor at position, ignoring pre-
    multipled Gdk scale factor (LP: #1351591)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Wed, 21 Oct 2015 15:54:44 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers