When opening and then closing the dash quickly the panel is too slow to update

Bug #1044086 reported by Brandon Schaefer on 2012-08-30
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Nick Dedekind
unity (Ubuntu)
Medium
Nick Dedekind

Bug Description

When you open then close the dash quickly the panel is too slow to keep up with the current state of the dash. Leaving the panel thinking the dash is open when it is closed.

To reproduce:
Double click on the Dash icon in the launcher...

Screenshot:
http://i.imgur.com/rte5f.jpg

Related branches

Omer Akram (om26er) wrote :

wow if i tap super key twice I see magic

Changed in unity:
importance: Undecided → High
status: New → Confirmed
milestone: none → 6.4
importance: High → Medium
Bilal Akhtar (bilalakhtar) wrote :

I wasn't able to reproduce this here, on Quantal, unity trunk. It's probably because of the multimonitor setup on your system which probably slows down the opening/closing of the dash.

Omer Akram (om26er) wrote :

I don't have multimonitor setup. Plus my machine is quite fast I would say

Changed in unity:
milestone: 6.4 → 6.6
Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
status: Confirmed → In Progress
Omer Akram (om26er) on 2012-09-05
summary: - When opening and then closing the dash quickly the panel is to slow to
+ When opening and then closing the dash quickly the panel is too slow to
update
description: updated
Changed in unity:
assignee: Brandon Schaefer (brandontschaefer) → Nick Dedekind (nick-dedekind)
Changed in unity:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2012-09-14
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Fix Committed
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in unity:
milestone: 6.6 → 7.0
Francis Ginther (fginther) wrote :

I've seen a re-occurrence of this with:
 - compiz - 1:0.9.8.2+bzr3377-0ubuntu1~test2
 - nux - 3.6.0-0ubuntu1~test2
 - unity - 6.6.0-0ubuntu1~test1

unity was built by Timo, so I'm assuming it has this fixed based on the related branch:
lp:~timo-jyrinki/ubuntu/quantal/unity/ubuntu.660

Omer Akram (om26er) wrote :

yeah, the issue is still there. Its very clearly visible on low end machines.

Omer Akram (om26er) on 2012-09-20
no longer affects: unity/6.0
Changed in unity:
milestone: 7.0 → 6.6
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 6.6.0-0ubuntu1

---------------
unity (6.6.0-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Fixes non-escaped character sequences in dash previews (LP: #1039020)
    - Updated background layer for preview cover-art and details panels
      to be 10% low-light
    - Expand a PlacesGroup if it is the only category that contains results
      (LP: #950710)
    - Update unity autopilot tests to match autopilot API
    - Updated the convert files to fix some typos in the key names
    - Add gmodule dependency
    - Activate proper result if the categories aren't displayed in-order
      (LP: #1040101)
    - Refactor device launcher icons (LP: #713423)
    - LauncherController: make the controller enable the launcher struts,
      based on hide-mode option (LP: #1044005)
    - Launcher: make always possible to drag an icon to the bottom or top
      of its sub list (LP: #1043968)
    - Don't desat bfb/hud icon in DNDReset (LP: #1043963)
    - Progressively adjust the speed of the minimize animation. First
      time it is used is slower, then speeds up the more it is used.
      (LP: #1017510)
    - Implement new ordering of categories for home lens. (LP: #1043915)
    - UnityWindow now implements ScaleWindowInterface (LP: #876017)
    - Launcher: restore an icon position after that the dragging has been
      cancelled (LP: #955561)
    - LauncherDragWindow: cancel drag on window mapped/unmapped
      (LP: #1044723)
    - Now there is a check of an override color in RefreshColor (which is
      called when a PropertyNotify event happens). Also added a check in
      FullySaturateColor to a void division by zero. (LP: #975350)
    - Queue redraw after cover-art texture is updated from a url/file source.
      (LP: #1043947)
    - Fixed ability to delete glib::Source wrapper during its callback
      (LP: #1044823)
    - Close preview when dash is hidden. (LP: #1045298)
    - LauncherModel: rewrite the Reordering functions to keep the icon
      priority deltas (LP: #761155)
    - Make sure we can pass extra hints when activating preview actions.
      (LP: #1046352)
    - UnityWindow: scale window code improved (LP: #1033935)
    - The mouse will now cause the HUD buttons to change selection
      (LP: #1042692)
    - "Alt+Space" shortcut to reveal the window menu is not hardcoded, but a
       Compiz key option. " (Hold)" should also be translated. Made all
       Compiz plug-in names and all Compiz plug-in option names in
       unityshell.cpp static constants.
    - remove unity --reset, it's not anymore really needed now that we are
      in stable days of unity and we moved to gsettings
    - Removed the variables 'oldPrev' and 'oldNext' which got assigned the
      value NULL, but then were never used
    - Fixed the size of the previews to 770x380 pixels. (LP: #1045243)
    - UnityWindow: use smart pointers, use static close_icon (with dynamic
      state) and PanelStyle context (LP: #1033935) (LP: #1045127)
      (LP: #1046124) (LP: #1046126)
    - Remove everything in the #ifndef USE_MODERN_COMPIZ_GL ifdefs and remove
      the ifdefs alltogether. unity now requires compiz...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Francis Ginther (fginther) wrote :

I'm still seeing this with 6.6.0+bzr2754stagingubuntu1~test1 from unity-team/ppa.

Omer Akram (om26er) wrote :

Please open a new bug using the command 'ubuntu-bug unity' this particular bug was fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers