Cannot focus password field after clicking an appindicator

Bug #1049261 reported by Francesco Fumanti
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity Greeter
Fix Released
Undecided
Unassigned
unity-greeter (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

I am using unity-greeter version 12.10.2-0ubuntu4.

My system is set to automatically open Onboard when the unity-greeter appears; but this might not be relevant. Thus, when unity-greeter appears, Onboard also appears and the focus is set to the password field and I can immediately enter the password; so everything is ok so far.

However, if I click on an appindicator, the focus goes away from the password field, and clicking on the password field to set the focus back to it does not work; as if the clicks were ignored. I have to restart the computer to put unity-greeter in its state where the password field is selected (since it gets automatically selected when the unity-greeter appears).

If you need further pieces of information, please ask for them.

Cheers

Adolfo Jayme (fitojb)
tags: added: a11y
Revision history for this message
Francesco Fumanti (frafu) wrote :

I would not tag it as an accessibility issue, since I could reproduce the problem also with Onboard disabled.

Revision history for this message
marmuta (marmuta) wrote :

Confirming, the focus on the password entry is lost when any of the indicators is clicked. X falls back to focus-follows-mouse and with the pointer over the screen keyboard, key strokes are sent to Onboard instead of the password box.

Changed in unity-greeter:
status: New → Confirmed
Michael Terry (mterry)
Changed in unity-greeter:
status: Confirmed → Fix Committed
milestone: none → 12.10.4
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-greeter (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 12.10.4-0ubuntu1

---------------
unity-greeter (12.10.4-0ubuntu1) quantal; urgency=low

  * New upstream bug fix release
    - Fix rendering of password entry's spinner (LP: #1059447)
    - Fix rendering of password entry's cursor after closing a dialog
      (LP: #1049261)
    - Fix slight pixel jump in names as they finish scrolling (LP: #1056941)
    - Fix not being able to click on first few sessions in session chooser
      (LP: #1052453)
    - Cleanly close onboard keyboard to prevent it crashing on login
      (LP: #1055698)
    - Use a lightdm hint for controlling whether remote login is enabled
  * debian/patches/trunk_session_chooser.patch,
    debian/patches/02_use_remote_login_hint.patch:
    - Dropped, included upstream
 -- Michael Terry <email address hidden> Mon, 01 Oct 2012 12:33:16 -0400

Changed in unity-greeter (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers